graphics/pqp

A Proximity Query Package
Directory:
graphics/pqp (package's history)
Package version:
pqp-1.3r3
Home page:
http://gamma.cs.unc.edu/SSV/
License:
pqp-license
Source archive:
http://gamma.cs.unc.edu/software/downloads/SSV/pqp-1.3.tar.gz
Description:
PQP is a library for performing three types of proximity queries on a pair of geometric models composed of triangles: * Collision detection - detecting whether the two models overlap, and optionally, all of the triangles that overlap. * Distance computation - computing the minimum distance between a pair of models, i.e., the distance between the closest pair of points. * Tolerance verification - determining whether two models are closer or farther than a tolerance distance.
Run dependencies:
libstdc++
Build dependencies:
digest>=20080510, g++>=3, install-sh, libtool>=1.5.22, patch>=2.0, pax, pkg_install>=20110805.7, tnftp>=20091122
General options:
debug
Produce debugging information for binary programs
c++-compiler alternatives:
g++
Use the GNU C++ compiler
clang++
Use the LLVM C++ compiler
ccache-g++
Use ccache and the GNU C++ compiler
ccache-clang++
Use ccache and the LLVM C++ compiler