robotpkg/motion/nhfc-genom3 bulk build results

Log for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server on CentOS-7-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/tnftp-20151004~ssl.tgz ===> Checking bootstrap dependencies for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20151004~ssl found => Required system package gzip: gzip-1.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.12: pkg_install-20211115.3 found ===> Done bootstrap-depends for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server ===> Installing full dependencies for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server => Required system package boost-headers>=1.60: MISSING => Dependency digest-20080510 already installed => Required system package gcc>=4.9: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/genom3-2.99.42.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/genom3-openprs-1.0.9r5.tgz => Required robotpkg package genom3-ros>=1.31: N/A => Dependency openprs-1.1b11 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/openrobots2-idl-2.3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-actionlib-1.12.0r1.tgz robotpkg_add: no pkg found for 'ros-gennodejs>=2.0', sorry. robotpkg_add: Can't install dependency ros-gennodejs>=2.0 robotpkg_add: Expected dependency ros-gennodejs>=2.0 still missing robotpkg_add: Can't install dependency ros-message-generation>=0.4 robotpkg_add: Expected dependency ros-message-generation>=0.4 still missing To use ros, the following environment variables must contain those values: robotpkg_add: Can't install dependency ros-comm-msgs>=1.10.3 robotpkg_add: Expected dependency ros-comm-msgs>=1.10.3 still missing ROS_MASTER_URI http://localhost:11311 robotpkg_add: Can't install dependency ros-comm>=1.13<1.15 ROS_PACKAGE_PATH /opt/openrobots/share robotpkg_add: Expected dependency ros-comm>=1.13<1.15 still missing PYTHONPATH /opt/openrobots/lib/python2.7/site-packages robotpkg_add: 1 package addition failed PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-comm-1.14.3r3.tgz robotpkg_add: no pkg found for 'ros-gennodejs>=2.0', sorry. robotpkg_add: Can't install dependency ros-gennodejs>=2.0 robotpkg_add: Expected dependency ros-gennodejs>=2.0 still missing To use ros, the following environment variables must contain those values: robotpkg_add: Can't install dependency ros-message-generation>=0.4 robotpkg_add: Expected dependency ros-message-generation>=0.4 still missing ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share robotpkg_add: Can't install dependency ros-comm-msgs>=1.10.3 PYTHONPATH /opt/openrobots/lib/python2.7/site-packages robotpkg_add: Expected dependency ros-comm-msgs>=1.10.3 still missing PATH /opt/openrobots/bin robotpkg_add: 1 package addition failed As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-common-msgs-1.12.6.tgz robotpkg_add: no pkg found for 'ros-gennodejs>=2.0', sorry. robotpkg_add: Can't install dependency ros-gennodejs>=2.0 robotpkg_add: Expected dependency ros-gennodejs>=2.0 still missing robotpkg_add: Can't install dependency ros-message-generation>=0.4 To use ros, the following environment variables must contain those values: robotpkg_add: Expected dependency ros-message-generation>=0.4 still missing ROS_MASTER_URI http://localhost:11311 robotpkg_add: 1 package addition failed ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-genmsg-0.5.11.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-genpy-0.6.7.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-message-generation-0.4.0.tgz robotpkg_add: no pkg found for 'ros-gennodejs>=2.0', sorry. robotpkg_add: Can't install dependency ros-gennodejs>=2.0 robotpkg_add: Expected dependency ros-gennodejs>=2.0 still missing robotpkg_add: 1 package addition failed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-ros-1.14.4r1.tgz => Dependency ros-rospack-2.5.1 already installed => Dependency tnftp-20151004~ssl already installed => Dependency transgen3-1.0b5 already installed ERROR: ====================================================================== ERROR: Missing system packages required for nhfc-genom3-2.4~codels+openprs+ros-client-c+ros-client-ros+ros-server: ERROR: ERROR: boost-headers>=1.60 (CentOS package boost-devel) ERROR: gcc>=4.9 ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/motion/nhfc-genom3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Deinstalling for nhfc-genom3 Removed digest-20080510 Removing dependency eltclsh-1.19 Removing dependency Removing dependency transgen3-1.0b5 Removing dependency genom3-openprs-1.0.9r5 Removed genom3-2.99.42 Removed openrobots2-idl-2.3 Removing dependency py27-catkin-pkg-0.5.2 Removing dependency py27-ros-catkin-0.7.16r1 Removing dependency Removing dependency ros-ros-1.14.4r1 Removing dependency ros-genpy-0.6.7 Removed ros-genmsg-0.5.11 Removed tnftp-20151004~ssl