robotpkg/wip bulk build results

Log for Ubuntu-20.04-x86_64 (Back)

--- Syncing bulk database ---------------------------------------- setting Ubuntu-20.04-x86_64 as running --- Updating robotpkg -------------------------------------------- Pulling /local/robotpkg/var/lib/robotpkg/wip HEAD is now at 13a9cd66 [wip/py-sot-talos] Update to v1.2.1 Updating pkgtools/pkg_install ===> Updating for pkg_install-20110805.10 pkg_install-20110805.10 is already installed and up-to-date. Updating pkgtools/rbulkit ===> Updating for rbulkit-20200227 rbulkit-20200227 is already installed and up-to-date. Updating pkgtools/pkgrepo2deb ===> Updating for pkgrepo2deb-1.8 pkgrepo2deb-1.8 is already installed and up-to-date. --- Running build for bulk-rbulk-wip ------------------------------- ===> Sorting packages for rbulk wip set Scanning wip/py-mavlink:*~doc Scanning wip/head-action:*~doc Scanning pkgtools/tnftp:tnftp>=20130505~ssl Scanning wip/py-sot-core-v3:*~doc Scanning wip/py-pal:*~doc Scanning wip/talos-robot:*~doc Scanning wip/py-libnabo:*~doc Scanning wip/soth:*~doc Scanning wip/cppad:*~doc Scanning wip/py-sot-tools-v3:*~doc Scanning wip/urg:*~doc Scanning wip/py-bmtools:*~doc Scanning wip/py-prf-ros-controllers:*~doc Scanning wip/multicontact-api:*~doc Scanning wip/pal-hardware-gazebo:*~doc Scanning wip/infuse-msgs-ros:*~doc Scanning wip/pmb2-navigation:*~doc Scanning wip/sot-hrp2:*~doc Scanning wip/py-dynamic-graph-v3:*~doc Scanning wip/infuse-idl:*~doc Scanning wip/tiago-description-calibration:*~doc Scanning wip/py-skeleton-model:*~doc Scanning wip/talos-simulation:*~doc Scanning wip/py-osqp:*~doc Scanning wip/sot-core-v3:*~doc Scanning wip/msgconnector:*~doc Scanning wip/talos-data:*~doc Scanning wip/ros-swri-math-util:*~doc Scanning wip/FRILibrary:*~doc Scanning wip/py-prf-ros-control:*~doc Scanning wip/py-talos-rbprm:*~doc Scanning wip/ddp-actuator-solver:*~doc Scanning wip/sot-talos-balance:*~doc Scanning wip/talos-moveit-config:*~doc Scanning wip/pal-wsg-gripper:*~doc Scanning wip/cppadcodegen:*~doc Scanning wip/dynamic-graph-tutorial:*~doc Scanning wip/ros-moveit:*~doc Scanning wip/py-example-adder:*~doc Scanning wip/openhrp3-hrp2:*~doc Scanning wip/libpointmatcher:*~doc Scanning wip/py-talos-dev:*~doc Scanning wip/dptu-genom3:*~doc Scanning wip/ros-aicp-mapping:*~doc Scanning wip/py-multicontact-api:*~doc Scanning wip/ros-warehouse-ros:*~doc Scanning wip/tiago-navigation:*~doc Scanning wip/eiquadprog:*~doc Scanning wip/pmb2-robot:*~doc Scanning wip/ros-moveit-resources:*~doc Scanning wip/py-sot-torque-control:*~doc Scanning wip/hey5-description:*~doc Scanning wip/infuse-novatel-gps-driver-ros:*~doc Scanning wip/py-hpp-centroidal-dynamics:*~doc Scanning wip/ros-urdf-geometry-parser:*~doc Scanning wip/py-pycddlib:*~doc Scanning wip/tiago-dev:*~doc Scanning wip/hpp-benchmark:*~doc Scanning wip/ros-swri-roscpp:*~doc Scanning wip/parametric-curves:*~doc Scanning wip/py-sot-tiago:*~doc Scanning wip/py-hpp-romeo:*~doc Scanning wip/talos-metapkg-ros-control-sot:*~doc Scanning wip/py-sl1m:*~doc Scanning wip/example-adder:*~doc Scanning wip/aruco-ros:*~doc Scanning wip/infuse-asn1-conversions:*~doc Scanning wip/py-hpp-spline:*~doc Scanning wip/ros-object-recognition-msgs:*~doc Scanning wip/timeoptimization:*~doc Scanning wip/infuse-envire:*~doc Scanning wip/pal-gazebo-plugins:*~doc Scanning wip/py-pal-statistics:*~doc Scanning wip/ros-universal-robot:*~doc Scanning wip/pal-hardware-interfaces:*~doc Scanning wip/py-hpp-baxter:*~doc Scanning wip/dynamic-introspection:*~doc [wip/dynamic-introspection:*~doc] Warning: the LICENSE of wip/dynamic-introspection is undefined. Scanning wip/ros-srdfdom:*~doc Scanning wip/py-hpp-affordance-corba:*~doc Scanning wip/py-hpp-rbprm-robot-data:*~doc Scanning wip/pal-transmissions:*~doc Scanning wip/py-sot-talos-balance:*~doc Scanning wip/py-ospi:*~doc Scanning wip/sot-torque-control:*~doc Scanning wip/antlr2:*~doc Scanning wip/py-gurobi:*~doc [wip/py-gurobi:*~doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/rqt-dynamic-graph:*~doc Scanning wip/libnabo:*~doc Scanning wip/pal-gripper:*~doc Scanning wip/py-hpp-rbprm:*~doc Scanning wip/ros-ouster-gazebo-simulation:*~doc Scanning wip/sot-tools-v3:*~doc Scanning wip/ur5-description:*~doc [wip/ur5-description:*~doc] Warning: the LICENSE of wip/ur5-description is undefined. Scanning wip/simple-grasping-action:*~doc Scanning wip/py-multiprocess:*~doc Scanning wip/py-qpoases:*~doc Scanning wip/osg-dae:*~doc Scanning wip/py-roscontrol-sot:*~doc Scanning wip/pal-msgs:*~doc Scanning wip/tiago-metapkg-ros-control-sot:*~doc Scanning wip/backward-ros:*~doc Scanning wip/sot-dynamic-pinocchio-v3:*~doc Scanning wip/ros-swri-string-util:*~doc Scanning wip/rviz-plugin-covariance:*~doc Scanning wip/openhrp3-simulator-wo-rtm:*~doc Scanning wip/py-dill:*~doc Scanning wip/ros-octomap-msgs:*~doc Scanning wip/py-hpp-hrp2:*~doc Scanning wip/hrp2-14-description:*~doc Scanning wip/ros-swri-nodelet:*~doc Scanning wip/py-mraa:*~doc Scanning wip/octovis:*~doc Scanning wip/py-hqp:*~doc Scanning wip/py-parametric-curves:*~doc Scanning wip/py-sot-dynamic-pinocchio-v3:*~doc Scanning wip/py-dynamic-graph-tutorial:*~doc Scanning wip/ros-image-pipeline:*~doc Scanning wip/py-casadi:*~doc Scanning wip/infuse-asn1-types:*~doc Scanning wip/jsbsim:*~doc Scanning wip/hpp-affordance:*~doc Scanning wip/ros-swri-serial-util:*~doc Scanning wip/ros-moveit-msgs:*~doc Scanning wip/pyrene-motions:*~doc Scanning wip/py-scs:*~doc Scanning wip/ros-pcl-msgs:*~doc Scanning wip/play-motion:*~doc Scanning wip/py-hpp-bezier-com-traj:*~doc Scanning wip/py-hpp-universal-robot:*~doc Scanning wip/hatponboard-lib:*~doc Scanning wip/pmb2-simulation:*~doc Scanning wip/py-talos-torque-control:*~doc Scanning wip/hrp2-dev:*~doc Scanning wip/ros-py-urdf-parser:*~doc Scanning wip/can-utils:*~doc Scanning wip/pal-gazebo-worlds:*~doc Scanning wip/libhatp:*~doc Scanning wip/py-cvxpy:*~doc Scanning wip/ros-perception-pcl:*~doc Scanning wip/roralink:*~doc Scanning wip/py-dynamic-graph-bridge-v3:*~doc Scanning wip/py-hpp-rbprm-corba:*~doc Scanning mapping/octomap:octomap>=1.8.0 Scanning wip/fcl:*~doc Scanning wip/py-tiago-tutorials:*~doc Scanning wip/sot-pattern-generator-v3:*~doc Scanning wip/jrl-walkgen-v3:*~doc Scanning wip/py-qt-gepetto-pythonqt:*~doc Scanning wip/py-ecos:*~doc Scanning wip/prf-teleop-tools:*~doc Scanning wip/tiago-moveit-config:*~doc Scanning wip/prf-roboticsgroup-gazebo-plugins:*~doc Scanning wip/py-ros-baxter-common:*~doc Scanning wip/tf-lookup:*~doc Scanning wip/ompl:*~doc Scanning wip/sot-hrp2-v3:*~doc Scanning wip/tiago-robot:*~doc Scanning wip/py-solo-pybullet:*~doc Scanning wip/ros-four-wheel-steering-msgs:*~doc Scanning wip/dynamic-graph-v3:*~doc Scanning wip/morse-ros:*~doc Scanning wip/tiago-data:*~doc Scanning wip/py-prf-gazebo-ros-pkgs:*~doc Scanning wip/py-sot-pattern-generator-v3:*~doc Scanning wip/talos-torque-control:*~doc Scanning wip/pal-navigation-sm:*~doc Scanning wip/py-sot-application-v3:*~doc Scanning wip/py-morse:*~doc Scanning wip/py-sot-talos:*~doc Scanning wip/tiago-simulation:*~doc Scanning wip/py-sot-talos:py38-sot-talos-1.2.1~!doc Scanning wip/py-sot-talos:py37-sot-talos-1.2.1~!doc Scanning wip/py-sot-talos:py36-sot-talos-1.2.1~!doc Scanning wip/py-sot-talos:py35-sot-talos-1.2.1~!doc Scanning wip/py-sot-talos:py34-sot-talos-1.2.1~!doc Scanning wip/py-morse:py38-morse-1.4~!doc Scanning wip/py-morse:py36-morse-1.4~!doc Scanning wip/py-morse:py35-morse-1.4~!doc Scanning wip/py-morse:py34-morse-1.4~!doc Scanning wip/py-sot-application-v3:py38-sot-application-v3-1.2.3~!doc Scanning wip/py-sot-application-v3:py37-sot-application-v3-1.2.3~!doc Scanning wip/py-sot-application-v3:py36-sot-application-v3-1.2.3~!doc Scanning wip/py-sot-application-v3:py35-sot-application-v3-1.2.3~!doc Scanning wip/py-sot-application-v3:py34-sot-application-v3-1.2.3~!doc Scanning wip/py-sot-pattern-generator-v3:py38-sot-pattern-generator-v3-3.3.0~!doc Scanning wip/py-sot-pattern-generator-v3:py37-sot-pattern-generator-v3-3.3.0~!doc Scanning wip/py-sot-pattern-generator-v3:py36-sot-pattern-generator-v3-3.3.0~!doc Scanning wip/py-sot-pattern-generator-v3:py35-sot-pattern-generator-v3-3.3.0~!doc Scanning wip/py-sot-pattern-generator-v3:py34-sot-pattern-generator-v3-3.3.0~!doc Scanning wip/py-prf-gazebo-ros-pkgs:py38-prf-gazebo-ros-pkgs-3.0.1~!doc Scanning wip/py-prf-gazebo-ros-pkgs:py37-prf-gazebo-ros-pkgs-3.0.1~!doc Scanning wip/py-prf-gazebo-ros-pkgs:py36-prf-gazebo-ros-pkgs-3.0.1~!doc Scanning wip/py-prf-gazebo-ros-pkgs:py35-prf-gazebo-ros-pkgs-3.0.1~!doc Scanning wip/py-prf-gazebo-ros-pkgs:py34-prf-gazebo-ros-pkgs-3.0.1~!doc Scanning wip/py-solo-pybullet:py38-solo-pybullet-0.1.0~!doc Scanning wip/py-solo-pybullet:py37-solo-pybullet-0.1.0~!doc Scanning wip/py-solo-pybullet:py36-solo-pybullet-0.1.0~!doc Scanning wip/py-solo-pybullet:py35-solo-pybullet-0.1.0~!doc Scanning wip/py-solo-pybullet:py34-solo-pybullet-0.1.0~!doc Scanning wip/py-ros-baxter-common:py38-ros-baxter-common-1.2.0r1~!doc Scanning wip/py-ros-baxter-common:py37-ros-baxter-common-1.2.0r1~!doc Scanning wip/py-ros-baxter-common:py36-ros-baxter-common-1.2.0r1~!doc Scanning wip/py-ros-baxter-common:py35-ros-baxter-common-1.2.0r1~!doc Scanning wip/py-ros-baxter-common:py34-ros-baxter-common-1.2.0r1~!doc Scanning wip/py-ecos:py38-ecos-2.0.7.post1~!doc Scanning wip/py-ecos:py37-ecos-2.0.7.post1~!doc Scanning wip/py-ecos:py36-ecos-2.0.7.post1~!doc Scanning wip/py-ecos:py35-ecos-2.0.7.post1~!doc Scanning wip/py-ecos:py34-ecos-2.0.7.post1~!doc Scanning wip/py-qt-gepetto-pythonqt:py38-qt5-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py38-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py37-qt5-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py37-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py36-qt5-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py36-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py35-qt5-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py35-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py34-qt5-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py34-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-qt-gepetto-pythonqt:py27-qt4-gepetto-pythonqt-0.0.1r2~!doc Scanning wip/py-tiago-tutorials:py38-tiago-tutorials-2.0.3~!doc Scanning wip/py-tiago-tutorials:py37-tiago-tutorials-2.0.3~!doc Scanning wip/py-tiago-tutorials:py36-tiago-tutorials-2.0.3~!doc Scanning wip/py-tiago-tutorials:py35-tiago-tutorials-2.0.3~!doc Scanning wip/py-tiago-tutorials:py34-tiago-tutorials-2.0.3~!doc Scanning wip/py-hpp-rbprm-corba:py38-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py37-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py36-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py35-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py34-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py27-hpp-rbprm-corba-4.9.0r1~!doc Scanning wip/py-hpp-rbprm-corba:py38-hpp-rbprm-corba-4.9.0r1~doc Scanning wip/py-hpp-rbprm-corba:py37-hpp-rbprm-corba-4.9.0r1~doc Scanning wip/py-hpp-rbprm-corba:py36-hpp-rbprm-corba-4.9.0r1~doc Scanning wip/py-hpp-rbprm-corba:py35-hpp-rbprm-corba-4.9.0r1~doc Scanning wip/py-hpp-rbprm-corba:py34-hpp-rbprm-corba-4.9.0r1~doc Scanning wip/py-dynamic-graph-bridge-v3:py38-dynamic-graph-bridge-v3-3.3.2~!doc Scanning wip/py-dynamic-graph-bridge-v3:py37-dynamic-graph-bridge-v3-3.3.2~!doc Scanning wip/py-dynamic-graph-bridge-v3:py36-dynamic-graph-bridge-v3-3.3.2~!doc Scanning wip/py-dynamic-graph-bridge-v3:py35-dynamic-graph-bridge-v3-3.3.2~!doc Scanning wip/py-dynamic-graph-bridge-v3:py34-dynamic-graph-bridge-v3-3.3.2~!doc Scanning wip/py-cvxpy:py38-cvxpy-1.0.31~!doc Scanning wip/py-cvxpy:py37-cvxpy-1.0.31~!doc Scanning wip/py-cvxpy:py36-cvxpy-1.0.31~!doc Scanning wip/py-cvxpy:py35-cvxpy-1.0.31~!doc Scanning wip/py-cvxpy:py34-cvxpy-1.0.31~!doc Scanning wip/ros-py-urdf-parser:ros-py38-urdf-parser-0.4.0r1~!doc Scanning wip/ros-py-urdf-parser:ros-py37-urdf-parser-0.4.0r1~!doc Scanning wip/ros-py-urdf-parser:ros-py36-urdf-parser-0.4.0r1~!doc Scanning wip/ros-py-urdf-parser:ros-py35-urdf-parser-0.4.0r1~!doc Scanning wip/ros-py-urdf-parser:ros-py34-urdf-parser-0.4.0r1~!doc Scanning wip/py-talos-torque-control:py38-talos-torque-control-1.0.1~!doc Scanning wip/py-talos-torque-control:py37-talos-torque-control-1.0.1~!doc Scanning wip/py-talos-torque-control:py36-talos-torque-control-1.0.1~!doc Scanning wip/py-talos-torque-control:py35-talos-torque-control-1.0.1~!doc Scanning wip/py-talos-torque-control:py34-talos-torque-control-1.0.1~!doc Scanning wip/hatponboard-lib:hatponboard-lib-3.4.0~!doc Scanning wip/hatponboard-lib:hatponboard-lib-3.4.0~doc Scanning wip/py-hpp-universal-robot:py38-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py37-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py36-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py35-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py34-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py27-hpp-universal-robot-4.9.0~!doc Scanning wip/py-hpp-universal-robot:py38-hpp-universal-robot-4.9.0~doc Scanning wip/py-hpp-universal-robot:py37-hpp-universal-robot-4.9.0~doc Scanning wip/py-hpp-universal-robot:py36-hpp-universal-robot-4.9.0~doc Scanning wip/py-hpp-universal-robot:py35-hpp-universal-robot-4.9.0~doc Scanning wip/py-hpp-universal-robot:py34-hpp-universal-robot-4.9.0~doc Scanning wip/py-hpp-bezier-com-traj:py38-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py37-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py36-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py35-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py34-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py27-hpp-bezier-com-traj-4.9.0~!doc Scanning wip/py-hpp-bezier-com-traj:py38-hpp-bezier-com-traj-4.9.0~doc Scanning wip/py-hpp-bezier-com-traj:py37-hpp-bezier-com-traj-4.9.0~doc Scanning wip/py-hpp-bezier-com-traj:py36-hpp-bezier-com-traj-4.9.0~doc Scanning wip/py-hpp-bezier-com-traj:py35-hpp-bezier-com-traj-4.9.0~doc Scanning wip/py-hpp-bezier-com-traj:py34-hpp-bezier-com-traj-4.9.0~doc Scanning wip/py-scs:py38-scs-2.1.2~!doc Scanning wip/py-scs:py37-scs-2.1.2~!doc Scanning wip/py-scs:py36-scs-2.1.2~!doc Scanning wip/py-scs:py35-scs-2.1.2~!doc Scanning wip/py-scs:py34-scs-2.1.2~!doc Scanning wip/hpp-affordance:hpp-affordance-4.9.0~!doc Scanning wip/py-casadi:py38-casadi-3.4.5~!doc Scanning wip/py-casadi:py37-casadi-3.4.5~!doc Scanning wip/py-casadi:py36-casadi-3.4.5~!doc Scanning wip/py-casadi:py35-casadi-3.4.5~!doc Scanning wip/py-casadi:py34-casadi-3.4.5~!doc Scanning wip/py-dynamic-graph-tutorial:py38-dynamic-graph-tutorial-1.2.1~!doc Scanning wip/py-dynamic-graph-tutorial:py37-dynamic-graph-tutorial-1.2.1~!doc Scanning wip/py-dynamic-graph-tutorial:py36-dynamic-graph-tutorial-1.2.1~!doc Scanning wip/py-dynamic-graph-tutorial:py35-dynamic-graph-tutorial-1.2.1~!doc Scanning wip/py-dynamic-graph-tutorial:py34-dynamic-graph-tutorial-1.2.1~!doc Scanning wip/py-sot-dynamic-pinocchio-v3:py38-sot-dynamic-pinocchio-v3-3.5.1~!doc Scanning wip/py-sot-dynamic-pinocchio-v3:py37-sot-dynamic-pinocchio-v3-3.5.1~!doc Scanning wip/py-sot-dynamic-pinocchio-v3:py36-sot-dynamic-pinocchio-v3-3.5.1~!doc Scanning wip/py-sot-dynamic-pinocchio-v3:py35-sot-dynamic-pinocchio-v3-3.5.1~!doc Scanning wip/py-sot-dynamic-pinocchio-v3:py34-sot-dynamic-pinocchio-v3-3.5.1~!doc Scanning wip/py-parametric-curves:py38-parametric-curves-1.3.1~!doc Scanning wip/py-parametric-curves:py37-parametric-curves-1.3.1~!doc Scanning wip/py-parametric-curves:py36-parametric-curves-1.3.1~!doc Scanning wip/py-parametric-curves:py35-parametric-curves-1.3.1~!doc Scanning wip/py-parametric-curves:py34-parametric-curves-1.3.1~!doc Scanning wip/py-hpp-hrp2:py38-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py37-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py36-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py35-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py34-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py27-hpp-hrp2-4.9.0~!doc Scanning wip/py-hpp-hrp2:py38-hpp-hrp2-4.9.0~doc Scanning wip/py-hpp-hrp2:py37-hpp-hrp2-4.9.0~doc Scanning wip/py-hpp-hrp2:py36-hpp-hrp2-4.9.0~doc Scanning wip/py-hpp-hrp2:py35-hpp-hrp2-4.9.0~doc Scanning wip/py-hpp-hrp2:py34-hpp-hrp2-4.9.0~doc Scanning wip/py-dill:py38-dill-0.3.1.1~!doc Scanning wip/py-dill:py37-dill-0.3.1.1~!doc Scanning wip/py-dill:py36-dill-0.3.1.1~!doc Scanning wip/py-dill:py35-dill-0.3.1.1~!doc Scanning wip/py-dill:py34-dill-0.3.1.1~!doc Scanning wip/py-roscontrol-sot:py38-roscontrol-sot-0.5.0~!doc Scanning wip/py-roscontrol-sot:py37-roscontrol-sot-0.5.0~!doc Scanning wip/py-roscontrol-sot:py36-roscontrol-sot-0.5.0~!doc Scanning wip/py-roscontrol-sot:py35-roscontrol-sot-0.5.0~!doc Scanning wip/py-roscontrol-sot:py34-roscontrol-sot-0.5.0~!doc Scanning wip/py-qpoases:py38-qpoases-3.2.1~!doc Scanning wip/py-qpoases:py37-qpoases-3.2.1~!doc Scanning wip/py-qpoases:py36-qpoases-3.2.1~!doc Scanning wip/py-qpoases:py35-qpoases-3.2.1~!doc Scanning wip/py-qpoases:py34-qpoases-3.2.1~!doc Scanning wip/py-multiprocess:py38-multiprocess-0.70.9~!doc Scanning wip/py-multiprocess:py37-multiprocess-0.70.9~!doc Scanning wip/py-multiprocess:py36-multiprocess-0.70.9~!doc Scanning wip/py-multiprocess:py35-multiprocess-0.70.9~!doc Scanning wip/py-multiprocess:py34-multiprocess-0.70.9~!doc Scanning wip/py-hpp-rbprm:py38-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py37-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py36-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py35-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py34-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py27-hpp-rbprm-4.9.0r1~!doc Scanning wip/py-hpp-rbprm:py38-hpp-rbprm-4.9.0r1~doc Scanning wip/py-hpp-rbprm:py37-hpp-rbprm-4.9.0r1~doc Scanning wip/py-hpp-rbprm:py36-hpp-rbprm-4.9.0r1~doc Scanning wip/py-hpp-rbprm:py35-hpp-rbprm-4.9.0r1~doc Scanning wip/py-hpp-rbprm:py34-hpp-rbprm-4.9.0r1~doc Scanning wip/rqt-dynamic-graph:py38-rqt-dynamic-graph-1.0.0~!doc Scanning wip/rqt-dynamic-graph:py37-rqt-dynamic-graph-1.0.0~!doc Scanning wip/rqt-dynamic-graph:py36-rqt-dynamic-graph-1.0.0~!doc Scanning wip/rqt-dynamic-graph:py35-rqt-dynamic-graph-1.0.0~!doc Scanning wip/rqt-dynamic-graph:py34-rqt-dynamic-graph-1.0.0~!doc Scanning wip/py-gurobi:py38-gurobi-9.0.2~!doc [wip/py-gurobi:py38-gurobi-9.0.2~!doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/py-gurobi:py37-gurobi-9.0.2~!doc [wip/py-gurobi:py37-gurobi-9.0.2~!doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/py-gurobi:py36-gurobi-9.0.2~!doc [wip/py-gurobi:py36-gurobi-9.0.2~!doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/py-gurobi:py35-gurobi-9.0.2~!doc [wip/py-gurobi:py35-gurobi-9.0.2~!doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/py-gurobi:py34-gurobi-9.0.2~!doc [wip/py-gurobi:py34-gurobi-9.0.2~!doc] Warning: the LICENSE of wip/py-gurobi is undefined. Scanning wip/py-sot-talos-balance:py38-sot-talos-balance-1.9.0~!doc Scanning wip/py-sot-talos-balance:py37-sot-talos-balance-1.9.0~!doc Scanning wip/py-sot-talos-balance:py36-sot-talos-balance-1.9.0~!doc Scanning wip/py-sot-talos-balance:py35-sot-talos-balance-1.9.0~!doc Scanning wip/py-sot-talos-balance:py34-sot-talos-balance-1.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py38-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py37-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py36-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py35-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py34-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py27-hpp-rbprm-robot-data-4.9.0~!doc Scanning wip/py-hpp-rbprm-robot-data:py38-hpp-rbprm-robot-data-4.9.0~doc Scanning wip/py-hpp-rbprm-robot-data:py37-hpp-rbprm-robot-data-4.9.0~doc Scanning wip/py-hpp-rbprm-robot-data:py36-hpp-rbprm-robot-data-4.9.0~doc Scanning wip/py-hpp-rbprm-robot-data:py35-hpp-rbprm-robot-data-4.9.0~doc Scanning wip/py-hpp-rbprm-robot-data:py34-hpp-rbprm-robot-data-4.9.0~doc Scanning wip/py-hpp-affordance-corba:py38-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py37-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py36-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py35-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py34-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py27-hpp-affordance-corba-4.9.0~!doc Scanning wip/py-hpp-affordance-corba:py38-hpp-affordance-corba-4.9.0~doc Scanning wip/py-hpp-affordance-corba:py37-hpp-affordance-corba-4.9.0~doc Scanning wip/py-hpp-affordance-corba:py36-hpp-affordance-corba-4.9.0~doc Scanning wip/py-hpp-affordance-corba:py35-hpp-affordance-corba-4.9.0~doc Scanning wip/py-hpp-affordance-corba:py34-hpp-affordance-corba-4.9.0~doc Scanning wip/py-hpp-baxter:py38-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py37-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py36-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py35-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py34-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py27-hpp-baxter-4.9.0~!doc Scanning wip/py-hpp-baxter:py38-hpp-baxter-4.9.0~doc Scanning wip/py-hpp-baxter:py37-hpp-baxter-4.9.0~doc Scanning wip/py-hpp-baxter:py36-hpp-baxter-4.9.0~doc Scanning wip/py-hpp-baxter:py35-hpp-baxter-4.9.0~doc Scanning wip/py-hpp-baxter:py34-hpp-baxter-4.9.0~doc Scanning wip/py-pal-statistics:py38-pal-statistics-1.3.1r4~!doc Scanning wip/py-pal-statistics:py37-pal-statistics-1.3.1r4~!doc Scanning wip/py-pal-statistics:py36-pal-statistics-1.3.1r4~!doc Scanning wip/py-pal-statistics:py35-pal-statistics-1.3.1r4~!doc Scanning wip/py-pal-statistics:py34-pal-statistics-1.3.1r4~!doc Scanning wip/py-hpp-spline:py38-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py37-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py36-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py35-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py34-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py27-hpp-spline-4.8.2~!doc Scanning wip/py-hpp-spline:py38-hpp-spline-4.8.2~doc Scanning wip/py-hpp-spline:py37-hpp-spline-4.8.2~doc Scanning wip/py-hpp-spline:py36-hpp-spline-4.8.2~doc Scanning wip/py-hpp-spline:py35-hpp-spline-4.8.2~doc Scanning wip/py-hpp-spline:py34-hpp-spline-4.8.2~doc Scanning wip/py-sl1m:py38-sl1m-0.1.0~!doc Scanning wip/py-sl1m:py37-sl1m-0.1.0~!doc Scanning wip/py-sl1m:py36-sl1m-0.1.0~!doc Scanning wip/py-sl1m:py35-sl1m-0.1.0~!doc Scanning wip/py-sl1m:py34-sl1m-0.1.0~!doc Scanning wip/py-hpp-romeo:py38-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py37-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py36-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py35-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py34-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py27-hpp-romeo-4.9.0~!doc Scanning wip/py-hpp-romeo:py38-hpp-romeo-4.9.0~doc Scanning wip/py-hpp-romeo:py37-hpp-romeo-4.9.0~doc Scanning wip/py-hpp-romeo:py36-hpp-romeo-4.9.0~doc Scanning wip/py-hpp-romeo:py35-hpp-romeo-4.9.0~doc Scanning wip/py-hpp-romeo:py34-hpp-romeo-4.9.0~doc Scanning wip/py-sot-tiago:py38-sot-tiago-1.4.1~!doc Scanning wip/py-sot-tiago:py37-sot-tiago-1.4.1~!doc Scanning wip/py-sot-tiago:py36-sot-tiago-1.4.1~!doc Scanning wip/py-sot-tiago:py35-sot-tiago-1.4.1~!doc Scanning wip/py-sot-tiago:py34-sot-tiago-1.4.1~!doc Scanning wip/hpp-benchmark:py38-qt5-hpp-benchmark~!doc Scanning graphics/py-qt-hpp-gepetto-viewer:py38-qt5-hpp-gepetto-viewer>=4.9.0 Scanning wip/hpp-benchmark:py38-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py37-qt5-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py37-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py36-qt5-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py36-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py35-qt5-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py35-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py34-qt5-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py34-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py27-qt5-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py27-qt4-hpp-benchmark~!doc Scanning wip/hpp-benchmark:py38-qt5-hpp-benchmark~doc Scanning wip/hpp-benchmark:py38-qt4-hpp-benchmark~doc Scanning wip/hpp-benchmark:py37-qt5-hpp-benchmark~doc Scanning wip/hpp-benchmark:py37-qt4-hpp-benchmark~doc Scanning wip/hpp-benchmark:py36-qt5-hpp-benchmark~doc Scanning wip/hpp-benchmark:py36-qt4-hpp-benchmark~doc Scanning wip/hpp-benchmark:py35-qt5-hpp-benchmark~doc Scanning wip/hpp-benchmark:py35-qt4-hpp-benchmark~doc Scanning wip/hpp-benchmark:py34-qt5-hpp-benchmark~doc Scanning wip/hpp-benchmark:py34-qt4-hpp-benchmark~doc Scanning wip/hpp-benchmark:py27-qt4-hpp-benchmark~doc Scanning wip/py-pycddlib:py38-pycddlib-2.1.1~!doc Scanning wip/py-pycddlib:py37-pycddlib-2.1.1~!doc Scanning wip/py-pycddlib:py36-pycddlib-2.1.1~!doc Scanning wip/py-pycddlib:py35-pycddlib-2.1.1~!doc Scanning wip/py-pycddlib:py34-pycddlib-2.1.1~!doc Scanning wip/py-hpp-centroidal-dynamics:py38-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py37-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py36-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py35-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py34-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py27-hpp-centroidal-dynamics-4.9.0~!doc Scanning wip/py-hpp-centroidal-dynamics:py38-hpp-centroidal-dynamics-4.9.0~doc Scanning wip/py-hpp-centroidal-dynamics:py37-hpp-centroidal-dynamics-4.9.0~doc Scanning wip/py-hpp-centroidal-dynamics:py36-hpp-centroidal-dynamics-4.9.0~doc Scanning wip/py-hpp-centroidal-dynamics:py35-hpp-centroidal-dynamics-4.9.0~doc Scanning wip/py-hpp-centroidal-dynamics:py34-hpp-centroidal-dynamics-4.9.0~doc Scanning wip/py-sot-torque-control:py38-sot-torque-control-1.5.2~!doc Scanning wip/py-sot-torque-control:py37-sot-torque-control-1.5.2~!doc Scanning wip/py-sot-torque-control:py36-sot-torque-control-1.5.2~!doc Scanning wip/py-sot-torque-control:py35-sot-torque-control-1.5.2~!doc Scanning wip/py-sot-torque-control:py34-sot-torque-control-1.5.2~!doc Scanning wip/py-multicontact-api:py38-multicontact-api-2.0.0~!doc Scanning wip/py-multicontact-api:py37-multicontact-api-2.0.0~!doc Scanning wip/py-multicontact-api:py36-multicontact-api-2.0.0~!doc Scanning wip/py-multicontact-api:py35-multicontact-api-2.0.0~!doc Scanning wip/py-multicontact-api:py34-multicontact-api-2.0.0~!doc Scanning wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* Scanning wip/dptu-genom3:dptu-genom3-0.2~codels+pocolibs-client-c+openprs+pocolibs-server+!*+!doc Scanning wip/py-talos-dev:py38-talos-dev-20200511~!doc Scanning wip/py-talos-dev:py37-talos-dev-20200511~!doc Scanning wip/py-talos-dev:py36-talos-dev-20200511~!doc Scanning wip/py-talos-dev:py35-talos-dev-20200511~!doc Scanning wip/py-talos-dev:py34-talos-dev-20200511~!doc Scanning wip/py-example-adder:py38-example-adder-2.0.1~!doc Scanning wip/py-example-adder:py37-example-adder-2.0.1~!doc Scanning wip/py-example-adder:py36-example-adder-2.0.1~!doc Scanning wip/py-example-adder:py35-example-adder-2.0.1~!doc Scanning wip/py-example-adder:py34-example-adder-2.0.1~!doc Scanning wip/py-talos-rbprm:py38-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py37-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py36-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py35-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py34-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py27-talos-rbprm-4.9.0~!doc Scanning wip/py-talos-rbprm:py38-talos-rbprm-4.9.0~doc Scanning wip/py-talos-rbprm:py37-talos-rbprm-4.9.0~doc Scanning wip/py-talos-rbprm:py36-talos-rbprm-4.9.0~doc Scanning wip/py-talos-rbprm:py35-talos-rbprm-4.9.0~doc Scanning wip/py-talos-rbprm:py34-talos-rbprm-4.9.0~doc Scanning wip/py-prf-ros-control:py38-prf-ros-control-0.2.8r2~!doc Scanning wip/py-prf-ros-control:py37-prf-ros-control-0.2.8r2~!doc Scanning wip/py-prf-ros-control:py36-prf-ros-control-0.2.8r2~!doc Scanning wip/py-prf-ros-control:py35-prf-ros-control-0.2.8r2~!doc Scanning wip/py-prf-ros-control:py34-prf-ros-control-0.2.8r2~!doc Scanning wip/msgconnector:msgconnector-2.13.0~!doc Scanning wip/py-osqp:py38-osqp-0.6.1~!doc Scanning wip/py-osqp:py37-osqp-0.6.1~!doc Scanning wip/py-osqp:py36-osqp-0.6.1~!doc Scanning wip/py-osqp:py35-osqp-0.6.1~!doc Scanning wip/py-osqp:py34-osqp-0.6.1~!doc Scanning wip/py-dynamic-graph-v3:py38-dynamic-graph-v3-3.5.2~!doc Scanning wip/py-dynamic-graph-v3:py37-dynamic-graph-v3-3.5.2~!doc Scanning wip/py-dynamic-graph-v3:py36-dynamic-graph-v3-3.5.2~!doc Scanning wip/py-dynamic-graph-v3:py35-dynamic-graph-v3-3.5.2~!doc Scanning wip/py-dynamic-graph-v3:py34-dynamic-graph-v3-3.5.2~!doc Scanning wip/py-prf-ros-controllers:py38-prf-ros-controllers-0.3.15r2~!doc Scanning wip/py-prf-ros-controllers:py37-prf-ros-controllers-0.3.15r2~!doc Scanning wip/py-prf-ros-controllers:py36-prf-ros-controllers-0.3.15r2~!doc Scanning wip/py-prf-ros-controllers:py35-prf-ros-controllers-0.3.15r2~!doc Scanning wip/py-prf-ros-controllers:py34-prf-ros-controllers-0.3.15r2~!doc Scanning wip/py-sot-tools-v3:py38-sot-tools-v3-2.2.2~!doc Scanning wip/py-sot-tools-v3:py37-sot-tools-v3-2.2.2~!doc Scanning wip/py-sot-tools-v3:py36-sot-tools-v3-2.2.2~!doc Scanning wip/py-sot-tools-v3:py35-sot-tools-v3-2.2.2~!doc Scanning wip/py-sot-tools-v3:py34-sot-tools-v3-2.2.2~!doc Scanning wip/py-libnabo:py38-libnabo-1.0.7r1~!doc Scanning wip/py-libnabo:py37-libnabo-1.0.7r1~!doc Scanning wip/py-libnabo:py36-libnabo-1.0.7r1~!doc Scanning wip/py-libnabo:py35-libnabo-1.0.7r1~!doc Scanning wip/py-libnabo:py34-libnabo-1.0.7r1~!doc Scanning wip/py-pal:py38-pal-python-0.9.14os1~!doc Scanning wip/py-pal:py37-pal-python-0.9.14os1~!doc Scanning wip/py-pal:py36-pal-python-0.9.14os1~!doc Scanning wip/py-pal:py35-pal-python-0.9.14os1~!doc Scanning wip/py-pal:py34-pal-python-0.9.14os1~!doc Scanning wip/py-sot-core-v3:py38-sot-core-v3-4.9.0~!doc Scanning wip/py-sot-core-v3:py37-sot-core-v3-4.9.0~!doc Scanning wip/py-sot-core-v3:py36-sot-core-v3-4.9.0~!doc Scanning wip/py-sot-core-v3:py35-sot-core-v3-4.9.0~!doc Scanning wip/py-sot-core-v3:py34-sot-core-v3-4.9.0~!doc Scanning wip/py-mavlink:py38-mavlink-1.1.62~!doc Scanning wip/py-mavlink:py37-mavlink-1.1.62~!doc Scanning wip/py-mavlink:py36-mavlink-1.1.62~!doc Scanning wip/py-mavlink:py35-mavlink-1.1.62~!doc Scanning wip/py-mavlink:py34-mavlink-1.1.62~!doc Scanned 833 packages (755 unique) [24%] Processing wip/py-ros-baxter-common:py27-ros-baxter-common-1.2.0r1~!doc ===> Cleaning temporary files for py27-ros-baxter-common-1.2.0r1 ===> Bulk building for py27-ros-baxter-common-1.2.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-ros-baxter-common-1.2.0r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-ros-baxter-common/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-ros-baxter-common-1.2.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-ros-baxter-common-1.2.0r1 ===> Done bulk for py27-ros-baxter-common-1.2.0r1 [24%] Processing wip/py-ros-baxter-common:py34-ros-baxter-common-1.2.0r1~!doc ===> Bulk building for py34-ros-baxter-common-1.2.0r1 Binary package for py34-ros-baxter-common-1.2.0r1 is up-to-date. [24%] Processing wip/py-ros-baxter-common:py35-ros-baxter-common-1.2.0r1~!doc ===> Bulk building for py35-ros-baxter-common-1.2.0r1 Binary package for py35-ros-baxter-common-1.2.0r1 is up-to-date. [24%] Processing wip/py-ros-baxter-common:py36-ros-baxter-common-1.2.0r1~!doc ===> Bulk building for py36-ros-baxter-common-1.2.0r1 Binary package for py36-ros-baxter-common-1.2.0r1 is up-to-date. [24%] Processing wip/py-ros-baxter-common:py37-ros-baxter-common-1.2.0r1~!doc ===> Cleaning temporary files for py37-ros-baxter-common-1.2.0r1 ===> Bulk building for py37-ros-baxter-common-1.2.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-ros-baxter-common-1.2.0r1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-ros-baxter-common/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-ros-baxter-common-1.2.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-ros-baxter-common-1.2.0r1 ===> Done bulk for py37-ros-baxter-common-1.2.0r1 [25%] Processing wip/py-ros-baxter-common:py38-ros-baxter-common-1.2.0r1~!doc ===> Bulk building for py38-ros-baxter-common-1.2.0r1 Binary package for py38-ros-baxter-common-1.2.0r1 is up-to-date. [25%] Processing wip/ompl:ompl-1.4.1~!doc ===> Cleaning temporary files for ompl-1.4.1 ===> Bulk building for ompl-1.4.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.54: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.54: boost-libs-1.71.0 found => Required system package boostlib-math>=1.54: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.54: boost-libs-1.71.0 found => Required system package cmake>=2.8.7: cmake-3.16.3 found => Required system package g++>=4.8: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | /usr/bin/g++ -std=c++11 -pipe -O3 -DNDEBUG -O3 -rdynamic CMakeFiles/demo_ThunderLightning.dir/ThunderLightning.cpp.o -o ../bin/demo_ThunderLightning -Wl,-rpath,/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source/lib ../lib/libompl.so.1.4.1 /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_serialization.so.1.71.0 -lpthread | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source' | [ 94%] Built target demo_ThunderLightning | [ 94%] Linking CXX executable ../bin/demo_CForestCircleGridBenchmark | cd /local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source/demos && /usr/bin/cmake -E cmake_link_script CMakeFiles/demo_CForestCircleGridBenchmark.dir/link.txt --verbose=1 | /usr/bin/g++ -std=c++11 -pipe -O3 -DNDEBUG -O3 -rdynamic CMakeFiles/demo_CForestCircleGridBenchmark.dir/CForestCircleGridBenchmark.cpp.o -o ../bin/demo_CForestCircleGridBenchmark -Wl,-rpath,/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source/lib ../lib/libompl.so.1.4.1 /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.71.0 /usr/lib/x86_64-linux-gnu/libboost_serialization.so.1.71.0 -lpthread | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source' | [ 94%] Built target demo_CForestCircleGridBenchmark | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.4.1-Source' | make: *** [Makefile:166: all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/ompl/work/build.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/build/build.mk:199: do-build] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking ompl-1.4.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for ompl-1.4.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ompl-1.4.1 ===> Done bulk for ompl-1.4.1 [25%] Processing wip/tf-lookup:tf-lookup-0.0.1r1~!doc ===> Cleaning temporary files for tf-lookup-0.0.1r1 ===> Bulk building for tf-lookup-0.0.1r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tf-lookup-0.0.1r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tf-lookup/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tf-lookup-0.0.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tf-lookup-0.0.1r1 ===> Done bulk for tf-lookup-0.0.1r1 [25%] Processing wip/py-solo-pybullet:py27-solo-pybullet-0.1.0~!doc ===> Cleaning temporary files for py27-solo-pybullet-0.1.0 ===> Bulk building for py27-solo-pybullet-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-example-robot-data>=2.0.0: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-solo-pybullet-0.1.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-solo-pybullet/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-solo-pybullet-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-solo-pybullet-0.1.0 ===> Done bulk for py27-solo-pybullet-0.1.0 [25%] Processing wip/py-solo-pybullet:py34-solo-pybullet-0.1.0~!doc ===> Bulk building for py34-solo-pybullet-0.1.0 Binary package for py34-solo-pybullet-0.1.0 is up-to-date. [25%] Processing wip/py-solo-pybullet:py35-solo-pybullet-0.1.0~!doc ===> Bulk building for py35-solo-pybullet-0.1.0 Binary package for py35-solo-pybullet-0.1.0 is up-to-date. [25%] Processing wip/py-solo-pybullet:py36-solo-pybullet-0.1.0~!doc ===> Bulk building for py36-solo-pybullet-0.1.0 Binary package for py36-solo-pybullet-0.1.0 is up-to-date. [26%] Processing wip/py-solo-pybullet:py37-solo-pybullet-0.1.0~!doc ===> Cleaning temporary files for py37-solo-pybullet-0.1.0 ===> Bulk building for py37-solo-pybullet-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-example-robot-data>=2.0.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-solo-pybullet-0.1.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-solo-pybullet/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-solo-pybullet-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-solo-pybullet-0.1.0 ===> Done bulk for py37-solo-pybullet-0.1.0 [26%] Processing wip/py-solo-pybullet:py38-solo-pybullet-0.1.0~!doc ===> Bulk building for py38-solo-pybullet-0.1.0 Binary package for py38-solo-pybullet-0.1.0 is up-to-date. [26%] Processing wip/ros-four-wheel-steering-msgs:ros-four-wheel-steering-msgs-1.0.0~!doc ===> Cleaning temporary files for ros-four-wheel-steering-msgs-1.0.0 ===> Bulk building for ros-four-wheel-steering-msgs-1.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-four-wheel-steering-msgs-1.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-four-wheel-steering-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-four-wheel-steering-msgs-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-four-wheel-steering-msgs-1.0.0 ===> Done bulk for ros-four-wheel-steering-msgs-1.0.0 [26%] Processing wip/dynamic-graph-v3:dynamic-graph-v3-4.1.0~!doc ===> Bulk building for dynamic-graph-v3-4.1.0 Binary package for dynamic-graph-v3-4.1.0 is up-to-date. [26%] Processing wip/morse-ros:morse-ros-1.4~!doc ===> Cleaning temporary files for morse-ros-1.4 ===> Bulk building for morse-ros-1.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package morse>=1.0: N/A => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for morse-ros-1.4: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/morse-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for morse-ros-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for morse-ros-1.4 ===> Done bulk for morse-ros-1.4 [26%] Processing wip/tiago-data:tiago-data-1.1.0~!doc ===> Cleaning temporary files for tiago-data-1.1.0 ===> Bulk building for tiago-data-1.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-data-1.1.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-data/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-data-1.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-data-1.1.0 ===> Done bulk for tiago-data-1.1.0 [28%] Processing wip/py-morse:py34-morse-1.4~!doc ===> Bulk building for py34-morse-1.4 Binary package for py34-morse-1.4 is up-to-date. [28%] Processing wip/py-morse:py35-morse-1.4~!doc ===> Bulk building for py35-morse-1.4 Binary package for py35-morse-1.4 is up-to-date. [28%] Processing wip/py-morse:py36-morse-1.4~!doc ===> Bulk building for py36-morse-1.4 Binary package for py36-morse-1.4 is up-to-date. [28%] Processing wip/py-morse:py37-morse-1.4~!doc ===> Cleaning temporary files for py37-morse-1.4 ===> Bulk building for py37-morse-1.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-morse-1.4: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-morse/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-morse-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-morse-1.4 ===> Done bulk for py37-morse-1.4 [28%] Processing wip/py-morse:py38-morse-1.4~!doc ===> Bulk building for py38-morse-1.4 Binary package for py38-morse-1.4 is up-to-date. [29%] Processing wip/py-mavlink:py27-mavlink-1.1.62~!doc ===> Bulk building for py27-mavlink-1.1.62 Binary package for py27-mavlink-1.1.62 is up-to-date. [29%] Processing wip/py-mavlink:py34-mavlink-1.1.62~!doc ===> Bulk building for py34-mavlink-1.1.62 Binary package for py34-mavlink-1.1.62 is up-to-date. [29%] Processing wip/py-mavlink:py35-mavlink-1.1.62~!doc ===> Bulk building for py35-mavlink-1.1.62 Binary package for py35-mavlink-1.1.62 is up-to-date. [29%] Processing wip/py-mavlink:py36-mavlink-1.1.62~!doc ===> Bulk building for py36-mavlink-1.1.62 Binary package for py36-mavlink-1.1.62 is up-to-date. [29%] Processing wip/py-mavlink:py37-mavlink-1.1.62~!doc ===> Cleaning temporary files for py37-mavlink-1.1.62 ===> Bulk building for py37-mavlink-1.1.62 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.25.1 found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-mavlink-1.1.62: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-mavlink/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-mavlink-1.1.62 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-mavlink-1.1.62 ===> Done bulk for py37-mavlink-1.1.62 [29%] Processing wip/py-mavlink:py38-mavlink-1.1.62~!doc ===> Bulk building for py38-mavlink-1.1.62 Binary package for py38-mavlink-1.1.62 is up-to-date. [29%] Processing wip/head-action:head-action-0.0.1r4~!doc ===> Cleaning temporary files for head-action-0.0.1r4 ===> Bulk building for head-action-0.0.1r4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/orocos-kdl-1.4.0.tgz => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-kdl-parser>=1.13<1.14: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-orocos-kinematics-dynamics>=1.1: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for head-action-0.0.1r4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/head-action/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for head-action-0.0.1r4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for head-action-0.0.1r4 ===> Done bulk for head-action-0.0.1r4 [29%] Processing wip/soth:soth-2.0.4~!doc ===> Cleaning temporary files for soth-2.0.4 ===> Bulk building for soth-2.0.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=3.1.0: cmake-3.16.3 found => Required system package doxygen>=1.5: doxygen-1.8.17 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | | affects policy settings. CMake is implying the NO_POLICY_SCOPE option for | compatibility, so the effects are applied to the including context. | Call Stack (most recent call first): | cmake/boost.cmake:128 (FIND_PACKAGE) | CMakeLists.txt:53 (SEARCH_FOR_BOOST) | This warning is for project developers. Use -Wno-dev to suppress it. | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/soth/work/soth-2.0.4/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/soth/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking soth-2.0.4 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for soth-2.0.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for soth-2.0.4 ===> Done bulk for soth-2.0.4 [30%] Processing wip/py-pal:py27-pal-python-0.9.14os1~!doc ===> Cleaning temporary files for py27-pal-python-0.9.14os1 ===> Bulk building for py27-pal-python-0.9.14os1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-pal-python-0.9.14os1: ERROR: ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-pal/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-pal-python-0.9.14os1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-pal-python-0.9.14os1 ===> Done bulk for py27-pal-python-0.9.14os1 [30%] Processing wip/py-pal:py34-pal-python-0.9.14os1~!doc ===> Bulk building for py34-pal-python-0.9.14os1 Binary package for py34-pal-python-0.9.14os1 is up-to-date. [30%] Processing wip/py-pal:py35-pal-python-0.9.14os1~!doc ===> Bulk building for py35-pal-python-0.9.14os1 Binary package for py35-pal-python-0.9.14os1 is up-to-date. [30%] Processing wip/py-pal:py36-pal-python-0.9.14os1~!doc ===> Bulk building for py36-pal-python-0.9.14os1 Binary package for py36-pal-python-0.9.14os1 is up-to-date. [30%] Processing wip/py-pal:py37-pal-python-0.9.14os1~!doc ===> Cleaning temporary files for py37-pal-python-0.9.14os1 ===> Bulk building for py37-pal-python-0.9.14os1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-pal-python-0.9.14os1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-pal/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-pal-python-0.9.14os1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-pal-python-0.9.14os1 ===> Done bulk for py37-pal-python-0.9.14os1 [30%] Processing wip/py-pal:py38-pal-python-0.9.14os1~!doc ===> Bulk building for py38-pal-python-0.9.14os1 Binary package for py38-pal-python-0.9.14os1 is up-to-date. [30%] Processing wip/talos-robot:talos-robot-1.1.3~!doc ===> Cleaning temporary files for talos-robot-1.1.3 ===> Bulk building for talos-robot-1.1.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package head-action>=0.0.1: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tf-lookup>=0.0.1: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for talos-robot-1.1.3: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/talos-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for talos-robot-1.1.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-robot-1.1.3 ===> Done bulk for talos-robot-1.1.3 [30%] Processing wip/py-libnabo:py27-libnabo-1.0.7r1~!doc ===> Cleaning temporary files for py27-libnabo-1.0.7r1 ===> Bulk building for py27-libnabo-1.0.7r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-libnabo-1.0.7r1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-libnabo/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-libnabo-1.0.7r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-libnabo-1.0.7r1 ===> Done bulk for py27-libnabo-1.0.7r1 [31%] Processing wip/py-libnabo:py34-libnabo-1.0.7r1~!doc ===> Bulk building for py34-libnabo-1.0.7r1 Binary package for py34-libnabo-1.0.7r1 is up-to-date. [31%] Processing wip/py-libnabo:py35-libnabo-1.0.7r1~!doc ===> Bulk building for py35-libnabo-1.0.7r1 Binary package for py35-libnabo-1.0.7r1 is up-to-date. [31%] Processing wip/py-libnabo:py36-libnabo-1.0.7r1~!doc ===> Bulk building for py36-libnabo-1.0.7r1 Binary package for py36-libnabo-1.0.7r1 is up-to-date. [31%] Processing wip/py-libnabo:py37-libnabo-1.0.7r1~!doc ===> Cleaning temporary files for py37-libnabo-1.0.7r1 ===> Bulk building for py37-libnabo-1.0.7r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-libnabo-1.0.7r1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-libnabo/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-libnabo-1.0.7r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-libnabo-1.0.7r1 ===> Done bulk for py37-libnabo-1.0.7r1 [31%] Processing wip/py-libnabo:py38-libnabo-1.0.7r1~!doc ===> Bulk building for py38-libnabo-1.0.7r1 Binary package for py38-libnabo-1.0.7r1 is up-to-date. [31%] Processing wip/cppad:cppad-20200000.2~!doc ===> Bulk building for cppad-20200000.2 Binary package for cppad-20200000.2 is up-to-date. [31%] Processing wip/py-bmtools:py27-bmtools-1.0.1~!doc ===> Bulk building for py27-bmtools-1.0.1 Binary package for py27-bmtools-1.0.1 is up-to-date. [32%] Processing wip/urg:urg-0.8.18~!doc ===> Bulk building for urg-0.8.18 Binary package for urg-0.8.18 is up-to-date. [32%] Processing wip/infuse-msgs-ros:infuse-msgs-ros-0.1.0~!doc ===> Cleaning temporary files for infuse-msgs-ros-0.1.0 ===> Bulk building for infuse-msgs-ros-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for infuse-msgs-ros-0.1.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/infuse-msgs-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for infuse-msgs-ros-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for infuse-msgs-ros-0.1.0 ===> Done bulk for infuse-msgs-ros-0.1.0 [32%] Processing wip/pmb2-navigation:pmb2-navigation-2.0.1~!doc ===> Cleaning temporary files for pmb2-navigation-2.0.1 ===> Bulk building for pmb2-navigation-2.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pmb2-navigation-2.0.1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pmb2-navigation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pmb2-navigation-2.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pmb2-navigation-2.0.1 ===> Done bulk for pmb2-navigation-2.0.1 [32%] Processing wip/infuse-idl:infuse-idl-0.1.1~!doc ===> Bulk building for infuse-idl-0.1.1 Binary package for infuse-idl-0.1.1 is up-to-date. [32%] Processing wip/py-dynamic-graph-v3:py27-dynamic-graph-v3-3.5.2~!doc ===> Cleaning temporary files for py27-dynamic-graph-v3-3.5.2 ===> Bulk building for py27-dynamic-graph-v3-3.5.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Required system package py-sphinx>=1.1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-dynamic-graph-v3-3.5.2: ERROR: ERROR: py-sphinx>=1.1 (Ubuntu package python-sphinx) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-dynamic-graph-v3-3.5.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-dynamic-graph-v3-3.5.2 ===> Done bulk for py27-dynamic-graph-v3-3.5.2 [32%] Processing wip/py-dynamic-graph-v3:py34-dynamic-graph-v3-3.5.2~!doc ===> Bulk building for py34-dynamic-graph-v3-3.5.2 Binary package for py34-dynamic-graph-v3-3.5.2 is up-to-date. [32%] Processing wip/py-dynamic-graph-v3:py35-dynamic-graph-v3-3.5.2~!doc ===> Bulk building for py35-dynamic-graph-v3-3.5.2 Binary package for py35-dynamic-graph-v3-3.5.2 is up-to-date. [32%] Processing wip/py-dynamic-graph-v3:py36-dynamic-graph-v3-3.5.2~!doc ===> Bulk building for py36-dynamic-graph-v3-3.5.2 Binary package for py36-dynamic-graph-v3-3.5.2 is up-to-date. [33%] Processing wip/py-dynamic-graph-v3:py37-dynamic-graph-v3-3.5.2~!doc ===> Cleaning temporary files for py37-dynamic-graph-v3-3.5.2 ===> Bulk building for py37-dynamic-graph-v3-3.5.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-dynamic-graph-v3-3.5.2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-dynamic-graph-v3-3.5.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-dynamic-graph-v3-3.5.2 ===> Done bulk for py37-dynamic-graph-v3-3.5.2 [33%] Processing wip/py-dynamic-graph-v3:py38-dynamic-graph-v3-3.5.2~!doc ===> Bulk building for py38-dynamic-graph-v3-3.5.2 Binary package for py38-dynamic-graph-v3-3.5.2 is up-to-date. [33%] Processing wip/py-skeleton-model:py27-skeleton_model-1.0.1~!doc ===> Cleaning temporary files for py27-skeleton_model-1.0.1 ===> Bulk building for py27-skeleton_model-1.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Use python-2.7: python<3 provided by python27>=2.7<2.8 => Required system package py27-setuptools: py27-setuptools found => Required system package python27>=2.7<2.8: python27-2.7.181 found => SHA1 checksums OK => RMD160 checksums OK => Compiling python files robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/hqp/wrapper.py.orig' => Registering installation for py27-skeleton_model-1.0.1 robotpkg_admin: py27-skeleton_model-1.0.1: File `/opt/openrobots/lib/python2.7/site-packages/hqp/wrapper.py.orig' is in +CONTENTS but not on filesystem! robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/hqp/wrapper.py.orig' robotpkg_create: lstat failed for file lib/python2.7/site-packages/hqp/wrapper.py.orig: No such file or directory make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:74: pkg-tarup] Error 2 => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/pub => Updating debian binary packages make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/package/package.mk:147: package-failed] Error 2 => Marking py27-skeleton_model-1.0.1 as broken ERROR: make: *** [package] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/lib/python2.7/site-packages/hqp/wrapper.py.orig ===> Logging bulk summary for py27-skeleton_model-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-skeleton_model-1.0.1 ===> Done bulk for py27-skeleton_model-1.0.1 [33%] Processing wip/py-osqp:py27-osqp-0.6.1~!doc ===> Cleaning temporary files for py27-osqp-0.6.1 ===> Bulk building for py27-osqp-0.6.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package py27-numpy>=1: MISSING => Required system package py27-scipy>=0.17.0: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-osqp-0.6.1: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-scipy>=0.17.0 (Ubuntu package python-scipy) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-osqp/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-osqp-0.6.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-osqp-0.6.1 ===> Done bulk for py27-osqp-0.6.1 [33%] Processing wip/py-osqp:py34-osqp-0.6.1~!doc ===> Bulk building for py34-osqp-0.6.1 Binary package for py34-osqp-0.6.1 is up-to-date. [33%] Processing wip/py-osqp:py35-osqp-0.6.1~!doc ===> Bulk building for py35-osqp-0.6.1 Binary package for py35-osqp-0.6.1 is up-to-date. [33%] Processing wip/py-osqp:py36-osqp-0.6.1~!doc ===> Bulk building for py36-osqp-0.6.1 Binary package for py36-osqp-0.6.1 is up-to-date. [34%] Processing wip/py-osqp:py37-osqp-0.6.1~!doc ===> Cleaning temporary files for py37-osqp-0.6.1 ===> Bulk building for py37-osqp-0.6.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-osqp-0.6.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-osqp/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-osqp-0.6.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-osqp-0.6.1 ===> Done bulk for py37-osqp-0.6.1 [34%] Processing wip/py-osqp:py38-osqp-0.6.1~!doc ===> Bulk building for py38-osqp-0.6.1 Binary package for py38-osqp-0.6.1 is up-to-date. [34%] Processing wip/FRILibrary:FRILibrary-1.2r1~!doc ===> Bulk building for FRILibrary-1.2r1 Binary package for FRILibrary-1.2r1 is up-to-date. [34%] Processing wip/ros-swri-math-util:ros-swri-math-util-2.3.0~!doc ===> Cleaning temporary files for ros-swri-math-util-2.3.0 ===> Bulk building for ros-swri-math-util-2.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-swri-math-util-2.3.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-swri-math-util/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-swri-math-util-2.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-swri-math-util-2.3.0 ===> Done bulk for ros-swri-math-util-2.3.0 [34%] Processing wip/py-prf-ros-control:py27-prf-ros-control-0.2.8r2~!doc ===> Cleaning temporary files for py27-prf-ros-control-0.2.8r2 ===> Bulk building for py27-prf-ros-control-0.2.8r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-rospkg-1.1.7.tgz => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-resource-retriever>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-rqt>=0.3<0.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-prf-ros-control-0.2.8r2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-ros-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-prf-ros-control-0.2.8r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-prf-ros-control-0.2.8r2 ===> Done bulk for py27-prf-ros-control-0.2.8r2 [34%] Processing wip/py-prf-ros-control:py34-prf-ros-control-0.2.8r2~!doc ===> Bulk building for py34-prf-ros-control-0.2.8r2 Binary package for py34-prf-ros-control-0.2.8r2 is up-to-date. [34%] Processing wip/py-prf-ros-control:py35-prf-ros-control-0.2.8r2~!doc ===> Bulk building for py35-prf-ros-control-0.2.8r2 Binary package for py35-prf-ros-control-0.2.8r2 is up-to-date. [34%] Processing wip/py-prf-ros-control:py36-prf-ros-control-0.2.8r2~!doc ===> Bulk building for py36-prf-ros-control-0.2.8r2 Binary package for py36-prf-ros-control-0.2.8r2 is up-to-date. [35%] Processing wip/py-prf-ros-control:py37-prf-ros-control-0.2.8r2~!doc ===> Cleaning temporary files for py37-prf-ros-control-0.2.8r2 ===> Bulk building for py37-prf-ros-control-0.2.8r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-rospkg>=1.0.29: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-resource-retriever>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-rqt>=0.3<0.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-prf-ros-control-0.2.8r2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-ros-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-prf-ros-control-0.2.8r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-prf-ros-control-0.2.8r2 ===> Done bulk for py37-prf-ros-control-0.2.8r2 [35%] Processing wip/py-prf-ros-control:py38-prf-ros-control-0.2.8r2~!doc ===> Bulk building for py38-prf-ros-control-0.2.8r2 Binary package for py38-prf-ros-control-0.2.8r2 is up-to-date. [35%] Processing wip/cppadcodegen:cppadcodegen-2.4.3~!doc ===> Bulk building for cppadcodegen-2.4.3 Binary package for cppadcodegen-2.4.3 is up-to-date. [35%] Processing wip/pal-wsg-gripper:pal-wsg-gripper-0.0.9r1~!doc ===> Cleaning temporary files for pal-wsg-gripper-0.0.9r1 ===> Bulk building for pal-wsg-gripper-0.0.9r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-wsg-gripper-0.0.9r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-wsg-gripper-0.0.9r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-wsg-gripper-0.0.9r1 ===> Done bulk for pal-wsg-gripper-0.0.9r1 [35%] Processing wip/talos-moveit-config:talos-moveit-config-0.3.2~!doc ===> Cleaning temporary files for talos-moveit-config-0.3.2 ===> Bulk building for talos-moveit-config-0.3.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-joint-state-publisher>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for talos-moveit-config-0.3.2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/talos-moveit-config/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for talos-moveit-config-0.3.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-moveit-config-0.3.2 ===> Done bulk for talos-moveit-config-0.3.2 [35%] Processing wip/dynamic-graph-tutorial:dynamic-graph-tutorial-1.2.1~!doc ===> Bulk building for dynamic-graph-tutorial-1.2.1 Binary package for dynamic-graph-tutorial-1.2.1 is up-to-date. [35%] Processing wip/dptu-genom3:dptu-genom3-0.2~codels+pocolibs-client-c+openprs+pocolibs-server+!*+!doc ===> Bulk building for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server Binary package for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server is up-to-date. [36%] Processing wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* ===> Cleaning temporary files for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server ===> Bulk building for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/genom3-2.99.36.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/genom3-openprs-1.0.9r5.tgz => Required robotpkg package genom3-ros>=1.24: N/A => Dependency openprs-1.1b10 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/openrobots-idl-1.6.tgz => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-rospack>=2.5<2.6: N/A => Dependency tnftp-20130505~ssl already installed => Dependency transgen3-1.0b5 already installed ===> Logging bulk summary for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server ===> Done bulk for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server [36%] Processing wip/pmb2-robot:pmb2-robot-3.0.5~!doc ===> Cleaning temporary files for pmb2-robot-3.0.5 ===> Bulk building for pmb2-robot-3.0.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tf-lookup>=0.0.1: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pmb2-robot-3.0.5: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pmb2-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pmb2-robot-3.0.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pmb2-robot-3.0.5 ===> Done bulk for pmb2-robot-3.0.5 [36%] Processing wip/eiquadprog:eiquadprog-1.1.3~!doc ===> Bulk building for eiquadprog-1.1.3 Binary package for eiquadprog-1.1.3 is up-to-date. [36%] Processing wip/hey5-description:hey5-description-1.0.3~!doc ===> Cleaning temporary files for hey5-description-1.0.3 ===> Bulk building for hey5-description-1.0.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for hey5-description-1.0.3: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hey5-description/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for hey5-description-1.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hey5-description-1.0.3 ===> Done bulk for hey5-description-1.0.3 [36%] Processing wip/py-hpp-centroidal-dynamics:py27-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py27-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py27-hpp-centroidal-dynamics-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-centroidal-dynamics-4.9.0~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-centroidal-dynamics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py27-hpp-centroidal-dynamics-4.9.0~doc [36%] Processing wip/py-hpp-centroidal-dynamics:py34-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py34-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py34-hpp-centroidal-dynamics-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py34-hpp-centroidal-dynamics-4.9.0~doc [36%] Processing wip/py-hpp-centroidal-dynamics:py35-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py35-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py35-hpp-centroidal-dynamics-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py35-hpp-centroidal-dynamics-4.9.0~doc [36%] Processing wip/py-hpp-centroidal-dynamics:py36-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py36-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py36-hpp-centroidal-dynamics-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py36-hpp-centroidal-dynamics-4.9.0~doc [37%] Processing wip/py-hpp-centroidal-dynamics:py37-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py37-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py37-hpp-centroidal-dynamics-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required system package python37>=3.7<3.8: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-centroidal-dynamics-4.9.0~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-centroidal-dynamics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py37-hpp-centroidal-dynamics-4.9.0~doc [37%] Processing wip/py-hpp-centroidal-dynamics:py38-hpp-centroidal-dynamics-4.9.0~doc ===> Cleaning temporary files for py38-hpp-centroidal-dynamics-4.9.0~doc ===> Bulk building for py38-hpp-centroidal-dynamics-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-centroidal-dynamics-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-centroidal-dynamics-4.9.0~doc ===> Done bulk for py38-hpp-centroidal-dynamics-4.9.0~doc [37%] Processing wip/py-hpp-centroidal-dynamics:py27-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py27-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py27-hpp-centroidal-dynamics-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-centroidal-dynamics-4.9.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-centroidal-dynamics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py27-hpp-centroidal-dynamics-4.9.0 [37%] Processing wip/py-hpp-centroidal-dynamics:py34-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py34-hpp-centroidal-dynamics-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py34-hpp-centroidal-dynamics-4.9.0 [37%] Processing wip/py-hpp-centroidal-dynamics:py35-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py35-hpp-centroidal-dynamics-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py35-hpp-centroidal-dynamics-4.9.0 [37%] Processing wip/py-hpp-centroidal-dynamics:py36-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py36-hpp-centroidal-dynamics-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py36-hpp-centroidal-dynamics-4.9.0 [37%] Processing wip/py-hpp-centroidal-dynamics:py37-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py37-hpp-centroidal-dynamics-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required system package python37>=3.7<3.8: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-centroidal-dynamics-4.9.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-centroidal-dynamics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py37-hpp-centroidal-dynamics-4.9.0 [38%] Processing wip/py-hpp-centroidal-dynamics:py38-hpp-centroidal-dynamics-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-centroidal-dynamics-4.9.0 ===> Bulk building for py38-hpp-centroidal-dynamics-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-centroidal-dynamics-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-centroidal-dynamics-4.9.0 ===> Done bulk for py38-hpp-centroidal-dynamics-4.9.0 [38%] Processing wip/py-pycddlib:py27-pycddlib-2.1.1~!doc ===> Bulk building for py27-pycddlib-2.1.1 Binary package for py27-pycddlib-2.1.1 is up-to-date. [38%] Processing wip/py-pycddlib:py34-pycddlib-2.1.1~!doc ===> Bulk building for py34-pycddlib-2.1.1 Binary package for py34-pycddlib-2.1.1 is up-to-date. [38%] Processing wip/py-pycddlib:py35-pycddlib-2.1.1~!doc ===> Bulk building for py35-pycddlib-2.1.1 Binary package for py35-pycddlib-2.1.1 is up-to-date. [38%] Processing wip/py-pycddlib:py36-pycddlib-2.1.1~!doc ===> Bulk building for py36-pycddlib-2.1.1 Binary package for py36-pycddlib-2.1.1 is up-to-date. [38%] Processing wip/py-pycddlib:py37-pycddlib-2.1.1~!doc ===> Cleaning temporary files for py37-pycddlib-2.1.1 ===> Bulk building for py37-pycddlib-2.1.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-pycddlib-2.1.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-pycddlib/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-pycddlib-2.1.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-pycddlib-2.1.1 ===> Done bulk for py37-pycddlib-2.1.1 [38%] Processing wip/py-pycddlib:py38-pycddlib-2.1.1~!doc ===> Bulk building for py38-pycddlib-2.1.1 Binary package for py38-pycddlib-2.1.1 is up-to-date. [38%] Processing wip/ros-urdf-geometry-parser:ros-urdf-geometry-parser-0.0.3~!doc ===> Cleaning temporary files for ros-urdf-geometry-parser-0.0.3 ===> Bulk building for ros-urdf-geometry-parser-0.0.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-urdf-geometry-parser-0.0.3: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-urdf-geometry-parser/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-urdf-geometry-parser-0.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-urdf-geometry-parser-0.0.3 ===> Done bulk for ros-urdf-geometry-parser-0.0.3 [39%] Processing wip/ros-swri-roscpp:ros-swri-roscpp-2.3.0~!doc ===> Cleaning temporary files for ros-swri-roscpp-2.3.0 ===> Bulk building for ros-swri-roscpp-2.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-diagnostics>=1.9<1.10: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-swri-roscpp-2.3.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-swri-roscpp/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-swri-roscpp-2.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-swri-roscpp-2.3.0 ===> Done bulk for ros-swri-roscpp-2.3.0 [39%] Processing wip/parametric-curves:parametric-curves-1.3.1~!doc ===> Bulk building for parametric-curves-1.3.1 Binary package for parametric-curves-1.3.1 is up-to-date. [39%] Processing wip/py-hpp-romeo:py27-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py27-hpp-romeo-4.9.0~doc ===> Bulk building for py27-hpp-romeo-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-romeo-4.9.0~doc ===> Done bulk for py27-hpp-romeo-4.9.0~doc [39%] Processing wip/py-hpp-romeo:py34-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py34-hpp-romeo-4.9.0~doc ===> Bulk building for py34-hpp-romeo-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-romeo-4.9.0~doc ===> Done bulk for py34-hpp-romeo-4.9.0~doc [39%] Processing wip/py-hpp-romeo:py35-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py35-hpp-romeo-4.9.0~doc ===> Bulk building for py35-hpp-romeo-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-romeo-4.9.0~doc ===> Done bulk for py35-hpp-romeo-4.9.0~doc [39%] Processing wip/py-hpp-romeo:py36-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py36-hpp-romeo-4.9.0~doc ===> Bulk building for py36-hpp-romeo-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-romeo-4.9.0~doc ===> Done bulk for py36-hpp-romeo-4.9.0~doc [39%] Processing wip/py-hpp-romeo:py37-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py37-hpp-romeo-4.9.0~doc ===> Bulk building for py37-hpp-romeo-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-romeo-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-romeo/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-romeo-4.9.0~doc ===> Done bulk for py37-hpp-romeo-4.9.0~doc [40%] Processing wip/py-hpp-romeo:py38-hpp-romeo-4.9.0~doc ===> Cleaning temporary files for py38-hpp-romeo-4.9.0~doc ===> Bulk building for py38-hpp-romeo-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-romeo-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-romeo-4.9.0~doc ===> Done bulk for py38-hpp-romeo-4.9.0~doc [40%] Processing wip/py-hpp-romeo:py27-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py27-hpp-romeo-4.9.0 ===> Bulk building for py27-hpp-romeo-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-romeo-4.9.0 ===> Done bulk for py27-hpp-romeo-4.9.0 [40%] Processing wip/py-hpp-romeo:py34-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-romeo-4.9.0 ===> Bulk building for py34-hpp-romeo-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-romeo-4.9.0 ===> Done bulk for py34-hpp-romeo-4.9.0 [40%] Processing wip/py-hpp-romeo:py35-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-romeo-4.9.0 ===> Bulk building for py35-hpp-romeo-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-romeo-4.9.0 ===> Done bulk for py35-hpp-romeo-4.9.0 [40%] Processing wip/py-hpp-romeo:py36-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-romeo-4.9.0 ===> Bulk building for py36-hpp-romeo-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-romeo-4.9.0 ===> Done bulk for py36-hpp-romeo-4.9.0 [40%] Processing wip/py-hpp-romeo:py37-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-romeo-4.9.0 ===> Bulk building for py37-hpp-romeo-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-romeo-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-romeo/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-romeo-4.9.0 ===> Done bulk for py37-hpp-romeo-4.9.0 [40%] Processing wip/py-hpp-romeo:py38-hpp-romeo-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-romeo-4.9.0 ===> Bulk building for py38-hpp-romeo-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-romeo-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-romeo-4.9.0 ===> Done bulk for py38-hpp-romeo-4.9.0 [40%] Processing wip/example-adder:example-adder-2.0.1~!doc ===> Bulk building for example-adder-2.0.1 Binary package for example-adder-2.0.1 is up-to-date. [41%] Processing wip/aruco-ros:aruco-ros-0.2.4~!doc ===> Cleaning temporary files for aruco-ros-0.2.4 ===> Bulk building for aruco-ros-0.2.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-dynamic-reconfigure>=1.5.32: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-vision-opencv>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for aruco-ros-0.2.4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/aruco-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for aruco-ros-0.2.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for aruco-ros-0.2.4 ===> Done bulk for aruco-ros-0.2.4 [41%] Processing wip/py-hpp-spline:py27-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py27-hpp-spline-4.8.2~doc ===> Bulk building for py27-hpp-spline-4.8.2~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-spline-4.8.2~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-spline/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-spline-4.8.2~doc ===> Done bulk for py27-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py34-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py34-hpp-spline-4.8.2~doc ===> Bulk building for py34-hpp-spline-4.8.2~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-spline-4.8.2~doc ===> Done bulk for py34-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py35-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py35-hpp-spline-4.8.2~doc ===> Bulk building for py35-hpp-spline-4.8.2~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-spline-4.8.2~doc ===> Done bulk for py35-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py36-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py36-hpp-spline-4.8.2~doc ===> Bulk building for py36-hpp-spline-4.8.2~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-spline-4.8.2~doc ===> Done bulk for py36-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py37-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py37-hpp-spline-4.8.2~doc ===> Bulk building for py37-hpp-spline-4.8.2~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-spline-4.8.2~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-spline/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-spline-4.8.2~doc ===> Done bulk for py37-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py38-hpp-spline-4.8.2~doc ===> Cleaning temporary files for py38-hpp-spline-4.8.2~doc ===> Bulk building for py38-hpp-spline-4.8.2~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-spline-4.8.2~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-spline-4.8.2~doc ===> Done bulk for py38-hpp-spline-4.8.2~doc [41%] Processing wip/py-hpp-spline:py27-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py27-hpp-spline-4.8.2 ===> Bulk building for py27-hpp-spline-4.8.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-spline-4.8.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-spline/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-spline-4.8.2 ===> Done bulk for py27-hpp-spline-4.8.2 [42%] Processing wip/py-hpp-spline:py34-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py34-hpp-spline-4.8.2 ===> Bulk building for py34-hpp-spline-4.8.2 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-spline-4.8.2 ===> Done bulk for py34-hpp-spline-4.8.2 [42%] Processing wip/py-hpp-spline:py35-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py35-hpp-spline-4.8.2 ===> Bulk building for py35-hpp-spline-4.8.2 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-spline-4.8.2 ===> Done bulk for py35-hpp-spline-4.8.2 [42%] Processing wip/py-hpp-spline:py36-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py36-hpp-spline-4.8.2 ===> Bulk building for py36-hpp-spline-4.8.2 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-spline-4.8.2 ===> Done bulk for py36-hpp-spline-4.8.2 [42%] Processing wip/py-hpp-spline:py37-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py37-hpp-spline-4.8.2 ===> Bulk building for py37-hpp-spline-4.8.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-spline-4.8.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-spline/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-spline-4.8.2 ===> Done bulk for py37-hpp-spline-4.8.2 [42%] Processing wip/py-hpp-spline:py38-hpp-spline-4.8.2~!doc ===> Cleaning temporary files for py38-hpp-spline-4.8.2 ===> Bulk building for py38-hpp-spline-4.8.2 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-spline-4.8.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-spline-4.8.2 ===> Done bulk for py38-hpp-spline-4.8.2 [42%] Processing wip/ros-object-recognition-msgs:ros-object-recognition-msgs-0.4.1r1~!doc ===> Cleaning temporary files for ros-object-recognition-msgs-0.4.1r1 ===> Bulk building for ros-object-recognition-msgs-0.4.1r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-object-recognition-msgs-0.4.1r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-object-recognition-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-object-recognition-msgs-0.4.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-object-recognition-msgs-0.4.1r1 ===> Done bulk for ros-object-recognition-msgs-0.4.1r1 [43%] Processing wip/timeoptimization:timeoptimization-1.1.0~!doc ===> Cleaning temporary files for timeoptimization-1.1.0 ===> Bulk building for timeoptimization-1.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for timeoptimization-1.1.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/timeoptimization/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for timeoptimization-1.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for timeoptimization-1.1.0 ===> Done bulk for timeoptimization-1.1.0 [43%] Processing wip/infuse-envire:infuse-envire-0.1.1~!doc ===> Bulk building for infuse-envire-0.1.1 Binary package for infuse-envire-0.1.1 is up-to-date. [43%] Processing wip/py-pal-statistics:py27-pal-statistics-1.3.1r4~!doc ===> Cleaning temporary files for py27-pal-statistics-1.3.1r4 ===> Bulk building for py27-pal-statistics-1.3.1r4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-pal-statistics-1.3.1r4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-pal-statistics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-pal-statistics-1.3.1r4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-pal-statistics-1.3.1r4 ===> Done bulk for py27-pal-statistics-1.3.1r4 [43%] Processing wip/py-pal-statistics:py34-pal-statistics-1.3.1r4~!doc ===> Bulk building for py34-pal-statistics-1.3.1r4 Binary package for py34-pal-statistics-1.3.1r4 is up-to-date. [43%] Processing wip/py-pal-statistics:py35-pal-statistics-1.3.1r4~!doc ===> Bulk building for py35-pal-statistics-1.3.1r4 Binary package for py35-pal-statistics-1.3.1r4 is up-to-date. [43%] Processing wip/py-pal-statistics:py36-pal-statistics-1.3.1r4~!doc ===> Bulk building for py36-pal-statistics-1.3.1r4 Binary package for py36-pal-statistics-1.3.1r4 is up-to-date. [43%] Processing wip/py-pal-statistics:py37-pal-statistics-1.3.1r4~!doc ===> Cleaning temporary files for py37-pal-statistics-1.3.1r4 ===> Bulk building for py37-pal-statistics-1.3.1r4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-pal-statistics-1.3.1r4: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-pal-statistics/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-pal-statistics-1.3.1r4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-pal-statistics-1.3.1r4 ===> Done bulk for py37-pal-statistics-1.3.1r4 [43%] Processing wip/py-pal-statistics:py38-pal-statistics-1.3.1r4~!doc ===> Bulk building for py38-pal-statistics-1.3.1r4 Binary package for py38-pal-statistics-1.3.1r4 is up-to-date. [44%] Processing wip/py-hpp-baxter:py27-hpp-baxter-4.9.0~doc ===> Bulk building for py27-hpp-baxter-4.9.0~doc Binary package for py27-hpp-baxter-4.9.0~doc is up-to-date. [44%] Processing wip/py-hpp-baxter:py34-hpp-baxter-4.9.0~doc ===> Cleaning temporary files for py34-hpp-baxter-4.9.0~doc ===> Bulk building for py34-hpp-baxter-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-baxter-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-baxter-4.9.0~doc ===> Done bulk for py34-hpp-baxter-4.9.0~doc [44%] Processing wip/py-hpp-baxter:py35-hpp-baxter-4.9.0~doc ===> Cleaning temporary files for py35-hpp-baxter-4.9.0~doc ===> Bulk building for py35-hpp-baxter-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-baxter-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-baxter-4.9.0~doc ===> Done bulk for py35-hpp-baxter-4.9.0~doc [44%] Processing wip/py-hpp-baxter:py36-hpp-baxter-4.9.0~doc ===> Cleaning temporary files for py36-hpp-baxter-4.9.0~doc ===> Bulk building for py36-hpp-baxter-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-baxter-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-baxter-4.9.0~doc ===> Done bulk for py36-hpp-baxter-4.9.0~doc [44%] Processing wip/py-hpp-baxter:py37-hpp-baxter-4.9.0~doc ===> Cleaning temporary files for py37-hpp-baxter-4.9.0~doc ===> Bulk building for py37-hpp-baxter-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-baxter-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-baxter/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-baxter-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-baxter-4.9.0~doc ===> Done bulk for py37-hpp-baxter-4.9.0~doc [44%] Processing wip/py-hpp-baxter:py38-hpp-baxter-4.9.0~doc ===> Cleaning temporary files for py38-hpp-baxter-4.9.0~doc ===> Bulk building for py38-hpp-baxter-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-baxter-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-baxter-4.9.0~doc ===> Done bulk for py38-hpp-baxter-4.9.0~doc [44%] Processing wip/py-hpp-baxter:py27-hpp-baxter-4.9.0~!doc ===> Bulk building for py27-hpp-baxter-4.9.0 Binary package for py27-hpp-baxter-4.9.0 is up-to-date. [45%] Processing wip/py-hpp-baxter:py34-hpp-baxter-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-baxter-4.9.0 ===> Bulk building for py34-hpp-baxter-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-baxter-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-baxter-4.9.0 ===> Done bulk for py34-hpp-baxter-4.9.0 [45%] Processing wip/py-hpp-baxter:py35-hpp-baxter-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-baxter-4.9.0 ===> Bulk building for py35-hpp-baxter-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-baxter-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-baxter-4.9.0 ===> Done bulk for py35-hpp-baxter-4.9.0 [45%] Processing wip/py-hpp-baxter:py36-hpp-baxter-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-baxter-4.9.0 ===> Bulk building for py36-hpp-baxter-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-baxter-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-baxter-4.9.0 ===> Done bulk for py36-hpp-baxter-4.9.0 [45%] Processing wip/py-hpp-baxter:py37-hpp-baxter-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-baxter-4.9.0 ===> Bulk building for py37-hpp-baxter-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-baxter-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-baxter/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-baxter-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-baxter-4.9.0 ===> Done bulk for py37-hpp-baxter-4.9.0 [45%] Processing wip/py-hpp-baxter:py38-hpp-baxter-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-baxter-4.9.0 ===> Bulk building for py38-hpp-baxter-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-baxter-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-baxter-4.9.0 ===> Done bulk for py38-hpp-baxter-4.9.0 [45%] Processing wip/pal-hardware-interfaces:pal-hardware-interfaces-0.0.4~!doc ===> Cleaning temporary files for pal-hardware-interfaces-0.0.4 ===> Bulk building for pal-hardware-interfaces-0.0.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-hardware-interfaces-0.0.4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-hardware-interfaces/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-hardware-interfaces-0.0.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-hardware-interfaces-0.0.4 ===> Done bulk for pal-hardware-interfaces-0.0.4 [45%] Processing wip/py-hpp-rbprm-robot-data:py27-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py27-hpp-rbprm-robot-data-4.9.0~doc Binary package for py27-hpp-rbprm-robot-data-4.9.0~doc is up-to-date. [45%] Processing wip/py-hpp-rbprm-robot-data:py34-hpp-rbprm-robot-data-4.9.0~doc ===> Cleaning temporary files for py34-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py34-hpp-rbprm-robot-data-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-robot-data-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-robot-data-4.9.0~doc ===> Done bulk for py34-hpp-rbprm-robot-data-4.9.0~doc [46%] Processing wip/py-hpp-rbprm-robot-data:py35-hpp-rbprm-robot-data-4.9.0~doc ===> Cleaning temporary files for py35-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py35-hpp-rbprm-robot-data-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-robot-data-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-robot-data-4.9.0~doc ===> Done bulk for py35-hpp-rbprm-robot-data-4.9.0~doc [46%] Processing wip/py-hpp-rbprm-robot-data:py36-hpp-rbprm-robot-data-4.9.0~doc ===> Cleaning temporary files for py36-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py36-hpp-rbprm-robot-data-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-robot-data-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-robot-data-4.9.0~doc ===> Done bulk for py36-hpp-rbprm-robot-data-4.9.0~doc [46%] Processing wip/py-hpp-rbprm-robot-data:py37-hpp-rbprm-robot-data-4.9.0~doc ===> Cleaning temporary files for py37-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py37-hpp-rbprm-robot-data-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-robot-data-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm-robot-data/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-rbprm-robot-data-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-robot-data-4.9.0~doc ===> Done bulk for py37-hpp-rbprm-robot-data-4.9.0~doc [46%] Processing wip/py-hpp-rbprm-robot-data:py38-hpp-rbprm-robot-data-4.9.0~doc ===> Cleaning temporary files for py38-hpp-rbprm-robot-data-4.9.0~doc ===> Bulk building for py38-hpp-rbprm-robot-data-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-robot-data-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-robot-data-4.9.0~doc ===> Done bulk for py38-hpp-rbprm-robot-data-4.9.0~doc [46%] Processing wip/py-hpp-rbprm-robot-data:py27-hpp-rbprm-robot-data-4.9.0~!doc ===> Bulk building for py27-hpp-rbprm-robot-data-4.9.0 Binary package for py27-hpp-rbprm-robot-data-4.9.0 is up-to-date. [46%] Processing wip/py-hpp-rbprm-robot-data:py34-hpp-rbprm-robot-data-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-rbprm-robot-data-4.9.0 ===> Bulk building for py34-hpp-rbprm-robot-data-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-robot-data-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-robot-data-4.9.0 ===> Done bulk for py34-hpp-rbprm-robot-data-4.9.0 [46%] Processing wip/py-hpp-rbprm-robot-data:py35-hpp-rbprm-robot-data-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-rbprm-robot-data-4.9.0 ===> Bulk building for py35-hpp-rbprm-robot-data-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-robot-data-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-robot-data-4.9.0 ===> Done bulk for py35-hpp-rbprm-robot-data-4.9.0 [47%] Processing wip/py-hpp-rbprm-robot-data:py36-hpp-rbprm-robot-data-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-rbprm-robot-data-4.9.0 ===> Bulk building for py36-hpp-rbprm-robot-data-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-robot-data-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-robot-data-4.9.0 ===> Done bulk for py36-hpp-rbprm-robot-data-4.9.0 [47%] Processing wip/py-hpp-rbprm-robot-data:py37-hpp-rbprm-robot-data-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-rbprm-robot-data-4.9.0 ===> Bulk building for py37-hpp-rbprm-robot-data-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-robot-data-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm-robot-data/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-rbprm-robot-data-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-robot-data-4.9.0 ===> Done bulk for py37-hpp-rbprm-robot-data-4.9.0 [47%] Processing wip/py-hpp-rbprm-robot-data:py38-hpp-rbprm-robot-data-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-rbprm-robot-data-4.9.0 ===> Bulk building for py38-hpp-rbprm-robot-data-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-robot-data-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-robot-data-4.9.0 ===> Done bulk for py38-hpp-rbprm-robot-data-4.9.0 [47%] Processing wip/pal-transmissions:pal-transmissions-0.2.4~!doc ===> Cleaning temporary files for pal-transmissions-0.2.4 ===> Bulk building for pal-transmissions-0.2.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-transmissions-0.2.4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-transmissions/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-transmissions-0.2.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-transmissions-0.2.4 ===> Done bulk for pal-transmissions-0.2.4 [47%] Processing wip/py-ospi:py27-ospi-1.0.3~!doc ===> Bulk building for py27-ospi-1.0.3 Binary package for py27-ospi-1.0.3 is up-to-date. [47%] Processing wip/antlr2:antlr2-2.7.7~!doc ===> Bulk building for antlr2-2.7.7 Binary package for antlr2-2.7.7 is up-to-date. [47%] Processing wip/rqt-dynamic-graph:py27-rqt-dynamic-graph-1.0.0~!doc ===> Cleaning temporary files for py27-rqt-dynamic-graph-1.0.0 ===> Bulk building for py27-rqt-dynamic-graph-1.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-rqt>=0.3<0.6: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-rqt-dynamic-graph-1.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/rqt-dynamic-graph/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-rqt-dynamic-graph-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-rqt-dynamic-graph-1.0.0 ===> Done bulk for py27-rqt-dynamic-graph-1.0.0 [47%] Processing wip/rqt-dynamic-graph:py34-rqt-dynamic-graph-1.0.0~!doc ===> Bulk building for py34-rqt-dynamic-graph-1.0.0 Binary package for py34-rqt-dynamic-graph-1.0.0 is up-to-date. [48%] Processing wip/rqt-dynamic-graph:py35-rqt-dynamic-graph-1.0.0~!doc ===> Bulk building for py35-rqt-dynamic-graph-1.0.0 Binary package for py35-rqt-dynamic-graph-1.0.0 is up-to-date. [48%] Processing wip/rqt-dynamic-graph:py36-rqt-dynamic-graph-1.0.0~!doc ===> Bulk building for py36-rqt-dynamic-graph-1.0.0 Binary package for py36-rqt-dynamic-graph-1.0.0 is up-to-date. [48%] Processing wip/rqt-dynamic-graph:py37-rqt-dynamic-graph-1.0.0~!doc ===> Cleaning temporary files for py37-rqt-dynamic-graph-1.0.0 ===> Bulk building for py37-rqt-dynamic-graph-1.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-rqt>=0.3<0.6: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-rqt-dynamic-graph-1.0.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/rqt-dynamic-graph/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-rqt-dynamic-graph-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-rqt-dynamic-graph-1.0.0 ===> Done bulk for py37-rqt-dynamic-graph-1.0.0 [48%] Processing wip/rqt-dynamic-graph:py38-rqt-dynamic-graph-1.0.0~!doc ===> Bulk building for py38-rqt-dynamic-graph-1.0.0 Binary package for py38-rqt-dynamic-graph-1.0.0 is up-to-date. [48%] Processing wip/py-gurobi:py27-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. ===> Cleaning temporary files for py27-gurobi-9.0.2 ===> Bulk building for py27-gurobi-9.0.2 => Checking for clear installation Warning: the LICENSE of wip/py-gurobi is undefined. => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/py-gurobi is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed Warning: the LICENSE of wip/py-gurobi is undefined. => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package GNU m4>=1.4: gm4-1.4.18 found => Required system package libstdc++: libstdc++ found => Required system package libtool>=1.5.22: libtool-2.4.6 found => Required system package python27>=2.7<2.8: python27-2.7.181 found Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. => SHA1 checksums OK => RMD160 checksums OK Warning: the LICENSE of wip/py-gurobi is undefined. An unexpected error occured. The last 10 log lines are shown below. | libtool: install: install /local/robotpkg/var/tmp/robotpkg/wip/py-gurobi/work/gurobi902/linux64/lib/libgurobi_g++4.2.a /opt/openrobots/lib/libgurobi_g++4.2.a | libtool: install: chmod 644 /opt/openrobots/lib/libgurobi_g++4.2.a | libtool: install: ranlib /opt/openrobots/lib/libgurobi_g++4.2.a | libtool: install: install /local/robotpkg/var/tmp/robotpkg/wip/py-gurobi/work/gurobi902/linux64/lib/libgurobi_g++5.2.a /opt/openrobots/lib/libgurobi_g++5.2.a | libtool: install: chmod 644 /opt/openrobots/lib/libgurobi_g++5.2.a | libtool: install: ranlib /opt/openrobots/lib/libgurobi_g++5.2.a | /local/robotpkg/var/lib/robotpkg/mk/internal/logfilter: 6: eval: @: not found | Usage: /usr/bin/libtool [OPTION]... [MODE-ARG]... | Try 'libtool --help' for more information. | libtool: error: '/opt/openrobots/bin' is not a directory For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-gurobi/work/install.log make[4]: *** [Makefile:24: post-install] Error 1 => Compiling python files => Undoing failed installation ERROR: ====================================================================== ERROR: Installation of py27-gurobi-9.0.2 failed. ERROR: ERROR: Check /local/robotpkg/var/tmp/robotpkg/wip/py-gurobi/work/install.log for details ERROR: ====================================================================== make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/install/install.mk:263: install-failed] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking py27-gurobi-9.0.2 as broken ERROR: make: *** [package] Error 2 Warning: the LICENSE of wip/py-gurobi is undefined. ===> Logging bulk summary for py27-gurobi-9.0.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. ===> Cleaning temporary files for py27-gurobi-9.0.2 ===> Done bulk for py27-gurobi-9.0.2 [48%] Processing wip/py-gurobi:py34-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. ===> Bulk building for py34-gurobi-9.0.2 Binary package for py34-gurobi-9.0.2 is up-to-date. [48%] Processing wip/py-gurobi:py35-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. ===> Bulk building for py35-gurobi-9.0.2 Binary package for py35-gurobi-9.0.2 is up-to-date. [49%] Processing wip/py-gurobi:py36-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. ===> Bulk building for py36-gurobi-9.0.2 Binary package for py36-gurobi-9.0.2 is up-to-date. [49%] Processing wip/py-gurobi:py37-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. ===> Cleaning temporary files for py37-gurobi-9.0.2 ===> Bulk building for py37-gurobi-9.0.2 => Checking for clear installation Warning: the LICENSE of wip/py-gurobi is undefined. => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/py-gurobi is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed Warning: the LICENSE of wip/py-gurobi is undefined. ERROR: ====================================================================== ERROR: Missing system packages required for py37-gurobi-9.0.2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-gurobi/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 Warning: the LICENSE of wip/py-gurobi is undefined. ===> Logging bulk summary for py37-gurobi-9.0.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. Warning: the LICENSE of wip/py-gurobi is undefined. ===> Cleaning temporary files for py37-gurobi-9.0.2 ===> Done bulk for py37-gurobi-9.0.2 [49%] Processing wip/py-gurobi:py38-gurobi-9.0.2~!doc Warning: the LICENSE of wip/py-gurobi is undefined. ===> Bulk building for py38-gurobi-9.0.2 Binary package for py38-gurobi-9.0.2 is up-to-date. [49%] Processing wip/libnabo:libnabo-1.0.7~!doc ===> Bulk building for libnabo-1.0.7 Binary package for libnabo-1.0.7 is up-to-date. [49%] Processing wip/pal-gripper:pal-gripper-0.0.13~!doc ===> Cleaning temporary files for pal-gripper-0.0.13 ===> Bulk building for pal-gripper-0.0.13 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-gripper-0.0.13: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-gripper/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-gripper-0.0.13 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-gripper-0.0.13 ===> Done bulk for pal-gripper-0.0.13 [49%] Processing wip/simple-grasping-action:simple-grasping-action-1.0.1r2~!doc ===> Cleaning temporary files for simple-grasping-action-1.0.1r2 ===> Bulk building for simple-grasping-action-1.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for simple-grasping-action-1.0.1r2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/simple-grasping-action/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for simple-grasping-action-1.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for simple-grasping-action-1.0.1r2 ===> Done bulk for simple-grasping-action-1.0.1r2 [49%] Processing wip/ur5-description:ur5-description-1.0.1~!doc Warning: the LICENSE of wip/ur5-description is undefined. ===> Bulk building for ur5-description-1.0.1 Binary package for ur5-description-1.0.1 is up-to-date. [49%] Processing wip/ros-ouster-gazebo-simulation:ros-ouster-gazebo-simulation-2.0.0~!doc ===> Cleaning temporary files for ros-ouster-gazebo-simulation-2.0.0 ===> Bulk building for ros-ouster-gazebo-simulation-2.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package gazebo-ros-pkgs>=2.8<2.9: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-ouster-gazebo-simulation-2.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-ouster-gazebo-simulation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-ouster-gazebo-simulation-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-ouster-gazebo-simulation-2.0.0 ===> Done bulk for ros-ouster-gazebo-simulation-2.0.0 [50%] Processing wip/osg-dae:osg-dae-3.2.1r2~!doc ===> Cleaning temporary files for osg-dae-3.2.1r2 ===> Bulk building for osg-dae-3.2.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/collada-dom-2.3.1r2.tgz => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-system>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=2.6: cmake-3.16.3 found => Required system package doxygen>=1.5: doxygen-1.8.17 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package openscenegraph>=3: openscenegraph-3.6.4 found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required robotpkg package collada-dom>=2.3.1: collada-dom-2.3.1r2 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for osg-dae-3.2.1r2 An unexpected error occured. The last 10 log lines are shown below. | 193 | domCommon_float_or_param_type_complexType(DAE& dae, daeElement* elt) : elemFloat(), elemParam() {} | | ~~~~~^~~ | /opt/openrobots/include/collada-dom/1.4/dom/domCommon_float_or_param_type.h:193:66: warning: unused parameter 'elt' [-Wunused-parameter] | 193 | domCommon_float_or_param_type_complexType(DAE& dae, daeElement* elt) : elemFloat(), elemParam() {} | | ~~~~~~~~~~~~^~~ | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/osg-dae/work/osg-dae-3.2.1' | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/osg-dae/work/osg-dae-3.2.1' | make[2]: *** [src/osgPlugins/dae/CMakeFiles/osgdb_dae.dir/build.make:183: src/osgPlugins/dae/CMakeFiles/osgdb_dae.dir/daeWMaterials.o] Error 1 | make[1]: *** [CMakeFiles/Makefile2:497: src/osgPlugins/dae/CMakeFiles/osgdb_dae.dir/all] Error 2 | make: *** [Makefile:144: all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/osg-dae/work/build.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/build/build.mk:199: do-build] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking osg-dae-3.2.1r2 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for osg-dae-3.2.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for osg-dae-3.2.1r2 ===> Done bulk for osg-dae-3.2.1r2 [50%] Processing wip/py-qpoases:py27-qpoases-3.2.1~!doc ===> Cleaning temporary files for py27-qpoases-3.2.1 ===> Bulk building for py27-qpoases-3.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package unzip: unzip found => Dependency digest-20080510 already installed => Required system package py27-numpy>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qpoases-3.2.1: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-qpoases/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qpoases-3.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qpoases-3.2.1 ===> Done bulk for py27-qpoases-3.2.1 [50%] Processing wip/py-qpoases:py34-qpoases-3.2.1~!doc ===> Bulk building for py34-qpoases-3.2.1 Binary package for py34-qpoases-3.2.1 is up-to-date. [50%] Processing wip/py-qpoases:py35-qpoases-3.2.1~!doc ===> Bulk building for py35-qpoases-3.2.1 Binary package for py35-qpoases-3.2.1 is up-to-date. [50%] Processing wip/py-qpoases:py36-qpoases-3.2.1~!doc ===> Bulk building for py36-qpoases-3.2.1 Binary package for py36-qpoases-3.2.1 is up-to-date. [50%] Processing wip/py-qpoases:py37-qpoases-3.2.1~!doc ===> Cleaning temporary files for py37-qpoases-3.2.1 ===> Bulk building for py37-qpoases-3.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package unzip: unzip found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qpoases-3.2.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-qpoases/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-qpoases-3.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qpoases-3.2.1 ===> Done bulk for py37-qpoases-3.2.1 [50%] Processing wip/py-qpoases:py38-qpoases-3.2.1~!doc ===> Bulk building for py38-qpoases-3.2.1 Binary package for py38-qpoases-3.2.1 is up-to-date. [50%] Processing wip/pal-msgs:pal-msgs-0.12.14~!doc ===> Cleaning temporary files for pal-msgs-0.12.14 ===> Bulk building for pal-msgs-0.12.14 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package humanoid-nav-msgs>=0.1: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-rospkg-1.1.7.tgz => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-msgs-0.12.14: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-msgs-0.12.14 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-msgs-0.12.14 ===> Done bulk for pal-msgs-0.12.14 [52%] Processing wip/backward-ros:backward-ros-0.1.7~!doc ===> Cleaning temporary files for backward-ros-0.1.7 ===> Bulk building for backward-ros-0.1.7 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for backward-ros-0.1.7: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/backward-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for backward-ros-0.1.7 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for backward-ros-0.1.7 ===> Done bulk for backward-ros-0.1.7 [52%] Processing wip/ros-swri-string-util:ros-swri-string-util-2.3.0~!doc ===> Cleaning temporary files for ros-swri-string-util-2.3.0 ===> Bulk building for ros-swri-string-util-2.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-swri-string-util-2.3.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-swri-string-util/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-swri-string-util-2.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-swri-string-util-2.3.0 ===> Done bulk for ros-swri-string-util-2.3.0 [52%] Processing wip/rviz-plugin-covariance:rviz-plugin-covariance-0.0.6os1r1~!doc ===> Cleaning temporary files for rviz-plugin-covariance-0.0.6os1r1 ===> Bulk building for rviz-plugin-covariance-0.0.6os1r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-rviz>=1.9: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for rviz-plugin-covariance-0.0.6os1r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/rviz-plugin-covariance/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for rviz-plugin-covariance-0.0.6os1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for rviz-plugin-covariance-0.0.6os1r1 ===> Done bulk for rviz-plugin-covariance-0.0.6os1r1 [53%] Processing wip/openhrp3-simulator-wo-rtm:openhrp3-simulator-wo-rtm-1.2.0~!doc ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Bulk building for openhrp3-simulator-wo-rtm-1.2.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-qt5-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for openhrp3-simulator-wo-rtm-1.2.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/openhrp3-simulator-wo-rtm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for openhrp3-simulator-wo-rtm-1.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Done bulk for openhrp3-simulator-wo-rtm-1.2.0 [53%] Processing wip/py-dill:py27-dill-0.3.1.1~!doc ===> Bulk building for py27-dill-0.3.1.1 Binary package for py27-dill-0.3.1.1 is up-to-date. [53%] Processing wip/py-dill:py34-dill-0.3.1.1~!doc ===> Bulk building for py34-dill-0.3.1.1 Binary package for py34-dill-0.3.1.1 is up-to-date. [53%] Processing wip/py-dill:py35-dill-0.3.1.1~!doc ===> Bulk building for py35-dill-0.3.1.1 Binary package for py35-dill-0.3.1.1 is up-to-date. [53%] Processing wip/py-dill:py36-dill-0.3.1.1~!doc ===> Bulk building for py36-dill-0.3.1.1 Binary package for py36-dill-0.3.1.1 is up-to-date. [53%] Processing wip/py-dill:py37-dill-0.3.1.1~!doc ===> Cleaning temporary files for py37-dill-0.3.1.1 ===> Bulk building for py37-dill-0.3.1.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-dill-0.3.1.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dill/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-dill-0.3.1.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-dill-0.3.1.1 ===> Done bulk for py37-dill-0.3.1.1 [53%] Processing wip/py-dill:py38-dill-0.3.1.1~!doc ===> Bulk building for py38-dill-0.3.1.1 Binary package for py38-dill-0.3.1.1 is up-to-date. [54%] Processing wip/ros-octomap-msgs:ros-octomap-msgs-0.3.3r1~!doc ===> Cleaning temporary files for ros-octomap-msgs-0.3.3r1 ===> Bulk building for ros-octomap-msgs-0.3.3r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-octomap-msgs-0.3.3r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-octomap-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-octomap-msgs-0.3.3r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-octomap-msgs-0.3.3r1 ===> Done bulk for ros-octomap-msgs-0.3.3r1 [54%] Processing wip/py-hpp-hrp2:py27-hpp-hrp2-4.9.0~doc ===> Bulk building for py27-hpp-hrp2-4.9.0~doc Binary package for py27-hpp-hrp2-4.9.0~doc is up-to-date. [54%] Processing wip/py-hpp-hrp2:py34-hpp-hrp2-4.9.0~doc ===> Cleaning temporary files for py34-hpp-hrp2-4.9.0~doc ===> Bulk building for py34-hpp-hrp2-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-hrp2-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-hrp2-4.9.0~doc ===> Done bulk for py34-hpp-hrp2-4.9.0~doc [54%] Processing wip/py-hpp-hrp2:py35-hpp-hrp2-4.9.0~doc ===> Cleaning temporary files for py35-hpp-hrp2-4.9.0~doc ===> Bulk building for py35-hpp-hrp2-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-hrp2-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-hrp2-4.9.0~doc ===> Done bulk for py35-hpp-hrp2-4.9.0~doc [54%] Processing wip/py-hpp-hrp2:py36-hpp-hrp2-4.9.0~doc ===> Cleaning temporary files for py36-hpp-hrp2-4.9.0~doc ===> Bulk building for py36-hpp-hrp2-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-hrp2-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-hrp2-4.9.0~doc ===> Done bulk for py36-hpp-hrp2-4.9.0~doc [54%] Processing wip/py-hpp-hrp2:py37-hpp-hrp2-4.9.0~doc ===> Cleaning temporary files for py37-hpp-hrp2-4.9.0~doc ===> Bulk building for py37-hpp-hrp2-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-hrp2-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-hrp2/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-hrp2-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-hrp2-4.9.0~doc ===> Done bulk for py37-hpp-hrp2-4.9.0~doc [54%] Processing wip/py-hpp-hrp2:py38-hpp-hrp2-4.9.0~doc ===> Cleaning temporary files for py38-hpp-hrp2-4.9.0~doc ===> Bulk building for py38-hpp-hrp2-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-hrp2-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-hrp2-4.9.0~doc ===> Done bulk for py38-hpp-hrp2-4.9.0~doc [54%] Processing wip/py-hpp-hrp2:py27-hpp-hrp2-4.9.0~!doc ===> Bulk building for py27-hpp-hrp2-4.9.0 Binary package for py27-hpp-hrp2-4.9.0 is up-to-date. [55%] Processing wip/py-hpp-hrp2:py34-hpp-hrp2-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-hrp2-4.9.0 ===> Bulk building for py34-hpp-hrp2-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-hrp2-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-hrp2-4.9.0 ===> Done bulk for py34-hpp-hrp2-4.9.0 [55%] Processing wip/py-hpp-hrp2:py35-hpp-hrp2-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-hrp2-4.9.0 ===> Bulk building for py35-hpp-hrp2-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-hrp2-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-hrp2-4.9.0 ===> Done bulk for py35-hpp-hrp2-4.9.0 [55%] Processing wip/py-hpp-hrp2:py36-hpp-hrp2-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-hrp2-4.9.0 ===> Bulk building for py36-hpp-hrp2-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-hrp2-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-hrp2-4.9.0 ===> Done bulk for py36-hpp-hrp2-4.9.0 [55%] Processing wip/py-hpp-hrp2:py37-hpp-hrp2-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-hrp2-4.9.0 ===> Bulk building for py37-hpp-hrp2-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-hrp2-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-hrp2/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-hrp2-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-hrp2-4.9.0 ===> Done bulk for py37-hpp-hrp2-4.9.0 [55%] Processing wip/py-hpp-hrp2:py38-hpp-hrp2-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-hrp2-4.9.0 ===> Bulk building for py38-hpp-hrp2-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-hrp2-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-hrp2-4.9.0 ===> Done bulk for py38-hpp-hrp2-4.9.0 [55%] Processing wip/hrp2-14-description:hrp2-14-description-1.0.5~!doc ===> Cleaning temporary files for hrp2-14-description-1.0.5 ===> Bulk building for hrp2-14-description-1.0.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/robot-capsule-urdf-1.0.1r2.tgz => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for hrp2-14-description-1.0.5: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hrp2-14-description/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for hrp2-14-description-1.0.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hrp2-14-description-1.0.5 ===> Done bulk for hrp2-14-description-1.0.5 [55%] Processing wip/ros-swri-nodelet:ros-swri-nodelet-2.3.0~!doc ===> Cleaning temporary files for ros-swri-nodelet-2.3.0 ===> Bulk building for ros-swri-nodelet-2.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-swri-nodelet-2.3.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-swri-nodelet/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-swri-nodelet-2.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-swri-nodelet-2.3.0 ===> Done bulk for ros-swri-nodelet-2.3.0 [56%] Processing wip/py-mraa:mraa-1.9.0~!doc ===> Cleaning temporary files for mraa-1.9.0 ===> Bulk building for mraa-1.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package libjson-c>=0.10: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for mraa-1.9.0: ERROR: ERROR: libjson-c>=0.10 ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-mraa/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for mraa-1.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for mraa-1.9.0 ===> Done bulk for mraa-1.9.0 [56%] Processing wip/py-hqp:py27-hqp-1.0.1~!doc ===> Bulk building for py27-hqp-1.0.1 Binary package for py27-hqp-1.0.1 is up-to-date. [56%] Processing wip/octovis:octoviz-1.6.1~!doc ===> Cleaning temporary files for octoviz-1.6.1 ===> Bulk building for octoviz-1.6.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package libqglviewer>=2.3: MISSING => Required system package mesa>=6.5: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/octomap-1.9.0.tgz => Required system package qt4-libs>=4.6.2: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for octoviz-1.6.1: ERROR: ERROR: libqglviewer>=2.3 (Ubuntu package libqglviewer-qt4-dev) ERROR: mesa>=6.5 (Ubuntu package libgl1-mesa-dev) ERROR: qt4-libs>=4.6.2 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/octovis/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for octoviz-1.6.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for octoviz-1.6.1 ===> Done bulk for octoviz-1.6.1 [56%] Processing wip/py-parametric-curves:py27-parametric-curves-1.3.1~!doc ===> Cleaning temporary files for py27-parametric-curves-1.3.1 ===> Bulk building for py27-parametric-curves-1.3.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-parametric-curves-1.3.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-parametric-curves/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-parametric-curves-1.3.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-parametric-curves-1.3.1 ===> Done bulk for py27-parametric-curves-1.3.1 [56%] Processing wip/py-parametric-curves:py34-parametric-curves-1.3.1~!doc ===> Bulk building for py34-parametric-curves-1.3.1 Binary package for py34-parametric-curves-1.3.1 is up-to-date. [56%] Processing wip/py-parametric-curves:py35-parametric-curves-1.3.1~!doc ===> Bulk building for py35-parametric-curves-1.3.1 Binary package for py35-parametric-curves-1.3.1 is up-to-date. [56%] Processing wip/py-parametric-curves:py36-parametric-curves-1.3.1~!doc ===> Bulk building for py36-parametric-curves-1.3.1 Binary package for py36-parametric-curves-1.3.1 is up-to-date. [56%] Processing wip/py-parametric-curves:py37-parametric-curves-1.3.1~!doc ===> Cleaning temporary files for py37-parametric-curves-1.3.1 ===> Bulk building for py37-parametric-curves-1.3.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-parametric-curves-1.3.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-parametric-curves/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-parametric-curves-1.3.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-parametric-curves-1.3.1 ===> Done bulk for py37-parametric-curves-1.3.1 [57%] Processing wip/py-parametric-curves:py38-parametric-curves-1.3.1~!doc ===> Bulk building for py38-parametric-curves-1.3.1 Binary package for py38-parametric-curves-1.3.1 is up-to-date. [57%] Processing wip/ros-image-pipeline:ros-image-pipeline-1.14.0~!doc ===> Cleaning temporary files for ros-image-pipeline-1.14.0 ===> Bulk building for ros-image-pipeline-1.14.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-dynamic-reconfigure>=1.5.32: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-vision-opencv>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-image-pipeline-1.14.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-image-pipeline/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-image-pipeline-1.14.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-image-pipeline-1.14.0 ===> Done bulk for ros-image-pipeline-1.14.0 [57%] Processing wip/py-dynamic-graph-tutorial:py27-dynamic-graph-tutorial-1.2.1~!doc ===> Cleaning temporary files for py27-dynamic-graph-tutorial-1.2.1 ===> Bulk building for py27-dynamic-graph-tutorial-1.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-tutorial-1.2.1.tgz => Dependency dynamic-graph-v3-4.1.0 already installed => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-dynamic-graph-tutorial-1.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-dynamic-graph-tutorial-1.2.1 ===> Done bulk for py27-dynamic-graph-tutorial-1.2.1 [57%] Processing wip/py-dynamic-graph-tutorial:py34-dynamic-graph-tutorial-1.2.1~!doc ===> Bulk building for py34-dynamic-graph-tutorial-1.2.1 Binary package for py34-dynamic-graph-tutorial-1.2.1 is up-to-date. [57%] Processing wip/py-dynamic-graph-tutorial:py35-dynamic-graph-tutorial-1.2.1~!doc ===> Bulk building for py35-dynamic-graph-tutorial-1.2.1 Binary package for py35-dynamic-graph-tutorial-1.2.1 is up-to-date. [57%] Processing wip/py-dynamic-graph-tutorial:py36-dynamic-graph-tutorial-1.2.1~!doc ===> Bulk building for py36-dynamic-graph-tutorial-1.2.1 Binary package for py36-dynamic-graph-tutorial-1.2.1 is up-to-date. [57%] Processing wip/py-dynamic-graph-tutorial:py37-dynamic-graph-tutorial-1.2.1~!doc ===> Cleaning temporary files for py37-dynamic-graph-tutorial-1.2.1 ===> Bulk building for py37-dynamic-graph-tutorial-1.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-tutorial-1.2.1.tgz => Dependency dynamic-graph-v3-4.1.0 already installed => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-dynamic-graph-tutorial-1.2.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-dynamic-graph-tutorial-1.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-dynamic-graph-tutorial-1.2.1 ===> Done bulk for py37-dynamic-graph-tutorial-1.2.1 [58%] Processing wip/py-dynamic-graph-tutorial:py38-dynamic-graph-tutorial-1.2.1~!doc ===> Bulk building for py38-dynamic-graph-tutorial-1.2.1 Binary package for py38-dynamic-graph-tutorial-1.2.1 is up-to-date. [58%] Processing wip/jsbsim:jsbsim-20150424~!doc ===> Bulk building for jsbsim-20150424 Binary package for jsbsim-20150424 is up-to-date. [58%] Processing wip/py-casadi:py27-casadi-3.4.5~!doc ===> Cleaning temporary files for py27-casadi-3.4.5 ===> Bulk building for py27-casadi-3.4.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Required system package cmake>=2.6: cmake-3.16.3 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package lapack: lapack found => Required system package libstdc++: libstdc++ found => Required system package python27>=2.7<2.8: python27-2.7.181 found => Required system package swig>=1.3: swig-4.0.1 found => Required system package tinyxml2>=2: tinyxml2-26.22.20.26.22.20 found => Required robotpkg package qpoases>=3.2: qpoases-3.2.1r1~doc found => SHA1 checksums OK => RMD160 checksums OK => Compiling python files File "/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.py", line 274 raise Exception("Error occured in entry context with powerIndex %s, at canonicalIndex %s" % (str(powerIndex),str(canonicalIndex))) from e ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.py", line 274 raise Exception("Error occured in entry context with powerIndex %s, at canonicalIndex %s" % (str(powerIndex),str(canonicalIndex))) from e ^ SyntaxError: invalid syntax robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyo' => Registering installation for py27-casadi-3.4.5 robotpkg_admin: py27-casadi-3.4.5: File `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py27-casadi-3.4.5: File `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyo' is in +CONTENTS but not on filesystem! robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyo' robotpkg_create: lstat failed for file lib/python2.7/site-packages/casadi/tools/structure3.pyc: No such file or directory make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:74: pkg-tarup] Error 2 => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/pub => Updating debian binary packages make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/package/package.mk:147: package-failed] Error 2 => Marking py27-casadi-3.4.5 as broken ERROR: make: *** [package] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python2.7/site-packages/casadi/tools/structure3.pyo ===> Logging bulk summary for py27-casadi-3.4.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-casadi-3.4.5 ===> Done bulk for py27-casadi-3.4.5 [58%] Processing wip/py-casadi:py34-casadi-3.4.5~!doc ===> Bulk building for py34-casadi-3.4.5 Binary package for py34-casadi-3.4.5 is up-to-date. [58%] Processing wip/py-casadi:py35-casadi-3.4.5~!doc ===> Bulk building for py35-casadi-3.4.5 Binary package for py35-casadi-3.4.5 is up-to-date. [58%] Processing wip/py-casadi:py36-casadi-3.4.5~!doc ===> Bulk building for py36-casadi-3.4.5 Binary package for py36-casadi-3.4.5 is up-to-date. [58%] Processing wip/py-casadi:py37-casadi-3.4.5~!doc ===> Cleaning temporary files for py37-casadi-3.4.5 ===> Bulk building for py37-casadi-3.4.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/qpoases-3.2.1r1~doc.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-casadi-3.4.5: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-casadi/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-casadi-3.4.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-casadi-3.4.5 ===> Done bulk for py37-casadi-3.4.5 [58%] Processing wip/py-casadi:py38-casadi-3.4.5~!doc ===> Bulk building for py38-casadi-3.4.5 Binary package for py38-casadi-3.4.5 is up-to-date. [59%] Processing wip/infuse-asn1-types:infuse-asn1-types-0.3~!doc ===> Cleaning temporary files for infuse-asn1-types-0.3 ===> Bulk building for infuse-asn1-types-0.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package mono>=4.2: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for infuse-asn1-types-0.3: ERROR: ERROR: mono>=4.2 (Ubuntu package mono-devel) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/infuse-asn1-types/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for infuse-asn1-types-0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for infuse-asn1-types-0.3 ===> Done bulk for infuse-asn1-types-0.3 [59%] Processing wip/hpp-affordance:hpp-affordance-4.9.0~doc ===> Cleaning temporary files for hpp-affordance-4.9.0~doc ===> Bulk building for hpp-affordance-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Dependency tnftp-20130505~ssl already installed => Building with the following options: => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=3.1.0: cmake-3.16.3 found => Required system package doxygen>=1.5: doxygen-1.8.17 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=4.8: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package latex>=3.14: latex-3.14159265 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required robotpkg package hpp-fcl>=1.4: hpp-fcl-1.4.4~doc found => Required robotpkg package octomap>=1.6.0: octomap-1.9.0 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and references files it does not | provide. | | | | -- Generating done | CMake Generate step failed. Build files cannot be regenerated correctly. For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/hpp-affordance/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking hpp-affordance-4.9.0~doc as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for hpp-affordance-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hpp-affordance-4.9.0~doc ===> Done bulk for hpp-affordance-4.9.0~doc [59%] Processing wip/hpp-affordance:hpp-affordance-4.9.0~!doc ===> Cleaning temporary files for hpp-affordance-4.9.0 ===> Bulk building for hpp-affordance-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=3.1.0: cmake-3.16.3 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=4.8: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required robotpkg package hpp-fcl>=1.4: hpp-fcl-1.4.4~doc found => Required robotpkg package octomap>=1.6.0: octomap-1.9.0 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and references files it does not | provide. | | | | -- Generating done | CMake Generate step failed. Build files cannot be regenerated correctly. For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/hpp-affordance/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking hpp-affordance-4.9.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for hpp-affordance-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hpp-affordance-4.9.0 ===> Done bulk for hpp-affordance-4.9.0 [59%] Processing wip/ros-swri-serial-util:ros-swri-serial-util-2.3.0~!doc ===> Cleaning temporary files for ros-swri-serial-util-2.3.0 ===> Bulk building for ros-swri-serial-util-2.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-swri-serial-util-2.3.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-swri-serial-util/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-swri-serial-util-2.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-swri-serial-util-2.3.0 ===> Done bulk for ros-swri-serial-util-2.3.0 [59%] Processing wip/ros-moveit-msgs:ros-moveit-msgs-0.10.0r1~!doc ===> Cleaning temporary files for ros-moveit-msgs-0.10.0r1 ===> Bulk building for ros-moveit-msgs-0.10.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-object-recognition-msgs>=0.4.1: N/A => Required robotpkg package ros-octomap-msgs>=0.3.3: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-moveit-msgs-0.10.0r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-moveit-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-moveit-msgs-0.10.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-moveit-msgs-0.10.0r1 ===> Done bulk for ros-moveit-msgs-0.10.0r1 [59%] Processing wip/ros-pcl-msgs:ros-pcl-msgs-0.2.0~!doc ===> Cleaning temporary files for ros-pcl-msgs-0.2.0 ===> Bulk building for ros-pcl-msgs-0.2.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-pcl-msgs-0.2.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-pcl-msgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-pcl-msgs-0.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-pcl-msgs-0.2.0 ===> Done bulk for ros-pcl-msgs-0.2.0 [59%] Processing wip/py-scs:py27-scs-2.1.2~!doc ===> Cleaning temporary files for py27-scs-2.1.2 ===> Bulk building for py27-scs-2.1.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package py27-numpy>=1: MISSING => Required system package py27-scipy>=0.17.0: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-scs-2.1.2: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-scipy>=0.17.0 (Ubuntu package python-scipy) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-scs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-scs-2.1.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-scs-2.1.2 ===> Done bulk for py27-scs-2.1.2 [60%] Processing wip/py-scs:py34-scs-2.1.2~!doc ===> Bulk building for py34-scs-2.1.2 Binary package for py34-scs-2.1.2 is up-to-date. [60%] Processing wip/py-scs:py35-scs-2.1.2~!doc ===> Bulk building for py35-scs-2.1.2 Binary package for py35-scs-2.1.2 is up-to-date. [60%] Processing wip/py-scs:py36-scs-2.1.2~!doc ===> Bulk building for py36-scs-2.1.2 Binary package for py36-scs-2.1.2 is up-to-date. [60%] Processing wip/py-scs:py37-scs-2.1.2~!doc ===> Cleaning temporary files for py37-scs-2.1.2 ===> Bulk building for py37-scs-2.1.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-scs-2.1.2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-scs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-scs-2.1.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-scs-2.1.2 ===> Done bulk for py37-scs-2.1.2 [60%] Processing wip/py-scs:py38-scs-2.1.2~!doc ===> Bulk building for py38-scs-2.1.2 Binary package for py38-scs-2.1.2 is up-to-date. [60%] Processing wip/pyrene-motions:pyrene-motions-1.0.0~!doc ===> Bulk building for pyrene-motions-1.0.0 Binary package for pyrene-motions-1.0.0 is up-to-date. [60%] Processing wip/py-hpp-bezier-com-traj:py27-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py27-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py27-hpp-bezier-com-traj-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Required robotpkg package py27-curves>=0.3.1: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-hpp-centroidal-dynamics>=4.9.0: N/A => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-bezier-com-traj-4.9.0~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-bezier-com-traj/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py27-hpp-bezier-com-traj-4.9.0~doc [60%] Processing wip/py-hpp-bezier-com-traj:py34-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py34-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py34-hpp-bezier-com-traj-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py34-hpp-bezier-com-traj-4.9.0~doc [61%] Processing wip/py-hpp-bezier-com-traj:py35-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py35-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py35-hpp-bezier-com-traj-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py35-hpp-bezier-com-traj-4.9.0~doc [61%] Processing wip/py-hpp-bezier-com-traj:py36-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py36-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py36-hpp-bezier-com-traj-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py36-hpp-bezier-com-traj-4.9.0~doc [61%] Processing wip/py-hpp-bezier-com-traj:py37-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py37-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py37-hpp-bezier-com-traj-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Required robotpkg package py37-curves>=0.3.1: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-centroidal-dynamics>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-bezier-com-traj-4.9.0~doc: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-bezier-com-traj/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py37-hpp-bezier-com-traj-4.9.0~doc [61%] Processing wip/py-hpp-bezier-com-traj:py38-hpp-bezier-com-traj-4.9.0~doc ===> Cleaning temporary files for py38-hpp-bezier-com-traj-4.9.0~doc ===> Bulk building for py38-hpp-bezier-com-traj-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-bezier-com-traj-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-bezier-com-traj-4.9.0~doc ===> Done bulk for py38-hpp-bezier-com-traj-4.9.0~doc [61%] Processing wip/py-hpp-bezier-com-traj:py27-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py27-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py27-hpp-bezier-com-traj-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Required robotpkg package py27-curves>=0.3.1: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-hpp-centroidal-dynamics>=4.9.0: N/A => Required system package py27-numpy>=1: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-hpp-bezier-com-traj-4.9.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-bezier-com-traj/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py27-hpp-bezier-com-traj-4.9.0 [61%] Processing wip/py-hpp-bezier-com-traj:py34-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py34-hpp-bezier-com-traj-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py34-hpp-bezier-com-traj-4.9.0 [61%] Processing wip/py-hpp-bezier-com-traj:py35-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py35-hpp-bezier-com-traj-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py35-hpp-bezier-com-traj-4.9.0 [61%] Processing wip/py-hpp-bezier-com-traj:py36-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py36-hpp-bezier-com-traj-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py36-hpp-bezier-com-traj-4.9.0 [62%] Processing wip/py-hpp-bezier-com-traj:py37-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py37-hpp-bezier-com-traj-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Required robotpkg package py37-curves>=0.3.1: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-centroidal-dynamics>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-bezier-com-traj-4.9.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-bezier-com-traj/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py37-hpp-bezier-com-traj-4.9.0 [62%] Processing wip/py-hpp-bezier-com-traj:py38-hpp-bezier-com-traj-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-bezier-com-traj-4.9.0 ===> Bulk building for py38-hpp-bezier-com-traj-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-bezier-com-traj-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-bezier-com-traj-4.9.0 ===> Done bulk for py38-hpp-bezier-com-traj-4.9.0 [62%] Processing wip/pmb2-simulation:pmb2-simulation-2.0.12~!doc ===> Cleaning temporary files for pmb2-simulation-2.0.12 ===> Bulk building for pmb2-simulation-2.0.12 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pmb2-simulation-2.0.12: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pmb2-simulation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pmb2-simulation-2.0.12 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pmb2-simulation-2.0.12 ===> Done bulk for pmb2-simulation-2.0.12 [62%] Processing wip/py-hpp-universal-robot:py27-hpp-universal-robot-4.9.0~doc ===> Bulk building for py27-hpp-universal-robot-4.9.0~doc Binary package for py27-hpp-universal-robot-4.9.0~doc is up-to-date. [62%] Processing wip/py-hpp-universal-robot:py34-hpp-universal-robot-4.9.0~doc ===> Cleaning temporary files for py34-hpp-universal-robot-4.9.0~doc ===> Bulk building for py34-hpp-universal-robot-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-universal-robot-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-universal-robot-4.9.0~doc ===> Done bulk for py34-hpp-universal-robot-4.9.0~doc [62%] Processing wip/py-hpp-universal-robot:py35-hpp-universal-robot-4.9.0~doc ===> Cleaning temporary files for py35-hpp-universal-robot-4.9.0~doc ===> Bulk building for py35-hpp-universal-robot-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-universal-robot-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-universal-robot-4.9.0~doc ===> Done bulk for py35-hpp-universal-robot-4.9.0~doc [62%] Processing wip/py-hpp-universal-robot:py36-hpp-universal-robot-4.9.0~doc ===> Cleaning temporary files for py36-hpp-universal-robot-4.9.0~doc ===> Bulk building for py36-hpp-universal-robot-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-universal-robot-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-universal-robot-4.9.0~doc ===> Done bulk for py36-hpp-universal-robot-4.9.0~doc [63%] Processing wip/py-hpp-universal-robot:py37-hpp-universal-robot-4.9.0~doc ===> Cleaning temporary files for py37-hpp-universal-robot-4.9.0~doc ===> Bulk building for py37-hpp-universal-robot-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/example-robot-data-3.3.0.tgz => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-universal-robot-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-universal-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-universal-robot-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-universal-robot-4.9.0~doc ===> Done bulk for py37-hpp-universal-robot-4.9.0~doc [63%] Processing wip/py-hpp-universal-robot:py38-hpp-universal-robot-4.9.0~doc ===> Cleaning temporary files for py38-hpp-universal-robot-4.9.0~doc ===> Bulk building for py38-hpp-universal-robot-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-universal-robot-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-universal-robot-4.9.0~doc ===> Done bulk for py38-hpp-universal-robot-4.9.0~doc [63%] Processing wip/py-hpp-universal-robot:py27-hpp-universal-robot-4.9.0~!doc ===> Bulk building for py27-hpp-universal-robot-4.9.0 Binary package for py27-hpp-universal-robot-4.9.0 is up-to-date. [63%] Processing wip/py-hpp-universal-robot:py34-hpp-universal-robot-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-universal-robot-4.9.0 ===> Bulk building for py34-hpp-universal-robot-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-universal-robot-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-universal-robot-4.9.0 ===> Done bulk for py34-hpp-universal-robot-4.9.0 [63%] Processing wip/py-hpp-universal-robot:py35-hpp-universal-robot-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-universal-robot-4.9.0 ===> Bulk building for py35-hpp-universal-robot-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-universal-robot-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-universal-robot-4.9.0 ===> Done bulk for py35-hpp-universal-robot-4.9.0 [63%] Processing wip/py-hpp-universal-robot:py36-hpp-universal-robot-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-universal-robot-4.9.0 ===> Bulk building for py36-hpp-universal-robot-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-universal-robot-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-universal-robot-4.9.0 ===> Done bulk for py36-hpp-universal-robot-4.9.0 [63%] Processing wip/py-hpp-universal-robot:py37-hpp-universal-robot-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-universal-robot-4.9.0 ===> Bulk building for py37-hpp-universal-robot-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/example-robot-data-3.3.0.tgz => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-universal-robot-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-universal-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-universal-robot-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-universal-robot-4.9.0 ===> Done bulk for py37-hpp-universal-robot-4.9.0 [63%] Processing wip/py-hpp-universal-robot:py38-hpp-universal-robot-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-universal-robot-4.9.0 ===> Bulk building for py38-hpp-universal-robot-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-universal-robot-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-universal-robot-4.9.0 ===> Done bulk for py38-hpp-universal-robot-4.9.0 [64%] Processing wip/ros-py-urdf-parser:ros-py27-urdf-parser-0.4.0r1~!doc ===> Cleaning temporary files for ros-py27-urdf-parser-0.4.0r1 ===> Bulk building for ros-py27-urdf-parser-0.4.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-object-recognition-msgs>=0.4.1: N/A => Required robotpkg package ros-octomap-msgs>=0.3.3: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-py27-urdf-parser-0.4.0r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-py-urdf-parser/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-py27-urdf-parser-0.4.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-py27-urdf-parser-0.4.0r1 ===> Done bulk for ros-py27-urdf-parser-0.4.0r1 [64%] Processing wip/ros-py-urdf-parser:ros-py34-urdf-parser-0.4.0r1~!doc ===> Bulk building for ros-py34-urdf-parser-0.4.0r1 Binary package for ros-py34-urdf-parser-0.4.0r1 is up-to-date. [64%] Processing wip/ros-py-urdf-parser:ros-py35-urdf-parser-0.4.0r1~!doc ===> Bulk building for ros-py35-urdf-parser-0.4.0r1 Binary package for ros-py35-urdf-parser-0.4.0r1 is up-to-date. [64%] Processing wip/ros-py-urdf-parser:ros-py36-urdf-parser-0.4.0r1~!doc ===> Bulk building for ros-py36-urdf-parser-0.4.0r1 Binary package for ros-py36-urdf-parser-0.4.0r1 is up-to-date. [64%] Processing wip/ros-py-urdf-parser:ros-py37-urdf-parser-0.4.0r1~!doc ===> Cleaning temporary files for ros-py37-urdf-parser-0.4.0r1 ===> Bulk building for ros-py37-urdf-parser-0.4.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-object-recognition-msgs>=0.4.1: N/A => Required robotpkg package ros-octomap-msgs>=0.3.3: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-py37-urdf-parser-0.4.0r1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-py-urdf-parser/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-py37-urdf-parser-0.4.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-py37-urdf-parser-0.4.0r1 ===> Done bulk for ros-py37-urdf-parser-0.4.0r1 [64%] Processing wip/ros-py-urdf-parser:ros-py38-urdf-parser-0.4.0r1~!doc ===> Bulk building for ros-py38-urdf-parser-0.4.0r1 Binary package for ros-py38-urdf-parser-0.4.0r1 is up-to-date. [64%] Processing wip/can-utils:can-utils-2018.02.0~!doc ===> Cleaning temporary files for can-utils-2018.02.0 ===> Bulk building for can-utils-2018.02.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package autoconf>=2.59: autoconf-2.69 found => Required system package automake>=1.8: automake-1.16.1 found => Required system package gcc>=3: gcc-9 found => Required system package GNU m4>=1.4: gm4-1.4.18 found => SHA1 checksums OK => RMD160 checksums OK => Running autoreconf in can-utils-2018.02.0/ => Modifying GNU configure scripts to avoid --recheck => Disabling fatal errors with C++ preprocessor in GNU configure scripts An unexpected error occured. The last 10 log lines are shown below. | /usr/bin/gcc canbusload.o canframelen.o -o canbusload | /usr/bin/gcc log2long.o lib.o -o log2long | /usr/bin/gcc log2asc.o lib.o -o log2asc | make: *** [: slcanpty] Error 1 | /usr/bin/gcc asc2log.o lib.o -o asc2log | /usr/bin/gcc jacd.o libj1939.o -o jacd | /usr/bin/gcc jspy.o libj1939.o -o jspy | /usr/bin/gcc jsr.o libj1939.o -o jsr | /usr/bin/gcc testj1939.o libj1939.o -o testj1939 | make: Target 'all' not remade because of errors. For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/can-utils/work/build.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/build/build.mk:199: do-build] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking can-utils-2018.02.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for can-utils-2018.02.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for can-utils-2018.02.0 ===> Done bulk for can-utils-2018.02.0 [65%] Processing wip/libhatp:libhatp-1.3.0~!doc ===> Bulk building for libhatp-1.3.0 Binary package for libhatp-1.3.0 is up-to-date. [65%] Processing wip/ros-perception-pcl:ros-perception-pcl-1.7.0r2~!doc ===> Cleaning temporary files for ros-perception-pcl-1.7.0r2 ===> Bulk building for ros-perception-pcl-1.7.0r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-dynamic-reconfigure>=1.5.32: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-pcl-msgs>=0.2.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-perception-pcl-1.7.0r2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-perception-pcl/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-perception-pcl-1.7.0r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-perception-pcl-1.7.0r2 ===> Done bulk for ros-perception-pcl-1.7.0r2 [65%] Processing wip/roralink:roralink-0.3.0-Source~!doc ===> Cleaning temporary files for roralink-0.3.0-Source ===> Bulk building for roralink-0.3.0-Source => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package cmake>=2.6: cmake-3.16.3 found => Required system package gcc>=3: gcc-9 found => Fetching roralink-0.3.0-Source.tar.gz => Total size: 12237 bytes fetch: Unable to fetch expected file roralink-0.3.0-Source.tar.gz tnftp: Error retrieving file `404 Not Found' fetch: Unable to fetch expected file roralink-0.3.0-Source.tar.gz => Total size: 12237 bytes tnftp: Error retrieving file `404 Not Found' fetch: Unable to fetch expected file roralink-0.3.0-Source.tar.gz ERROR: ====================================================================== ERROR: Could not fetch the following file: ERROR: roralink-0.3.0-Source.tar.gz ERROR: ERROR: Please retrieve this file manually into: ERROR: /opt/robotpkg/var/lib/robotpkg/distfiles/ ERROR: ====================================================================== make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/fetch/fetch.mk:185: /opt/robotpkg/var/lib/robotpkg/distfiles/roralink-0.3.0-Source.tar.gz] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking roralink-0.3.0-Source as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for roralink-0.3.0-Source => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for roralink-0.3.0-Source ===> Done bulk for roralink-0.3.0-Source [65%] Processing wip/fcl:fcl-0.5.0~!doc ===> Bulk building for fcl-0.5.0 Binary package for fcl-0.5.0 is up-to-date. [65%] Processing wip/py-qt-gepetto-pythonqt:py27-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Cleaning temporary files for py27-qt4-gepetto-pythonqt-0.0.1r2 ===> Bulk building for py27-qt4-gepetto-pythonqt-0.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package qt4-libs>=4.6.2<5: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qt4-gepetto-pythonqt-0.0.1r2: ERROR: ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qt4-gepetto-pythonqt-0.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt4-gepetto-pythonqt-0.0.1r2 ===> Done bulk for py27-qt4-gepetto-pythonqt-0.0.1r2 [65%] Processing wip/py-qt-gepetto-pythonqt:py27-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Cleaning temporary files for py27-qt5-gepetto-pythonqt-0.0.1r2 ===> Bulk building for py27-qt5-gepetto-pythonqt-0.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Use qt-5: qt>=4 provided by => Required system package cmake>=2.6: cmake-3.16.3 found => Required system package g++>=4.8: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package python27>=2.7<2.8: python27-2.7.181 found => Required system package qt5-qtbase>=5<6: qt5-qtbase-5.12.8 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | /usr/include/python2.7/abstract.h:1354:50: warning: ISO C++ forbids converting a string constant to 'char*' [-Wwrite-strings] | 1354 | #define PyMapping_Items(O) PyObject_CallMethod(O,"items",NULL) | | ^~~~~~~ | /local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/PythonQt-0.0.1/src/PythonQtConversion.cpp:956:23: note: in expansion of macro 'PyMapping_Items' | 956 | PyObject* items = PyMapping_Items(val); | | ^~~~~~~~~~~~~~~ | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/PythonQt-0.0.1' | make[1]: *** [CMakeFiles/Makefile2:120: CMakeFiles/PythonQt.dir/all] Error 2 | make: *** [Makefile:133: all] Error 2 | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/PythonQt-0.0.1' For details or bug reports, check the complete log file in: => Marking py27-qt5-gepetto-pythonqt-0.0.1r2 as broken /local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/build.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/build/build.mk:199: do-build] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py27-qt5-gepetto-pythonqt-0.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt5-gepetto-pythonqt-0.0.1r2 ===> Done bulk for py27-qt5-gepetto-pythonqt-0.0.1r2 [65%] Processing wip/py-qt-gepetto-pythonqt:py34-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py34-qt4-gepetto-pythonqt-0.0.1r2 Binary package for py34-qt4-gepetto-pythonqt-0.0.1r2 is up-to-date. [65%] Processing wip/py-qt-gepetto-pythonqt:py34-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py34-qt5-gepetto-pythonqt-0.0.1r2 Binary package for py34-qt5-gepetto-pythonqt-0.0.1r2 is up-to-date. [66%] Processing wip/py-qt-gepetto-pythonqt:py35-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py35-qt4-gepetto-pythonqt-0.0.1r2 Binary package for py35-qt4-gepetto-pythonqt-0.0.1r2 is up-to-date. [66%] Processing wip/py-qt-gepetto-pythonqt:py35-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py35-qt5-gepetto-pythonqt-0.0.1r2 Binary package for py35-qt5-gepetto-pythonqt-0.0.1r2 is up-to-date. [66%] Processing wip/py-qt-gepetto-pythonqt:py36-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py36-qt4-gepetto-pythonqt-0.0.1r2 Binary package for py36-qt4-gepetto-pythonqt-0.0.1r2 is up-to-date. [66%] Processing wip/py-qt-gepetto-pythonqt:py36-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py36-qt5-gepetto-pythonqt-0.0.1r2 Binary package for py36-qt5-gepetto-pythonqt-0.0.1r2 is up-to-date. [66%] Processing wip/py-qt-gepetto-pythonqt:py37-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Cleaning temporary files for py37-qt4-gepetto-pythonqt-0.0.1r2 ===> Bulk building for py37-qt4-gepetto-pythonqt-0.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Required system package qt4-libs>=4.6.2<5: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt4-gepetto-pythonqt-0.0.1r2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-qt4-gepetto-pythonqt-0.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt4-gepetto-pythonqt-0.0.1r2 ===> Done bulk for py37-qt4-gepetto-pythonqt-0.0.1r2 [66%] Processing wip/py-qt-gepetto-pythonqt:py37-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Cleaning temporary files for py37-qt5-gepetto-pythonqt-0.0.1r2 ===> Bulk building for py37-qt5-gepetto-pythonqt-0.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt5-gepetto-pythonqt-0.0.1r2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-qt-gepetto-pythonqt/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-qt5-gepetto-pythonqt-0.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt5-gepetto-pythonqt-0.0.1r2 ===> Done bulk for py37-qt5-gepetto-pythonqt-0.0.1r2 [66%] Processing wip/py-qt-gepetto-pythonqt:py38-qt4-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py38-qt4-gepetto-pythonqt-0.0.1r2 Binary package for py38-qt4-gepetto-pythonqt-0.0.1r2 is up-to-date. [67%] Processing wip/py-qt-gepetto-pythonqt:py38-qt5-gepetto-pythonqt-0.0.1r2~!doc ===> Bulk building for py38-qt5-gepetto-pythonqt-0.0.1r2 Binary package for py38-qt5-gepetto-pythonqt-0.0.1r2 is up-to-date. [67%] Processing wip/prf-teleop-tools:prf-teleop-tools-0.3.2~!doc ===> Cleaning temporary files for prf-teleop-tools-0.3.2 ===> Bulk building for prf-teleop-tools-0.3.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-four-wheel-steering-msgs>=1.0.0: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-urdf-geometry-parser>=0.0.3: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for prf-teleop-tools-0.3.2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/prf-teleop-tools/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for prf-teleop-tools-0.3.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for prf-teleop-tools-0.3.2 ===> Done bulk for prf-teleop-tools-0.3.2 [67%] Processing wip/py-ecos:py27-ecos-2.0.7.post1~!doc ===> Cleaning temporary files for py27-ecos-2.0.7.post1 ===> Bulk building for py27-ecos-2.0.7.post1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package py27-numpy>=1: MISSING => Required system package py27-scipy>=0.17.0: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-ecos-2.0.7.post1: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-scipy>=0.17.0 (Ubuntu package python-scipy) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-ecos/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-ecos-2.0.7.post1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-ecos-2.0.7.post1 ===> Done bulk for py27-ecos-2.0.7.post1 [67%] Processing wip/py-ecos:py34-ecos-2.0.7.post1~!doc ===> Bulk building for py34-ecos-2.0.7.post1 Binary package for py34-ecos-2.0.7.post1 is up-to-date. [67%] Processing wip/py-ecos:py35-ecos-2.0.7.post1~!doc ===> Bulk building for py35-ecos-2.0.7.post1 Binary package for py35-ecos-2.0.7.post1 is up-to-date. [67%] Processing wip/py-ecos:py36-ecos-2.0.7.post1~!doc ===> Bulk building for py36-ecos-2.0.7.post1 Binary package for py36-ecos-2.0.7.post1 is up-to-date. [67%] Processing wip/py-ecos:py37-ecos-2.0.7.post1~!doc ===> Cleaning temporary files for py37-ecos-2.0.7.post1 ===> Bulk building for py37-ecos-2.0.7.post1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-ecos-2.0.7.post1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-ecos/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-ecos-2.0.7.post1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-ecos-2.0.7.post1 ===> Done bulk for py37-ecos-2.0.7.post1 [67%] Processing wip/py-ecos:py38-ecos-2.0.7.post1~!doc ===> Bulk building for py38-ecos-2.0.7.post1 Binary package for py38-ecos-2.0.7.post1 is up-to-date. [68%] Processing wip/tiago-moveit-config:tiago-moveit-config-1.0.2~!doc ===> Cleaning temporary files for tiago-moveit-config-1.0.2 ===> Bulk building for tiago-moveit-config-1.0.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-moveit-config-1.0.2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-moveit-config/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-moveit-config-1.0.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-moveit-config-1.0.2 ===> Done bulk for tiago-moveit-config-1.0.2 [68%] Processing wip/tiago-robot:tiago-robot-2.0.26~!doc ===> Cleaning temporary files for tiago-robot-2.0.26 ===> Bulk building for tiago-robot-2.0.26 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package head-action>=0.0.1: N/A => Required robotpkg package hey5-description>=1.0.1: N/A => Required robotpkg package pal-gripper>=0.0.13: N/A => Required robotpkg package pal-wsg-gripper>=0.0.7: N/A => Required robotpkg package pmb2-robot>=1.1.8: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tf-lookup>=0.0.1: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-robot-2.0.26: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-robot-2.0.26 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-robot-2.0.26 ===> Done bulk for tiago-robot-2.0.26 [68%] Processing wip/py-prf-gazebo-ros-pkgs:py27-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Cleaning temporary files for py27-prf-gazebo-ros-pkgs-3.0.1 ===> Bulk building for py27-prf-gazebo-ros-pkgs-3.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package ros-angles>=1.9: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-diagnostics>=1.9<1.10: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-image-common>=1.11<1.12: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-vision-opencv>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-prf-gazebo-ros-pkgs-3.0.1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-gazebo-ros-pkgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-prf-gazebo-ros-pkgs-3.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-prf-gazebo-ros-pkgs-3.0.1 ===> Done bulk for py27-prf-gazebo-ros-pkgs-3.0.1 [68%] Processing wip/py-prf-gazebo-ros-pkgs:py34-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Bulk building for py34-prf-gazebo-ros-pkgs-3.0.1 Binary package for py34-prf-gazebo-ros-pkgs-3.0.1 is up-to-date. [68%] Processing wip/py-prf-gazebo-ros-pkgs:py35-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Bulk building for py35-prf-gazebo-ros-pkgs-3.0.1 Binary package for py35-prf-gazebo-ros-pkgs-3.0.1 is up-to-date. [68%] Processing wip/py-prf-gazebo-ros-pkgs:py36-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Bulk building for py36-prf-gazebo-ros-pkgs-3.0.1 Binary package for py36-prf-gazebo-ros-pkgs-3.0.1 is up-to-date. [68%] Processing wip/py-prf-gazebo-ros-pkgs:py37-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Cleaning temporary files for py37-prf-gazebo-ros-pkgs-3.0.1 ===> Bulk building for py37-prf-gazebo-ros-pkgs-3.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-prf-ros-control>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package ros-angles>=1.9: N/A => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-diagnostics>=1.9<1.10: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-image-common>=1.11<1.12: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-vision-opencv>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-prf-gazebo-ros-pkgs-3.0.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-gazebo-ros-pkgs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-prf-gazebo-ros-pkgs-3.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-prf-gazebo-ros-pkgs-3.0.1 ===> Done bulk for py37-prf-gazebo-ros-pkgs-3.0.1 [69%] Processing wip/py-prf-gazebo-ros-pkgs:py38-prf-gazebo-ros-pkgs-3.0.1~!doc ===> Bulk building for py38-prf-gazebo-ros-pkgs-3.0.1 Binary package for py38-prf-gazebo-ros-pkgs-3.0.1 is up-to-date. [69%] Processing wip/pal-navigation-sm:pal-navigation-sm-0.1.7os1r1~!doc ===> Cleaning temporary files for pal-navigation-sm-0.1.7os1r1 ===> Bulk building for pal-navigation-sm-0.1.7os1r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-pal-python>=0.9.14os1: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-navigation-sm-0.1.7os1r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-navigation-sm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-navigation-sm-0.1.7os1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-navigation-sm-0.1.7os1r1 ===> Done bulk for pal-navigation-sm-0.1.7os1r1 [69%] Processing wip/py-prf-ros-controllers:py27-prf-ros-controllers-0.3.15r2~!doc ===> Cleaning temporary files for py27-prf-ros-controllers-0.3.15r2 ===> Bulk building for py27-prf-ros-controllers-0.3.15r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-four-wheel-steering-msgs>=1.0.0: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-urdf-geometry-parser>=0.0.3: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-prf-ros-controllers-0.3.15r2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-ros-controllers/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-prf-ros-controllers-0.3.15r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-prf-ros-controllers-0.3.15r2 ===> Done bulk for py27-prf-ros-controllers-0.3.15r2 [69%] Processing wip/py-prf-ros-controllers:py34-prf-ros-controllers-0.3.15r2~!doc ===> Bulk building for py34-prf-ros-controllers-0.3.15r2 Binary package for py34-prf-ros-controllers-0.3.15r2 is up-to-date. [69%] Processing wip/py-prf-ros-controllers:py35-prf-ros-controllers-0.3.15r2~!doc ===> Bulk building for py35-prf-ros-controllers-0.3.15r2 Binary package for py35-prf-ros-controllers-0.3.15r2 is up-to-date. [69%] Processing wip/py-prf-ros-controllers:py36-prf-ros-controllers-0.3.15r2~!doc ===> Bulk building for py36-prf-ros-controllers-0.3.15r2 Binary package for py36-prf-ros-controllers-0.3.15r2 is up-to-date. [69%] Processing wip/py-prf-ros-controllers:py37-prf-ros-controllers-0.3.15r2~!doc ===> Cleaning temporary files for py37-prf-ros-controllers-0.3.15r2 ===> Bulk building for py37-prf-ros-controllers-0.3.15r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-prf-ros-control>=0.2: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-four-wheel-steering-msgs>=1.0.0: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-urdf-geometry-parser>=0.0.3: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-prf-ros-controllers-0.3.15r2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-prf-ros-controllers/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-prf-ros-controllers-0.3.15r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-prf-ros-controllers-0.3.15r2 ===> Done bulk for py37-prf-ros-controllers-0.3.15r2 [69%] Processing wip/py-prf-ros-controllers:py38-prf-ros-controllers-0.3.15r2~!doc ===> Bulk building for py38-prf-ros-controllers-0.3.15r2 Binary package for py38-prf-ros-controllers-0.3.15r2 is up-to-date. [70%] Processing wip/multicontact-api:multicontact-api-2.0.0~!doc ===> Bulk building for multicontact-api-2.0.0 Binary package for multicontact-api-2.0.0 is up-to-date. [70%] Processing wip/sot-hrp2:sot-hrp2-1.1.2~!doc ===> Cleaning temporary files for sot-hrp2-1.1.2 ===> Bulk building for sot-hrp2-1.1.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-2.5.7.tgz => Required robotpkg package dynamic-graph-bridge>=1.0.0: N/A => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hrp2-14-1.9.3.tgz => Required robotpkg package hrp2-14-description>=1.0.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hrp2-bringup-1.0.6.tgz => Dependency hrp2-computer-monitor-1.0.2 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hrp2-dynamics-1.5.3.tgz => Dependency hrp2-machine-1.0.2 already installed => Dependency jrl-mal-1.19.6r1~jrl-mathtools already installed => Required robotpkg package py27-dynamic-graph>=2.5: N/A => Required robotpkg package py27-sot-application>=1.0.0: N/A => Required robotpkg package py27-sot-tools>=1.0: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-realtime-tools>=1.8.2: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package sot-core>=2.5: N/A => Required robotpkg package sot-dynamic>=2.5: N/A => Required robotpkg package sot-dyninv>=2.0.0: NOT found ERROR: Required robotpkg package sot-dyninv>=2.0.0: NOT found => Required robotpkg package sot-pattern-generator>=2.7: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-hrp2-1.1.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrp2-1.1.2 ===> Done bulk for sot-hrp2-1.1.2 [70%] Processing wip/sot-core-v3:sot-core-v3-4.9.0~!doc ===> Cleaning temporary files for sot-core-v3-4.9.0 ===> Bulk building for sot-core-v3-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/example-robot-data-3.3.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=3.1.0: cmake-3.16.3 found => Required system package doxygen>=1.5: doxygen-1.8.17 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package graphviz>=2: graphviz-2.43.0 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required system package urdfdom>=0.2.8: urdfdom-1.0.4 found => Required robotpkg package dynamic-graph-v3>=3.8.1: dynamic-graph-v3-4.1.0 found => Required robotpkg package example-robot-data>=3.2.0: example-robot-data-3.3.0 found => Required robotpkg package hpp-fcl>=1.4: hpp-fcl-1.4.4~doc found => Required robotpkg package octomap>=1.6.0: octomap-1.9.0 found => Required robotpkg package pinocchio>=2.3<3.0.0: pinocchio-2.4.4 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and references files it does not | provide. | | | | -- Generating done | CMake Generate step failed. Build files cannot be regenerated correctly. For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/sot-core-v3/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking sot-core-v3-4.9.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for sot-core-v3-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-core-v3-4.9.0 ===> Done bulk for sot-core-v3-4.9.0 [70%] Processing wip/msgconnector:msgconnector-2.13.0~!doc ===> Cleaning temporary files for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp ===> Bulk building for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/libhatp-1.3.0.tgz => Required robotpkg package liboro>=1.0: NOT found ERROR: Required robotpkg package liboro>=1.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/openprs-1.1b10.tgz => Dependency tnftp-20130505~ssl already installed => Required robotpkg package yarp>=2.3.1: N/A ===> Logging bulk summary for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp ===> Done bulk for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp [70%] Processing wip/talos-data:talos-data-1.2.2~!doc ===> Cleaning temporary files for talos-data-1.2.2 ===> Bulk building for talos-data-1.2.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for talos-data-1.2.2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/talos-data/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for talos-data-1.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-data-1.2.2 ===> Done bulk for talos-data-1.2.2 [70%] Processing wip/py-talos-rbprm:py27-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py27-talos-rbprm-4.9.0~doc ===> Bulk building for py27-talos-rbprm-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-talos-rbprm-4.9.0~doc ===> Done bulk for py27-talos-rbprm-4.9.0~doc [70%] Processing wip/py-talos-rbprm:py34-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py34-talos-rbprm-4.9.0~doc ===> Bulk building for py34-talos-rbprm-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-talos-rbprm-4.9.0~doc ===> Done bulk for py34-talos-rbprm-4.9.0~doc [70%] Processing wip/py-talos-rbprm:py35-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py35-talos-rbprm-4.9.0~doc ===> Bulk building for py35-talos-rbprm-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-talos-rbprm-4.9.0~doc ===> Done bulk for py35-talos-rbprm-4.9.0~doc [71%] Processing wip/py-talos-rbprm:py36-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py36-talos-rbprm-4.9.0~doc ===> Bulk building for py36-talos-rbprm-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-talos-rbprm-4.9.0~doc ===> Done bulk for py36-talos-rbprm-4.9.0~doc [71%] Processing wip/py-talos-rbprm:py37-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py37-talos-rbprm-4.9.0~doc ===> Bulk building for py37-talos-rbprm-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-talos-rbprm-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-talos-rbprm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-talos-rbprm-4.9.0~doc ===> Done bulk for py37-talos-rbprm-4.9.0~doc [71%] Processing wip/py-talos-rbprm:py38-talos-rbprm-4.9.0~doc ===> Cleaning temporary files for py38-talos-rbprm-4.9.0~doc ===> Bulk building for py38-talos-rbprm-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-talos-rbprm-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-talos-rbprm-4.9.0~doc ===> Done bulk for py38-talos-rbprm-4.9.0~doc [71%] Processing wip/py-talos-rbprm:py27-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py27-talos-rbprm-4.9.0 ===> Bulk building for py27-talos-rbprm-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-talos-rbprm-4.9.0 ===> Done bulk for py27-talos-rbprm-4.9.0 [71%] Processing wip/py-talos-rbprm:py34-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py34-talos-rbprm-4.9.0 ===> Bulk building for py34-talos-rbprm-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-talos-rbprm-4.9.0 ===> Done bulk for py34-talos-rbprm-4.9.0 [71%] Processing wip/py-talos-rbprm:py35-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py35-talos-rbprm-4.9.0 ===> Bulk building for py35-talos-rbprm-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-talos-rbprm-4.9.0 ===> Done bulk for py35-talos-rbprm-4.9.0 [71%] Processing wip/py-talos-rbprm:py36-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py36-talos-rbprm-4.9.0 ===> Bulk building for py36-talos-rbprm-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-talos-rbprm-4.9.0 ===> Done bulk for py36-talos-rbprm-4.9.0 [72%] Processing wip/py-talos-rbprm:py37-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py37-talos-rbprm-4.9.0 ===> Bulk building for py37-talos-rbprm-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-talos-rbprm-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-talos-rbprm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-talos-rbprm-4.9.0 ===> Done bulk for py37-talos-rbprm-4.9.0 [72%] Processing wip/py-talos-rbprm:py38-talos-rbprm-4.9.0~!doc ===> Cleaning temporary files for py38-talos-rbprm-4.9.0 ===> Bulk building for py38-talos-rbprm-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-talos-rbprm-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-talos-rbprm-4.9.0 ===> Done bulk for py38-talos-rbprm-4.9.0 [72%] Processing wip/ddp-actuator-solver:ddp-actuator-solver-1.2.0~!doc ===> Bulk building for ddp-actuator-solver-1.2.0 Binary package for ddp-actuator-solver-1.2.0 is up-to-date. [72%] Processing wip/py-example-adder:py27-example-adder-2.0.1~!doc ===> Cleaning temporary files for py27-example-adder-2.0.1 ===> Bulk building for py27-example-adder-2.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/example-adder-2.0.1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Required system package boost-headers>=1.34.1: boost-headers-1.71 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.71.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.71.0 found => Required system package cmake>=3.1.0: cmake-3.16.3 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package python27>=2.7<2.8: python27-2.7.181 found => Required robotpkg package example-adder>=1.0.0: example-adder-2.0.1 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | Could NOT find Boost (missing: python) (found version "1.71.0") | Call Stack (most recent call first): | /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE) | /usr/share/cmake-3.16/Modules/FindBoost.cmake:2179 (find_package_handle_standard_args) | cmake/boost.cmake:128 (FIND_PACKAGE) | CMakeLists.txt:35 (SEARCH_FOR_BOOST) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-example-adder/work/example-adder-2.0.1/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-example-adder/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking py27-example-adder-2.0.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py27-example-adder-2.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-example-adder-2.0.1 ===> Done bulk for py27-example-adder-2.0.1 [72%] Processing wip/py-example-adder:py34-example-adder-2.0.1~!doc ===> Bulk building for py34-example-adder-2.0.1 Binary package for py34-example-adder-2.0.1 is up-to-date. [72%] Processing wip/py-example-adder:py35-example-adder-2.0.1~!doc ===> Bulk building for py35-example-adder-2.0.1 Binary package for py35-example-adder-2.0.1 is up-to-date. [72%] Processing wip/py-example-adder:py36-example-adder-2.0.1~!doc ===> Bulk building for py36-example-adder-2.0.1 Binary package for py36-example-adder-2.0.1 is up-to-date. [72%] Processing wip/py-example-adder:py37-example-adder-2.0.1~!doc ===> Cleaning temporary files for py37-example-adder-2.0.1 ===> Bulk building for py37-example-adder-2.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/example-adder-2.0.1.tgz => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-example-adder-2.0.1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-example-adder/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-example-adder-2.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-example-adder-2.0.1 ===> Done bulk for py37-example-adder-2.0.1 [73%] Processing wip/py-example-adder:py38-example-adder-2.0.1~!doc ===> Bulk building for py38-example-adder-2.0.1 Binary package for py38-example-adder-2.0.1 is up-to-date. [73%] Processing wip/libpointmatcher:libpointmatcher-1.3.1~!doc ===> Bulk building for libpointmatcher-1.3.1 Binary package for libpointmatcher-1.3.1 is up-to-date. [73%] Processing wip/ros-aicp-mapping:ros-aicp-mapping-0.0.1r2~!doc ===> Cleaning temporary files for ros-aicp-mapping-0.0.1r2 ===> Bulk building for ros-aicp-mapping-0.0.1r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/libnabo-1.0.7.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/libpointmatcher-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/octomap-1.9.0.tgz => Required system package opencv3>=3: MISSING => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-perception-pcl>=1.7.0: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-aicp-mapping-0.0.1r2: ERROR: ERROR: opencv3>=3 (Ubuntu package libopencv-dev libcv-dev libhighgui-dev) ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-aicp-mapping/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-aicp-mapping-0.0.1r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-aicp-mapping-0.0.1r2 ===> Done bulk for ros-aicp-mapping-0.0.1r2 [73%] Processing wip/py-multicontact-api:py27-multicontact-api-2.0.0~!doc ===> Cleaning temporary files for py27-multicontact-api-2.0.0 ===> Bulk building for py27-multicontact-api-2.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Dependency hpp-fcl-1.4.4~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/multicontact-api-2.0.0.tgz => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py27-curves>=0.3.1: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-multicontact-api-2.0.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-multicontact-api/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-multicontact-api-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-multicontact-api-2.0.0 ===> Done bulk for py27-multicontact-api-2.0.0 [73%] Processing wip/py-multicontact-api:py34-multicontact-api-2.0.0~!doc ===> Bulk building for py34-multicontact-api-2.0.0 Binary package for py34-multicontact-api-2.0.0 is up-to-date. [73%] Processing wip/py-multicontact-api:py35-multicontact-api-2.0.0~!doc ===> Bulk building for py35-multicontact-api-2.0.0 Binary package for py35-multicontact-api-2.0.0 is up-to-date. [73%] Processing wip/py-multicontact-api:py36-multicontact-api-2.0.0~!doc ===> Bulk building for py36-multicontact-api-2.0.0 Binary package for py36-multicontact-api-2.0.0 is up-to-date. [74%] Processing wip/py-multicontact-api:py37-multicontact-api-2.0.0~!doc ===> Cleaning temporary files for py37-multicontact-api-2.0.0 ===> Bulk building for py37-multicontact-api-2.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed => Dependency hpp-fcl-1.4.4~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/multicontact-api-2.0.0.tgz => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py37-curves>=0.3.1: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-multicontact-api-2.0.0: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-multicontact-api/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-multicontact-api-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-multicontact-api-2.0.0 ===> Done bulk for py37-multicontact-api-2.0.0 [74%] Processing wip/py-multicontact-api:py38-multicontact-api-2.0.0~!doc ===> Bulk building for py38-multicontact-api-2.0.0 Binary package for py38-multicontact-api-2.0.0 is up-to-date. [74%] Processing wip/tiago-navigation:tiago-navigation-2.0.0~!doc ===> Cleaning temporary files for tiago-navigation-2.0.0 ===> Bulk building for tiago-navigation-2.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-navigation-sm>=0.1.7: N/A => Required robotpkg package pmb2-navigation>=1.0.4: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package rviz-plugin-covariance>=0.0.6: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-navigation-2.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-navigation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-navigation-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-navigation-2.0.0 ===> Done bulk for tiago-navigation-2.0.0 [74%] Processing wip/ros-warehouse-ros:ros-warehouse-ros-0.9.2r1~!doc ===> Cleaning temporary files for ros-warehouse-ros-0.9.2r1 ===> Bulk building for ros-warehouse-ros-0.9.2r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-object-recognition-msgs>=0.4.1: N/A => Required robotpkg package ros-octomap-msgs>=0.3.3: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-warehouse-ros-0.9.2r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-warehouse-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-warehouse-ros-0.9.2r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-warehouse-ros-0.9.2r1 ===> Done bulk for ros-warehouse-ros-0.9.2r1 [74%] Processing wip/ros-moveit-resources:ros-moveit-resources-0.6.5~!doc ===> Cleaning temporary files for ros-moveit-resources-0.6.5 ===> Bulk building for ros-moveit-resources-0.6.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-joint-state-publisher>=1.12<1.13: N/A => Required robotpkg package ros-robot-state-publisher>=1.9: N/A => Required robotpkg package ros-warehouse-ros>=0.9.2: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-moveit-resources-0.6.5: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-moveit-resources/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-moveit-resources-0.6.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-moveit-resources-0.6.5 ===> Done bulk for ros-moveit-resources-0.6.5 [74%] Processing wip/infuse-novatel-gps-driver-ros:infuse-novatel-gps-driver-ros-0.1.0~!doc ===> Cleaning temporary files for infuse-novatel-gps-driver-ros-0.1.0 ===> Bulk building for infuse-novatel-gps-driver-ros-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed WARNING: Cannot check installed version of libpcap => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-console-bridge>=0.5<0.6: N/A => Required robotpkg package ros-diagnostics>=1.9<1.10: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-gps-umd>=0.2.0: NOT found ERROR: Required robotpkg package ros-gps-umd>=0.2.0: NOT found => Required robotpkg package ros-nodelet-core>=1.9<1.10: N/A => Required robotpkg package ros-swri-math-util>=2.3.0: N/A => Required robotpkg package ros-swri-nodelet>=2.3.0: N/A => Required robotpkg package ros-swri-roscpp>=2.3.0: N/A => Required robotpkg package ros-swri-serial-util>=2.3.0: N/A => Required robotpkg package ros-swri-string-util>=2.3.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for infuse-novatel-gps-driver-ros-0.1.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/infuse-novatel-gps-driver-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for infuse-novatel-gps-driver-ros-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for infuse-novatel-gps-driver-ros-0.1.0 ===> Done bulk for infuse-novatel-gps-driver-ros-0.1.0 [74%] Processing wip/hpp-benchmark:py27-qt4-hpp-benchmark~doc ===> Cleaning temporary files for py27-qt4-hpp-benchmark~doc ===> Bulk building for py27-qt4-hpp-benchmark~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Required system package openscenegraph-qt4>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-baxter-4.9.0~doc.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py27-hpp-romeo>=4.9.0: N/A => Required robotpkg package py27-qt4-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py27-qt4-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py27-qt4-hpp-gepetto-viewer>=4.9.0: N/A => Required system package qt4-libs>=4.6.2<5: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qt4-hpp-benchmark~doc: ERROR: ERROR: openscenegraph-qt4>=3 (Ubuntu package libopenscenegraph-dev for qt4) ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qt4-hpp-benchmark~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt4-hpp-benchmark~doc ===> Done bulk for py27-qt4-hpp-benchmark~doc [74%] Processing wip/hpp-benchmark:py27-qt5-hpp-benchmark~doc ===> Cleaning temporary files for py27-qt5-hpp-benchmark~doc ===> Bulk building for py27-qt5-hpp-benchmark~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Required system package openscenegraph-qt5>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-baxter-4.9.0~doc.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py27-hpp-romeo>=4.9.0: N/A => Required robotpkg package py27-qt5-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py27-qt5-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py27-qt5-hpp-gepetto-viewer>=4.9.0: N/A => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qt5-hpp-benchmark~doc: ERROR: ERROR: openscenegraph-qt5>=3 (Ubuntu package libopenscenegraph-dev for qt5) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qt5-hpp-benchmark~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt5-hpp-benchmark~doc ===> Done bulk for py27-qt5-hpp-benchmark~doc [75%] Processing wip/hpp-benchmark:py34-qt4-hpp-benchmark~doc ===> Bulk building for py34-qt4-hpp-benchmark~doc Binary package for py34-qt4-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py34-qt5-hpp-benchmark~doc ===> Bulk building for py34-qt5-hpp-benchmark~doc Binary package for py34-qt5-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py35-qt4-hpp-benchmark~doc ===> Bulk building for py35-qt4-hpp-benchmark~doc Binary package for py35-qt4-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py35-qt5-hpp-benchmark~doc ===> Bulk building for py35-qt5-hpp-benchmark~doc Binary package for py35-qt5-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py36-qt4-hpp-benchmark~doc ===> Bulk building for py36-qt4-hpp-benchmark~doc Binary package for py36-qt4-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py36-qt5-hpp-benchmark~doc ===> Bulk building for py36-qt5-hpp-benchmark~doc Binary package for py36-qt5-hpp-benchmark~doc is up-to-date. [75%] Processing wip/hpp-benchmark:py37-qt4-hpp-benchmark~doc ===> Cleaning temporary files for py37-qt4-hpp-benchmark~doc ===> Bulk building for py37-qt4-hpp-benchmark~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Required system package openscenegraph-qt4>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-baxter>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-romeo>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-qt4-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py37-qt4-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py37-qt4-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required system package qt4-libs>=4.6.2<5: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt4-hpp-benchmark~doc: ERROR: ERROR: openscenegraph-qt4>=3 (Ubuntu package libopenscenegraph-dev for qt4) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-qt4-hpp-benchmark~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt4-hpp-benchmark~doc ===> Done bulk for py37-qt4-hpp-benchmark~doc [76%] Processing wip/hpp-benchmark:py37-qt5-hpp-benchmark~doc ===> Cleaning temporary files for py37-qt5-hpp-benchmark~doc ===> Bulk building for py37-qt5-hpp-benchmark~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Required system package openscenegraph-qt5>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-baxter>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-romeo>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-qt5-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py37-qt5-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py37-qt5-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt5-hpp-benchmark~doc: ERROR: ERROR: openscenegraph-qt5>=3 (Ubuntu package libopenscenegraph-dev for qt5) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-qt5-hpp-benchmark~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt5-hpp-benchmark~doc ===> Done bulk for py37-qt5-hpp-benchmark~doc [76%] Processing wip/hpp-benchmark:py38-qt4-hpp-benchmark~doc ===> Bulk building for py38-qt4-hpp-benchmark~doc Binary package for py38-qt4-hpp-benchmark~doc is up-to-date. [76%] Processing wip/hpp-benchmark:py38-qt5-hpp-benchmark~doc ===> Bulk building for py38-qt5-hpp-benchmark~doc Binary package for py38-qt5-hpp-benchmark~doc is up-to-date. [76%] Processing wip/hpp-benchmark:py27-qt4-hpp-benchmark~!doc ===> Cleaning temporary files for py27-qt4-hpp-benchmark ===> Bulk building for py27-qt4-hpp-benchmark => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Required system package openscenegraph-qt4>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-baxter-4.9.0~doc.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py27-hpp-romeo>=4.9.0: N/A => Required robotpkg package py27-qt4-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py27-qt4-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py27-qt4-hpp-gepetto-viewer>=4.9.0: N/A => Required system package qt4-libs>=4.6.2<5: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qt4-hpp-benchmark: ERROR: ERROR: openscenegraph-qt4>=3 (Ubuntu package libopenscenegraph-dev for qt4) ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qt4-hpp-benchmark => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt4-hpp-benchmark ===> Done bulk for py27-qt4-hpp-benchmark [76%] Processing wip/hpp-benchmark:py27-qt5-hpp-benchmark~!doc ===> Cleaning temporary files for py27-qt5-hpp-benchmark ===> Bulk building for py27-qt5-hpp-benchmark => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Required system package openscenegraph-qt5>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-baxter-4.9.0~doc.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py27-hpp-romeo>=4.9.0: N/A => Required robotpkg package py27-qt5-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py27-qt5-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py27-qt5-hpp-gepetto-viewer>=4.9.0: N/A => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-qt5-hpp-benchmark: ERROR: ERROR: openscenegraph-qt5>=3 (Ubuntu package libopenscenegraph-dev for qt5) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-qt5-hpp-benchmark => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-qt5-hpp-benchmark ===> Done bulk for py27-qt5-hpp-benchmark [76%] Processing wip/hpp-benchmark:py34-qt4-hpp-benchmark~!doc ===> Bulk building for py34-qt4-hpp-benchmark Binary package for py34-qt4-hpp-benchmark is up-to-date. [76%] Processing wip/hpp-benchmark:py34-qt5-hpp-benchmark~!doc ===> Bulk building for py34-qt5-hpp-benchmark Binary package for py34-qt5-hpp-benchmark is up-to-date. [76%] Processing wip/hpp-benchmark:py35-qt4-hpp-benchmark~!doc ===> Bulk building for py35-qt4-hpp-benchmark Binary package for py35-qt4-hpp-benchmark is up-to-date. [77%] Processing wip/hpp-benchmark:py35-qt5-hpp-benchmark~!doc ===> Bulk building for py35-qt5-hpp-benchmark Binary package for py35-qt5-hpp-benchmark is up-to-date. [77%] Processing wip/hpp-benchmark:py36-qt4-hpp-benchmark~!doc ===> Bulk building for py36-qt4-hpp-benchmark Binary package for py36-qt4-hpp-benchmark is up-to-date. [77%] Processing wip/hpp-benchmark:py36-qt5-hpp-benchmark~!doc ===> Bulk building for py36-qt5-hpp-benchmark Binary package for py36-qt5-hpp-benchmark is up-to-date. [77%] Processing wip/hpp-benchmark:py37-qt4-hpp-benchmark~!doc ===> Cleaning temporary files for py37-qt4-hpp-benchmark ===> Bulk building for py37-qt4-hpp-benchmark => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Required system package openscenegraph-qt4>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-baxter>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-romeo>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-qt4-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py37-qt4-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py37-qt4-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required system package qt4-libs>=4.6.2<5: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt4-hpp-benchmark: ERROR: ERROR: openscenegraph-qt4>=3 (Ubuntu package libopenscenegraph-dev for qt4) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: qt4-libs>=4.6.2<5 (Ubuntu package libqt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-qt4-hpp-benchmark => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt4-hpp-benchmark ===> Done bulk for py37-qt4-hpp-benchmark [77%] Processing wip/hpp-benchmark:py37-qt5-hpp-benchmark~!doc ===> Cleaning temporary files for py37-qt5-hpp-benchmark ===> Bulk building for py37-qt5-hpp-benchmark => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Required system package openscenegraph-qt5>=3: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-baxter>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-romeo>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-qt5-gepetto-viewer>=4.6.0: N/A => Required robotpkg package py37-qt5-gepetto-viewer-corba>=5.3.0: N/A => Required robotpkg package py37-qt5-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package romeo-description>=0.4.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-qt5-hpp-benchmark: ERROR: ERROR: openscenegraph-qt5>=3 (Ubuntu package libopenscenegraph-dev for qt5) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/hpp-benchmark/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-qt5-hpp-benchmark => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-qt5-hpp-benchmark ===> Done bulk for py37-qt5-hpp-benchmark [77%] Processing wip/hpp-benchmark:py38-qt4-hpp-benchmark~!doc ===> Bulk building for py38-qt4-hpp-benchmark Binary package for py38-qt4-hpp-benchmark is up-to-date. [77%] Processing wip/hpp-benchmark:py38-qt5-hpp-benchmark~!doc ===> Bulk building for py38-qt5-hpp-benchmark Binary package for py38-qt5-hpp-benchmark is up-to-date. [78%] Processing wip/infuse-asn1-conversions:infuse-asn1-conversions-0.4r1~!doc ===> Cleaning temporary files for infuse-asn1-conversions-0.4r1 ===> Bulk building for infuse-asn1-conversions-0.4r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package infuse-asn1-types>=0.2: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for infuse-asn1-conversions-0.4r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for infuse-asn1-conversions-0.4r1 ===> Done bulk for infuse-asn1-conversions-0.4r1 [78%] Processing wip/pal-gazebo-plugins:pal-gazebo-plugins-2.0.0~!doc ===> Cleaning temporary files for pal-gazebo-plugins-2.0.0 ===> Bulk building for pal-gazebo-plugins-2.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-msgs>=0.11.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-gazebo-plugins-2.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-gazebo-plugins/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-gazebo-plugins-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-gazebo-plugins-2.0.0 ===> Done bulk for pal-gazebo-plugins-2.0.0 [78%] Processing wip/dynamic-introspection:dynamic-introspection-1.0.12~!doc Warning: the LICENSE of wip/dynamic-introspection is undefined. Warning: the LICENSE of wip/dynamic-introspection is undefined. ===> Cleaning temporary files for dynamic-introspection-1.0.12 ===> Bulk building for dynamic-introspection-1.0.12 => Checking for clear installation Warning: the LICENSE of wip/dynamic-introspection is undefined. => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/dynamic-introspection is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found Warning: the LICENSE of wip/dynamic-introspection is undefined. Warning: the LICENSE of wip/dynamic-introspection is undefined. => Required robotpkg package backward-ros>=0.1.4: N/A => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-pal-statistics>=1.1.0: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Dependency tnftp-20130505~ssl already installed Warning: the LICENSE of wip/dynamic-introspection is undefined. ERROR: ====================================================================== ERROR: Missing system packages required for dynamic-introspection-1.0.12: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/dynamic-introspection/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 Warning: the LICENSE of wip/dynamic-introspection is undefined. ===> Logging bulk summary for dynamic-introspection-1.0.12 => Checking leftover files => Creating bulk log files => Logging bulk metadata Warning: the LICENSE of wip/dynamic-introspection is undefined. Warning: the LICENSE of wip/dynamic-introspection is undefined. Warning: the LICENSE of wip/dynamic-introspection is undefined. ===> Cleaning temporary files for dynamic-introspection-1.0.12 ===> Done bulk for dynamic-introspection-1.0.12 [78%] Processing wip/py-hpp-affordance-corba:py27-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py27-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py27-hpp-affordance-corba-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-template-corba-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py27-hpp-affordance-corba-4.9.0~doc [78%] Processing wip/py-hpp-affordance-corba:py34-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py34-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py34-hpp-affordance-corba-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py34-hpp-affordance-corba-4.9.0~doc [78%] Processing wip/py-hpp-affordance-corba:py35-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py35-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py35-hpp-affordance-corba-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py35-hpp-affordance-corba-4.9.0~doc [78%] Processing wip/py-hpp-affordance-corba:py36-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py36-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py36-hpp-affordance-corba-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py36-hpp-affordance-corba-4.9.0~doc [78%] Processing wip/py-hpp-affordance-corba:py37-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py37-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py37-hpp-affordance-corba-4.9.0~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-template-corba-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-affordance-corba-4.9.0~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-affordance-corba/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py37-hpp-affordance-corba-4.9.0~doc [79%] Processing wip/py-hpp-affordance-corba:py38-hpp-affordance-corba-4.9.0~doc ===> Cleaning temporary files for py38-hpp-affordance-corba-4.9.0~doc ===> Bulk building for py38-hpp-affordance-corba-4.9.0~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-affordance-corba-4.9.0~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-affordance-corba-4.9.0~doc ===> Done bulk for py38-hpp-affordance-corba-4.9.0~doc [79%] Processing wip/py-hpp-affordance-corba:py27-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py27-hpp-affordance-corba-4.9.0 ===> Bulk building for py27-hpp-affordance-corba-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-template-corba-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-affordance-corba-4.9.0 ===> Done bulk for py27-hpp-affordance-corba-4.9.0 [79%] Processing wip/py-hpp-affordance-corba:py34-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py34-hpp-affordance-corba-4.9.0 ===> Bulk building for py34-hpp-affordance-corba-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-affordance-corba-4.9.0 ===> Done bulk for py34-hpp-affordance-corba-4.9.0 [79%] Processing wip/py-hpp-affordance-corba:py35-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py35-hpp-affordance-corba-4.9.0 ===> Bulk building for py35-hpp-affordance-corba-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-affordance-corba-4.9.0 ===> Done bulk for py35-hpp-affordance-corba-4.9.0 [79%] Processing wip/py-hpp-affordance-corba:py36-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py36-hpp-affordance-corba-4.9.0 ===> Bulk building for py36-hpp-affordance-corba-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-affordance-corba-4.9.0 ===> Done bulk for py36-hpp-affordance-corba-4.9.0 [79%] Processing wip/py-hpp-affordance-corba:py37-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py37-hpp-affordance-corba-4.9.0 ===> Bulk building for py37-hpp-affordance-corba-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-template-corba-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-affordance-corba-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-affordance-corba/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-affordance-corba-4.9.0 ===> Done bulk for py37-hpp-affordance-corba-4.9.0 [79%] Processing wip/py-hpp-affordance-corba:py38-hpp-affordance-corba-4.9.0~!doc ===> Cleaning temporary files for py38-hpp-affordance-corba-4.9.0 ===> Bulk building for py38-hpp-affordance-corba-4.9.0 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-affordance-corba-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-affordance-corba-4.9.0 ===> Done bulk for py38-hpp-affordance-corba-4.9.0 [80%] Processing wip/ros-srdfdom:ros-srdfdom-0.5.1~!doc ===> Cleaning temporary files for ros-srdfdom-0.5.1 ===> Bulk building for ros-srdfdom-0.5.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-cmake-modules>=0.3: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-console-bridge>=0.5<0.6: N/A => Required robotpkg package ros-py27-urdf-parser>=0.4.0: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-srdfdom-0.5.1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-srdfdom/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-srdfdom-0.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-srdfdom-0.5.1 ===> Done bulk for ros-srdfdom-0.5.1 [80%] Processing wip/sot-torque-control:sot-torque-control-1.5.2~!doc ===> Cleaning temporary files for sot-torque-control-1.5.2 ===> Bulk building for sot-torque-control-1.5.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ===> Logging bulk summary for sot-torque-control-1.5.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-torque-control-1.5.2 ===> Done bulk for sot-torque-control-1.5.2 [80%] Processing wip/py-hpp-rbprm:py27-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py27-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py27-hpp-rbprm-4.9.0r1~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Dependency hpp-fcl-1.4.4~doc already installed => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-statistics-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py27-curves>=0.3.1: N/A => Required robotpkg package py27-hpp-bezier-com-traj>=4.9.0: N/A => Required robotpkg package py27-hpp-centroidal-dynamics>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-rbprm-robot-data-4.9.0~doc.tgz => Required robotpkg package py27-hpp-spline>=4.5.0: N/A => Required robotpkg package py27-talos-rbprm>=4.7.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py27-hpp-rbprm-4.9.0r1~doc [80%] Processing wip/py-hpp-rbprm:py34-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py34-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py34-hpp-rbprm-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py34-hpp-rbprm-4.9.0r1~doc [80%] Processing wip/py-hpp-rbprm:py35-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py35-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py35-hpp-rbprm-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py35-hpp-rbprm-4.9.0r1~doc [80%] Processing wip/py-hpp-rbprm:py36-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py36-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py36-hpp-rbprm-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py36-hpp-rbprm-4.9.0r1~doc [80%] Processing wip/py-hpp-rbprm:py37-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py37-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py37-hpp-rbprm-4.9.0r1~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Dependency hpp-fcl-1.4.4~doc already installed => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-statistics-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py37-curves>=0.3.1: N/A => Required robotpkg package py37-hpp-bezier-com-traj>=4.9.0: N/A => Required robotpkg package py37-hpp-centroidal-dynamics>=4.9.0: N/A => Required robotpkg package py37-hpp-environments>=4.7.0: N/A => Required robotpkg package py37-hpp-rbprm-robot-data>=4.9.0: N/A => Required robotpkg package py37-hpp-spline>=4.5.0: N/A => Required robotpkg package py37-talos-rbprm>=4.7.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-4.9.0r1~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py37-hpp-rbprm-4.9.0r1~doc [80%] Processing wip/py-hpp-rbprm:py38-hpp-rbprm-4.9.0r1~doc ===> Cleaning temporary files for py38-hpp-rbprm-4.9.0r1~doc ===> Bulk building for py38-hpp-rbprm-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-4.9.0r1~doc ===> Done bulk for py38-hpp-rbprm-4.9.0r1~doc [81%] Processing wip/py-hpp-rbprm:py27-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py27-hpp-rbprm-4.9.0r1 ===> Bulk building for py27-hpp-rbprm-4.9.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Dependency hpp-fcl-1.4.4~doc already installed => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-statistics-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py27-curves>=0.3.1: N/A => Required robotpkg package py27-hpp-bezier-com-traj>=4.9.0: N/A => Required robotpkg package py27-hpp-centroidal-dynamics>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-rbprm-robot-data-4.9.0~doc.tgz => Required robotpkg package py27-hpp-spline>=4.5.0: N/A => Required robotpkg package py27-talos-rbprm>=4.7.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-rbprm-4.9.0r1 ===> Done bulk for py27-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-hpp-rbprm:py34-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py34-hpp-rbprm-4.9.0r1 ===> Bulk building for py34-hpp-rbprm-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-4.9.0r1 ===> Done bulk for py34-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-hpp-rbprm:py35-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py35-hpp-rbprm-4.9.0r1 ===> Bulk building for py35-hpp-rbprm-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-4.9.0r1 ===> Done bulk for py35-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-hpp-rbprm:py36-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py36-hpp-rbprm-4.9.0r1 ===> Bulk building for py36-hpp-rbprm-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-4.9.0r1 ===> Done bulk for py36-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-hpp-rbprm:py37-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py37-hpp-rbprm-4.9.0r1 ===> Bulk building for py37-hpp-rbprm-4.9.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/curves-0.4.1r1.tgz => Dependency digest-20080510 already installed ERROR: Required robotpkg package hpp-affordance>=4.9.0: BROKEN => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Dependency hpp-fcl-1.4.4~doc already installed => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-statistics-4.9.0~doc.tgz => Dependency hpp-util-4.9.0~doc already installed => Dependency octomap-1.9.0 already installed => Dependency pinocchio-2.4.4 already installed => Required robotpkg package py37-curves>=0.3.1: N/A => Required robotpkg package py37-hpp-bezier-com-traj>=4.9.0: N/A => Required robotpkg package py37-hpp-centroidal-dynamics>=4.9.0: N/A => Required robotpkg package py37-hpp-environments>=4.7.0: N/A => Required robotpkg package py37-hpp-rbprm-robot-data>=4.9.0: N/A => Required robotpkg package py37-hpp-spline>=4.5.0: N/A => Required robotpkg package py37-talos-rbprm>=4.7.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-4.9.0r1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-4.9.0r1 ===> Done bulk for py37-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-hpp-rbprm:py38-hpp-rbprm-4.9.0r1~!doc ===> Cleaning temporary files for py38-hpp-rbprm-4.9.0r1 ===> Bulk building for py38-hpp-rbprm-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-4.9.0r1 ===> Done bulk for py38-hpp-rbprm-4.9.0r1 [81%] Processing wip/py-multiprocess:py27-multiprocess-0.70.9~!doc ===> Cleaning temporary files for py27-multiprocess-0.70.9 ===> Bulk building for py27-multiprocess-0.70.9 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-dill-0.3.1.1.tgz => Required system package py27-numpy>=1: MISSING => Required system package py27-scipy>=0.17.0: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-multiprocess-0.70.9: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-scipy>=0.17.0 (Ubuntu package python-scipy) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-multiprocess/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-multiprocess-0.70.9 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-multiprocess-0.70.9 ===> Done bulk for py27-multiprocess-0.70.9 [81%] Processing wip/py-multiprocess:py34-multiprocess-0.70.9~!doc ===> Bulk building for py34-multiprocess-0.70.9 Binary package for py34-multiprocess-0.70.9 is up-to-date. [82%] Processing wip/py-multiprocess:py35-multiprocess-0.70.9~!doc ===> Bulk building for py35-multiprocess-0.70.9 Binary package for py35-multiprocess-0.70.9 is up-to-date. [82%] Processing wip/py-multiprocess:py36-multiprocess-0.70.9~!doc ===> Bulk building for py36-multiprocess-0.70.9 Binary package for py36-multiprocess-0.70.9 is up-to-date. [82%] Processing wip/py-multiprocess:py37-multiprocess-0.70.9~!doc ===> Cleaning temporary files for py37-multiprocess-0.70.9 ===> Bulk building for py37-multiprocess-0.70.9 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-dill>=0.3.1.1: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-multiprocess-0.70.9: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-multiprocess/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-multiprocess-0.70.9 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-multiprocess-0.70.9 ===> Done bulk for py37-multiprocess-0.70.9 [82%] Processing wip/py-multiprocess:py38-multiprocess-0.70.9~!doc ===> Bulk building for py38-multiprocess-0.70.9 Binary package for py38-multiprocess-0.70.9 is up-to-date. [82%] Processing wip/sot-tools-v3:sot-tools-v3-2.2.2~!doc ===> Cleaning temporary files for sot-tools-v3-2.2.2 ===> Bulk building for sot-tools-v3-2.2.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-tools-v3-2.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-tools-v3-2.2.2 ===> Done bulk for sot-tools-v3-2.2.2 [82%] Processing wip/sot-dynamic-pinocchio-v3:sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Cleaning temporary files for sot-dynamic-pinocchio-v3-3.5.1 ===> Bulk building for sot-dynamic-pinocchio-v3-3.5.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-dynamic-pinocchio-v3-3.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-dynamic-pinocchio-v3-3.5.1 ===> Done bulk for sot-dynamic-pinocchio-v3-3.5.1 [82%] Processing wip/hatponboard-lib:hatponboard-lib-3.4.0~doc ===> Cleaning temporary files for hatponboard-lib-3.4.0~doc+enable-goal ===> Bulk building for hatponboard-lib-3.4.0~doc+enable-goal => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found WARNING: Cannot check installed version of antlr2 => Dependency digest-20080510 already installed => Required robotpkg package msgconnector>=2.13.0: N/A => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of antlr2 ===> Logging bulk summary for hatponboard-lib-3.4.0~doc+enable-goal => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hatponboard-lib-3.4.0~doc+enable-goal ===> Done bulk for hatponboard-lib-3.4.0~doc+enable-goal [83%] Processing wip/hatponboard-lib:hatponboard-lib-3.4.0~!doc ===> Cleaning temporary files for hatponboard-lib-3.4.0~enable-goal ===> Bulk building for hatponboard-lib-3.4.0~enable-goal => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found WARNING: Cannot check installed version of antlr2 => Dependency digest-20080510 already installed => Required robotpkg package msgconnector>=2.13.0: N/A => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of antlr2 ===> Logging bulk summary for hatponboard-lib-3.4.0~enable-goal => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hatponboard-lib-3.4.0~enable-goal ===> Done bulk for hatponboard-lib-3.4.0~enable-goal [83%] Processing wip/pal-gazebo-worlds:pal-gazebo-worlds-2.0.36~!doc ===> Cleaning temporary files for pal-gazebo-worlds-2.0.36 ===> Bulk building for pal-gazebo-worlds-2.0.36 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-gazebo-worlds-2.0.36: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-gazebo-worlds/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-gazebo-worlds-2.0.36 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-gazebo-worlds-2.0.36 ===> Done bulk for pal-gazebo-worlds-2.0.36 [83%] Processing wip/py-cvxpy:py27-cvxpy-1.0.31~!doc ===> Cleaning temporary files for py27-cvxpy-1.0.31 ===> Bulk building for py27-cvxpy-1.0.31 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-ecos>=2.0.7: N/A => Required robotpkg package py27-multiprocess>=0.6.1: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-osqp>=0.6.1: N/A => Required system package py27-scipy>=0.17.0: MISSING => Required robotpkg package py27-scs>=2.1.2: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-cvxpy-1.0.31: ERROR: ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-scipy>=0.17.0 (Ubuntu package python-scipy) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-cvxpy/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-cvxpy-1.0.31 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-cvxpy-1.0.31 ===> Done bulk for py27-cvxpy-1.0.31 [83%] Processing wip/py-cvxpy:py34-cvxpy-1.0.31~!doc ===> Bulk building for py34-cvxpy-1.0.31 Binary package for py34-cvxpy-1.0.31 is up-to-date. [83%] Processing wip/py-cvxpy:py35-cvxpy-1.0.31~!doc ===> Bulk building for py35-cvxpy-1.0.31 Binary package for py35-cvxpy-1.0.31 is up-to-date. [83%] Processing wip/py-cvxpy:py36-cvxpy-1.0.31~!doc ===> Bulk building for py36-cvxpy-1.0.31 Binary package for py36-cvxpy-1.0.31 is up-to-date. [83%] Processing wip/py-cvxpy:py37-cvxpy-1.0.31~!doc ===> Cleaning temporary files for py37-cvxpy-1.0.31 ===> Bulk building for py37-cvxpy-1.0.31 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-ecos>=2.0.7: N/A => Required robotpkg package py37-multiprocess>=0.6.1: N/A => Required robotpkg package py37-osqp>=0.6.1: N/A => Required robotpkg package py37-scs>=2.1.2: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-cvxpy-1.0.31: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-cvxpy/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-cvxpy-1.0.31 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-cvxpy-1.0.31 ===> Done bulk for py37-cvxpy-1.0.31 [83%] Processing wip/py-cvxpy:py38-cvxpy-1.0.31~!doc ===> Bulk building for py38-cvxpy-1.0.31 Binary package for py38-cvxpy-1.0.31 is up-to-date. [84%] Processing wip/py-hpp-rbprm-corba:py27-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py27-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py27-hpp-rbprm-corba-4.9.0r1~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-util-4.9.0~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-affordance-corba>=4.9.0: N/A => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-environments-4.9.0~doc.tgz => Required robotpkg package py27-hpp-rbprm>=4.9.0: N/A => Required robotpkg package py27-{qt4,qt5}-hpp-gepetto-viewer>=4.9.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py27-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py34-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py34-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py34-hpp-rbprm-corba-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py34-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py35-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py35-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py35-hpp-rbprm-corba-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py35-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py36-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py36-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py36-hpp-rbprm-corba-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py36-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py37-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py37-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py37-hpp-rbprm-corba-4.9.0r1~doc => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-util-4.9.0~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-affordance-corba>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-environments>=4.7.0: N/A => Required robotpkg package py37-hpp-rbprm>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-{qt4,qt5}-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-corba-4.9.0r1~doc: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm-corba/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py37-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py38-hpp-rbprm-corba-4.9.0r1~doc ===> Cleaning temporary files for py38-hpp-rbprm-corba-4.9.0r1~doc ===> Bulk building for py38-hpp-rbprm-corba-4.9.0r1~doc ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-corba-4.9.0r1~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-corba-4.9.0r1~doc ===> Done bulk for py38-hpp-rbprm-corba-4.9.0r1~doc [84%] Processing wip/py-hpp-rbprm-corba:py27-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py27-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py27-hpp-rbprm-corba-4.9.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-util-4.9.0~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-hpp-affordance-corba>=4.9.0: N/A => Required robotpkg package py27-hpp-corbaserver>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/py27-hpp-environments-4.9.0~doc.tgz => Required robotpkg package py27-hpp-rbprm>=4.9.0: N/A => Required robotpkg package py27-{qt4,qt5}-hpp-gepetto-viewer>=4.9.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py27-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-hpp-rbprm-corba:py34-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py34-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py34-hpp-rbprm-corba-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python34 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py34-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py34-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py34-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-hpp-rbprm-corba:py35-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py35-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py35-hpp-rbprm-corba-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python35 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py35-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py35-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-hpp-rbprm-corba:py36-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py36-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py36-hpp-rbprm-corba-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python36 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py36-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py36-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py36-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-hpp-rbprm-corba:py37-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py37-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py37-hpp-rbprm-corba-4.9.0r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package hpp-constraints>=4.9.0: N/A => Required robotpkg package hpp-core>=4.9.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-environments-4.9.0~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package hpp-pinocchio>=4.9.0: NOT found ERROR: Required robotpkg package hpp-pinocchio>=4.9.0: NOT found => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-util-4.9.0~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-hpp-affordance-corba>=4.9.0: N/A => Required robotpkg package py37-hpp-corbaserver>=4.9.0: N/A => Required robotpkg package py37-hpp-environments>=4.7.0: N/A => Required robotpkg package py37-hpp-rbprm>=4.9.0: N/A => Required robotpkg package py37-omniORBpy: N/A => Required robotpkg package py37-{qt4,qt5}-hpp-gepetto-viewer>=4.9.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-hpp-rbprm-corba-4.9.0r1: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hpp-rbprm-corba/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg ===> Logging bulk summary for py37-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py37-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-hpp-rbprm-corba:py38-hpp-rbprm-corba-4.9.0r1~!doc ===> Cleaning temporary files for py38-hpp-rbprm-corba-4.9.0r1 ===> Bulk building for py38-hpp-rbprm-corba-4.9.0r1 ERROR: This package cannot be built for the following reason: ERROR: ====================================================================== ERROR: No acceptable python alternatives could be found ERROR: PREFER_ALTERNATIVE.python = python27 python37 ERROR: ERROR: Suggested value: python38 ERROR: ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:221: cbbh] Error 2 ===> Logging bulk summary for py38-hpp-rbprm-corba-4.9.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py38-hpp-rbprm-corba-4.9.0r1 ===> Done bulk for py38-hpp-rbprm-corba-4.9.0r1 [85%] Processing wip/py-dynamic-graph-bridge-v3:py27-dynamic-graph-bridge-v3-3.3.2~!doc ===> Cleaning temporary files for py27-dynamic-graph-bridge-v3-3.3.2 ===> Bulk building for py27-dynamic-graph-bridge-v3-3.3.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-hpp-fcl>=1.2.0: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-realtime-tools>=1.8.2: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-rospack>=2.5<2.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-dynamic-graph-bridge-v3-3.3.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-bridge-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-dynamic-graph-bridge-v3-3.3.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-dynamic-graph-bridge-v3-3.3.2 ===> Done bulk for py27-dynamic-graph-bridge-v3-3.3.2 [85%] Processing wip/py-dynamic-graph-bridge-v3:py34-dynamic-graph-bridge-v3-3.3.2~!doc ===> Bulk building for py34-dynamic-graph-bridge-v3-3.3.2 Binary package for py34-dynamic-graph-bridge-v3-3.3.2 is up-to-date. [85%] Processing wip/py-dynamic-graph-bridge-v3:py35-dynamic-graph-bridge-v3-3.3.2~!doc ===> Bulk building for py35-dynamic-graph-bridge-v3-3.3.2 Binary package for py35-dynamic-graph-bridge-v3-3.3.2 is up-to-date. [86%] Processing wip/py-dynamic-graph-bridge-v3:py36-dynamic-graph-bridge-v3-3.3.2~!doc ===> Bulk building for py36-dynamic-graph-bridge-v3-3.3.2 Binary package for py36-dynamic-graph-bridge-v3-3.3.2 is up-to-date. [86%] Processing wip/py-dynamic-graph-bridge-v3:py37-dynamic-graph-bridge-v3-3.3.2~!doc ===> Cleaning temporary files for py37-dynamic-graph-bridge-v3-3.3.2 ===> Bulk building for py37-dynamic-graph-bridge-v3-3.3.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-fcl>=1.2.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-realtime-tools>=1.8.2: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-rospack>=2.5<2.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-dynamic-graph-bridge-v3-3.3.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-bridge-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-dynamic-graph-bridge-v3-3.3.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-dynamic-graph-bridge-v3-3.3.2 ===> Done bulk for py37-dynamic-graph-bridge-v3-3.3.2 [86%] Processing wip/py-dynamic-graph-bridge-v3:py38-dynamic-graph-bridge-v3-3.3.2~!doc ===> Bulk building for py38-dynamic-graph-bridge-v3-3.3.2 Binary package for py38-dynamic-graph-bridge-v3-3.3.2 is up-to-date. [86%] Processing wip/jrl-walkgen-v3:jrl-walkgen-v3-4.2.3~!doc ===> Cleaning temporary files for jrl-walkgen-v3-4.2.3 ===> Bulk building for jrl-walkgen-v3-4.2.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/eigen-quadprog-1.0.0r1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/eiquadprog-1.1.3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jrl-walkgen-v3-4.2.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jrl-walkgen-v3-4.2.3 ===> Done bulk for jrl-walkgen-v3-4.2.3 [86%] Processing wip/prf-roboticsgroup-gazebo-plugins:prf-roboticsgroup-gazebo-plugins-0.1.3r1~!doc ===> Cleaning temporary files for prf-roboticsgroup-gazebo-plugins-0.1.3r1 ===> Bulk building for prf-roboticsgroup-gazebo-plugins-0.1.3r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for prf-roboticsgroup-gazebo-plugins-0.1.3r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/prf-roboticsgroup-gazebo-plugins/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for prf-roboticsgroup-gazebo-plugins-0.1.3r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for prf-roboticsgroup-gazebo-plugins-0.1.3r1 ===> Done bulk for prf-roboticsgroup-gazebo-plugins-0.1.3r1 [86%] Processing wip/talos-torque-control:talos-torque-control-1.0.1~!doc ===> Cleaning temporary files for talos-torque-control-1.0.1 ===> Bulk building for talos-torque-control-1.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ===> Logging bulk summary for talos-torque-control-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-torque-control-1.0.1 ===> Done bulk for talos-torque-control-1.0.1 [86%] Processing wip/py-sot-core-v3:py27-sot-core-v3-4.9.0~!doc ===> Cleaning temporary files for py27-sot-core-v3-4.9.0 ===> Bulk building for py27-sot-core-v3-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/example-robot-data-3.3.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-example-robot-data>=2.0.0: N/A => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-sot-core-v3-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-core-v3-4.9.0 ===> Done bulk for py27-sot-core-v3-4.9.0 [87%] Processing wip/py-sot-core-v3:py34-sot-core-v3-4.9.0~!doc ===> Bulk building for py34-sot-core-v3-4.9.0 Binary package for py34-sot-core-v3-4.9.0 is up-to-date. [87%] Processing wip/py-sot-core-v3:py35-sot-core-v3-4.9.0~!doc ===> Bulk building for py35-sot-core-v3-4.9.0 Binary package for py35-sot-core-v3-4.9.0 is up-to-date. [87%] Processing wip/py-sot-core-v3:py36-sot-core-v3-4.9.0~!doc ===> Bulk building for py36-sot-core-v3-4.9.0 Binary package for py36-sot-core-v3-4.9.0 is up-to-date. [87%] Processing wip/py-sot-core-v3:py37-sot-core-v3-4.9.0~!doc ===> Cleaning temporary files for py37-sot-core-v3-4.9.0 ===> Bulk building for py37-sot-core-v3-4.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/example-robot-data-3.3.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-example-robot-data>=2.0.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required system package python37>=3.7<3.8: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-core-v3-4.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-core-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-core-v3-4.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-core-v3-4.9.0 ===> Done bulk for py37-sot-core-v3-4.9.0 [87%] Processing wip/py-sot-core-v3:py38-sot-core-v3-4.9.0~!doc ===> Bulk building for py38-sot-core-v3-4.9.0 Binary package for py38-sot-core-v3-4.9.0 is up-to-date. [87%] Processing wip/py-sot-tools-v3:py27-sot-tools-v3-2.2.2~!doc ===> Cleaning temporary files for py27-sot-tools-v3-2.2.2 ===> Bulk building for py27-sot-tools-v3-2.2.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-hpp-fcl>=1.2.0: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required system package py-sphinx>=1.1: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-tools-v3-2.2.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py-sphinx>=1.1 (Ubuntu package python-sphinx) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-tools-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-tools-v3-2.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-tools-v3-2.2.2 ===> Done bulk for py27-sot-tools-v3-2.2.2 [87%] Processing wip/py-sot-tools-v3:py34-sot-tools-v3-2.2.2~!doc ===> Bulk building for py34-sot-tools-v3-2.2.2 Binary package for py34-sot-tools-v3-2.2.2 is up-to-date. [87%] Processing wip/py-sot-tools-v3:py35-sot-tools-v3-2.2.2~!doc ===> Bulk building for py35-sot-tools-v3-2.2.2 Binary package for py35-sot-tools-v3-2.2.2 is up-to-date. [88%] Processing wip/py-sot-tools-v3:py36-sot-tools-v3-2.2.2~!doc ===> Bulk building for py36-sot-tools-v3-2.2.2 Binary package for py36-sot-tools-v3-2.2.2 is up-to-date. [88%] Processing wip/py-sot-tools-v3:py37-sot-tools-v3-2.2.2~!doc ===> Cleaning temporary files for py37-sot-tools-v3-2.2.2 ===> Bulk building for py37-sot-tools-v3-2.2.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-fcl>=1.2.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required system package python37>=3.7<3.8: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-tools-v3-2.2.2: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-tools-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-tools-v3-2.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-tools-v3-2.2.2 ===> Done bulk for py37-sot-tools-v3-2.2.2 [88%] Processing wip/py-sot-tools-v3:py38-sot-tools-v3-2.2.2~!doc ===> Bulk building for py38-sot-tools-v3-2.2.2 Binary package for py38-sot-tools-v3-2.2.2 is up-to-date. [88%] Processing wip/pal-hardware-gazebo:pal-hardware-gazebo-1.0.0~!doc ===> Cleaning temporary files for pal-hardware-gazebo-1.0.0 ===> Bulk building for pal-hardware-gazebo-1.0.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package dynamic-introspection>=1.0.5: N/A => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-pal-statistics>=1.1.0: N/A => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for pal-hardware-gazebo-1.0.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/pal-hardware-gazebo/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for pal-hardware-gazebo-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-hardware-gazebo-1.0.0 ===> Done bulk for pal-hardware-gazebo-1.0.0 [88%] Processing wip/talos-simulation:talos-simulation-0.1.8r2~!doc ===> Cleaning temporary files for talos-simulation-0.1.8r2 ===> Bulk building for talos-simulation-0.1.8r2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package head-action>=0.0.1: N/A => Required robotpkg package pal-gazebo-plugins>=2.0.0: N/A => Required robotpkg package pal-gazebo-worlds>=2.0.0: N/A => Required robotpkg package pal-hardware-gazebo>=1.0.0: N/A => Required robotpkg package prf-roboticsgroup-gazebo-plugins>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package talos-moveit-config>=0.2.3: N/A => Required robotpkg package talos-robot>=0.0.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for talos-simulation-0.1.8r2: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/talos-simulation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for talos-simulation-0.1.8r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-simulation-0.1.8r2 ===> Done bulk for talos-simulation-0.1.8r2 [88%] Processing wip/sot-talos-balance:sot-talos-balance-1.9.0~!doc ===> Cleaning temporary files for sot-talos-balance-1.9.0 ===> Bulk building for sot-talos-balance-1.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/eiquadprog-1.1.3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ===> Logging bulk summary for sot-talos-balance-1.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-talos-balance-1.9.0 ===> Done bulk for sot-talos-balance-1.9.0 [88%] Processing wip/ros-moveit:ros-moveit-0.10.5r1~!doc ===> Cleaning temporary files for ros-moveit-0.10.5r1 ===> Bulk building for ros-moveit-0.10.5r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/fcl-0.5.0.tgz => Dependency octomap-1.9.0 already installed ERROR: Required robotpkg package ompl>=0.12.2: BROKEN => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/orocos-kdl-1.4.0.tgz => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/robot-capsule-urdf-1.0.1r2.tgz => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package ros-angles>=1.9: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-comm-msgs>=1.10.3: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-console>=1.13<1.15: N/A => Required robotpkg package ros-control>=0.14<0.18: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-dynamic-reconfigure>=1.5.32: N/A => Required robotpkg package ros-eigen-stl-containers>=0.1: N/A => Required robotpkg package ros-geometric-shapes>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-image-common>=1.11<1.12: N/A => Required robotpkg package ros-interactive-markers>=1.11<1.12: N/A => Required robotpkg package ros-kdl-parser>=1.13<1.14: N/A => Required robotpkg package ros-moveit-msgs>=0.10.0: N/A => Required robotpkg package ros-moveit-resources>=0.6.4: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-random-numbers>=0.1: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-rviz>=1.9: N/A => Required robotpkg package ros-srdfdom>=0.4.2: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-vision-opencv>=1.13<1.14: N/A => Required robotpkg package ros-warehouse-ros>=0.9.2: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-moveit-0.10.5r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-moveit/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-moveit-0.10.5r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-moveit-0.10.5r1 ===> Done bulk for ros-moveit-0.10.5r1 [89%] Processing wip/py-sot-torque-control:py27-sot-torque-control-1.5.2~!doc ===> Cleaning temporary files for py27-sot-torque-control-1.5.2 ===> Bulk building for py27-sot-torque-control-1.5.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-parametric-curves>=1.0.0: N/A => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required system package py-sphinx>=1.1: MISSING => Required robotpkg package py27-tsid>=1.0.0: N/A => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-torque-control-1.5.2: ERROR: ERROR: py-sphinx>=1.1 (Ubuntu package python-sphinx) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-torque-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-torque-control-1.5.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-torque-control-1.5.2 ===> Done bulk for py27-sot-torque-control-1.5.2 [89%] Processing wip/py-sot-torque-control:py34-sot-torque-control-1.5.2~!doc ===> Bulk building for py34-sot-torque-control-1.5.2 Binary package for py34-sot-torque-control-1.5.2 is up-to-date. [89%] Processing wip/py-sot-torque-control:py35-sot-torque-control-1.5.2~!doc ===> Bulk building for py35-sot-torque-control-1.5.2 Binary package for py35-sot-torque-control-1.5.2 is up-to-date. [89%] Processing wip/py-sot-torque-control:py36-sot-torque-control-1.5.2~!doc ===> Bulk building for py36-sot-torque-control-1.5.2 Binary package for py36-sot-torque-control-1.5.2 is up-to-date. [89%] Processing wip/py-sot-torque-control:py37-sot-torque-control-1.5.2~!doc ===> Cleaning temporary files for py37-sot-torque-control-1.5.2 ===> Bulk building for py37-sot-torque-control-1.5.2 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-parametric-curves>=1.0.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-tsid>=1.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-torque-control-1.5.2: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-torque-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-torque-control-1.5.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-torque-control-1.5.2 ===> Done bulk for py37-sot-torque-control-1.5.2 [89%] Processing wip/py-sot-torque-control:py38-sot-torque-control-1.5.2~!doc ===> Bulk building for py38-sot-torque-control-1.5.2 Binary package for py38-sot-torque-control-1.5.2 is up-to-date. [89%] Processing wip/py-sl1m:py27-sl1m-0.1.0~!doc ===> Cleaning temporary files for py27-sl1m-0.1.0 ===> Bulk building for py27-sl1m-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-cvxpy>=1.0.31: N/A ERROR: Required robotpkg package py27-gurobi>=9.0.2: BROKEN => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/py27-pycddlib-2.1.1.tgz => Required robotpkg package py27-quadprog>=0.1.6: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-sl1m-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sl1m-0.1.0 ===> Done bulk for py27-sl1m-0.1.0 [89%] Processing wip/py-sl1m:py34-sl1m-0.1.0~!doc ===> Bulk building for py34-sl1m-0.1.0 Binary package for py34-sl1m-0.1.0 is up-to-date. [90%] Processing wip/py-sl1m:py35-sl1m-0.1.0~!doc ===> Bulk building for py35-sl1m-0.1.0 Binary package for py35-sl1m-0.1.0 is up-to-date. [90%] Processing wip/py-sl1m:py36-sl1m-0.1.0~!doc ===> Bulk building for py36-sl1m-0.1.0 Binary package for py36-sl1m-0.1.0 is up-to-date. [90%] Processing wip/py-sl1m:py37-sl1m-0.1.0~!doc ===> Cleaning temporary files for py37-sl1m-0.1.0 ===> Bulk building for py37-sl1m-0.1.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py37-cvxpy>=1.0.31: N/A => Required robotpkg package py37-gurobi>=9.0.2: N/A => Required robotpkg package py37-pycddlib>=2.1.1: N/A => Required robotpkg package py37-quadprog>=0.1.6: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sl1m-0.1.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sl1m/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sl1m-0.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sl1m-0.1.0 ===> Done bulk for py37-sl1m-0.1.0 [90%] Processing wip/py-sl1m:py38-sl1m-0.1.0~!doc ===> Bulk building for py38-sl1m-0.1.0 Binary package for py38-sl1m-0.1.0 is up-to-date. [90%] Processing wip/ros-universal-robot:ros-universal-robot-1.2.5~!doc ===> Cleaning temporary files for ros-universal-robot-1.2.5 ===> Bulk building for ros-universal-robot-1.2.5 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package gazebo-ros-pkgs>=2.8<2.9: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/robot-capsule-urdf-1.0.1r2.tgz => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control>=0.14<0.18: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-dynamic-reconfigure>=1.5.32: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry2>=0.6<0.7: N/A => Required robotpkg package ros-joint-state-publisher>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-moveit>=0.10.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-robot-state-publisher>=1.9: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-urdf>=1.13<1.14: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for ros-universal-robot-1.2.5: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/ros-universal-robot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for ros-universal-robot-1.2.5 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ros-universal-robot-1.2.5 ===> Done bulk for ros-universal-robot-1.2.5 [90%] Processing wip/py-sot-talos-balance:py27-sot-talos-balance-1.9.0~!doc ===> Cleaning temporary files for py27-sot-talos-balance-1.9.0 ===> Bulk building for py27-sot-talos-balance-1.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/eiquadprog-1.1.3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-parametric-curves>=1.0.0: N/A => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-torque-control>=1.0.0: N/A => Required system package py-sphinx>=1.1: MISSING => Required robotpkg package py27-tsid>=1.0.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Required robotpkg package sot-talos-balance>=1.3.1: N/A ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-talos-balance-1.9.0: ERROR: ERROR: py-sphinx>=1.1 (Ubuntu package python-sphinx) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-talos-balance/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-talos-balance-1.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-talos-balance-1.9.0 ===> Done bulk for py27-sot-talos-balance-1.9.0 [90%] Processing wip/py-sot-talos-balance:py34-sot-talos-balance-1.9.0~!doc ===> Bulk building for py34-sot-talos-balance-1.9.0 Binary package for py34-sot-talos-balance-1.9.0 is up-to-date. [90%] Processing wip/py-sot-talos-balance:py35-sot-talos-balance-1.9.0~!doc ===> Bulk building for py35-sot-talos-balance-1.9.0 Binary package for py35-sot-talos-balance-1.9.0 is up-to-date. [91%] Processing wip/py-sot-talos-balance:py36-sot-talos-balance-1.9.0~!doc ===> Bulk building for py36-sot-talos-balance-1.9.0 Binary package for py36-sot-talos-balance-1.9.0 is up-to-date. [91%] Processing wip/py-sot-talos-balance:py37-sot-talos-balance-1.9.0~!doc ===> Cleaning temporary files for py37-sot-talos-balance-1.9.0 ===> Bulk building for py37-sot-talos-balance-1.9.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/eiquadprog-1.1.3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-parametric-curves>=1.0.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-torque-control>=1.0.0: N/A => Required robotpkg package py37-tsid>=1.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Required robotpkg package sot-talos-balance>=1.3.1: N/A ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-talos-balance-1.9.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-talos-balance/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-talos-balance-1.9.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-talos-balance-1.9.0 ===> Done bulk for py37-sot-talos-balance-1.9.0 [91%] Processing wip/py-sot-talos-balance:py38-sot-talos-balance-1.9.0~!doc ===> Bulk building for py38-sot-talos-balance-1.9.0 Binary package for py38-sot-talos-balance-1.9.0 is up-to-date. [91%] Processing wip/py-roscontrol-sot:py27-roscontrol-sot-0.5.0~!doc ===> Cleaning temporary files for py27-roscontrol-sot-0.5.0 ===> Bulk building for py27-roscontrol-sot-0.5.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package pal-msgs>=0.11.3: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-realtime-tools>=1.8.2: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-rospack>=2.5<2.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-roscontrol-sot-0.5.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-roscontrol-sot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-roscontrol-sot-0.5.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-roscontrol-sot-0.5.0 ===> Done bulk for py27-roscontrol-sot-0.5.0 [91%] Processing wip/py-roscontrol-sot:py34-roscontrol-sot-0.5.0~!doc ===> Bulk building for py34-roscontrol-sot-0.5.0 Binary package for py34-roscontrol-sot-0.5.0 is up-to-date. [91%] Processing wip/py-roscontrol-sot:py35-roscontrol-sot-0.5.0~!doc ===> Bulk building for py35-roscontrol-sot-0.5.0 Binary package for py35-roscontrol-sot-0.5.0 is up-to-date. [91%] Processing wip/py-roscontrol-sot:py36-roscontrol-sot-0.5.0~!doc ===> Bulk building for py36-roscontrol-sot-0.5.0 Binary package for py36-roscontrol-sot-0.5.0 is up-to-date. [92%] Processing wip/py-roscontrol-sot:py37-roscontrol-sot-0.5.0~!doc ===> Cleaning temporary files for py37-roscontrol-sot-0.5.0 ===> Bulk building for py37-roscontrol-sot-0.5.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package pal-msgs>=0.11.3: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-prf-ros-control>=0.2: N/A => Required robotpkg package py37-prf-ros-controllers>=0.2.8: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-msgs>=1.4<1.6: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-realtime-tools>=1.8.2: N/A => Required robotpkg package ros-roscpp-core>=0.6<0.7: N/A => Required robotpkg package ros-rospack>=2.5<2.6: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-roscontrol-sot-0.5.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-roscontrol-sot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-roscontrol-sot-0.5.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-roscontrol-sot-0.5.0 ===> Done bulk for py37-roscontrol-sot-0.5.0 [92%] Processing wip/py-roscontrol-sot:py38-roscontrol-sot-0.5.0~!doc ===> Bulk building for py38-roscontrol-sot-0.5.0 Binary package for py38-roscontrol-sot-0.5.0 is up-to-date. [92%] Processing wip/tiago-metapkg-ros-control-sot:tiago-metapkg-ros-control-sot-1.0.4~!doc ===> Cleaning temporary files for tiago-metapkg-ros-control-sot-1.0.4 ===> Bulk building for tiago-metapkg-ros-control-sot-1.0.4 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-roscontrol-sot>=0.2.0: N/A => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-metapkg-ros-control-sot-1.0.4: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-metapkg-ros-control-sot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-metapkg-ros-control-sot-1.0.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-metapkg-ros-control-sot-1.0.4 ===> Done bulk for tiago-metapkg-ros-control-sot-1.0.4 [92%] Processing wip/py-sot-dynamic-pinocchio-v3:py27-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Cleaning temporary files for py27-sot-dynamic-pinocchio-v3-3.5.1 ===> Bulk building for py27-sot-dynamic-pinocchio-v3-3.5.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-tools-v3>=2.0: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-dynamic-pinocchio-v3-3.5.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-dynamic-pinocchio-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-dynamic-pinocchio-v3-3.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-dynamic-pinocchio-v3-3.5.1 ===> Done bulk for py27-sot-dynamic-pinocchio-v3-3.5.1 [92%] Processing wip/py-sot-dynamic-pinocchio-v3:py34-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Bulk building for py34-sot-dynamic-pinocchio-v3-3.5.1 Binary package for py34-sot-dynamic-pinocchio-v3-3.5.1 is up-to-date. [92%] Processing wip/py-sot-dynamic-pinocchio-v3:py35-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Bulk building for py35-sot-dynamic-pinocchio-v3-3.5.1 Binary package for py35-sot-dynamic-pinocchio-v3-3.5.1 is up-to-date. [92%] Processing wip/py-sot-dynamic-pinocchio-v3:py36-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Bulk building for py36-sot-dynamic-pinocchio-v3-3.5.1 Binary package for py36-sot-dynamic-pinocchio-v3-3.5.1 is up-to-date. [92%] Processing wip/py-sot-dynamic-pinocchio-v3:py37-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Cleaning temporary files for py37-sot-dynamic-pinocchio-v3-3.5.1 ===> Bulk building for py37-sot-dynamic-pinocchio-v3-3.5.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-tools-v3>=2.0: N/A => Required system package python37>=3.7<3.8: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-dynamic-pinocchio-v3-3.5.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-dynamic-pinocchio-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-dynamic-pinocchio-v3-3.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-dynamic-pinocchio-v3-3.5.1 ===> Done bulk for py37-sot-dynamic-pinocchio-v3-3.5.1 [93%] Processing wip/py-sot-dynamic-pinocchio-v3:py38-sot-dynamic-pinocchio-v3-3.5.1~!doc ===> Bulk building for py38-sot-dynamic-pinocchio-v3-3.5.1 Binary package for py38-sot-dynamic-pinocchio-v3-3.5.1 is up-to-date. [93%] Processing wip/play-motion:play-motion-0.4.8r1~!doc ===> Cleaning temporary files for play-motion-0.4.8r1 ===> Bulk building for play-motion-0.4.8r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-moveit>=0.10.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for play-motion-0.4.8r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/play-motion/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for play-motion-0.4.8r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for play-motion-0.4.8r1 ===> Done bulk for play-motion-0.4.8r1 [93%] Processing wip/py-talos-torque-control:py27-talos-torque-control-1.0.1~!doc ===> Cleaning temporary files for py27-talos-torque-control-1.0.1 ===> Bulk building for py27-talos-torque-control-1.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-hpp-fcl>=1.2.0: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-parametric-curves>=1.0.0: N/A => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-torque-control>=1.0.0: N/A => Required system package py-sphinx>=1.1: MISSING => Required robotpkg package py27-tsid>=1.0.0: N/A => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN ERROR: Required robotpkg package talos-torque-control>=1.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py27-talos-torque-control-1.0.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: py-sphinx>=1.1 (Ubuntu package python-sphinx) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-talos-torque-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-talos-torque-control-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-talos-torque-control-1.0.1 ===> Done bulk for py27-talos-torque-control-1.0.1 [93%] Processing wip/py-talos-torque-control:py34-talos-torque-control-1.0.1~!doc ===> Bulk building for py34-talos-torque-control-1.0.1 Binary package for py34-talos-torque-control-1.0.1 is up-to-date. [93%] Processing wip/py-talos-torque-control:py35-talos-torque-control-1.0.1~!doc ===> Bulk building for py35-talos-torque-control-1.0.1 Binary package for py35-talos-torque-control-1.0.1 is up-to-date. [93%] Processing wip/py-talos-torque-control:py36-talos-torque-control-1.0.1~!doc ===> Bulk building for py36-talos-torque-control-1.0.1 Binary package for py36-talos-torque-control-1.0.1 is up-to-date. [93%] Processing wip/py-talos-torque-control:py37-talos-torque-control-1.0.1~!doc ===> Cleaning temporary files for py37-talos-torque-control-1.0.1 ===> Bulk building for py37-talos-torque-control-1.0.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/ddp-actuator-solver-1.2.0.tgz => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/parametric-curves-1.3.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-fcl>=1.2.0: N/A => Required robotpkg package py37-parametric-curves>=1.0.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-torque-control>=1.0.0: N/A => Required robotpkg package py37-tsid>=1.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Dependency qpoases-3.2.1r1~doc already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/simple-humanoid-description-1.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-torque-control>=1.0.0: BROKEN ERROR: Required robotpkg package talos-torque-control>=1.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Required robotpkg package tsid>=1.0.0: NOT found ERROR: Required robotpkg package tsid>=1.0.0: NOT found ERROR: ====================================================================== ERROR: Missing system packages required for py37-talos-torque-control-1.0.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-talos-torque-control/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-talos-torque-control-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-talos-torque-control-1.0.1 ===> Done bulk for py37-talos-torque-control-1.0.1 [94%] Processing wip/py-talos-torque-control:py38-talos-torque-control-1.0.1~!doc ===> Bulk building for py38-talos-torque-control-1.0.1 Binary package for py38-talos-torque-control-1.0.1 is up-to-date. [94%] Processing wip/sot-pattern-generator-v3:sot-pattern-generator-v3-3.3.0~!doc ===> Cleaning temporary files for sot-pattern-generator-v3-3.3.0 ===> Bulk building for sot-pattern-generator-v3-3.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package jrl-walkgen-v3>=4.0.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-pattern-generator-v3-3.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-pattern-generator-v3-3.3.0 ===> Done bulk for sot-pattern-generator-v3-3.3.0 [94%] Processing wip/sot-hrp2-v3:sot-hrp2-v3-2.1.3~!doc ===> Cleaning temporary files for sot-hrp2-v3-2.1.3 ===> Bulk building for sot-hrp2-v3-2.1.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-sot-tools-v3>=2.0: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-hrp2-v3-2.1.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrp2-v3-2.1.3 ===> Done bulk for sot-hrp2-v3-2.1.3 [94%] Processing wip/py-sot-pattern-generator-v3:py27-sot-pattern-generator-v3-3.3.0~!doc ===> Cleaning temporary files for py27-sot-pattern-generator-v3-3.3.0 ===> Bulk building for py27-sot-pattern-generator-v3-3.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package jrl-walkgen-v3>=4.0.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Required robotpkg package sot-pattern-generator-v3>=2.10: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-sot-pattern-generator-v3-3.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-pattern-generator-v3-3.3.0 ===> Done bulk for py27-sot-pattern-generator-v3-3.3.0 [94%] Processing wip/py-sot-pattern-generator-v3:py34-sot-pattern-generator-v3-3.3.0~!doc ===> Bulk building for py34-sot-pattern-generator-v3-3.3.0 Binary package for py34-sot-pattern-generator-v3-3.3.0 is up-to-date. [94%] Processing wip/py-sot-pattern-generator-v3:py35-sot-pattern-generator-v3-3.3.0~!doc ===> Bulk building for py35-sot-pattern-generator-v3-3.3.0 Binary package for py35-sot-pattern-generator-v3-3.3.0 is up-to-date. [94%] Processing wip/py-sot-pattern-generator-v3:py36-sot-pattern-generator-v3-3.3.0~!doc ===> Bulk building for py36-sot-pattern-generator-v3-3.3.0 Binary package for py36-sot-pattern-generator-v3-3.3.0 is up-to-date. [94%] Processing wip/py-sot-pattern-generator-v3:py37-sot-pattern-generator-v3-3.3.0~!doc ===> Cleaning temporary files for py37-sot-pattern-generator-v3-3.3.0 ===> Bulk building for py37-sot-pattern-generator-v3-3.3.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Required robotpkg package jrl-walkgen-v3>=4.0.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required system package python37>=3.7<3.8: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN => Required robotpkg package sot-pattern-generator-v3>=2.10: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-pattern-generator-v3-3.3.0: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-pattern-generator-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-pattern-generator-v3-3.3.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-pattern-generator-v3-3.3.0 ===> Done bulk for py37-sot-pattern-generator-v3-3.3.0 [95%] Processing wip/py-sot-pattern-generator-v3:py38-sot-pattern-generator-v3-3.3.0~!doc ===> Bulk building for py38-sot-pattern-generator-v3-3.3.0 Binary package for py38-sot-pattern-generator-v3-3.3.0 is up-to-date. [95%] Processing wip/py-sot-application-v3:py27-sot-application-v3-1.2.3~!doc ===> Cleaning temporary files for py27-sot-application-v3-1.2.3 ===> Bulk building for py27-sot-application-v3-1.2.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py27-sot-tools-v3>=2.0: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-application-v3-1.2.3: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-application-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-application-v3-1.2.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-application-v3-1.2.3 ===> Done bulk for py27-sot-application-v3-1.2.3 [95%] Processing wip/py-sot-application-v3:py34-sot-application-v3-1.2.3~!doc ===> Bulk building for py34-sot-application-v3-1.2.3 Binary package for py34-sot-application-v3-1.2.3 is up-to-date. [95%] Processing wip/py-sot-application-v3:py35-sot-application-v3-1.2.3~!doc ===> Bulk building for py35-sot-application-v3-1.2.3 Binary package for py35-sot-application-v3-1.2.3 is up-to-date. [95%] Processing wip/py-sot-application-v3:py36-sot-application-v3-1.2.3~!doc ===> Bulk building for py36-sot-application-v3-1.2.3 Binary package for py36-sot-application-v3-1.2.3 is up-to-date. [95%] Processing wip/py-sot-application-v3:py37-sot-application-v3-1.2.3~!doc ===> Cleaning temporary files for py37-sot-application-v3-1.2.3 ===> Bulk building for py37-sot-application-v3-1.2.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py37-sot-tools-v3>=2.0: N/A => Required system package python37>=3.7<3.8: MISSING ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN ERROR: Required robotpkg package sot-tools-v3>=2.0: BROKEN => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-application-v3-1.2.3: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-application-v3/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-application-v3-1.2.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-application-v3-1.2.3 ===> Done bulk for py37-sot-application-v3-1.2.3 [95%] Processing wip/py-sot-application-v3:py38-sot-application-v3-1.2.3~!doc ===> Bulk building for py38-sot-application-v3-1.2.3 Binary package for py38-sot-application-v3-1.2.3 is up-to-date. [96%] Processing wip/py-sot-talos:py27-sot-talos-1.2.1~!doc ===> Cleaning temporary files for py27-sot-talos-1.2.1 ===> Bulk building for py27-sot-talos-1.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required robotpkg package py27-hpp-fcl>=1.2.0: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-application-v3>=1.1.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py27-sot-tools-v3>=2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/pyrene-motions-1.0.0.tgz => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-talos-1.2.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-talos/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-talos-1.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-talos-1.2.1 ===> Done bulk for py27-sot-talos-1.2.1 [96%] Processing wip/py-sot-talos:py34-sot-talos-1.2.1~!doc ===> Bulk building for py34-sot-talos-1.2.1 Binary package for py34-sot-talos-1.2.1 is up-to-date. [96%] Processing wip/py-sot-talos:py35-sot-talos-1.2.1~!doc ===> Bulk building for py35-sot-talos-1.2.1 Binary package for py35-sot-talos-1.2.1 is up-to-date. [96%] Processing wip/py-sot-talos:py36-sot-talos-1.2.1~!doc ===> Bulk building for py36-sot-talos-1.2.1 Binary package for py36-sot-talos-1.2.1 is up-to-date. [96%] Processing wip/py-sot-talos:py37-sot-talos-1.2.1~!doc ===> Cleaning temporary files for py37-sot-talos-1.2.1 ===> Bulk building for py37-sot-talos-1.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-hpp-fcl>=1.2.0: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-application-v3>=1.1.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py37-sot-tools-v3>=2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/pyrene-motions-1.0.0.tgz => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Required robotpkg package talos-data>=1.1.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-talos-1.2.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-talos/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-talos-1.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-talos-1.2.1 ===> Done bulk for py37-sot-talos-1.2.1 [96%] Processing wip/py-sot-talos:py38-sot-talos-1.2.1~!doc ===> Bulk building for py38-sot-talos-1.2.1 Binary package for py38-sot-talos-1.2.1 is up-to-date. [96%] Processing wip/tiago-description-calibration:tiago-description-calibration-0.0.6r1~!doc ===> Cleaning temporary files for tiago-description-calibration-0.0.6r1 ===> Bulk building for tiago-description-calibration-0.0.6r1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-gazebo-plugins>=2.0.0: N/A => Required robotpkg package pal-hardware-gazebo>=1.0.0: N/A => Required robotpkg package play-motion>=0.4.5: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tiago-moveit-config>=0.0.15: N/A => Required robotpkg package tiago-robot>=0.0.35: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-description-calibration-0.0.6r1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-description-calibration/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-description-calibration-0.0.6r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-description-calibration-0.0.6r1 ===> Done bulk for tiago-description-calibration-0.0.6r1 [96%] Processing wip/openhrp3-hrp2:openhrp3-hrp2-1.2.1~!doc ===> Cleaning temporary files for openhrp3-hrp2-1.2.1 ===> Bulk building for openhrp3-hrp2-1.2.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hrp2-14-1.9.3.tgz => Required robotpkg package openhrp3-simulator-wo-rtm>=1.0.0: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required system package py27-empy>=3: MISSING => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package ros-xacro>=1.13<1.14: N/A => Required robotpkg package sot-hrp2-v3>=2.0.0: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for openhrp3-hrp2-1.2.1: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/openhrp3-hrp2/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for openhrp3-hrp2-1.2.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-hrp2-1.2.1 ===> Done bulk for openhrp3-hrp2-1.2.1 [97%] Processing wip/py-sot-tiago:py27-sot-tiago-1.4.1~!doc ===> Cleaning temporary files for py27-sot-tiago-1.4.1 ===> Bulk building for py27-sot-tiago-1.4.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py27-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py27-eigenpy>=1.6.12: N/A => Required system package py27-numpy>=1: MISSING => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py27-sot-application-v3>=1.1.0: N/A => Required robotpkg package py27-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py27-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py27-sot-tools-v3>=2.0: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Required robotpkg package tiago-data>=0.0.1: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-sot-tiago-1.4.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: py27-numpy>=1 (Ubuntu package python-numpy (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-tiago/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-sot-tiago-1.4.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-tiago-1.4.1 ===> Done bulk for py27-sot-tiago-1.4.1 [97%] Processing wip/py-sot-tiago:py34-sot-tiago-1.4.1~!doc ===> Bulk building for py34-sot-tiago-1.4.1 Binary package for py34-sot-tiago-1.4.1 is up-to-date. [97%] Processing wip/py-sot-tiago:py35-sot-tiago-1.4.1~!doc ===> Bulk building for py35-sot-tiago-1.4.1 Binary package for py35-sot-tiago-1.4.1 is up-to-date. [97%] Processing wip/py-sot-tiago:py36-sot-tiago-1.4.1~!doc ===> Bulk building for py36-sot-tiago-1.4.1 Binary package for py36-sot-tiago-1.4.1 is up-to-date. [97%] Processing wip/py-sot-tiago:py37-sot-tiago-1.4.1~!doc ===> Cleaning temporary files for py37-sot-tiago-1.4.1 ===> Bulk building for py37-sot-tiago-1.4.1 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required system package boost-libs>=1.34.1: MISSING => Dependency digest-20080510 already installed => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: N/A => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-20.04-x86_64/All/dynamic-graph-v3-4.1.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/hpp-fcl-1.4.4~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/pinocchio-2.4.4.tgz => Required robotpkg package py37-dynamic-graph-bridge-v3>=3.0.0: N/A => Required robotpkg package py37-dynamic-graph-v3>=3.0: N/A => Required robotpkg package py37-eigenpy>=1.6.12: N/A => Required robotpkg package py37-pinocchio>=2.0.0<3.0.0: N/A => Required robotpkg package py37-sot-application-v3>=1.1.0: N/A => Required robotpkg package py37-sot-core-v3>=4.1.0<5.0.0: N/A => Required robotpkg package py37-sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: N/A => Required robotpkg package py37-sot-tools-v3>=2.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A ERROR: Required robotpkg package sot-core-v3>=4.1.0<5.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: BROKEN => Required robotpkg package tiago-data>=0.0.1: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-sot-tiago-1.4.1: ERROR: ERROR: boostlib-python>=1.34.1 (Ubuntu package libboost-python-dev) ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-sot-tiago/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-sot-tiago-1.4.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-sot-tiago-1.4.1 ===> Done bulk for py37-sot-tiago-1.4.1 [97%] Processing wip/py-sot-tiago:py38-sot-tiago-1.4.1~!doc ===> Bulk building for py38-sot-tiago-1.4.1 Binary package for py38-sot-tiago-1.4.1 is up-to-date. [97%] Processing wip/talos-metapkg-ros-control-sot:talos-metapkg-ros-control-sot-0.2.0~!doc ===> Cleaning temporary files for talos-metapkg-ros-control-sot-0.2.0 ===> Bulk building for talos-metapkg-ros-control-sot-0.2.0 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-hardware-interfaces>=0.0.3: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-roscontrol-sot>=0.2.0: N/A => Required robotpkg package py27-sot-talos>=1.1.0: N/A => Required robotpkg package ros-actionlib>=1.11<1.13: N/A => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-class-loader>=0.4<0.5: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-control-toolbox>=1.16<1.19: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-geometry>=1.12<1.13: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-pluginlib>=1.12<1.13: N/A => Required robotpkg package ros-ros>=1.14<1.15: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for talos-metapkg-ros-control-sot-0.2.0: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/talos-metapkg-ros-control-sot/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for talos-metapkg-ros-control-sot-0.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-metapkg-ros-control-sot-0.2.0 ===> Done bulk for talos-metapkg-ros-control-sot-0.2.0 [98%] Processing wip/hrp2-dev:hrp2-dev-20171009~!doc ===> Cleaning temporary files for hrp2-dev-20171009 ===> Bulk building for hrp2-dev-20171009 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package hrp2-14-description>=1.0.0: N/A => Required robotpkg package openhrp3-hrp2>=1.0.0: N/A ===> Logging bulk summary for hrp2-dev-20171009 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hrp2-dev-20171009 ===> Done bulk for hrp2-dev-20171009 [98%] Processing wip/tiago-simulation:tiago-simulation-2.0.21~!doc ===> Cleaning temporary files for tiago-simulation-2.0.21 ===> Bulk building for tiago-simulation-2.0.21 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Dependency digest-20080510 already installed => Required robotpkg package pal-gazebo-plugins>=2.0.0: N/A => Required robotpkg package pal-gazebo-worlds>=2.0.0: N/A => Required robotpkg package pal-hardware-gazebo>=1.0.0: N/A => Required robotpkg package play-motion>=0.4.5: N/A => Required robotpkg package prf-teleop-tools>=0.3.1: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package simple-grasping-action>=0.9.14: N/A => Required robotpkg package tiago-description-calibration>=0.0.6: N/A => Required robotpkg package tiago-moveit-config>=0.0.15: N/A => Required robotpkg package tiago-robot>=0.0.35: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tiago-simulation-2.0.21: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tiago-simulation/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for tiago-simulation-2.0.21 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-simulation-2.0.21 ===> Done bulk for tiago-simulation-2.0.21 [98%] Processing wip/py-talos-dev:py27-talos-dev-20200511~!doc ===> Cleaning temporary files for py27-talos-dev-20200511 ===> Bulk building for py27-talos-dev-20200511 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package humanoid-nav-msgs>=0.1: N/A => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required robotpkg package py27-prf-ros-control>=0.2: N/A => Required robotpkg package py27-sot-talos>=1.1.0: N/A => Required robotpkg package py27-sot-talos-balance>=1.3.0: N/A => Required robotpkg package py27-talos-torque-control>=1.0.0: N/A => Required robotpkg package ros-robot-state-publisher>=1.9: N/A => Required robotpkg package talos-metapkg-ros-control-sot>=0.0.1: N/A => Required robotpkg package talos-simulation>=0.0.13: N/A ===> Logging bulk summary for py27-talos-dev-20200511 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-talos-dev-20200511 ===> Done bulk for py27-talos-dev-20200511 [98%] Processing wip/py-talos-dev:py34-talos-dev-20200511~!doc ===> Bulk building for py34-talos-dev-20200511 Binary package for py34-talos-dev-20200511 is up-to-date. [98%] Processing wip/py-talos-dev:py35-talos-dev-20200511~!doc ===> Bulk building for py35-talos-dev-20200511 Binary package for py35-talos-dev-20200511 is up-to-date. [98%] Processing wip/py-talos-dev:py36-talos-dev-20200511~!doc ===> Bulk building for py36-talos-dev-20200511 Binary package for py36-talos-dev-20200511 is up-to-date. [98%] Processing wip/py-talos-dev:py37-talos-dev-20200511~!doc ===> Cleaning temporary files for py37-talos-dev-20200511 ===> Bulk building for py37-talos-dev-20200511 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package humanoid-nav-msgs>=0.1: N/A => Required robotpkg package py37-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required robotpkg package py37-prf-ros-control>=0.2: N/A => Required robotpkg package py37-sot-talos>=1.1.0: N/A => Required robotpkg package py37-sot-talos-balance>=1.3.0: N/A => Required robotpkg package py37-talos-torque-control>=1.0.0: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package ros-robot-state-publisher>=1.9: N/A => Required robotpkg package talos-metapkg-ros-control-sot>=0.0.1: N/A => Required robotpkg package talos-simulation>=0.0.13: N/A ERROR: ====================================================================== ERROR: Missing system packages required for py37-talos-dev-20200511: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-talos-dev/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-talos-dev-20200511 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-talos-dev-20200511 ===> Done bulk for py37-talos-dev-20200511 [98%] Processing wip/py-talos-dev:py38-talos-dev-20200511~!doc ===> Bulk building for py38-talos-dev-20200511 Binary package for py38-talos-dev-20200511 is up-to-date. [99%] Processing wip/tiago-dev:tiago-dev-20190516r1~!doc ===> Cleaning temporary files for tiago-dev-20190516r1 ===> Bulk building for tiago-dev-20190516r1 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package pal-wsg-gripper>=0.0.7: N/A => Required robotpkg package py27-prf-gazebo-ros-pkgs>=3.0.1: N/A => Required robotpkg package py27-sot-tiago>=1.3.0: N/A => Required robotpkg package tiago-metapkg-ros-control-sot>=0.0.1: N/A => Required robotpkg package tiago-simulation>=2.0.6: N/A ===> Logging bulk summary for tiago-dev-20190516r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tiago-dev-20190516r1 ===> Done bulk for tiago-dev-20190516r1 [99%] Processing wip/py-tiago-tutorials:py27-tiago-tutorials-2.0.3~!doc ===> Cleaning temporary files for py27-tiago-tutorials-2.0.3 ===> Bulk building for py27-tiago-tutorials-2.0.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package aruco-ros>=0.2.3: N/A => Dependency digest-20080510 already installed => Required robotpkg package pal-gazebo-plugins>=2.0.0: N/A => Required robotpkg package pal-hardware-gazebo>=1.0.0: N/A => Required robotpkg package pal-msgs>=0.11.3: N/A => Required robotpkg package play-motion>=0.4.5: N/A => Required robotpkg package py27-catkin-pkg>=0.2: N/A => Required system package py27-empy>=3: MISSING => Required robotpkg package py27-prf-ros-controllers>=0.2.8: N/A => Required system package py27-pyparsing>=1: MISSING => Required robotpkg package py27-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-perception-pcl>=1.7.0: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tiago-moveit-config>=0.0.15: N/A => Required robotpkg package tiago-robot>=0.0.35: N/A => Required robotpkg package tiago-simulation>=2.0.6: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py27-tiago-tutorials-2.0.3: ERROR: ERROR: py27-empy>=3 (Ubuntu package python-empy (python-2.7)) ERROR: py27-pyparsing>=1 (Ubuntu package python-pyparsing (python-2.7)) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-tiago-tutorials/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py27-tiago-tutorials-2.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-tiago-tutorials-2.0.3 ===> Done bulk for py27-tiago-tutorials-2.0.3 [99%] Processing wip/py-tiago-tutorials:py34-tiago-tutorials-2.0.3~!doc ===> Bulk building for py34-tiago-tutorials-2.0.3 Binary package for py34-tiago-tutorials-2.0.3 is up-to-date. [99%] Processing wip/py-tiago-tutorials:py35-tiago-tutorials-2.0.3~!doc ===> Bulk building for py35-tiago-tutorials-2.0.3 Binary package for py35-tiago-tutorials-2.0.3 is up-to-date. [99%] Processing wip/py-tiago-tutorials:py36-tiago-tutorials-2.0.3~!doc ===> Bulk building for py36-tiago-tutorials-2.0.3 Binary package for py36-tiago-tutorials-2.0.3 is up-to-date. [99%] Processing wip/py-tiago-tutorials:py37-tiago-tutorials-2.0.3~!doc ===> Cleaning temporary files for py37-tiago-tutorials-2.0.3 ===> Bulk building for py37-tiago-tutorials-2.0.3 => Checking for clear installation => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-20.04-x86_64/All/tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.19 found => Required system package gzip: gzip-1.10 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found => Required robotpkg package aruco-ros>=0.2.3: N/A => Dependency digest-20080510 already installed => Required robotpkg package pal-gazebo-plugins>=2.0.0: N/A => Required robotpkg package pal-hardware-gazebo>=1.0.0: N/A => Required robotpkg package pal-msgs>=0.11.3: N/A => Required robotpkg package play-motion>=0.4.5: N/A => Required robotpkg package py37-catkin-pkg>=0.2: N/A => Required robotpkg package py37-prf-ros-controllers>=0.2.8: N/A => Required system package python37>=3.7<3.8: MISSING => Required robotpkg package py37-ros-catkin>=0.7<0.8: N/A => Required robotpkg package ros-comm>=1.13<1.15: N/A => Required robotpkg package ros-common-msgs>=1.12<1.13: N/A => Required robotpkg package ros-genmsg>=0.5<0.6: N/A => Required robotpkg package ros-genpy>=0.6<0.7: N/A => Required robotpkg package ros-message-generation>=0.4<0.5: N/A => Required robotpkg package ros-message-runtime>=0.4<0.5: N/A => Required robotpkg package ros-perception-pcl>=1.7.0: N/A => Required robotpkg package ros-std-msgs>=0.5: N/A => Required robotpkg package tiago-moveit-config>=0.0.15: N/A => Required robotpkg package tiago-robot>=0.0.35: N/A => Required robotpkg package tiago-simulation>=2.0.6: N/A => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py37-tiago-tutorials-2.0.3: ERROR: ERROR: python37>=3.7<3.8 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-tiago-tutorials/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/depends/sysdep.mk:35: sys-depends] Error 2 ===> Logging bulk summary for py37-tiago-tutorials-2.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py37-tiago-tutorials-2.0.3 ===> Done bulk for py37-tiago-tutorials-2.0.3 [99%] Processing wip/py-tiago-tutorials:py38-tiago-tutorials-2.0.3~!doc ===> Bulk building for py38-tiago-tutorials-2.0.3 Binary package for py38-tiago-tutorials-2.0.3 is up-to-date. ===> Done bulk for rbulk wip set 2235.51user 494.47system 31:23.49elapsed 144%CPU (0avgtext+0avgdata 983076maxresident)k 1234880inputs+10877504outputs (2211major+130881479minor)pagefaults 0swaps --- Updating bulk database --------------------------------------- Collecting session logs in /local/robotpkg/var/log/bulk updated pmb2-navigation-2.0.1 updated tiago-simulation-2.0.21 updated py37-multicontact-api-2.0.0 updated py34-hpp-rbprm-corba-4.9.0r1~doc updated tiago-robot-2.0.26 updated py35-hpp-rbprm-robot-data-4.9.0 updated py36-talos-rbprm-4.9.0 updated py35-hpp-universal-robot-4.9.0 updated py27-qt4-gepetto-pythonqt-0.0.1r2 updated hrp2-14-description-1.0.5 updated sot-talos-balance-1.9.0 updated py37-hpp-hrp2-4.9.0~doc updated py27-roscontrol-sot-0.5.0 updated sot-dynamic-pinocchio-v3-3.5.1 updated sot-tools-v3-2.2.2 updated py37-pycddlib-2.1.1 updated ros-moveit-msgs-0.10.0r1 updated py36-hpp-rbprm-corba-4.9.0r1~doc updated py37-hpp-universal-robot-4.9.0 updated ros-swri-math-util-2.3.0 updated py37-cvxpy-1.0.31 updated py37-qt5-gepetto-pythonqt-0.0.1r2 updated py27-pal-python-0.9.14os1 updated py34-hpp-affordance-corba-4.9.0 updated py37-libnabo-1.0.7r1 updated py34-hpp-hrp2-4.9.0~doc updated py35-hpp-rbprm-robot-data-4.9.0~doc updated py36-hpp-baxter-4.9.0~doc updated py37-gurobi-9.0.2 updated py35-hpp-rbprm-corba-4.9.0r1 updated py34-hpp-bezier-com-traj-4.9.0~doc updated py37-hpp-romeo-4.9.0 updated pal-hardware-gazebo-1.0.0 updated py35-hpp-universal-robot-4.9.0~doc updated py34-hpp-centroidal-dynamics-4.9.0~doc updated py27-talos-rbprm-4.9.0 updated py37-ecos-2.0.7.post1 updated can-utils-2018.02.0 updated py37-hpp-rbprm-corba-4.9.0r1 updated play-motion-0.4.8r1 updated py27-pal-statistics-1.3.1r4 updated py37-morse-1.4 updated ros-four-wheel-steering-msgs-1.0.0 updated py35-hpp-rbprm-4.9.0r1~doc updated py36-hpp-spline-4.8.2~doc updated py27-hpp-centroidal-dynamics-4.9.0~doc updated ros-swri-string-util-2.3.0 updated py27-sot-pattern-generator-v3-3.3.0 updated py35-hpp-baxter-4.9.0~doc updated py37-sot-talos-1.2.1 updated hatponboard-lib-3.4.0~doc+enable-goal updated hpp-affordance-4.9.0~doc updated tiago-description-calibration-0.0.6r1 updated py35-hpp-spline-4.8.2~doc updated py37-solo-pybullet-0.1.0 updated py37-mavlink-1.1.62 updated py35-hpp-hrp2-4.9.0 updated py27-ros-baxter-common-1.2.0r1 updated py37-prf-ros-control-0.2.8r2 updated py38-hpp-universal-robot-4.9.0 updated py37-hpp-baxter-4.9.0~doc updated ros-aicp-mapping-0.0.1r2 updated py37-multiprocess-0.70.9 updated py27-solo-pybullet-0.1.0 updated ros-moveit-0.10.5r1 updated py38-hpp-rbprm-4.9.0r1 updated morse-ros-1.4 updated py37-talos-dev-20200511 updated head-action-0.0.1r4 updated py35-hpp-bezier-com-traj-4.9.0 updated py27-qpoases-3.2.1 updated py27-sl1m-0.1.0 updated sot-torque-control-1.5.2 updated tiago-metapkg-ros-control-sot-1.0.4 updated ros-octomap-msgs-0.3.3r1 updated py38-talos-rbprm-4.9.0~doc updated py27-tiago-tutorials-2.0.3 updated talos-data-1.2.2 updated py35-hpp-romeo-4.9.0 updated py38-hpp-rbprm-4.9.0r1~doc updated pal-navigation-sm-0.1.7os1r1 updated py38-hpp-affordance-corba-4.9.0 updated py37-dynamic-graph-tutorial-1.2.1 updated ros-srdfdom-0.5.1 updated ros-swri-nodelet-2.3.0 updated py37-parametric-curves-1.3.1 updated soth-2.0.4 updated sot-hrp2-1.1.2 updated talos-metapkg-ros-control-sot-0.2.0 updated py37-hpp-rbprm-robot-data-4.9.0 updated py34-hpp-rbprm-robot-data-4.9.0~doc updated py34-hpp-romeo-4.9.0~doc updated py34-hpp-universal-robot-4.9.0 updated py38-hpp-centroidal-dynamics-4.9.0~doc updated talos-moveit-config-0.3.2 updated py34-hpp-romeo-4.9.0 updated py37-ros-baxter-common-1.2.0r1 updated ros-py27-urdf-parser-0.4.0r1 updated py37-hpp-romeo-4.9.0~doc updated py34-hpp-spline-4.8.2~doc updated ros-perception-pcl-1.7.0r2 updated py34-hpp-universal-robot-4.9.0~doc updated rviz-plugin-covariance-0.0.6os1r1 updated py37-hpp-bezier-com-traj-4.9.0 updated py27-scs-2.1.2 updated py37-qt5-hpp-benchmark~doc updated pal-wsg-gripper-0.0.9r1 updated py38-talos-rbprm-4.9.0 updated py37-hpp-spline-4.8.2~doc updated py37-hpp-baxter-4.9.0 updated ros-swri-roscpp-2.3.0 updated py37-qt4-hpp-benchmark~doc updated py27-dynamic-graph-bridge-v3-3.3.2 updated py27-hpp-rbprm-corba-4.9.0r1~doc updated hpp-affordance-4.9.0 updated py27-gurobi-9.0.2 updated infuse-novatel-gps-driver-ros-0.1.0 updated py37-sot-core-v3-4.9.0 updated py36-hpp-spline-4.8.2 updated sot-hrp2-v3-2.1.3 updated ros-image-pipeline-1.14.0 updated py37-sot-torque-control-1.5.2 updated py38-hpp-centroidal-dynamics-4.9.0 updated py36-hpp-centroidal-dynamics-4.9.0 updated aruco-ros-0.2.4 updated py38-hpp-baxter-4.9.0~doc updated py37-pal-python-0.9.14os1 updated py34-hpp-rbprm-robot-data-4.9.0 updated timeoptimization-1.1.0 updated py37-talos-rbprm-4.9.0 updated py35-hpp-rbprm-corba-4.9.0r1~doc updated py35-talos-rbprm-4.9.0 updated pmb2-simulation-2.0.12 updated py36-hpp-centroidal-dynamics-4.9.0~doc updated py34-hpp-bezier-com-traj-4.9.0 updated py36-hpp-rbprm-4.9.0r1 updated pal-gazebo-worlds-2.0.36 updated infuse-asn1-conversions-0.4r1 updated ros-urdf-geometry-parser-0.0.3 updated pal-hardware-interfaces-0.0.4 updated py37-sot-tools-v3-2.2.2 updated py35-hpp-romeo-4.9.0~doc updated msgconnector-2.13.0~bridge-print+liboro+openprs+yarp updated tiago-navigation-2.0.0 updated py37-hpp-universal-robot-4.9.0~doc updated py37-qpoases-3.2.1 updated py34-hpp-rbprm-corba-4.9.0r1 updated py35-hpp-baxter-4.9.0 updated talos-simulation-0.1.8r2 updated py27-sot-talos-1.2.1 updated py27-sot-tools-v3-2.2.2 updated py27-prf-gazebo-ros-pkgs-3.0.1 updated py36-hpp-bezier-com-traj-4.9.0 updated roralink-0.3.0-Source updated octoviz-1.6.1 updated ros-swri-serial-util-2.3.0 updated py34-hpp-baxter-4.9.0~doc updated sot-pattern-generator-v3-3.3.0 updated py36-hpp-universal-robot-4.9.0~doc updated py27-hpp-spline-4.8.2 updated py27-cvxpy-1.0.31 updated py37-hpp-rbprm-4.9.0r1 updated py37-dill-0.3.1.1 updated py37-hpp-rbprm-4.9.0r1~doc updated py37-rqt-dynamic-graph-1.0.0 updated py36-hpp-rbprm-corba-4.9.0r1 updated py37-hpp-hrp2-4.9.0 updated py37-tiago-tutorials-2.0.3 updated simple-grasping-action-1.0.1r2 updated tiago-data-1.1.0 updated talos-torque-control-1.0.1 updated py27-qt5-hpp-benchmark~doc updated py36-hpp-baxter-4.9.0 updated ompl-1.4.1 updated ros-universal-robot-1.2.5 updated py36-hpp-affordance-corba-4.9.0 updated py35-hpp-spline-4.8.2 updated py38-hpp-spline-4.8.2~doc updated py38-hpp-romeo-4.9.0~doc updated py38-hpp-rbprm-corba-4.9.0r1 updated infuse-msgs-ros-0.1.0 updated py38-hpp-rbprm-robot-data-4.9.0 updated ros-moveit-resources-0.6.5 updated tiago-dev-20190516r1 updated py38-hpp-spline-4.8.2 updated py38-hpp-hrp2-4.9.0 updated py37-talos-torque-control-1.0.1 updated py37-hpp-rbprm-robot-data-4.9.0~doc updated py35-talos-rbprm-4.9.0~doc updated pmb2-robot-3.0.5 updated py27-ecos-2.0.7.post1 updated py27-libnabo-1.0.7r1 updated py37-sot-tiago-1.4.1 updated py27-sot-torque-control-1.5.2 updated py27-hpp-affordance-corba-4.9.0~doc updated py37-hpp-centroidal-dynamics-4.9.0 updated infuse-asn1-types-0.3 updated py27-qt5-gepetto-pythonqt-0.0.1r2 updated py37-prf-ros-controllers-0.3.15r2 updated py27-hpp-romeo-4.9.0 updated py36-hpp-universal-robot-4.9.0 updated py34-hpp-hrp2-4.9.0 updated py38-hpp-bezier-com-traj-4.9.0 updated talos-robot-1.1.3 updated py27-sot-core-v3-4.9.0 updated py35-hpp-affordance-corba-4.9.0 updated py37-hpp-rbprm-corba-4.9.0r1~doc updated py36-hpp-rbprm-robot-data-4.9.0~doc updated py27-parametric-curves-1.3.1 updated py37-sot-dynamic-pinocchio-v3-3.5.1 updated py27-hpp-affordance-corba-4.9.0 updated py34-talos-rbprm-4.9.0 updated py35-hpp-centroidal-dynamics-4.9.0~doc updated py38-hpp-affordance-corba-4.9.0~doc updated py37-dynamic-graph-bridge-v3-3.3.2 updated py34-hpp-rbprm-4.9.0r1~doc updated py37-talos-rbprm-4.9.0~doc updated pal-gazebo-plugins-2.0.0 updated py38-hpp-rbprm-robot-data-4.9.0~doc updated py37-osqp-0.6.1 updated py36-hpp-hrp2-4.9.0 updated py37-hpp-affordance-corba-4.9.0 updated py37-sot-application-v3-1.2.3 updated py37-qt5-hpp-benchmark updated py37-prf-gazebo-ros-pkgs-3.0.1 updated py27-skeleton_model-1.0.1 updated py27-hpp-bezier-com-traj-4.9.0 updated ros-py37-urdf-parser-0.4.0r1 updated py27-multicontact-api-2.0.0 updated pal-transmissions-0.2.4 updated tf-lookup-0.0.1r1 updated py36-hpp-romeo-4.9.0~doc updated prf-roboticsgroup-gazebo-plugins-0.1.3r1 updated py36-hpp-rbprm-robot-data-4.9.0 updated py34-talos-rbprm-4.9.0~doc updated osg-dae-3.2.1r2 updated py27-dynamic-graph-tutorial-1.2.1 updated py37-scs-2.1.2 updated py35-hpp-bezier-com-traj-4.9.0~doc updated py27-sot-dynamic-pinocchio-v3-3.5.1 updated py37-qt4-hpp-benchmark updated py27-talos-torque-control-1.0.1 updated py37-dynamic-graph-v3-3.5.2 updated py36-hpp-bezier-com-traj-4.9.0~doc updated hatponboard-lib-3.4.0~enable-goal updated py27-hpp-bezier-com-traj-4.9.0~doc updated py35-hpp-rbprm-4.9.0r1 updated backward-ros-0.1.7 updated sot-core-v3-4.9.0 updated openhrp3-hrp2-1.2.1 updated py27-multiprocess-0.70.9 updated py37-hpp-bezier-com-traj-4.9.0~doc updated py34-hpp-spline-4.8.2 updated py37-sot-talos-balance-1.9.0 updated py35-hpp-hrp2-4.9.0~doc updated py37-sot-pattern-generator-v3-3.3.0 updated py36-hpp-affordance-corba-4.9.0~doc updated py36-hpp-hrp2-4.9.0~doc updated py27-rqt-dynamic-graph-1.0.0 updated py27-prf-ros-control-0.2.8r2 updated py27-hpp-romeo-4.9.0~doc updated py34-hpp-rbprm-4.9.0r1 updated py27-talos-dev-20200511 updated py37-hpp-affordance-corba-4.9.0~doc updated jrl-walkgen-v3-4.2.3 updated py34-hpp-affordance-corba-4.9.0~doc updated py38-hpp-hrp2-4.9.0~doc updated py27-hpp-centroidal-dynamics-4.9.0 updated ros-ouster-gazebo-simulation-2.0.0 updated py27-talos-rbprm-4.9.0~doc updated py38-hpp-rbprm-corba-4.9.0r1~doc updated py37-qt4-gepetto-pythonqt-0.0.1r2 updated mraa-1.9.0 updated py36-hpp-romeo-4.9.0 updated py27-hpp-spline-4.8.2~doc updated dynamic-introspection-1.0.12 updated py27-hpp-rbprm-4.9.0r1~doc updated py27-dynamic-graph-v3-3.5.2 updated py36-hpp-rbprm-4.9.0r1~doc updated py34-hpp-centroidal-dynamics-4.9.0 updated py37-hpp-centroidal-dynamics-4.9.0~doc updated py37-sl1m-0.1.0 updated py27-sot-tiago-1.4.1 updated openhrp3-simulator-wo-rtm-1.2.0 updated tiago-moveit-config-1.0.2 updated hrp2-dev-20171009 updated py27-casadi-3.4.5 updated py35-hpp-centroidal-dynamics-4.9.0 updated ros-warehouse-ros-0.9.2r1 updated dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server updated ros-object-recognition-msgs-0.4.1r1 updated py27-qt5-hpp-benchmark updated ros-pcl-msgs-0.2.0 updated hey5-description-1.0.3 updated py38-hpp-romeo-4.9.0 updated py38-hpp-bezier-com-traj-4.9.0~doc updated prf-teleop-tools-0.3.2 updated py27-hpp-rbprm-corba-4.9.0r1 updated py37-roscontrol-sot-0.5.0 updated py27-hpp-rbprm-4.9.0r1 updated py27-example-adder-2.0.1 updated py37-casadi-3.4.5 updated py38-hpp-baxter-4.9.0 updated pal-gripper-0.0.13 updated py27-sot-talos-balance-1.9.0 updated py27-qt4-hpp-benchmark updated py37-example-adder-2.0.1 updated pal-msgs-0.12.14 updated py36-talos-rbprm-4.9.0~doc updated py35-hpp-affordance-corba-4.9.0~doc updated py27-sot-application-v3-1.2.3 updated py27-osqp-0.6.1 updated py38-hpp-universal-robot-4.9.0~doc updated py37-pal-statistics-1.3.1r4 updated py34-hpp-baxter-4.9.0 updated py27-prf-ros-controllers-0.3.15r2 updated py37-hpp-spline-4.8.2 updated py27-qt4-hpp-benchmark~doc processed 318 packages