path/hpp-corbaserver

Humanoid Path Planner (Corba server for Humanoid Path Planner)
Directory:
path/hpp-corbaserver (package's history)
Package version:
hpp-corbaserver-4.6.1
Home page:
(none)
License:
gnu-lgpl-v3
Source archive:
ftp://ftp.openrobots.org/pub/openrobots/hpp-corbaserver/hpp-corbaserver-4.6.1.tar.gz
http://www.openrobots.org/distfiles/hpp-corbaserver/hpp-corbaserver-4.6.1.tar.gz
Description:
hpp-corbaserver implements a Corba interface with hpp-core library. Corba requests can be sent to trigger actions in a ProblemSolver instance. Three main Corba interfaces are implemented: * Robot: to build a Device and to insert it in the ProblemSolver instance, * Obstacle: to build obstacles and insert them in the ProblemSolver instance, * Problem: to define a path planning problem and solve it. Python clients are provided to control a path planning application.
Run dependencies:
boost-libs>=1.34.1, boost-libs>=1.34.1, boost-libs>=1.34.1, boost-libs>=1.34.1, hpp-constraints>=4.6.0, hpp-core>=4.6.0, hpp-fcl>=1.1.1, hpp-pinocchio>=4.6.0, hpp-template-corba>=4.5.0, libstdc++, octomap>=1.6.0, omniORB>=4.1.1, pinocchio>=2.0.0<3.0.0, py27-omniORBpy, python27>=2.7<2.8, tinyxml>=2, urdfdom>=0.2.8
Build dependencies:
boost-headers>=1.34.1, cmake>=2.6, digest>=20080510, doxygen>=1.5, eigen3>=3.2.92, g++>=3, gcc>=3, pax, pkg-config>=0.22, pkg_install>=20110805.9, tnftp>=20091122
General options:
benchmark
Measure computation times
debug
Produce debugging information for binary programs
doc
Enable documentation generation and installation
verbose
Compile in verbose mode
c++-compiler alternatives:
g++
Use the GNU C++ compiler
clang++
Use the LLVM C++ compiler
ccache-g++
Use ccache and the GNU C++ compiler
ccache-clang++
Use ccache and the LLVM C++ compiler
c-compiler alternatives:
gcc
Use the GNU C compiler
clang
Use the LLVM C compiler
ccache-gcc
Use ccache and the GNU C compiler
ccache-clang
Use ccache and the LLVM C compiler
python alternatives:
python27
Use python-2.7
python34
Use python-3.4
python35
Use python-3.5
python36
Use python-3.6
python37
Use python-3.7