robotpkg/robots/sot-openhrp bulk build results

Log for sot-openhrp-2.5.1~hrp2-laas on Debian-8.2-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for sot-openhrp-2.5.1~hrp2-laas Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Checking bootstrap dependencies for sot-openhrp-2.5.1~hrp2-laas => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found ===> Done bootstrap-depends for sot-openhrp-2.5.1~hrp2-laas Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Installing full dependencies for sot-openhrp-2.5.1~hrp2-laas Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Dependency digest-20080510 already installed => Installing dynamic-graph-corba-2.5.1r3.tgz => Installing sot-dynamic-2.9.2.tgz => Dependency tnftp-20130505~ssl already installed Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Checking build options for sot-openhrp-2.5.1~hrp2-laas => Building with the following options: hrp2-laas Compile plug-in for HRP2-14 ===> Checking alternatives for sot-openhrp-2.5.1~hrp2-laas => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.6 provided by python27>=2.7<2.8 ===> Checking dependencies for sot-openhrp-2.5.1~hrp2-laas => Required system package cmake>=2.6: cmake-3.0.2 found => Required system package doxygen>=1.5: doxygen-1.8.8 found => Required system package g++>=3: g++-4.9.2 found => Required system package gcc>=3: gcc-4.9.2 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.28 found => Required system package python27>=2.7<2.8: python27-2.7.9 found => Required robotpkg package dynamic-graph-corba>=2.5: dynamic-graph-corba-2.5.1r3 found => Required robotpkg package sot-dynamic>=2.5: sot-dynamic-2.9.2 found ===> Done depends for sot-openhrp-2.5.1~hrp2-laas Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Extracting for sot-openhrp-2.5.1~hrp2-laas => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for sot-openhrp-2.5.1~hrp2-laas CMake Warning (dev) at cmake/base.cmake:49 (INCLUDE): Syntax Warning in cmake code at /local/robotpkg/var/tmp/robotpkg/robots/sot-openhrp/work/sot-openhrp-2.5.1/cmake/debian.cmake:50:53 Argument not separated from preceding token by whitespace. Call Stack (most recent call first): CMakeLists.txt:18 (INCLUDE) This warning is for project developers. Use -Wno-dev to suppress it. CMake Warning (dev) at CMakeLists.txt:21 (INCLUDE): Syntax Warning in cmake code at /local/robotpkg/var/tmp/robotpkg/robots/sot-openhrp/work/sot-openhrp-2.5.1/cmake/cpack.cmake:28:38 Argument not separated from preceding token by whitespace. This warning is for project developers. Use -Wno-dev to suppress it. CMake Error at CMakeLists.txt:62 (MESSAGE): The directory 'GRX_PREFIX-NOTFOUND/HRP2LAAS' does not exist.Please check the ROBOT configuration variable. An unexpected error occured. The last 10 log lines are shown below. | -- Boost version: 1.55.0 | -- Found the following Boost libraries: | -- thread | CMake Error at CMakeLists.txt:62 (MESSAGE): | The directory 'GRX_PREFIX-NOTFOUND/HRP2LAAS' does not exist.Please check | the ROBOT configuration variable. | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/robots/sot-openhrp/work/sot-openhrp-2.5.1/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/robots/sot-openhrp/work/configure.log make[3]: *** [do-configure-cmake] Error 1 /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed make[2]: *** [pkg-check-installed] Error 2 => Marking sot-openhrp-2.5.1~hrp2-laas as broken ERROR: make: *** [package] Error 2 Warning: DOXYGEN_PLIST_DIR in robots/sot-openhrp is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Deinstalling for sot-openhrp Removed digest-20080510 Removing dependency dynamic-graph-2.5.7 Removing dependency hpp-template-corba-1.1.3r1 Removing dependency py27-dynamic-graph-2.5.6r1 Removing dependency sot-core-2.9.10 Removing dependency Removed dynamic-graph-corba-2.5.1r3 Removing dependency jrl-dynamics-1.25.0r1 Removing dependency py27-sot-tools-1.0.1 Removing dependency sot-core-2.9.10 Removing dependency Removed sot-dynamic-2.9.2 Removed tnftp-20130505~ssl