robotpkg/robots/rmp440-genom3 bulk build results

Log for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server on Fedora-27-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gzip: gzip-1.8 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server ===> Installing full dependencies for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/genom3-2.99.31.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/genom3-openprs-1.0.9r5.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/genom3-pocolibs-1.11.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/gyro-libs-3.1r2.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/mana-emergency-0.2.1r1.tgz => Dependency openprs-1.1b10 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/openrobots-idl-1.6.tgz => Dependency pocolibs-2.16 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/rmp440-libs-0.5r2.tgz => Dependency tnftp-20130505~ssl already installed => Dependency transgen3-1.0b5 already installed ===> Checking build options for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Building with the following options: codels Build server codels openprs Build an OpenPRS client pocolibs-client-c Build a pocolibs C client pocolibs-server Build a pocolibs server ===> Checking alternatives for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Required system package autoconf>=2.59: autoconf-2.69 found => Required system package automake>=1.8: automake-1.15.1 found => Required system package gcc>=3: gcc-7 found => Required system package gm4>=1.4: gm4-1.4.18 found => Required system package libftdi>=0.14: libftdi-1.3 found => Required system package libtool>=1.5.22: libtool-2.4.6 found => Required system package pkg-config>=0.22: pkg-config-1.3.12 found => Required robotpkg package genom3>=2.99.31: genom3-2.99.31 found => Required robotpkg package genom3-openprs>=1.0: genom3-openprs-1.0.9r5 found => Required robotpkg package genom3-pocolibs>=1.8: genom3-pocolibs-1.11 found => Required robotpkg package gyro-libs>=2.99.0: gyro-libs-3.1r2 found => Required robotpkg package mana-emergency>=0.2: mana-emergency-0.2.1r1 found => Required robotpkg package openprs>=1.1b7: openprs-1.1b10 found => Required robotpkg package openrobots-idl>=1.6: openrobots-idl-1.6 found => Required robotpkg package pocolibs>=2.11: pocolibs-2.16 found => Required robotpkg package rmp440-libs>=0.2: rmp440-libs-0.5r2 found => Required robotpkg package transgen3>=1.0b2: transgen3-1.0b5 found ===> Done depends for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server ===> Extracting for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => SHA1 checksums OK => RMD160 checksums OK ===> Patching for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Applying robotpkg patches for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server ===> Configuring for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Generating openprs/client => Running autoreconf for openprs/client autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: /usr/bin/aclocal --force -I autoconf autoreconf: configure.ac: tracing autoreconf: running: /usr/bin/libtoolize --copy --force autoreconf: running: /usr/bin/autoconf --force autoreconf: running: /usr/bin/autoheader --force autoreconf: running: /usr/bin/automake --add-missing --copy --force-missing configure.ac:12: installing 'autoconf/compile' configure.ac:12: installing 'autoconf/config.guess' configure.ac:12: installing 'autoconf/config.sub' configure.ac:9: installing 'autoconf/install-sh' configure.ac:9: installing 'autoconf/missing' Makefile.am: installing 'autoconf/depcomp' autoreconf: Leaving directory `.' => Generating pocolibs/client/c => Running autoreconf for pocolibs/client/c autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: /usr/bin/aclocal --force -I autoconf autoreconf: configure.ac: tracing autoreconf: running: /usr/bin/libtoolize --copy --force autoreconf: running: /usr/bin/autoconf --force autoreconf: running: /usr/bin/autoheader --force autoreconf: running: /usr/bin/automake --add-missing --copy --force-missing configure.ac:12: installing 'autoconf/compile' configure.ac:12: installing 'autoconf/config.guess' configure.ac:12: installing 'autoconf/config.sub' configure.ac:9: installing 'autoconf/install-sh' configure.ac:9: installing 'autoconf/missing' Makefile.am: installing 'autoconf/depcomp' autoreconf: Leaving directory `.' => Generating pocolibs/server => Running autoreconf for pocolibs/server autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: /usr/bin/aclocal --force -I autoconf autoreconf: configure.ac: tracing autoreconf: running: /usr/bin/libtoolize --copy --force autoreconf: running: /usr/bin/autoconf --force autoreconf: running: /usr/bin/autoheader --force autoreconf: running: /usr/bin/automake --add-missing --copy --force-missing configure.ac:12: installing 'autoconf/compile' configure.ac:12: installing 'autoconf/config.guess' configure.ac:12: installing 'autoconf/config.sub' configure.ac:9: installing 'autoconf/install-sh' configure.ac:9: installing 'autoconf/missing' Makefile.am: installing 'autoconf/depcomp' autoreconf: Leaving directory `.' => Modifying GNU configure scripts to avoid --recheck => Disabling fatal errors with C++ preprocessor in GNU configure scripts ===> Building for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server rmp440RequestOpenprs.c: In function 'init_rmp440_port_table': rmp440RequestOpenprs.c:91:3: warning: implicit declaration of function 'declare_genom3_port'; did you mean 'declare_genom3_poster'? [-Wimplicit-function-declaration] declare_genom3_port("genom_state", mod, ^~~~~~~~~~~~~~~~~~~ declare_genom3_poster rmp440EncodeDecodeOpenprs.c: In function 'encode_g3_float': rmp440EncodeDecodeOpenprs.c:1338:31: warning: passing argument 1 of 'PU_bind_float' from incompatible pointer type [-Wincompatible-pointer-types] if (!PU_bind_float(data,term)) ^~~~ In file included from rmp440EncodeDecodeOpenprs.c:18:0: /opt/openrobots/include/openprs/pu-parse-tl_f.h:19:10: note: expected 'double *' but argument is of type 'float *' PBoolean PU_bind_float(double *doublePtr, Term *paramTerm); ^~~~~~~~~~~~~ rmp440EncodeDecodeOpenprs.c: In function 'encode_g3_double': rmp440EncodeDecodeOpenprs.c:2042:17: warning: implicit declaration of function 'PU_bind_double'; did you mean 'PU_bind_float'? [-Wimplicit-function-declaration] if (!PU_bind_double(data,term)) ^~~~~~~~~~~~~~ PU_bind_float rmp440EncodeDecodeOpenprs.c: In function 'decode_g3_double': rmp440EncodeDecodeOpenprs.c:2050:13: warning: implicit declaration of function 'PUMakeTermDouble'; did you mean 'PUMakeTermTrue'? [-Wimplicit-function-declaration] return PUMakeTermDouble(data); ^~~~~~~~~~~~~~~~ PUMakeTermTrue rmp440EncodeDecodeOpenprs.c:2050:13: warning: return makes pointer from integer without a cast [-Wint-conversion] return PUMakeTermDouble(data); ^~~~~~~~~~~~~~~~~~~~~~ rmp440EncodeDecodeOpenprs.c: In function 'encode_g3_short': rmp440EncodeDecodeOpenprs.c:2443:9: warning: implicit declaration of function 'PU_bind_short'; did you mean 'PU_bind_float'? [-Wimplicit-function-declaration] if (!PU_bind_short(data, term)) ^~~~~~~~~~~~~ PU_bind_float rmp440EncodeDecodeOpenprs.c: In function 'genom_oprs_rmp440_exception': rmp440EncodeDecodeOpenprs.c:8415:3: warning: implicit declaration of function 'assert'; did you mean 'qsort'? [-Wimplicit-function-declaration] assert(!"unknown genom exception"); ^~~~~~ qsort ===> Installing for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server libtool: warning: relinking 'rmp440.la' libtool: warning: relinking 'rmp440-openprs-client.la' => Adding run-time search paths to pkg-config files => Registering installation for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added genom3-openprs-1.0.9r5 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added genom3-pocolibs-1.11 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added genom3-2.99.31 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added gyro-libs-3.1r2 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added mana-emergency-0.2.1r1 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added openprs-1.1b10 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added openrobots-idl-1.6 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added pocolibs-2.16 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added rmp440-libs-0.5r2 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Added transgen3-1.0b5 to the requirements of rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server ===> Done install for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server ===> Building binary package for rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Creating package /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server => Linking package in /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/pub ===> Deinstalling for rmp440-genom3 Removing dependency genom3-2.99.31 Removing dependency genom3-openprs-1.0.9r5 Removing dependency genom3-pocolibs-1.11 Removing dependency gyro-libs-3.1r2 Removing dependency mana-emergency-0.2.1r1 Removing dependency openprs-1.1b10 Removing dependency openrobots-idl-1.6 Removing dependency pocolibs-2.16 Removing dependency rmp440-libs-0.5r2 Removing dependency transgen3-1.0b5 Removing dependency Removed rmp440-genom3-0.1r1~codels+openprs+pocolibs-client-c+pocolibs-server Removed digest-20080510 Removed tnftp-20130505~ssl