robotpkg/middleware/orocos-rtt bulk build results

Log for orocos-rtt-2.8.1 on Ubuntu-17.10-x86_64: configure.log (Back)

--- Environment --- LOWER_ARCH=x86_64 OPSYS=Ubuntu GZIP_CMD=/bin/gzip _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD LC_TIME=C OS_KERNEL_VERSION=4.13.0-25-generic PKGREPO2DEB=/local/robotpkg/sbin/pkgrepo2deb BULKBASE=/opt/openrobots ECHO_N=echo -n _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.7 pkg_install>=20110805.7 pkg_install>=20110805.7 OS_VERSION=17.10 _override_vars_devel_boost_headers=PKGREQD PKGREQD PKGREQD ROBOTPKG_BASE=/local/robotpkg OLDPWD=/local/robotpkg/var/lib/robotpkg/pkgtools/pkgrepo2deb _override_vars_pkgtools_tnftp=PKGREQD PKGREQD _overrides_devel_boost_headers_PKGREQD=boost-headers>=1.38 boost-headers>=1.38 boost-headers>=1.38 PKG_DBDIR=/opt/openrobots/var/db/robotpkg hline="$bf======================================================================$rm" MACHINE_ARCH=x86_64 _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20091122 tnftp>=20091122 FC=false LC_CTYPE=C EXPECT_TARGETS=fetch install package LC_MONETARY=C PATCH=/usr/bin/patch _override_vars_devel_boost_libs=PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=orocos-rtt-2.8.1 RECURSIVE_PKGPATH=middleware/orocos-rtt\ tag=Ubuntu-17.10-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package _override_vars_pkgtools_digest=PKGREQD PKGREQD PKGREQD CPP=/usr/bin/gcc -E LOWER_OPSYS=ubuntu _overrides_devel_boost_libs_PKGREQD=boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 boost-libs>=1.38 bf= _override_vars_pkgtools_pkgrepo2deb=PKGREQD PKGREQD _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 digest>=20080510 GCC=/usr/bin/gcc DIGEST=/opt/openrobots/sbin/robotpkg_digest TAR=/bin/tar LOWER_OS_VERSION=17.10 MACHINE_KERNEL=Linux-4.13.0-25-generic-x86_64 _overrides_pkgtools_pkgrepo2deb_PKGREQD=pkgrepo2deb>=1.2.1 pkgrepo2deb>=1.2.1 OWNER_GID=robots PKGTOOLS_VERSION=20110805.7 RECURSIVE_PKGPATH=middleware/orocos-rtt GXX=/usr/bin/g++ MAKECONF=/opt/robotpkg/etc/robotpkg.conf _override_vars_archivers_pax=PKGREQD PKGREQD rm= LC_COLLATE=C OS_KERNEL=Linux ROBOTPKG_TRUSTED_ENV=robotpkg PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin _overrides_archivers_pax_PKGREQD=pax pax CXXCPP=/usr/bin/g++ -E CMAKE=/usr/bin/cmake _override_vars_middleware_orocos_rtt=PKGREQD MAKELEVEL=4 DEB_HOST_MULTIARCH=x86_64-linux-gnu MACHINE_PLATFORM=Ubuntu-17.10-x86_64 _overrides_middleware_orocos_rtt_PKGREQD=orocos-rtt-2.8.1 ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg TNFTP=/opt/openrobots/sbin/tnftp LANG=C MAKEOVERRIDES=PKGREQD.cmdline=orocos-rtt-2.8.1 RECURSIVE_PKGPATH=middleware/orocos-rtt\ tag=Ubuntu-17.10-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package LC_MESSAGES=C tag=Ubuntu-17.10-x86_64 CXX=/usr/bin/g++ LOCALBASE=/opt/openrobots OWNER_UID=rbulk BULK_LOGDIR=/local/robotpkg/var/log/bulk ZCAT=/bin/zcat DOXYGEN=/usr/bin/doxygen PAX=/bin/pax LOWER_OS_KERNEL=linux GPG=/usr/bin/gpg --homedir=/opt/robotpkg/etc/gnupg PWD=/local/robotpkg/var/lib/robotpkg/middleware/orocos-rtt _ROBOTPKG_NOW=0119141643 LC_NUMERIC=C CC=/usr/bin/gcc MFLAGS=--no-print-directory NODENAME=fluffy64-ubuntu1710 GIT=/usr/bin/git --- Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1 && cd /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1 && /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work PATH='/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin' LD_LIBRARY_PATH='' /usr/bin/cmake '-DBOOST_INCLUDEDIR=/usr/include' '-DBOOST_LIBRARYDIR=/usr/lib' '-DCMAKE_MODULE_PATH=' --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .; Not searching for unused variables given on the command line. CMake Deprecation Warning at CMakeLists.txt:13 (cmake_policy): The OLD behavior for policy CMP0026 will be removed from a future version of CMake. The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD. -- The C compiler identification is GNU 7.2.0 -- The CXX compiler identification is GNU 7.2.0 -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/g++ -- Check for working CXX compiler: /usr/bin/g++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done Orocos RTT version (2.8.1) No orocos-rtt.cmake file loaded, using default settings.See orocos-rtt.default.cmake No OROCOS_TARGET environment variable set. Using: gnulinux -- CMAKE_VERSION: 3.9.1 -- Boost version: 1.62.0 -- Using the following Boost include directory: /usr/include -- Found the following Boost libraries: -- filesystem: /usr/lib/x86_64-linux-gnu/libboost_filesystem.so -- system: /usr/lib/x86_64-linux-gnu/libboost_system.so -- unit_test_framework: /usr/lib/x86_64-linux-gnu/libboost_unit_test_framework.so -- thread: /usr/lib/x86_64-linux-gnu/libboost_thread.so -- serialization: /usr/lib/x86_64-linux-gnu/libboost_serialization.so Boost found in /usr/include -- Found Xerces: /usr/lib/x86_64-linux-gnu/libxerces-c.so Orocos target is gnulinux -- Found PTHREAD CMake Warning (dev) in config/check_depend.cmake: A logical block opening on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:312 (IF) closes on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:323 (ENDIF) with mis-matching arguments. Call Stack (most recent call first): CMakeLists.txt:115 (INCLUDE) This warning is for project developers. Use -Wno-dev to suppress it. ERROR: You seem to be using gcc version: 7 CMake Error at config/check_depend.cmake:321 (MESSAGE): ERROR: For gcc, Orocos requires version 4.x or 3.x Call Stack (most recent call first): CMakeLists.txt:115 (INCLUDE) -- Configuring incomplete, errors occurred! See also "/local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/CMakeFiles/CMakeOutput.log".