robotpkg/middleware/orocos-rtt bulk build results

Log for orocos-rtt-2.8.1 on Ubuntu-16.04-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for orocos-rtt-2.8.1 => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for orocos-rtt-2.8.1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.7.4 found => Required system package gnupg>=1: gnupg-1.4.20 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found ===> Done bootstrap-depends for orocos-rtt-2.8.1 ===> Installing full dependencies for orocos-rtt-2.8.1 => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed ===> Checking build options for orocos-rtt-2.8.1 => Building with no option. ===> Checking alternatives for orocos-rtt-2.8.1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for orocos-rtt-2.8.1 => Required system package boost-headers>=1.38: boost-headers-1.58 found => Required system package boostlib-filesystem>=1.38: boost-libs-1.58.0 found => Required system package boostlib-iostreams>=1.38: boost-libs-1.58.0 found => Required system package boostlib-math>=1.38: boost-libs-1.58.0 found => Required system package boostlib-thread>=1.38: boost-libs-1.58.0 found => Required system package cmake>=2.6: cmake-3.5.1 found => Required system package doxygen>=1.5: doxygen-1.8.11 found => Required system package g++>=3: g++-5.4.0 found => Required system package gcc>=3: gcc-5.4.0 found => Required system package libstdc++: libstdc++ found => Required system package xerces-c>=2: xerces-c-3.1.3 found ===> Done depends for orocos-rtt-2.8.1 ===> Extracting for orocos-rtt-2.8.1 => SHA1 checksums OK => RMD160 checksums OK ===> Patching for orocos-rtt-2.8.1 => Applying robotpkg patches for orocos-rtt-2.8.1 ===> Configuring for orocos-rtt-2.8.1 Orocos RTT version (2.8.1) No orocos-rtt.cmake file loaded, using default settings.See orocos-rtt.default.cmake No OROCOS_TARGET environment variable set. Using: gnulinux Boost found in /usr/include Orocos target is gnulinux CMake Warning (dev) at config/check_depend.cmake:115 (INCLUDE): A logical block opening on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:312 (IF) closes on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:323 (ENDIF) with mis-matching arguments. Call Stack (most recent call first): CMakeLists.txt:115 (INCLUDE) This warning is for project developers. Use -Wno-dev to suppress it. TLSF settings: -DUSE_SBRK -DUSE_MMAP -D_GNU_SOURCE -DTLSF_STATISTIC Building MQueue Transport library (Requires Boost >= 1.37.0). No default plugin path given, setting it to /opt/openrobots/lib/orocos. Define the DEFAULT_PLUGIN_PATH cmake variable to override this. ===> Building for orocos-rtt-2.8.1 In file included from /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/RealTimeTypekitTypes.cpp:42:0: /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:30:31: warning: type attributes ignored after type is already defined [-Wattributes] template class RTT_EXPORT DataSource< TYPE >; ^ /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:48:1: note: in expansion of macro 'RTT_EXPORT_TEMPLATE_TYPE' RTT_EXPORT_TEMPLATE_TYPE(std::string) ^ /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:31:31: warning: type attributes ignored after type is already defined [-Wattributes] template class RTT_EXPORT AssignableDataSource< TYPE >; ^ /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:48:1: note: in expansion of macro 'RTT_EXPORT_TEMPLATE_TYPE' RTT_EXPORT_TEMPLATE_TYPE(std::string) ^ /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:32:31: warning: type attributes ignored after type is already defined [-Wattributes] template class RTT_EXPORT ValueDataSource< TYPE >; ^ /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/rtt/typekit/Types.inc:48:1: note: in expansion of macro 'RTT_EXPORT_TEMPLATE_TYPE' RTT_EXPORT_TEMPLATE_TYPE(std::string) ^ ===> Installing for orocos-rtt-2.8.1 => Registering installation for orocos-rtt-2.8.1 ===> Done install for orocos-rtt-2.8.1 ===> Building binary package for orocos-rtt-2.8.1 Creating package /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04-x86_64/All/orocos-rtt-2.8.1 => Linking package in /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04-x86_64/pub => Building debian binary package dpkg-deb: building package 'robotpkg-orocos-rtt' in '/local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/pkg2deb.26197/robotpkg-orocos-rtt_2.8.1_amd64.deb'. WARNING: N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension WARNING: N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension ===> Deinstalling for orocos-rtt Removed orocos-rtt-2.8.1 Removed digest-20080510 Removed tnftp-20130505~ssl