robotpkg/middleware/orocos-rtt bulk build results

Log for orocos-rtt-2.8.1 on Fedora-26-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for orocos-rtt-2.8.1 => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for orocos-rtt-2.8.1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.13.6 found => Required system package gzip: gzip-1.8 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found ===> Done bootstrap-depends for orocos-rtt-2.8.1 ===> Installing full dependencies for orocos-rtt-2.8.1 => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed ===> Checking build options for orocos-rtt-2.8.1 => Building with no option. ===> Checking alternatives for orocos-rtt-2.8.1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for orocos-rtt-2.8.1 => Required system package boost-headers>=1.38: boost-headers-1.63 found => Required system package boostlib-filesystem>=1.38: boost-libs-1.63.0 found => Required system package boostlib-iostreams>=1.38: boost-libs-1.63.0 found => Required system package boostlib-math>=1.38: boost-libs-1.63.0 found => Required system package boostlib-thread>=1.38: boost-libs-1.63.0 found => Required system package cmake>=2.6: cmake-3.10.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package xerces-c>=2: xerces-c-3.1.4 found ===> Done depends for orocos-rtt-2.8.1 ===> Extracting for orocos-rtt-2.8.1 => SHA1 checksums OK => RMD160 checksums OK ===> Patching for orocos-rtt-2.8.1 => Applying robotpkg patches for orocos-rtt-2.8.1 ===> Configuring for orocos-rtt-2.8.1 CMake Deprecation Warning at CMakeLists.txt:13 (cmake_policy): The OLD behavior for policy CMP0026 will be removed from a future version of CMake. The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD. Orocos RTT version (2.8.1) No orocos-rtt.cmake file loaded, using default settings.See orocos-rtt.default.cmake No OROCOS_TARGET environment variable set. Using: gnulinux Boost found in /usr/include Orocos target is gnulinux CMake Warning (dev) in config/check_depend.cmake: A logical block opening on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:312 (IF) closes on the line /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/config/check_depend.cmake:323 (ENDIF) with mis-matching arguments. Call Stack (most recent call first): CMakeLists.txt:115 (INCLUDE) This warning is for project developers. Use -Wno-dev to suppress it. ERROR: You seem to be using gcc version: 7 CMake Error at config/check_depend.cmake:321 (MESSAGE): ERROR: For gcc, Orocos requires version 4.x or 3.x Call Stack (most recent call first): CMakeLists.txt:115 (INCLUDE) An unexpected error occured. The last 10 log lines are shown below. | 7 | | CMake Error at config/check_depend.cmake:321 (MESSAGE): | ERROR: For gcc, Orocos requires version 4.x or 3.x | Call Stack (most recent call first): | CMakeLists.txt:115 (INCLUDE) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/orocos-rtt-2.8.1/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/middleware/orocos-rtt/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/ do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/ pkg-check-installed] Error 2 => Marking orocos-rtt-2.8.1 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for orocos-rtt Removed digest-20080510 Removed tnftp-20130505~ssl