robotpkg/graphics/ros-qt-gui-core bulk build results

Log for ros-qt-gui-core-0.4.2 on Fedora-37-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for ros-qt-gui-core-0.4.2 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/tnftp-20151004~ssl.tgz ===> Checking bootstrap dependencies for ros-qt-gui-core-0.4.2 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20151004~ssl found => Required system package gzip: gzip-1.12 found => Required system package patch>=2.0: patch-2.7.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.12: pkg_install-20211115.3 found ===> Done bootstrap-depends for ros-qt-gui-core-0.4.2 ===> Installing full dependencies for ros-qt-gui-core-0.4.2 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/py311-catkin-pkg-0.5.2.tgz WARNING: Cannot check installed version of py-pyparsing => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/py311-rospkg-1.1.7.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/py311-ros-catkin-0.7.29.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python3.11/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/ros-class-loader-0.4.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/ros-cmake-modules-0.4.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/ros-nodelet-core-1.9.16.tgz => Dependency ros-pluginlib-1.12.1 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-37-x86_64/All/ros-python-qt-binding-0.3.6.tgz => Dependency tnftp-20151004~ssl already installed ===> Checking build options for ros-qt-gui-core-0.4.2 => Building with no option. ===> Checking alternatives for ros-qt-gui-core-0.4.2 => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.11: python>=2.5 provided by python311>=3.11<3.12 ===> Checking dependencies for ros-qt-gui-core-0.4.2 => Required system package cmake>=2.8.3: cmake-3.27.7 found => Required system package g++>=4.8: g++-12 found => Required system package gcc>=3: gcc-12 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.8.0 found => Required system package py311-empy>=3: py311-empy-3.3.4 found => Required system package py311-nose>=0.10: py311-nose-1.3.7 found => Required system package py311-pydot>=1: py311-pydot-1.4.2 found => Required system package py311-pyparsing>=1: py311-pyparsing found => Required system package py311-sip>=4: py311-sip-4.19.25 found => Required system package python311>=3.11<3.12: python311-3.11.6 found => Required system package qmake>=2: qmake-3.1 found => Required system package qt5-qtbase>=5<6: qt5-qtbase-5.15.10 found WARNING: Cannot check installed version of py-pyparsing => Required robotpkg package py311-catkin-pkg>=0.2: py311-catkin-pkg-0.5.2 found => Required robotpkg package py311-rospkg>=1.0.29: py311-rospkg-1.1.7 found => Required robotpkg package py311-ros-catkin>=0.7: py311-ros-catkin-0.7.29 found => Required robotpkg package ros-class-loader>=0.3: ros-class-loader-0.4.1 found => Required robotpkg package ros-cmake-modules>=0.3: ros-cmake-modules-0.4.1 found => Required robotpkg package ros-nodelet-core>=1.9: ros-nodelet-core-1.9.16 found => Required robotpkg package ros-pluginlib>=1.10: ros-pluginlib-1.12.1 found => Required robotpkg package ros-python-qt-binding>=0.2.10: ros-python-qt-binding-0.3.6 found WARNING: Using py311-catkin-pkg-0.5.2 in /opt/openrobots WARNING: Using py311-rospkg in /opt/openrobots WARNING: The following packages may interfere with the build because they WARNING: are located in paths used by other dependencies: WARNING: py-catkin-pkg-0.5.2 in /usr WARNING: py-rospkg in /usr ===> Done depends for ros-qt-gui-core-0.4.2 ===> Extracting for ros-qt-gui-core-0.4.2 => SHA1 checksums OK => RMD160 checksums OK ===> Patching for ros-qt-gui-core-0.4.2 => Applying robotpkg patches for ros-qt-gui-core-0.4.2 ===> Configuring for ros-qt-gui-core-0.4.2 => Replacing python interpreter path CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. /opt/openrobots/share/catkin/cmake//interrogate_setup_dot_py.py:43: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives import distutils.core CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. /opt/openrobots/share/catkin/cmake//interrogate_setup_dot_py.py:43: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives import distutils.core CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. /opt/openrobots/share/catkin/cmake//interrogate_setup_dot_py.py:43: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives import distutils.core CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:3 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. /opt/openrobots/share/catkin/cmake//interrogate_setup_dot_py.py:43: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives import distutils.core CMake Warning (dev) at src/qt_gui_cpp/CMakeLists.txt:2 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. This warning is for project developers. Use -Wno-dev to suppress it. CMake Warning (dev) at /opt/openrobots/share/python_qt_binding/cmake/sip_helper.cmake:9 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): src/qt_gui_cpp_sip/CMakeLists.txt:36 (include) This warning is for project developers. Use -Wno-dev to suppress it. CMake Warning (dev) at /opt/openrobots/share/python_qt_binding/cmake/sip_helper.cmake:11 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): src/qt_gui_cpp_sip/CMakeLists.txt:36 (include) This warning is for project developers. Use -Wno-dev to suppress it. CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required): Compatibility with CMake < 3.5 will be removed from a future version of CMake. Update the VERSION argument value or use a ... suffix to tell CMake that the project does not need compatibility with older versions. CMake Warning (dev) at /opt/openrobots/share/catkin/cmake/python.cmake:4 (find_package): Policy CMP0148 is not set: The FindPythonInterp and FindPythonLibs modules are removed. Run "cmake --help-policy CMP0148" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): /opt/openrobots/share/catkin/cmake/all.cmake:164 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:20 (include) CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. /opt/openrobots/share/catkin/cmake//interrogate_setup_dot_py.py:43: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives import distutils.core ===> Building for ros-qt-gui-core-0.4.2 /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp/plugin_provider.cpp: In member function 'virtual QMap qt_gui_cpp::PluginProvider::discover(QObject*)': /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp/plugin_provider.cpp:52:18: warning: 'QMap& QMap::unite(const QMap&) [with Key = QString; T = QString]' is deprecated: Use QMultiMap for maps storing multiple values with the same key. [-Wdeprecated-declarations] 52 | plugins.unite(plugin); | ~~~~~~~~~~~~~^~~~~~~~ In file included from /usr/include/qt5/QtCore/QMap:1, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/plugin_context.h:39, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/plugin.h:37, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/plugin_provider.h:36, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp/plugin_provider.cpp:33: /usr/include/qt5/QtCore/qmap.h:1378:15: note: declared here 1378 | QMap &QMap::unite(const QMap &other) | ^~~~~~~~~~~~ In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/ros_pluginlib_plugin_provider_for_plugin_providers.h:37, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/recursive_plugin_provider.h:37, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp/recursive_plugin_provider.cpp:33: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp/ros_pluginlib_plugin_provider.cpp:34: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ /opt/openrobots/share/python_qt_binding/cmake/sip_configure.py:2: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives from distutils.spawn import find_executable sip: Deprecation warning: qt_gui_cpp.sip:1: %Module version number should be specified using the 'version' argument make[3]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule. In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider_for_plugin_providers.h:37, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/recursive_plugin_provider.h:37, from recursive_plugin_provider.sip:8: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider_for_plugins.h:37, from ros_pluginlib_plugin_provider_for_plugins.sip:9: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider_for_plugin_providers.h:37, from ros_pluginlib_plugin_provider_for_plugin_providers.sip:9: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22, from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23, from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14, from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42, from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25, from /usr/include/boost/smart_ptr/shared_ptr.hpp:29, from /usr/include/boost/shared_ptr.hpp:17, from /usr/include/boost/date_time/time_clock.hpp:17, from /usr/include/boost/thread/thread_time.hpp:9, from /usr/include/boost/thread/lock_types.hpp:18, from /usr/include/boost/thread/pthread/thread_data.hpp:12, from /usr/include/boost/thread/thread_only.hpp:17, from /usr/include/boost/thread/thread.hpp:12, from /usr/include/boost/thread.hpp:13, from /opt/openrobots/include/class_loader/multi_library_class_loader.hpp:35, from /opt/openrobots/include/pluginlib/class_loader.hpp:38, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider.h:45, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/ros_pluginlib_plugin_provider_for_plugin_providers.h:37, from /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/recursive_plugin_provider.h:37, from recursive_plugin_provider.sip:8: /usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.' 36 | BOOST_PRAGMA_MESSAGE( | ^~~~~~~~~~~~~~~~~~~~ g++: fatal error: environment variable 'RPM_ARCH' not defined compilation terminated. make[3]: *** [Makefile:38: "/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip".so] Error 1 make[2]: *** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/build.make:77: /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip.so] Error 2 make[1]: *** [CMakeFiles/Makefile2:259: src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2 make: *** [Makefile:139: all] Error 2 An unexpected error occured. The last 10 log lines are shown below. => Marking ros-qt-gui-core-0.4.2 as broken | g++ -Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wl,--build-id=sha1 -specs=/usr/lib/rpm/redhat/redhat-package-notes -shared -Wl,--version-script="/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip".exp -o "/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip".so siplibqt_gui_cpp_sipcmodule.o siplibqt_gui_cpp_sipQList0101qt_gui_cppPluginProvider.o siplibqt_gui_cpp_sipQList0101qt_gui_cppPluginDescriptor.o siplibqt_gui_cpp_sipQMap0100QString0100QString.o siplibqt_gui_cpp_sipqt_gui_cppSettings.o siplibqt_gui_cpp_sipqt_gui_cppRosPluginlibPluginProvider_ForPlugins.o siplibqt_gui_cpp_sipqt_gui_cppRosPluginlibPluginProvider_ForPluginProviders.o siplibqt_gui_cpp_sipqt_gui_cppRecursivePluginProvider.o siplibqt_gui_cpp_sipqt_gui_cppPluginDescriptor.o siplibqt_gui_cpp_sipqt_gui_cppPluginContext.o siplibqt_gui_cpp_sipqt_gui_cppPluginBridge.o siplibqt_gui_cpp_sipqt_gui_cppPlugin.o siplibqt_gui_cpp_sipqt_gui_cppGenericProxy.o siplibqt_gui_cpp_sipqt_gui_cppCompositePluginProvider.o siplibqt_gui_cpp_sipqt_gui_cppPluginProvider.o siplibqt_gui_cpp_sipqt_gui_cpp.o -L/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib -L/usr/lib64 -L/usr/X11R6/lib -lqt_gui_cpp /opt/openrobots/lib/libclass_loader.so /usr/lib64/libPocoFoundation.so /usr/lib64/libdl.a /opt/openrobots/lib/librosconsole.so /opt/openrobots/lib/librosconsole_print.so /opt/openrobots/lib/librosconsole_backend_interface.so /usr/lib64/libboost_regex.so.1.78.0 /opt/openrobots/lib/librostime.so /usr/lib64/libboost_date_time.so.1.78.0 /opt/openrobots/lib/libcpp_common.so /usr/lib64/libboost_thread.so.1.78.0 /usr/lib64/libconsole_bridge.so.1.0 /opt/openrobots/lib/libroslib.so /opt/openrobots/lib/librospack.so /usr/lib64/libpython3.11.so /usr/lib64/libboost_filesystem.so.1.78.0 /usr/lib64/libboost_program_options.so.1.78.0 /usr/lib64/libboost_system.so.1.78.0 /usr/lib64/libtinyxml2.so /usr/lib64/libboost_filesystem.so.1.78.0 /usr/lib64/libboost_system.so.1.78.0 -lQt5Core -lQt5Gui -lQt5Widgets -lQt5PrintSupport -lXext -lX11 -lm -lpthread | g++: fatal error: environment variable 'RPM_ARCH' not defined | compilation terminated. | make[3]: *** [Makefile:38: "/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip".so] Error 1 | make[3]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp/sip/qt_gui_cpp_sip' | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp' | make[2]: *** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/build.make:77: /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/stage/lib/python3.11/site-packages/qt_gui_cpp/libqt_gui_cpp_sip.so] Error 2 | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/qt_gui_core-0.4.2/qt_gui_cpp' | make[1]: *** [CMakeFiles/Makefile2:259: src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2 | make: *** [Makefile:139: all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/graphics/ros-qt-gui-core/work/build.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/build/build.mk:204: do-build-make(qt_gui_cpp)] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Deinstalling for ros-qt-gui-core Removed digest-20080510 Removing dependency py311-rosdep-0.10.30r1 Removing dependency py311-ros-catkin-0.7.29 Removing dependency ros-rospack-2.5.1 Removing dependency ros-roscpp-core-0.6.11 Removing dependency ros-genmsg-0.5.11 Removing dependency ros-ros-1.14.4r1 Removing dependency ros-python-qt-binding-0.3.6 Removing dependency ros-console-1.13.7r1 Removing dependency ros-gennodejs-2.0.1 Removing dependency ros-genlisp-0.4.16 Removing dependency ros-geneus-2.2.6 Removing dependency ros-gencpp-0.6.0 Removing dependency ros-genpy-0.6.7 Removing dependency ros-message-runtime-0.4.12 Removing dependency ros-message-generation-0.4.0 Removing dependency ros-std-msgs-0.5.11 Removing dependency ros-comm-msgs-1.11.2r1 Removing dependency ros-cmake-modules-0.4.1 Removing dependency ros-class-loader-0.4.1 Removing dependency ros-pluginlib-1.12.1 Removing dependency ros-comm-1.14.11r3 Removing dependency ros-dynamic-reconfigure-1.5.49r1 Removing dependency ros-bond-core-1.8.2r1 Removing dependency ros-nodelet-core-1.9.16 Removed py311-catkin-pkg-0.5.2 Removed tnftp-20151004~ssl