robotpkg/graphics/py-qt-gepetto-viewer-corba bulk build results

Log for py35-qt5-gepetto-viewer-corba-5.5.1~doc on Ubuntu-16.04.pal-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/tnftp-20151004~ssl.tgz ===> Checking bootstrap dependencies for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20151004~ssl found => Required system package gnupg>=1: gnupg-1.4.20 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found ===> Done bootstrap-depends for py35-qt5-gepetto-viewer-corba-5.5.1~doc ===> Installing full dependencies for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/omniORB-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/openscenegraph-3.6.5r3.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/py35-omniORBpy-4.2.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/py35-qt5-gepetto-viewer-4.9.0r3~doc.tgz => Dependency qt5-osgqt-3.5.7r2 already installed => Dependency tnftp-20151004~ssl already installed ===> Checking build options for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Building with the following options: doc Enable documentation generation and installation ===> Checking alternatives for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.5: python>=2.5<3.9 provided by python35>=3.5<3.6 => Use qt-5: qt>=4 provided by ===> Checking dependencies for py35-qt5-gepetto-viewer-corba-5.5.1~doc => Required system package boost-headers>=1.34.1: boost-headers-1.58 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.58.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.58.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.58.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.58.0 found => Required system package cmake>=3.1.0: cmake-3.5.1 found => Required system package doxygen>=1.5: doxygen-1.8.11 found => Required system package eigen3>=3.0.0: eigen3-3.2.92 found => Required system package g++>=4.8: g++-5.4.0 found => Required system package gcc>=3: gcc-5.4.0 found => Required system package latex>=3.14: latex-3.14159265 found => Required system package libstdc++: libstdc++ found => Required system package mesa: mesa found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package python35>=3.5<3.6: python35-3.5.2 found => Required system package qt5-qtbase>=5<6: qt5-qtbase-5.5.1 found => Required robotpkg package omniORB>=4.1.1: omniORB-4.2.4 found => Required robotpkg package openscenegraph>=3: openscenegraph-3.6.5r3 found => Required robotpkg package py35-omniORBpy: py35-omniORBpy-4.2.4 found => Required robotpkg package py35-qt5-gepetto-viewer>=4.6.0: py35-qt5-gepetto-viewer-4.9.0r3~doc found => Required robotpkg package qt5-osgqt>=3: qt5-osgqt-3.5.7r2 found WARNING: Using omniORB-4.2.4 in /opt/openrobots WARNING: Using py35-omniORBpy in /opt/openrobots WARNING: The following packages may interfere with the build because they WARNING: are located in paths used by other dependencies: WARNING: omniORB-4.1.6 in /usr WARNING: py-omniORBpy in /usr ===> Done depends for py35-qt5-gepetto-viewer-corba-5.5.1~doc ===> Extracting for py35-qt5-gepetto-viewer-corba-5.5.1~doc => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for py35-qt5-gepetto-viewer-corba-5.5.1~doc CMake Error at src/CMakeLists.txt:88 (QT5_WRAP_CPP): Unknown CMake command "QT5_WRAP_CPP". An unexpected error occured. The last 10 log lines are shown below. | -- openscenegraph-osgQt5 is required. | -- Checking for module 'openscenegraph-osgQt5' | -- Found openscenegraph-osgQt5, version 3.5.7 | -- Pkg-config module openscenegraph-osgQt5 v3.5.7 has been detected with success. | CMake Error at src/CMakeLists.txt:88 (QT5_WRAP_CPP): /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed | Unknown CMake command "QT5_WRAP_CPP". | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work/gepetto-viewer-corba-5.5.1/build/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed /local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work/configure.log make[3]: *** [do-configure-cmake] Error 1 => Marking py35-qt5-gepetto-viewer-corba-5.5.1~doc as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Deinstalling for py35-qt5-gepetto-viewer-corba Removed digest-20080510 Removing dependency py35-omniORBpy-4.2.4 omniORB-4.2.4: removing default configuration file in /opt/openrobots/etc/omniORB.cfg robotpkg_delete: Couldn't remove /opt/openrobots/etc/omniORB.cfg Removed omniORB-4.2.4 Removing dependency collada-dom-2.4.0r1 Removing dependency Removing dependency qt5-osgqt-3.5.7r2 Removing dependency py35-qt5-gepetto-viewer-4.9.0r3~doc Removed openscenegraph-3.6.5r3 Removed tnftp-20151004~ssl