robotpkg/graphics/py-qt-gepetto-viewer-corba bulk build results

Log for py310-qt5-gepetto-viewer-corba-5.7.1 on Fedora-36-x86_64: configure.log (Back)

--- Environment --- EXPECT_TARGETS=fetch install package _override_vars_graphics_py_qt_gepetto_viewer_corba=PKGREQD PYTHON310_INCLUDE=/usr/include/python3.10/ _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.12 pkg_install>=20110805.12 pkg_install>=20110805.12 _override_vars_graphics_openscenegraph=PKGREQD PKGREQD PKGREQD PKG_CONFIG_PATH=/opt/openrobots/lib/pkgconfig BULKBASE=/opt/openrobots PYTHON_LIB=/usr/lib64/libpython3.10.so _overrides_graphics_qt_osgqt_PKGREQD=qt5-osgqt>=3 qt5-osgqt>=3 qt5-osgqt>=3 CPP=/usr/bin/gcc -E TAR=/usr/bin/tar _overrides_middleware_omniORB_PKGREQD=omniORB>=4.1.1 omniORB>=4.1.1 omniORB>=4.1.1 LC_MONETARY=C _override_vars_middleware_py_omniORBpy=PKGREQD PKGREQD PKGREQD _override_vars_pkgtools_tnftp=PKGREQD PKGREQD _override_vars_graphics_qt_osgqt=PKGREQD PKGREQD PKGREQD OPSYS=Fedora _override_vars_math_eigen3=PKGREQD PKGREQD PKGREQD ECHO_N=echo -n PWD=/local/robotpkg/var/lib/robotpkg/graphics/py-qt-gepetto-viewer-corba DIGEST=/opt/openrobots/sbin/robotpkg_digest PYTHON_INCLUDE_CONFIG=/usr/include/python3.10/ _override_vars_devel_boost_libs=PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD LOCALBASE=/opt/openrobots _override_vars_graphics_py_qt_gepetto_viewer=PKGREQD PKGREQD PKGREQD MAKEOVERRIDES=PKGREQD.cmdline=py310-qt5-gepetto-viewer-corba-5.7.1~!doc RECURSIVE_PKGPATH=graphics/py-qt-gepetto-viewer-corba\ tag=Fedora-36-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package CXX=/usr/bin/g++ PAX=/usr/bin/pax CXXCPP=/usr/bin/g++ -E MACHINE_PLATFORM=Fedora-36-x86_64 CMAKE=/usr/bin/cmake LANG=C OWNER_GID=robots OMNIIDL=/usr/bin/omniidl _overrides_graphics_py_qt_gepetto_viewer_corba_PKGREQD=py310-qt5-gepetto-viewer-corba-5.7.1~!doc _overrides_middleware_py_omniORBpy_PKGREQD=py310-omniORBpy py310-omniORBpy py310-omniORBpy BULK_LOGDIR=/local/robotpkg/var/log/bulk MACHINE_KERNEL=Linux-5.18.13-200.fc36.x86_64-x86_64 ROBOTPKG_TRUSTED_ENV=robotpkg _overrides_math_eigen3_PKGREQD=eigen3>=3.0.0 eigen3>=3.0.0 eigen3>=3.0.0 ROBOTPKG_BASE=/local/robotpkg _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 _ROBOTPKG_NOW=0801122903 _override_vars_middleware_omniORB=PKGREQD PKGREQD PKGREQD PKG_DBDIR=/opt/openrobots/var/db/robotpkg _overrides_devel_boost_headers_PKGREQD=boost-headers>=1.34.1 boost-headers>=1.34.1 boost-headers>=1.34.1 PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig:/usr/share/pkgconfig RECURSIVE_PKGPATH=graphics/py-qt-gepetto-viewer-corba GXX=/usr/bin/g++ OS_VERSION=36 MFLAGS=--no-print-directory GZIP_CMD=/usr/bin/gzip _overrides_graphics_py_qt_gepetto_viewer_PKGREQD=py310-qt5-gepetto-viewer>=4.13.0 py310-qt5-gepetto-viewer>=4.13.0 py310-qt5-gepetto-viewer>=4.13.0 tag=Fedora-36-x86_64 ZCAT=/usr/bin/zcat MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=py310-qt5-gepetto-viewer-corba-5.7.1~!doc RECURSIVE_PKGPATH=graphics/py-qt-gepetto-viewer-corba\ tag=Fedora-36-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package _override_vars_pkgtools_pkg_config=PKGREQD PKGREQD PKGREQD PYTHONPATH= _overrides_devel_boost_libs_PKGREQD=boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 PYTHON310=/usr/bin/python3.10 _override_vars_pkgtools_digest=PKGREQD PKGREQD _override_vars_devel_boost_headers=PKGREQD PKGREQD PKGREQD _override_vars_archivers_pax=PKGREQD PKGREQD LOWER_OS_KERNEL=linux LOWER_OS_VERSION=36 PYTHON=/usr/bin/python3.10 PYTHON310_LIB=/usr/lib64/libpython3.10.so PYTHON_INCLUDE=/usr/include/python3.10/ ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg SHLVL=4 GCC=/usr/bin/gcc MAKELEVEL=4 OWNER_UID=rbulk LC_MESSAGES=C rm= PYTHONDONTWRITEBYTECODE=1 MAKECONF=/opt/robotpkg/etc/robotpkg.conf hline="$bf======================================================================$rm" LC_CTYPE=C MACHINE_ARCH=x86_64 OS_KERNEL_VERSION=5.18.13-200.fc36.x86_64 _overrides_graphics_openscenegraph_PKGREQD=openscenegraph>=3 openscenegraph>=3 openscenegraph>=3 LC_TIME=C TNFTP=/opt/openrobots/sbin/tnftp FC=false LOWER_OPSYS=fedora _overrides_pkgtools_pkg_config_PKGREQD=pkg-config>=0.22 pkg-config>=0.22 pkg-config>=0.22 LC_COLLATE=C LOWER_ARCH=x86_64 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin _overrides_archivers_pax_PKGREQD=pax pax NODENAME=hydra64-fedora36 CC=/usr/bin/gcc PKGTOOLS_VERSION=20110805.12 bf= _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20130505~ssl tnftp>=20130505~ssl QT_SELECT=5 OS_KERNEL=Linux LC_NUMERIC=C OLDPWD=/local/robotpkg/var/lib/robotpkg/graphics/py-qt-gepetto-viewer-corba PKG_CONFIG=/usr/bin/pkg-config _=/usr/bin/env --- Running set -e;/bin/mkdir -p /local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work/gepetto-viewer-corba-5.7.1/build Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work/gepetto-viewer-corba-5.7.1 && cd 'build' && \ /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work PATH='/opt/openrobots/bin:/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin' LD_LIBRARY_PATH='' \ /usr/bin/cmake -DENFORCE_MINIMAL_CXX_STANDARD=ON -DCMAKE_INSTALL_LIBDIR=lib -DPYTHON_STANDARD_LAYOUT=ON -DBoost_NO_BOOST_CMAKE=ON '-DQt5Core_DIR=/usr/lib64/cmake/Qt5Core/' '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=/usr' '-DBOOST_INCLUDEDIR=/usr/include' '-DBOOST_LIBRARYDIR=/usr/lib' -DOMNIIDL=/usr/bin/omniidl -DPYTHON_SITELIB=lib/python3.10/site-packages -DPYTHON_EXECUTABLE=/usr/bin/python3.10 -DPYTHON_INCLUDE_DIR=/usr/include/python3.10/ -DPYTHON_INCLUDE_DIR2=/usr/include/python3.10/ -DPYTHON_LIBRARY=/usr/lib64/libpython3.10.so -DPython_EXECUTABLE=/usr/bin/python3.10 -DPython3_EXECUTABLE=/usr/bin/python3.10 -DPython2_EXECUTABLE=/bin/false -DINSTALL_DOCUMENTATION=FALSE --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE -DCMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG ' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .. Not searching for unused variables given on the command line. -- Package version (ROS package.xml): 5.7.1 -- The CXX compiler identification is GNU 12.1.1 -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/bin/g++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Found PkgConfig: /usr/bin/pkg-config (found version "1.8.0") -- Performing Test R-pedantic -- Performing Test R-pedantic - Success -- Performing Test R-Wno-long-long -- Performing Test R-Wno-long-long - Success -- Performing Test R-Wall -- Performing Test R-Wall - Success -- Performing Test R-Wextra -- Performing Test R-Wextra - Success -- Performing Test R-Wcast-align -- Performing Test R-Wcast-align - Success -- Performing Test R-Wcast-qual -- Performing Test R-Wcast-qual - Success -- Performing Test R-Wformat -- Performing Test R-Wformat - Success -- Performing Test R-Wwrite-strings -- Performing Test R-Wwrite-strings - Success -- Performing Test R-Wconversion -- Performing Test R-Wconversion - Success -- Found Doxygen: /usr/bin/doxygen (found version "1.9.1") found components: doxygen dot -- Found Python3: /usr/bin/python3.10 (found version "3.10.5") found components: Interpreter Development Development.Module Development.Embed -- PythonLibraryDirs: /usr/lib64 -- PythonLibVersionString: 3.10.5 -- Python site lib: lib/python3.10/site-packages :1: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives :1: DeprecationWarning: The distutils.sysconfig module is deprecated, use sysconfig instead :1: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives :1: DeprecationWarning: The distutils.sysconfig module is deprecated, use sysconfig instead -- omniORB4 >= 4.1.4 is required. -- Checking for module 'omniORB4>=4.1.4' -- Found omniORB4, version 4.3.0 -- Pkg-config module omniORB4 v4.3.0 has been detected with success. -- gepetto-viewer FOUND. gepetto-viewer at /opt/openrobots/lib/libgepetto-viewer.so -- openscenegraph >= 3.2 is required. -- Checking for module 'openscenegraph>=3.2' -- Found openscenegraph, version 3.6.5 -- Pkg-config module openscenegraph v3.6.5 has been detected with success. -- openthreads >= 2.6 is required. -- Checking for module 'openthreads>=2.6' -- Found openthreads, version 3.3.1 -- Pkg-config module openthreads v3.3.1 has been detected with success. -- openscenegraph-osgQt5 is required. -- Checking for module 'openscenegraph-osgQt5' -- Found openscenegraph-osgQt5, version 3.5.7 -- Pkg-config module openscenegraph-osgQt5 v3.5.7 has been detected with success. -- Default C++ standard: 201703 -- C++ standard sufficient: Minimal required 11, currently defined: 17 -- Doxygen rendering: using LaTeX backend -- Configuring done -- Generating done -- Build files have been written to: /local/robotpkg/var/tmp/robotpkg/graphics/py-qt-gepetto-viewer-corba/work/gepetto-viewer-corba-5.7.1/build