robotpkg/graphics/gepetto-viewer bulk build results

Log for py27-qt5-gepetto-viewer-4.6.0 on Ubuntu-14.04-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py27-qt5-gepetto-viewer-4.6.0 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-14.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-14.04-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py27-qt5-gepetto-viewer-4.6.0 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.16 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.6.1: pkgrepo2deb-1.6.1 found ===> Done bootstrap-depends for py27-qt5-gepetto-viewer-4.6.0 ===> Installing full dependencies for py27-qt5-gepetto-viewer-4.6.0 => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py27-qt5-gepetto-viewer-4.6.0 => Building with no option. ===> Checking alternatives for py27-qt5-gepetto-viewer-4.6.0 => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.8 provided by python27>=2.7<2.8 => Use qt-5: qt>=4 provided by ===> Checking dependencies for py27-qt5-gepetto-viewer-4.6.0 => Required system package boost-headers>=1.34.1: boost-headers-1.54 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.54.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.54.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.54.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.54.0 found => Required system package cmake>=2.6: cmake-2.8.12.2 found => Required system package g++>=4.8: g++-4.8 found => Required system package gcc>=3: gcc-4.8 found => Required system package libstdc++: libstdc++ found => Required system package openscenegraph>=3.2: openscenegraph-3.2.0 found => Required system package openthreads>=2: openthreads-2.6.0 found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.6 found => Required system package qt5-qtbase>=5<6: qt5-qtbase-5.2.1 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required system package urdfdom>=0.2.8: urdfdom-0.2.10 found => Required system package urdfdom-headers>=0.2.2: urdfdom-headers-0.2.3 found ===> Done depends for py27-qt5-gepetto-viewer-4.6.0 ===> Extracting for py27-qt5-gepetto-viewer-4.6.0 => SHA1 checksums OK => RMD160 checksums OK ===> Patching for py27-qt5-gepetto-viewer-4.6.0 => Applying robotpkg patches for py27-qt5-gepetto-viewer-4.6.0 ===> Configuring for py27-qt5-gepetto-viewer-4.6.0 CMake Warning at cmake/python.cmake:46 (MESSAGE): CMake versions older than 3.2 do not properly find Python. Custom macros are used to find it. Call Stack (most recent call first): CMakeLists.txt:27 (INCLUDE) CMake Error at src/CMakeLists.txt:176 (QT4_WRAP_UI): Unknown CMake command "QT4_WRAP_UI". An unexpected error occured. The last 10 log lines are shown below. | -- unit_test_framework | -- system | -- regex | -- Skipping PythonQt settings | CMake Error at src/CMakeLists.txt:176 (QT4_WRAP_UI): | Unknown CMake command "QT4_WRAP_UI". | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/graphics/gepetto-viewer/work/gepetto-viewer-4.6.0/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/graphics/gepetto-viewer/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking py27-qt5-gepetto-viewer-4.6.0 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for py27-qt5-gepetto-viewer Removed digest-20080510 Removed tnftp-20130505~ssl