robotpkg/wip/sot-hrp2-v3 bulk build results

Log for sot-hrp2-v3-2.1.3 on Ubuntu-16.04.pal-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for sot-hrp2-v3-2.1.3 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for sot-hrp2-v3-2.1.3 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.20 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found ===> Done bootstrap-depends for sot-hrp2-v3-2.1.3 ===> Installing full dependencies for sot-hrp2-v3-2.1.3 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/dynamic-graph-bridge-msgs-0.2.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-16.04.pal-x86_64/All/dynamic-graph-v3-4.2.2.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/hpp-fcl-1.4.5~doc.tgz => Dependency octomap-1.9.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04.pal-x86_64/All/pinocchio-2.4.7.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-16.04.pal-x86_64/All/py27-dynamic-graph-bridge-v3-3.3.2.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Dependency py27-dynamic-graph-v3-3.5.3 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-16.04.pal-x86_64/All/py27-sot-tools-v3-2.2.2.tgz => Dependency sot-core-v3-4.10.0 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-16.04.pal-x86_64/All/sot-dynamic-pinocchio-v3-3.5.2.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for sot-hrp2-v3-2.1.3 => Building with no option. ===> Checking alternatives for sot-hrp2-v3-2.1.3 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Use ros kinetic: ros>=groovy provided by ros-kinetic ===> Checking dependencies for sot-hrp2-v3-2.1.3 => Required system package cmake>=3.1.0: cmake-3.5.1 found => Required system package doxygen>=1.5: doxygen-1.8.11 found => Required system package eigen3>=3.0.0: eigen3-3.2.92 found => Required system package g++>=3: g++-5.4.0 found => Required system package gcc>=3: gcc-5.4.0 found => Required system package graphviz>=2: graphviz-2.38.0 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package python27>=2.7<2.8: python27-2.7.12 found => Required system package ros-comm>=1.12<1.13: ros-comm-1.12.14 found => Required system package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required system package ros-std-msgs>=0.5: ros-std-msgs-0.5.11 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required system package urdfdom>=0.2.8: urdfdom-0.4.0 found => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: dynamic-graph-bridge-msgs-0.2.0 found => Required robotpkg package dynamic-graph-v3>=3.8.1: dynamic-graph-v3-4.2.2 found => Required robotpkg package hpp-fcl>=1.4: hpp-fcl-1.4.5~doc found => Required robotpkg package octomap>=1.6.0: octomap-1.9.0 found => Required robotpkg package pinocchio>=2.3<3.0.0: pinocchio-2.4.7 found => Required robotpkg package py27-dynamic-graph-bridge-v3>=3.0.0: py27-dynamic-graph-bridge-v3-3.3.2 found => Required robotpkg package py27-dynamic-graph-v3>=3.0: py27-dynamic-graph-v3-3.5.3 found => Required robotpkg package py27-sot-tools-v3>=2.0: py27-sot-tools-v3-2.2.2 found => Required robotpkg package sot-core-v3>=4.1.0<5.0.0: sot-core-v3-4.10.0 found => Required robotpkg package sot-dynamic-pinocchio-v3>=3.2.0<4.0.0: sot-dynamic-pinocchio-v3-3.5.2 found ERROR: ====================================================================== ERROR: The following packages should be managed externally, but they are ERROR: still installed by robotpkg: ERROR: ERROR: ros-comm-1.14.4 in middleware/ros-comm ERROR: ros-message-runtime-0.4.12 in lang/ros-message-runtime ERROR: ros-std-msgs-0.5.11 in interfaces/ros-std-msgs ERROR: ERROR: Please use `robotpkg_delete` to deinstall the packages above or ERROR: update your settings in ERROR: /opt/robotpkg/etc/robotpkg-wip.conf ERROR: by adding: ERROR: PREFER.ros-comm = robotpkg ERROR: PREFER.ros-message-runtime = robotpkg ERROR: PREFER.ros-std-msgs = robotpkg ERROR: ====================================================================== make[2]: *** [do-depends] Error 1 /local/robotpkg/var/lib/robotpkg/mk/depends/depends.mk:70: recipe for target 'do-depends' failed ERROR: make: *** [depends] Error 2 ===> Deinstalling for sot-hrp2-v3 Removed digest-20080510 Removing dependency py27-dynamic-graph-bridge-v3-3.3.2 Removed dynamic-graph-bridge-msgs-0.2.0 Removing dependency sot-core-v3-4.10.0 Removing dependency sot-tools-v3-2.2.2 Removing dependency sot-dynamic-pinocchio-v3-3.5.2 Removing dependency py27-dynamic-graph-v3-3.5.3 Removing dependency py27-sot-core-v3-4.10.0 Removing dependency py27-sot-tools-v3-2.2.2 Removed dynamic-graph-v3-4.2.2 Removed tnftp-20130505~ssl