robotpkg/wip/py-jsbsim bulk build results

Log for py36-jsbsim-20150424r1 on Fedora-27-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py36-jsbsim-20150424r1 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py36-jsbsim-20150424r1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package cvs>=1: cvs-1.11.23 found => Required system package gzip: gzip-1.8 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for py36-jsbsim-20150424r1 ===> Installing full dependencies for py36-jsbsim-20150424r1 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/All/jsbsim-20150424.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py36-jsbsim-20150424r1 => Building with no option. ===> Checking alternatives for py36-jsbsim-20150424r1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.6: python>=2.5<3.8 provided by python36>=3.6<3.7 ===> Checking dependencies for py36-jsbsim-20150424r1 => Required system package cmake>=2.6: cmake-3.11.2 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package python36>=3.6<3.7: python36-3.6.6 found => Required robotpkg package jsbsim>=1.0: jsbsim-20150424 found ===> Done depends for py36-jsbsim-20150424r1 ===> Extracting for py36-jsbsim-20150424r1 => SHA1 checksums OK => RMD160 checksums OK /bin/cp /local/robotpkg/var/lib/robotpkg/wip/py-jsbsim/files/CMakeLists.txt /local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/jsbsim-20150424/tests ===> Configuring for py36-jsbsim-20150424r1 ===> Building for py36-jsbsim-20150424r1 ===> Installing for py36-jsbsim-20150424r1 => Compiling python files File "/opt/openrobots/lib/python3.6/site-packages/JSBSim_utils.py", line 195 print name_with_system_path ^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(name_with_system_path)? File "/opt/openrobots/lib/python3.6/site-packages/JSBSim_utils.py", line 195 print name_with_system_path ^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(name_with_system_path)? robotpkg_create: can't stat `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.opt-1.pyc' => Registering installation for py36-jsbsim-20150424r1 robotpkg_admin: py36-jsbsim-20150424r1: File `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py36-jsbsim-20150424r1: File `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.opt-1.pyc' is in +CONTENTS but not on filesystem! Added jsbsim-20150424 to the requirements of py36-jsbsim-20150424r1 ===> Done install for py36-jsbsim-20150424r1 ===> Building binary package for py36-jsbsim-20150424r1 robotpkg_create: can't stat `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.opt-1.pyc' Creating package /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/All/py36-jsbsim-20150424r1 robotpkg_create: lstat failed for file lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.pyc: No such file or directory make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:74: pkg-tarup] Error 2 => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/All => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/pub => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/jrl => Unlinking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/pal make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/package/package.mk:147: package-failed] Error 2 => Marking py36-jsbsim-20150424r1 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for py36-jsbsim Removing dependency jsbsim-20150424 Removing dependency robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.6/site-packages/__pycache__/JSBSim_utils.cpython-36.opt-1.pyc Removed py36-jsbsim-20150424r1 Removed digest-20080510 Removed tnftp-20130505~ssl