robotpkg/wip/py-dynamic-graph-v3 bulk build results

Log for py36-dynamic-graph-v3-3.3.2 on Fedora-28-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py36-dynamic-graph-v3-3.3.2 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-28-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-28-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py36-dynamic-graph-v3-3.3.2 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gzip: gzip-1.9 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for py36-dynamic-graph-v3-3.3.2 ===> Installing full dependencies for py36-dynamic-graph-v3-3.3.2 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-28-x86_64/All/dynamic-graph-v3-3.5.0.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py36-dynamic-graph-v3-3.3.2 => Building with no option. ===> Checking alternatives for py36-dynamic-graph-v3-3.3.2 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.6: python>=2.5<3.8 provided by python36>=3.6<3.7 ===> Checking dependencies for py36-dynamic-graph-v3-3.3.2 => Required system package cmake>=2.6: cmake-3.14.4 found => Required system package doxygen>=1.5: doxygen-1.8.14 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=3: g++-8 found => Required system package gcc>=3: gcc-8 found => Required system package graphviz>=2: graphviz-2.40.1 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.4.2 found => Required system package py-sphinx>=1.1: py-sphinx-1.7.5 found => Required system package python36>=3.6<3.7: python36-3.6.8 found => Required robotpkg package dynamic-graph-v3>=3.0.0: dynamic-graph-v3-3.5.0 found ===> Done depends for py36-dynamic-graph-v3-3.3.2 ===> Extracting for py36-dynamic-graph-v3-3.3.2 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for py36-dynamic-graph-v3-3.3.2 CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find PythonInterp: Found unsuitable version "3.6.8", but required is exact version "2.7" (found /usr/bin/python3.6) Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:376 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake/Modules/FindPythonInterp.cmake:160 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) cmake/python.cmake:47 (FIND_PACKAGE) CMakeLists.txt:45 (FINDPYTHON) An unexpected error occured. The last 10 log lines are shown below. | CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message): | Could NOT find PythonInterp: Found unsuitable version "3.6.8", but required | is exact version "2.7" (found /usr/bin/python3.6) | Call Stack (most recent call first): | /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:376 (_FPHSA_FAILURE_MESSAGE) | /usr/share/cmake/Modules/FindPythonInterp.cmake:160 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | cmake/python.cmake:47 (FIND_PACKAGE) | CMakeLists.txt:45 (FINDPYTHON) | | For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking py36-dynamic-graph-v3-3.3.2 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for py36-dynamic-graph-v3 Removed digest-20080510 Removed dynamic-graph-v3-3.5.0 Removed tnftp-20130505~ssl