robotpkg/wip/py-dynamic-graph-v3 bulk build results

Log for py35-dynamic-graph-v3-3.2.0 on Ubuntu-16.04-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py35-dynamic-graph-v3-3.2.0 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-16.04-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py35-dynamic-graph-v3-3.2.0 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.20 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.4: pkgrepo2deb-1.4 found ===> Done bootstrap-depends for py35-dynamic-graph-v3-3.2.0 ===> Installing full dependencies for py35-dynamic-graph-v3-3.2.0 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-16.04-x86_64/All/dynamic-graph-v3-3.2.1.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py35-dynamic-graph-v3-3.2.0 => Building with no option. ===> Checking alternatives for py35-dynamic-graph-v3-3.2.0 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.5: python>=2.5<3.8 provided by python35>=3.5<3.6 ===> Checking dependencies for py35-dynamic-graph-v3-3.2.0 => Required system package cmake>=2.6: cmake-3.5.1 found => Required system package doxygen>=1.5: doxygen-1.8.11 found => Required system package eigen3>=3.0.0: eigen3-3.2.92 found => Required system package g++>=3: g++-5.4.0 found => Required system package gcc>=3: gcc-5.4.0 found => Required system package graphviz>=2: graphviz-2.38.0 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py-sphinx>=1.1: py-sphinx-1.3.6 found => Required system package python35>=3.5<3.6: python35-3.5.2 found => Required robotpkg package dynamic-graph-v3>=3.0.0: dynamic-graph-v3-3.2.1 found ===> Done depends for py35-dynamic-graph-v3-3.2.0 ===> Extracting for py35-dynamic-graph-v3-3.2.0 => SHA1 checksums OK => RMD160 checksums OK ===> Patching for py35-dynamic-graph-v3-3.2.0 => Applying robotpkg patches for py35-dynamic-graph-v3-3.2.0 ===> Configuring for py35-dynamic-graph-v3-3.2.0 CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find PythonInterp: Found unsuitable version "3.5.2", but required is exact version "2.7" (found /usr/bin/python3.5) Call Stack (most recent call first): /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:386 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.5/Modules/FindPythonInterp.cmake:163 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) cmake/python.cmake:47 (FIND_PACKAGE) CMakeLists.txt:45 (FINDPYTHON) An unexpected error occured. The last 10 log lines are shown below. | Call Stack (most recent call first): | /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:386 (_FPHSA_FAILURE_MESSAGE) | /usr/share/cmake-3.5/Modules/FindPythonInterp.cmake:163 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | cmake/python.cmake:47 (FIND_PACKAGE) | CMakeLists.txt:45 (FINDPYTHON) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/dynamic-graph-python-3.2.0/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/dynamic-graph-python-3.2.0/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/configure.log make[3]: *** [do-configure-cmake] Error 1 /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed make[2]: *** [pkg-check-installed] Error 2 /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed => Marking py35-dynamic-graph-v3-3.2.0 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for py35-dynamic-graph-v3 Removed digest-20080510 Removed dynamic-graph-v3-3.2.1 Removed tnftp-20130505~ssl