robotpkg/wip/py-dynamic-graph-v3 bulk build results

Log for py27-dynamic-graph-v3-3.2.0 on NetBSD-8.0-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py27-dynamic-graph-v3-3.2.0 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/NetBSD-8.0-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/NetBSD-8.0-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py27-dynamic-graph-v3-3.2.0 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gzip: gzip-20150113 found => Required system package patch>=2.0: patch-2.0128 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for py27-dynamic-graph-v3-3.2.0 ===> Installing full dependencies for py27-dynamic-graph-v3-3.2.0 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/NetBSD-8.0-x86_64/All/dynamic-graph-v3-3.2.1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/NetBSD-8.0-x86_64/All/eigen3-3.2.4.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py27-dynamic-graph-v3-3.2.0 => Building with no option. ===> Checking alternatives for py27-dynamic-graph-v3-3.2.0 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.8 provided by python27>=2.7<2.8 ===> Checking dependencies for py27-dynamic-graph-v3-3.2.0 => Required system package cmake>=2.6: cmake-3.11.4 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package g++>=3: g++-5.5.0 found => Required system package gcc>=3: gcc-5.5.0 found => Required system package graphviz>=2: graphviz-2.40.1 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.4.1 found => Required system package py-sphinx>=1.1: py-sphinx-1.7.5 found => Required system package python27>=2.7<2.8: python27-2.7.15 found => Required robotpkg package dynamic-graph-v3>=3.0.0: dynamic-graph-v3-3.2.1 found => Required robotpkg package eigen3>=3.0.0: eigen3-3.2.4 found ===> Done depends for py27-dynamic-graph-v3-3.2.0 ===> Extracting for py27-dynamic-graph-v3-3.2.0 => SHA1 checksums OK => RMD160 checksums OK tar: ustar vol 1, 527 files, 2838528 bytes read, 0 bytes written in 1 secs (2838528 bytes/sec) ===> Patching for py27-dynamic-graph-v3-3.2.0 => Applying robotpkg patches for py27-dynamic-graph-v3-3.2.0 ===> Configuring for py27-dynamic-graph-v3-3.2.0 CMake Error at /usr/pkg/share/cmake-3.11/Modules/FindBoost.cmake:2044 (message): Unable to find the requested Boost libraries. Boost version: 1.67.0 Boost include path: /usr/pkg/include Could not find the following Boost libraries: boost_python Some (but not all) of the required Boost libraries were found. You may need to install these additional Boost libraries. Alternatively, set BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT to the location of Boost. Call Stack (most recent call first): cmake/boost.cmake:97 (FIND_PACKAGE) CMakeLists.txt:55 (SEARCH_FOR_BOOST) CMake Error at cmake/boost.cmake:100 (MESSAGE): Failed to detect Boost with the following components: Call Stack (most recent call first): CMakeLists.txt:55 (SEARCH_FOR_BOOST) An unexpected error occured. The last 10 log lines are shown below. | CMake Error at cmake/boost.cmake:100 (MESSAGE): | Failed to detect Boost with the following components: | | Call Stack (most recent call first): | CMakeLists.txt:55 (SEARCH_FOR_BOOST) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/dynamic-graph-python-3.2.0/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/dynamic-graph-python-3.2.0/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-v3/work/configure.log /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed gmake[3]: *** [do-configure-cmake] Error 1 /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed gmake[2]: *** [pkg-check-installed] Error 2 => Marking py27-dynamic-graph-v3-3.2.0 as broken ERROR: /usr/pkg/bin/gmake: *** [package] Error 2 ===> Deinstalling for py27-dynamic-graph-v3 Removed digest-20080510 Removed dynamic-graph-v3-3.2.1 Removed eigen3-3.2.4 Removed tnftp-20130505~ssl