robotpkg/wip/py-dynamic-graph-tutorial bulk build results

Log for py37-dynamic-graph-tutorial-1.2.0 on Ubuntu-19.04-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py37-dynamic-graph-tutorial-1.2.0 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-19.04-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-19.04-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py37-dynamic-graph-tutorial-1.2.0 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.2.12 found => Required system package gzip: gzip-1.9 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.7: pkgrepo2deb-1.7 found ===> Done bootstrap-depends for py37-dynamic-graph-tutorial-1.2.0 ===> Installing full dependencies for py37-dynamic-graph-tutorial-1.2.0 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-19.04-x86_64/All/dynamic-graph-tutorial-1.2.0.tgz => Dependency dynamic-graph-v3-3.8.1 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-19.04-x86_64/All/py37-dynamic-graph-v3-3.4.1.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py37-dynamic-graph-tutorial-1.2.0 => Building with no option. ===> Checking alternatives for py37-dynamic-graph-tutorial-1.2.0 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.7: python>=2.5<3.9 provided by python37>=3.7<3.8 ===> Checking dependencies for py37-dynamic-graph-tutorial-1.2.0 => Required system package boost-headers>=1.34.1: boost-headers-1.67 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.67.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.67.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.67.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.67.0 found => Required system package cmake>=2.6: cmake-3.13.4 found => Required system package g++>=3: g++-8 found => Required system package gcc>=3: gcc-8 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package python37>=3.7<3.8: python37-3.7.3 found => Required robotpkg package dynamic-graph-tutorial>=1.1.0: dynamic-graph-tutorial-1.2.0 found => Required robotpkg package dynamic-graph-v3>=3.8.1: dynamic-graph-v3-3.8.1 found => Required robotpkg package py37-dynamic-graph-v3>=3.0: py37-dynamic-graph-v3-3.4.1 found ===> Done depends for py37-dynamic-graph-tutorial-1.2.0 ===> Extracting for py37-dynamic-graph-tutorial-1.2.0 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for py37-dynamic-graph-tutorial-1.2.0 CMake Deprecation Warning at CMakeLists.txt:23 (CMAKE_POLICY): The OLD behavior for policy CMP0048 will be removed from a future version of CMake. The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD. CMake Deprecation Warning at cmake/python.cmake:210 (CMAKE_POLICY): The OLD behavior for policy CMP0037 will be removed from a future version of CMake. The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD. Call Stack (most recent call first): src/CMakeLists.txt:19 (DYNAMIC_GRAPH_PYTHON_MODULE) ===> Building for py37-dynamic-graph-tutorial-1.2.0 ===> Installing for py37-dynamic-graph-tutorial-1.2.0 WARNING: autodoc: failed to import class 'tutorial.InvertedPendulum' from module 'dynamic_graph'; the following exception was raised: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/sphinx/ext/autodoc/importer.py", line 154, in import_module __import__(modname) File "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/dynamic-graph-tutorial-1.2.0/src/dynamic_graph/tutorial/__init__.py", line 32, in dg.entity.updateEntityClasses(globals()) AttributeError: module 'dynamic_graph' has no attribute 'entity' WARNING: autodoc: failed to import class 'tutorial.FeedbackController' from module 'dynamic_graph'; the following exception was raised: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/sphinx/ext/autodoc/importer.py", line 154, in import_module __import__(modname) File "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/dynamic-graph-tutorial-1.2.0/src/dynamic_graph/tutorial/__init__.py", line 32, in dg.entity.updateEntityClasses(globals()) AttributeError: module 'dynamic_graph' has no attribute 'entity' WARNING: autodoc: failed to import module 'tutorial' from module 'dynamic_graph'; the following exception was raised: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/sphinx/ext/autodoc/importer.py", line 154, in import_module __import__(modname) File "/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/dynamic-graph-tutorial-1.2.0/src/dynamic_graph/tutorial/__init__.py", line 32, in dg.entity.updateEntityClasses(globals()) AttributeError: module 'dynamic_graph' has no attribute 'entity' WARNING: html_static_path entry '/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/dynamic-graph-tutorial-1.2.0/doc/sphinx/_static' does not exist => Compiling python files => Adding run-time search paths to pkg-config files => Registering installation for py37-dynamic-graph-tutorial-1.2.0 Added dynamic-graph-tutorial-1.2.0 to the requirements of py37-dynamic-graph-tutorial-1.2.0 Added dynamic-graph-v3-3.8.1 to the requirements of py37-dynamic-graph-tutorial-1.2.0 Added py37-dynamic-graph-v3-3.4.1 to the requirements of py37-dynamic-graph-tutorial-1.2.0 ===> Done install for py37-dynamic-graph-tutorial-1.2.0 ===> Building binary package for py37-dynamic-graph-tutorial-1.2.0 Creating package /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-19.04-x86_64/All/py37-dynamic-graph-tutorial-1.2.0 => Linking package in /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Ubuntu-19.04-x86_64/pub => Updating debian binary packages dpkg-deb: building package 'robotpkg-py37-dynamic-graph-tutorial' in '/local/robotpkg/var/tmp/robotpkg/wip/py-dynamic-graph-tutorial/work/pkg2deb.21240/robotpkg-py37-dynamic-graph-tutorial_1.2.0_amd64.deb'. updated /opt/robotpkg/var/lib/robotpkg/wip/packages/debian/pub/dists/disco/robotpkg/binary-amd64/robotpkg-py37-dynamic-graph-tutorial_1.2.0_amd64.deb ===> Deinstalling for py37-dynamic-graph-tutorial Removing dependency dynamic-graph-tutorial-1.2.0 Removing dependency dynamic-graph-v3-3.8.1 Removing dependency py37-dynamic-graph-v3-3.4.1 Removing dependency robotpkg_delete: couldn't entirely delete package `dynamic-graph-tutorial-1.2.0' original MD5 checksum failed, not deleting: /opt/openrobots/share/doc/dynamic-graph-tutorial/sphinx-html/.doctrees/environment.pickle original MD5 checksum failed, not deleting: /opt/openrobots/share/doc/dynamic-graph-tutorial/sphinx-html/.doctrees/index.doctree Removed py37-dynamic-graph-tutorial-1.2.0 Removed digest-20080510 Removed tnftp-20130505~ssl