robotpkg/wip/py-curves bulk build results

Log for py27-curves-0.4.1 on Fedora-31-x86_64: configure.log (Back)

--- Environment --- EXPECT_TARGETS=fetch install package _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.9 pkg_install>=20110805.9 pkg_install>=20110805.9 _overrides_wip_curves_PKGREQD=curves>=0.3.3 curves>=0.3.3 curves>=0.3.3 PKG_CONFIG_PATH=/opt/openrobots/lib/pkgconfig BULKBASE=/opt/openrobots PYTHON27_LIB=/usr/lib64/libpython2.7.so PYTHON_LIB=/usr/lib64/libpython2.7.so _overrides_math_py_eigenpy_PKGREQD=py27-eigenpy>=1.6.12 py27-eigenpy>=1.6.12 py27-eigenpy>=1.6.12 CPP=/usr/bin/gcc -E TAR=/usr/bin/tar LC_MONETARY=C _override_vars_pkgtools_tnftp=PKGREQD PKGREQD OPSYS=Fedora _override_vars_math_eigen3=PKGREQD PKGREQD PKGREQD ECHO_N=echo -n PWD=/local/robotpkg/var/lib/robotpkg/wip/py-curves DIGEST=/opt/openrobots/sbin/robotpkg_digest PYTHON_INCLUDE_CONFIG=/usr/include/python2.7/ _override_vars_devel_boost_libs=PKGREQD PKGREQD PKGREQD LOCALBASE=/opt/openrobots MAKEOVERRIDES=PKGREQD.cmdline=py27-curves-0.4.1~!doc RECURSIVE_PKGPATH=wip/py-curves\ tag=Fedora-31-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package CXX=/usr/bin/g++ _overrides_wip_py_curves_PKGREQD=py27-curves-0.4.1~!doc _override_vars_math_pinocchio=PKGREQD PKGREQD PKGREQD PAX=/usr/bin/pax CXXCPP=/usr/bin/g++ -E _overrides_devel_tinyxml_PKGREQD=tinyxml>=2 tinyxml>=2 tinyxml>=2 MACHINE_PLATFORM=Fedora-31-x86_64 CMAKE=/usr/bin/cmake LANG=C OWNER_GID=robots _override_vars_wip_curves=PKGREQD PKGREQD PKGREQD BULK_LOGDIR=/local/robotpkg/var/log/bulk MACHINE_KERNEL=Linux-5.5.15-200.fc31.x86_64-x86_64 ROBOTPKG_TRUSTED_ENV=robotpkg _overrides_math_eigen3_PKGREQD=eigen3>=3.0.0 eigen3>=3.0.0 eigen3>=3.0.0 ROBOTPKG_BASE=/local/robotpkg _override_vars_math_py_eigenpy=PKGREQD PKGREQD PKGREQD _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 _overrides_math_pinocchio_PKGREQD=pinocchio>=2.0.0<3.0.0 pinocchio>=2.0.0<3.0.0 pinocchio>=2.0.0<3.0.0 _override_vars_graphics_urdfdom=PKGREQD PKGREQD PKGREQD _ROBOTPKG_NOW=0414131537 PKG_DBDIR=/opt/openrobots/var/db/robotpkg _overrides_devel_boost_headers_PKGREQD=boost-headers>=1.34.1 boost-headers>=1.34.1 boost-headers>=1.34.1 PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig:/usr/share/pkgconfig RECURSIVE_PKGPATH=wip/py-curves GXX=/usr/bin/g++ OS_VERSION=31 MFLAGS=--no-print-directory GZIP_CMD=/usr/bin/gzip tag=Fedora-31-x86_64 ZCAT=/usr/bin/zcat MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=py27-curves-0.4.1~!doc RECURSIVE_PKGPATH=wip/py-curves\ tag=Fedora-31-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package _override_vars_pkgtools_pkg_config=PKGREQD PKGREQD PKGREQD PYTHONPATH=/opt/openrobots/lib/python2.7/site-packages _overrides_devel_boost_libs_PKGREQD=boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 PYTHON27=/usr/bin/python2.7 _override_vars_devel_tinyxml=PKGREQD PKGREQD PKGREQD _override_vars_pkgtools_digest=PKGREQD PKGREQD _override_vars_devel_boost_headers=PKGREQD PKGREQD PKGREQD _override_vars_archivers_pax=PKGREQD PKGREQD LOWER_OS_KERNEL=linux LOWER_OS_VERSION=31 PYTHON=/usr/bin/python2.7 _override_vars_wip_py_curves=PKGREQD PYTHON_INCLUDE=/usr/include/python2.7/ ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg SHLVL=4 GCC=/usr/bin/gcc _override_vars_math_py_pinocchio=PKGREQD PKGREQD PKGREQD MAKELEVEL=4 OWNER_UID=rbulk LC_MESSAGES=C rm= PYTHONDONTWRITEBYTECODE=1 _overrides_path_hpp_fcl_PKGREQD=hpp-fcl>=1.2.1 hpp-fcl>=1.2.1 hpp-fcl>=1.2.1 MAKECONF=/opt/robotpkg/etc/robotpkg-wip.conf hline="$bf======================================================================$rm" LC_CTYPE=C MACHINE_ARCH=x86_64 OS_KERNEL_VERSION=5.5.15-200.fc31.x86_64 PYTHON27_INCLUDE=/usr/include/python2.7/ LC_TIME=C TNFTP=/opt/openrobots/sbin/tnftp FC=false LOWER_OPSYS=fedora _overrides_pkgtools_pkg_config_PKGREQD=pkg-config>=0.22 pkg-config>=0.22 pkg-config>=0.22 LC_COLLATE=C LOWER_ARCH=x86_64 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin _overrides_archivers_pax_PKGREQD=pax pax NODENAME=hydra64-fedora31 CC=/usr/bin/gcc PKGTOOLS_VERSION=20110805.9 bf= _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20091122 tnftp>=20091122 _override_vars_path_hpp_fcl=PKGREQD PKGREQD PKGREQD _overrides_graphics_urdfdom_PKGREQD=urdfdom>=0.2.8 urdfdom>=0.2.8 urdfdom>=0.2.8 OS_KERNEL=Linux LC_NUMERIC=C OLDPWD=/local/robotpkg/var/lib/robotpkg/wip/py-curves PKG_CONFIG=/usr/bin/pkg-config _overrides_math_py_pinocchio_PKGREQD=py27-pinocchio>=2.0.0<3.0.0 py27-pinocchio>=2.0.0<3.0.0 py27-pinocchio>=2.0.0<3.0.0 _=/usr/bin/env --- Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/wip/py-curves/work/curves-0.4.1 && cd /local/robotpkg/var/tmp/robotpkg/wip/py-curves/work/curves-0.4.1 && /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/py-curves/work PATH='/opt/openrobots/bin:/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin' LD_LIBRARY_PATH='' /usr/bin/cmake -DINSTALL_PYTHON_INTERFACE_ONLY=ON -DINSTALL_DOCUMENTATION=OFF -DINSTALL_GENERATED_HEADERS=OFF -DINSTALL_PKG_CONFIG_FILE=OFF -DCMAKE_INSTALL_LIBDIR=lib -DPYTHON_STANDARD_LAYOUT=ON -DBoost_NO_BOOST_CMAKE=ON -DPYTHON_EXECUTABLE=/usr/bin/python2.7 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ -DPYTHON_LIBRARY=/usr/lib64/libpython2.7.so -DPYTHON_SITELIB=lib/python2.7/site-packages -DBUILD_PYTHON_INTERFACE=ON -DPYTHON_EXECUTABLE=/usr/bin/python2.7 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ -DPYTHON_INCLUDE_DIR2=/usr/include/python2.7/ -DPYTHON_LIBRARY=/usr/lib64/libpython2.7.so '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=' '-DBOOST_INCLUDEDIR=/usr/include' '-DBOOST_LIBRARYDIR=/usr/lib' --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .; Not searching for unused variables given on the command line. -- Found PkgConfig: /usr/bin/pkg-config (found version "1.6.3") -- The CXX compiler identification is GNU 9.3.1 -- Check for working CXX compiler: /usr/bin/g++ -- Check for working CXX compiler: /usr/bin/g++ - works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done -- Performing Test R-pedantic -- Performing Test R-pedantic - Success -- Performing Test R-Wno-long-long -- Performing Test R-Wno-long-long - Success -- Performing Test R-Wall -- Performing Test R-Wall - Success -- Performing Test R-Wextra -- Performing Test R-Wextra - Success -- Performing Test R-Wcast-align -- Performing Test R-Wcast-align - Success -- Performing Test R-Wcast-qual -- Performing Test R-Wcast-qual - Success -- Performing Test R-Wformat -- Performing Test R-Wformat - Success -- Performing Test R-Wwrite-strings -- Performing Test R-Wwrite-strings - Success -- Performing Test R-Wconversion -- Performing Test R-Wconversion - Success -- Found Doxygen: /usr/bin/doxygen (found version "1.8.15") found components: doxygen dot -- Found Eigen3: /usr/include/eigen3 (Required is at least version "2.91.0") -- eigen3 >= 3.0.5 is required. -- Checking for module 'eigen3>=3.0.5' -- Found eigen3, version 3.3.7 -- Pkg-config module eigen3 v3.3.7 has been detected with success. -- urdfdom >= 0.2.0 is required. -- Checking for module 'urdfdom>=0.2.0' -- Found urdfdom, version 1.0.0 -- Pkg-config module urdfdom v1.0.0 has been detected with success. -- hpp-fcl >= 1.0.0 is required. -- Checking for module 'hpp-fcl>=1.0.0' -- Found hpp-fcl, version 1.4.2 -- Pkg-config module hpp-fcl v1.4.2 has been detected with success. -- Found Python2: /usr/bin/python2.7 (found version "2.7.17") found components: Interpreter Development -- PythonLibraryDirs: /usr/lib64/python2.7/config -- PythonLibVersionString: 2.7.17 -- Python site lib: lib/python2.7/site-packages -- eigenpy searched on /opt/openrobots/lib, found? /opt/openrobots/lib/libeigenpy.so -- boost_python27 searched on /opt/openrobots/lib, found? /usr/lib64/libboost_python27.so -- eigen3 >= 3.0.5 is required. -- Checking for module 'eigen3>=3.0.5' -- Found eigen3, version 3.3.7 -- Pkg-config module eigen3 v3.3.7 has been detected with success. -- Found Boost: /usr/include (found version "1.69.0") CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:164 (message): Could NOT find Boost (missing: python) (found version "1.69.0") Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake/Modules/FindBoost.cmake:2145 (find_package_handle_standard_args) cmake/boost.cmake:135 (FIND_PACKAGE) -- Configuring incomplete, errors occurred! CMakeLists.txt:50 (SEARCH_FOR_BOOST) See also "/local/robotpkg/var/tmp/robotpkg/wip/py-curves/work/curves-0.4.1/CMakeFiles/CMakeOutput.log".