robotpkg/wip/py-curves bulk build results

Log for py27-curves-0.4.1 on Fedora-31-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for py27-curves-0.4.1 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for py27-curves-0.4.1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for py27-curves-0.4.1 ===> Installing full dependencies for py27-curves-0.4.1 => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-31-x86_64/All/curves-0.4.1.tgz => Dependency digest-20080510 already installed => Dependency hpp-fcl-1.4.2~doc already installed => Dependency pinocchio-2.3.1 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/py27-eigenpy-2.3.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/py27-pinocchio-2.3.1.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for py27-curves-0.4.1 => Building with no option. ===> Checking alternatives for py27-curves-0.4.1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 ===> Checking dependencies for py27-curves-0.4.1 => Required system package boost-headers>=1.34.1: boost-headers-1.69 found => Required system package boostlib-python>=1.34.1: boost-libs-1.69.0 found => Required system package cmake>=3.1.0: cmake-3.17.0 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.6.3 found => Required system package py27-numpy>=1: py27-numpy-1.16.4 found => Required system package python27>=2.7<2.8: python27-2.7.17 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required system package urdfdom>=0.2.8: urdfdom-1.0.0 found => Required robotpkg package curves>=0.3.3: curves-0.4.1 found => Required robotpkg package hpp-fcl>=1.2.1: hpp-fcl-1.4.2~doc found => Required robotpkg package pinocchio>=2.0.0<3.0.0: pinocchio-2.3.1 found => Required robotpkg package py27-eigenpy>=1.6.12: py27-eigenpy-2.3.0 found => Required robotpkg package py27-pinocchio>=2.0.0<3.0.0: py27-pinocchio-2.3.1 found ===> Done depends for py27-curves-0.4.1 ===> Extracting for py27-curves-0.4.1 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for py27-curves-0.4.1 CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:164 (message): Could NOT find Boost (missing: python) (found version "1.69.0") Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake/Modules/FindBoost.cmake:2145 (find_package_handle_standard_args) cmake/boost.cmake:135 (FIND_PACKAGE) CMakeLists.txt:50 (SEARCH_FOR_BOOST) An unexpected error occured. The last 10 log lines are shown below. | Could NOT find Boost (missing: python) (found version "1.69.0") | Call Stack (most recent call first): | /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE) | /usr/share/cmake/Modules/FindBoost.cmake:2145 (find_package_handle_standard_args) | cmake/boost.cmake:135 (FIND_PACKAGE) | -- Configuring incomplete, errors occurred! | CMakeLists.txt:50 (SEARCH_FOR_BOOST) | | | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-curves/work/curves-0.4.1/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-curves/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking py27-curves-0.4.1 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for py27-curves Removing dependency hpp-fcl-1.4.2~doc Removing dependency pinocchio-2.3.1 Removing dependency Removed curves-0.4.1 Removed digest-20080510 Removing dependency libccd-2.0 Removing dependency octomap-1.9.0 Removing dependency Removing dependency py27-hpp-fcl-1.4.2 Removing dependency pinocchio-2.3.1 Removing dependency py27-pinocchio-2.3.1 Removed hpp-fcl-1.4.2~doc Removed tnftp-20130505~ssl