robotpkg/wip/prf-teleop-tools bulk build results

Log for prf-teleop-tools-0.3.2 on CentOS-7-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for prf-teleop-tools-0.3.2 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for prf-teleop-tools-0.3.2 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gzip: gzip-1.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for prf-teleop-tools-0.3.2 ===> Installing full dependencies for prf-teleop-tools-0.3.2 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/CentOS-7-x86_64/All/pal-hardware-interfaces-0.0.3.tgz robotpkg_add: Conflicting PLIST with py27-ros-catkin-0.7.16: .rosinstall robotpkg_add: Can't install dependency ros-catkin>=0.6<0.7 robotpkg_add: Can't install dependency prf-ros-control>=0.2 robotpkg_add: 1 package addition failed To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/CentOS-7-x86_64/All/prf-ros-control-0.2.6r3.tgz robotpkg_add: Conflicting PLIST with py27-ros-catkin-0.7.16: .rosinstall robotpkg_add: Can't install dependency ros-catkin>=0.6<0.7 robotpkg_add: 1 package addition failed To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/py27-catkin-pkg-0.4.8.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-actionlib-1.11.15.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Dependency py27-ros-catkin-0.7.16 already installed => Dependency ros-class-loader-0.4.1 already installed => Dependency ros-comm-1.14.3r2 already installed => Dependency ros-common-msgs-1.12.6 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-control-msgs-1.4.0.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-control-toolbox-1.16.0.tgz => Required system package ros-four-wheel-steering-msgs>=1: MISSING => Dependency ros-genmsg-0.5.11 already installed => Dependency ros-genpy-0.6.7 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-geometry-1.12.0.tgz => Dependency ros-message-generation-0.4.0 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-pluginlib-1.12.1 already installed => Dependency ros-ros-1.14.4r1 already installed => Dependency ros-std-msgs-0.5.11 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-urdf-1.13.1.tgz => Required system package ros-urdf-geometry-parser>=0.0.1: MISSING => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/CentOS-7-x86_64/All/ros-xacro-1.13.2.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for prf-teleop-tools-0.3.2: ERROR: ERROR: ros-four-wheel-steering-msgs>=1 ERROR: ros-urdf-geometry-parser>=0.0.1 ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/prf-teleop-tools/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Deinstalling for prf-teleop-tools Removed digest-20080510 Removing dependency py27-rosdistro-0.3.5 Removing dependency py27-rosdep-0.10.30 Removing dependency py27-ros-catkin-0.7.16 Removing dependency ros-lint-0.11.2 Removing dependency ros-xacro-1.13.2 Removing dependency ros-orocos-kinematics-dynamics-1.4.0 Removing dependency ros-angles-1.9.11 Removing dependency ros-rospack-2.5.1 Removing dependency ros-roscpp-core-0.6.11 Removing dependency ros-genmsg-0.5.11 Removing dependency ros-ros-1.14.4r1 Removing dependency ros-console-1.13.7 Removing dependency ros-gennodejs-2.0.1 Removing dependency ros-genlisp-0.4.16 Removing dependency ros-geneus-2.2.6 Removing dependency ros-gencpp-0.6.0 Removing dependency ros-genpy-0.6.7 Removing dependency ros-message-runtime-0.4.12 Removing dependency ros-message-generation-0.4.0 Removing dependency ros-std-msgs-0.5.11 Removing dependency ros-common-msgs-1.12.6 Removing dependency ros-control-msgs-1.4.0 Removing dependency ros-comm-msgs-1.11.2r1 Removing dependency ros-class-loader-0.4.1 Removing dependency ros-pluginlib-1.12.1 Removing dependency ros-comm-1.14.3r2 Removing dependency ros-console-bridge-0.5.2 Removing dependency ros-urdf-1.13.1 Removing dependency ros-realtime-tools-1.11.0 Removing dependency ros-dynamic-reconfigure-1.5.49 Removing dependency ros-control-toolbox-1.16.0 Removing dependency ros-actionlib-1.11.15 Removing dependency ros-geometry2-0.6.5 Removing dependency ros-geometry-1.12.0 Removed py27-catkin-pkg-0.4.8 Removed tnftp-20130505~ssl