robotpkg/wip/prf-gazebo-ros-pkgs bulk build results

Log for prf-gazebo-ros-pkgs-2.6.7r4 on Fedora-27-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for prf-gazebo-ros-pkgs-2.6.7r4 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-27-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for prf-gazebo-ros-pkgs-2.6.7r4 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gzip: gzip-1.8 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for prf-gazebo-ros-pkgs-2.6.7r4 ===> Installing full dependencies for prf-gazebo-ros-pkgs-2.6.7r4 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-27-x86_64/All/prf-ros-control-0.2.6r3.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Dependency ros-actionlib-1.11.13 already installed => Dependency ros-catkin-0.7.14 already installed => Dependency ros-class-loader-0.4.1 already installed => Dependency ros-comm-1.14.3 already installed => Dependency ros-common-msgs-1.12.6 already installed => Dependency ros-control-toolbox-1.16.0 already installed => Dependency ros-genmsg-0.5.11 already installed => Dependency ros-geometry-1.12.0 already installed => Dependency ros-message-generation-0.4.0 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-pluginlib-1.12.1 already installed => Dependency ros-ros-1.14.4 already installed => Dependency ros-std-msgs-0.5.11 already installed => Dependency ros-urdf-1.13.1 already installed => Dependency tnftp-20130505~ssl already installed ===> Checking build options for prf-gazebo-ros-pkgs-2.6.7r4 => Building with no option. ===> Checking alternatives for prf-gazebo-ros-pkgs-2.6.7r4 => Use the GNU C++ compiler: c++-compiler provided by g++>=4.8 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros melodic: ros>=groovy ros>=hydro provided by ros-melodic ===> Checking dependencies for prf-gazebo-ros-pkgs-2.6.7r4 => Required system package boost-headers>=1.34.1: boost-headers-1.64 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.64.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.64.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.64.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.64.0 found => Required system package cmake>=2.8.3: cmake-3.11.2 found => Required system package eigen3>=3.0.0: eigen3-3.3.5 found => Required system package g++>=4.8: g++-7 found => Required system package gazebo>=1: gazebo-8.1.1 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libogre>=1.0: libogre-1.9.0 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.3.12 found => Required system package py27-empy>=3: py27-empy-3.3.2 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.15 found => Required robotpkg package prf-ros-control>=0.2: prf-ros-control-0.2.6r3 found => Required robotpkg package ros-actionlib>=1.11<1.12: ros-actionlib-1.11.13 found => Required robotpkg package ros-catkin>=0.7<0.8: ros-catkin-0.7.14 found => Required robotpkg package ros-class-loader>=0.4<0.5: ros-class-loader-0.4.1 found => Required robotpkg package ros-comm>=1.13<1.15: ros-comm-1.14.3 found => Required robotpkg package ros-common-msgs>=1.12<1.13: ros-common-msgs-1.12.6 found => Required robotpkg package ros-control-toolbox>=1.16<1.17: ros-control-toolbox-1.16.0 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.11 found => Required robotpkg package ros-geometry>=1.12<1.13: ros-geometry-1.12.0 found => Required robotpkg package ros-message-generation>=0.4<0.5: ros-message-generation-0.4.0 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-pluginlib>=1.12<1.13: ros-pluginlib-1.12.1 found => Required robotpkg package ros-ros>=1.14<1.15: ros-ros-1.14.4 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.11 found => Required robotpkg package ros-urdf>=1.13<1.14: ros-urdf-1.13.1 found ===> Done depends for prf-gazebo-ros-pkgs-2.6.7r4 ===> Extracting for prf-gazebo-ros-pkgs-2.6.7r4 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for prf-gazebo-ros-pkgs-2.6.7r4 CMake Warning (dev) at /usr/share/cmake/Modules/FindBoost.cmake:954 (if): Policy CMP0054 is not set: Only interpret if() arguments as variables or keywords when unquoted. Run "cmake --help-policy CMP0054" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Quoted variables like "chrono" will no longer be dereferenced when the policy is set to NEW. Since the policy is not set the OLD behavior will be used. Call Stack (most recent call first): /usr/share/cmake/Modules/FindBoost.cmake:1618 (_Boost_MISSING_DEPENDENCIES) /usr/share/cmake/Modules/FindOGRE.cmake:318 (find_package) /usr/lib64/cmake/gazebo/gazebo-config.cmake:162 (find_package) gazebo_dev/cmake/gazebo_dev-extras.cmake:2 (find_package) /local/robotpkg/var/tmp/robotpkg/wip/prf-gazebo-ros-pkgs/work/stage/share/gazebo_dev/cmake/gazebo_devConfig.cmake:197 (include) /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:76 (find_package) gazebo_ros/CMakeLists.txt:4 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. CMake Error at /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:83 (find_package): Could not find a package configuration file provided by "cmake_modules" with any of the following names: cmake_modulesConfig.cmake cmake_modules-config.cmake Add the installation prefix of "cmake_modules" to CMAKE_PREFIX_PATH or set "cmake_modules_DIR" to a directory containing one of the above files. If "cmake_modules" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): gazebo_ros/CMakeLists.txt:4 (find_package) An unexpected error occured. The last 10 log lines are shown below. | "cmake_modules_DIR" to a directory containing one of the above files. If | "cmake_modules" provides a separate development package or SDK, be sure it | has been installed. | Call Stack (most recent call first): | gazebo_ros/CMakeLists.txt:4 (find_package) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/prf-gazebo-ros-pkgs/work/gazebo_ros_pkgs-2.6.7/build/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/prf-gazebo-ros-pkgs/work/gazebo_ros_pkgs-2.6.7/build/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/prf-gazebo-ros-pkgs/work/configure.log make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: do-configure-cmake] Error 1 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: pkg-check-installed] Error 2 => Marking prf-gazebo-ros-pkgs-2.6.7r4 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for prf-gazebo-ros-pkgs Removed digest-20080510 Removing dependency py27-rospkg-1.1.7 Removing dependency ros-actionlib-1.11.13 Removing dependency ros-catkin-0.7.14 Removing dependency ros-class-loader-0.4.1 Removing dependency ros-comm-1.14.3 Removing dependency ros-common-msgs-1.12.6 Removing dependency ros-control-toolbox-1.16.0 Removing dependency ros-genmsg-0.5.11 Removing dependency ros-geometry-1.12.0 Removing dependency ros-message-generation-0.4.0 Removing dependency ros-message-runtime-0.4.12 Removing dependency ros-pluginlib-1.12.1 Removing dependency ros-resource-retriever-1.12.4 Removing dependency ros-ros-1.14.4 Removing dependency ros-rqt-0.5.0 Removing dependency ros-std-msgs-0.5.11 Removing dependency ros-urdf-1.13.1 Removing dependency Removed prf-ros-control-0.2.6r3 Removed tnftp-20130505~ssl