robotpkg/wip/pal-wsg-gripper bulk build results

Log for pal-wsg-gripper-0.0.9r1 on Debian-8-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for pal-wsg-gripper-0.0.9r1 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for pal-wsg-gripper-0.0.9r1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.18 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.8: pkgrepo2deb-1.8 found ===> Done bootstrap-depends for pal-wsg-gripper-0.0.9r1 ===> Installing full dependencies for pal-wsg-gripper-0.0.9r1 => Dependency digest-20080510 already installed => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/py27-catkin-pkg-0.4.8.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/py27-ros-catkin-0.7.16r1.tgz To use ros, the following environment variables must contain those values: ROS_MASTER_URI http://localhost:11311 ROS_PACKAGE_PATH /opt/openrobots/share PYTHONPATH /opt/openrobots/lib/python2.7/site-packages PATH /opt/openrobots/bin As an alternative to the above configuration, commands can be executed by using the `env.sh' wrapper. For instance, roscore can be started like so: /opt/openrobots/etc/ros/env.sh roscore In Bourne shell scripts, the following file can be sourced instead: /opt/openrobots/etc/ros/setup.sh => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/ros-comm-1.14.4.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/ros-common-msgs-1.12.6.tgz => Dependency ros-genmsg-0.5.11 already installed => Dependency ros-genpy-0.6.7 already installed => Dependency ros-message-generation-0.4.0 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.11 already installed => Dependency tnftp-20130505~ssl already installed ===> Checking build options for pal-wsg-gripper-0.0.9r1 => Building with no option. ===> Checking alternatives for pal-wsg-gripper-0.0.9r1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.9 provided by python27>=2.7<2.8 => Use ros melodic: ros>=groovy provided by ros-melodic ===> Checking dependencies for pal-wsg-gripper-0.0.9r1 => Required system package boost-headers>=1.34.1: boost-headers-1.55 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.55.0 found => Required system package cmake>=2.8.3: cmake-3.0.2 found => Required system package g++>=3: g++-4.9.2 found => Required system package gcc>=3: gcc-4.9.2 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.28 found => Required system package py27-empy>=3: py27-empy-3.3.2 found => Required system package py27-nose>=0.10: py27-nose-1.3.4 found => Required system package py27-pyparsing>=1: py27-pyparsing-2.0.3 found => Required system package python27>=2.7<2.8: python27-2.7.9 found => Required robotpkg package py27-catkin-pkg>=0.2: py27-catkin-pkg-0.4.8 found => Required robotpkg package py27-ros-catkin>=0.7<0.8: py27-ros-catkin-0.7.16r1 found => Required robotpkg package ros-comm>=1.13<1.15: ros-comm-1.14.4 found => Required robotpkg package ros-common-msgs>=1.12<1.13: ros-common-msgs-1.12.6 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.11 found => Required robotpkg package ros-genpy>=0.6<0.7: ros-genpy-0.6.7 found => Required robotpkg package ros-message-generation>=0.4<0.5: ros-message-generation-0.4.0 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.11 found ===> Done depends for pal-wsg-gripper-0.0.9r1 ===> Extracting for pal-wsg-gripper-0.0.9r1 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for pal-wsg-gripper-0.0.9r1 CMake Warning at /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:76 (find_package): Could not find a package configuration file provided by "xacro" with any of the following names: xacroConfig.cmake xacro-config.cmake Add the installation prefix of "xacro" to CMAKE_PREFIX_PATH or set "xacro_DIR" to a directory containing one of the above files. If "xacro" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): pal_wsg_gripper_description/CMakeLists.txt:4 (find_package) CMake Error at /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:83 (find_package): Could not find a package configuration file provided by "xacro" with any of the following names: xacroConfig.cmake xacro-config.cmake Add the installation prefix of "xacro" to CMAKE_PREFIX_PATH or set "xacro_DIR" to a directory containing one of the above files. If "xacro" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): pal_wsg_gripper_description/CMakeLists.txt:4 (find_package) An unexpected error occured. The last 10 log lines are shown below. | provides a separate development package or SDK, be sure it has been | installed. | Call Stack (most recent call first): /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed | pal_wsg_gripper_description/CMakeLists.txt:4 (find_package) | | /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed | -- Could not find the required component 'xacro'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found. | -- Configuring incomplete, errors occurred! => Marking pal-wsg-gripper-0.0.9r1 as broken | See also "/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Deinstalling for pal-wsg-gripper Removed digest-20080510 Removing dependency py27-rosdistro-0.3.5 Removing dependency py27-rosdep-0.10.30 Removing dependency py27-ros-catkin-0.7.16r1 Removing dependency ros-rospack-2.5.1 Removing dependency ros-roscpp-core-0.6.11 Removing dependency ros-genmsg-0.5.11 Removing dependency ros-ros-1.14.4r1 Removing dependency ros-console-1.13.7 Removing dependency ros-gennodejs-2.0.1 Removing dependency ros-genlisp-0.4.16 Removing dependency ros-geneus-2.2.6 Removing dependency ros-gencpp-0.6.0 Removing dependency ros-genpy-0.6.7 Removing dependency ros-message-runtime-0.4.12 Removing dependency ros-message-generation-0.4.0 Removing dependency ros-std-msgs-0.5.11 Removing dependency ros-common-msgs-1.12.6 Removing dependency ros-comm-msgs-1.11.2r1 Removing dependency ros-class-loader-0.4.1 Removing dependency ros-pluginlib-1.12.1 Removing dependency ros-comm-1.14.4 Removed py27-catkin-pkg-0.4.8 Removed tnftp-20130505~ssl