robotpkg/wip/pal-wsg-gripper bulk build results

Log for pal-wsg-gripper-0.0.9r1 on CentOS-7-x86_64: configure.log (Back)

--- Environment --- _ROBOTPKG_NOW=0929185928 _override_vars_middleware_ros_genmsg=PKGREQD PKGREQD PKGREQD CMAKE=/usr/bin/cmake CXXCPP=/usr/bin/g++ -E LOCALBASE=/opt/openrobots LC_MONETARY=C _override_vars_wip_pal_wsg_gripper=PKGREQD _overrides_sysutils_py_catkin_pkg_PKGREQD=py27-catkin-pkg>=0.2 py27-catkin-pkg>=0.2 py27-catkin-pkg>=0.2 LOWER_OS_VERSION=7 GZIP_CMD=/usr/bin/gzip ROBOTPKG_BASE=/local/robotpkg _overrides_wip_pal_wsg_gripper_PKGREQD=pal-wsg-gripper-0.0.9r1~!doc OS_KERNEL_VERSION=3.10.0-862.3.3.el7.x86_64 MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=pal-wsg-gripper-0.0.9r1~!doc BULKBASE=/opt/openrobots BULK_LOGDIR=/local/robotpkg/var/log/bulk tag=CentOS-7-x86_64 RECURSIVE_PKGPATH=wip/pal-wsg-gripper\ LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package LC_NUMERIC=C OWNER_UID=rbulk PYTHON27=/usr/bin/python2.7 MACHINE_PLATFORM=CentOS-7-x86_64 _overrides_pkgtools_pkg_config_PKGREQD=pkg-config>=0.22 pkg-config>=0.22 pkg-config>=0.22 MAKEOVERRIDES=PKGREQD.cmdline=pal-wsg-gripper-0.0.9r1~!doc BULKBASE=/opt/openrobots BULK_LOGDIR=/local/robotpkg/var/log/bulk tag=CentOS-7-x86_64 RECURSIVE_PKGPATH=wip/pal-wsg-gripper\ LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package _overrides_lang_ros_genpy_PKGREQD=ros-genpy>=0.6<0.7 ros-genpy>=0.6<0.7 ros-genpy>=0.6<0.7 _overrides_archivers_pax_PKGREQD=pax pax OS_KERNEL=Linux _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 BULKBASE=/opt/openrobots _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20130505~ssl tnftp>=20130505~ssl TAR=/usr/bin/tar LOWER_OPSYS=centos hline="$bf======================================================================$rm" MAKELEVEL=4 OWNER_GID=robots ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg MFLAGS=- --no-print-directory _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD CPP=/usr/bin/gcc -E rm= TNFTP=/opt/openrobots/sbin/tnftp MACHINE_KERNEL=Linux-3.10.0-862.3.3.el7.x86_64-x86_64 _override_vars_pkgtools_tnftp=PKGREQD PKGREQD PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin _overrides_lang_ros_message_runtime_PKGREQD=ros-message-runtime>=0.4<0.5 ros-message-runtime>=0.4<0.5 ros-message-runtime>=0.4<0.5 LC_MESSAGES=C _overrides_interfaces_ros_common_msgs_PKGREQD=ros-common-msgs>=1.12<1.13 ros-common-msgs>=1.12<1.13 ros-common-msgs>=1.12<1.13 MAKECONF=/opt/robotpkg/etc/robotpkg-wip.conf PKG_DBDIR=/opt/openrobots/var/db/robotpkg tag=CentOS-7-x86_64 bf= LC_COLLATE=C PWD=/local/robotpkg/var/lib/robotpkg/wip/pal-wsg-gripper PYTHON27_INCLUDE=/usr/include/python2.7/ PYTHON_LIB=/usr/lib64/libpython2.7.so _override_vars_lang_ros_message_runtime=PKGREQD PKGREQD PKGREQD LANG=C PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig:/usr/share/pkgconfig _override_vars_devel_boost_libs=PKGREQD PKGREQD PKGREQD _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.9 pkg_install>=20110805.9 pkg_install>=20110805.9 PYTHONDONTWRITEBYTECODE=1 _overrides_middleware_ros_genmsg_PKGREQD=ros-genmsg>=0.5<0.6 ros-genmsg>=0.5<0.6 ros-genmsg>=0.5<0.6 RECURSIVE_PKGPATH=wip/pal-wsg-gripper _overrides_lang_ros_message_generation_PKGREQD=ros-message-generation>=0.4<0.5 ros-message-generation>=0.4<0.5 ros-message-generation>=0.4<0.5 CXX=/usr/bin/g++ OS_VERSION=7 _overrides_middleware_ros_comm_PKGREQD=ros-comm>=1.13<1.15 ros-comm>=1.13<1.15 ros-comm>=1.13<1.15 _overrides_interfaces_ros_std_msgs_PKGREQD=ros-std-msgs>=0.5 ros-std-msgs>=0.5 ros-std-msgs>=0.5 SHLVL=4 _override_vars_interfaces_ros_std_msgs=PKGREQD PKGREQD PKGREQD _overrides_devel_boost_headers_PKGREQD=boost-headers>=1.34.1 boost-headers>=1.34.1 boost-headers>=1.34.1 ROBOTPKG_TRUSTED_ENV=robotpkg PKGTOOLS_VERSION=20110805.9 _override_vars_interfaces_ros_common_msgs=PKGREQD PKGREQD PKGREQD _override_vars_devel_ros_catkin=PKGREQD PKGREQD PKGREQD EXPECT_TARGETS=fetch install package LOWER_OS_KERNEL=linux PYTHON_INCLUDE_CONFIG=/usr/include/python2.7/ FC=false GCC=/usr/bin/gcc LOWER_ARCH=x86_64 MACHINE_ARCH=x86_64 _overrides_devel_ros_catkin_PKGREQD=py27-ros-catkin>=0.7<0.8 py27-ros-catkin>=0.7<0.8 py27-ros-catkin>=0.7<0.8 ROS_LANG_DISABLE=geneus:gennodejs PYTHONPATH=/opt/openrobots/lib/python2.7/site-packages _override_vars_pkgtools_pkg_config=PKGREQD PKGREQD PKGREQD _override_vars_devel_boost_headers=PKGREQD PKGREQD PKGREQD NOSETESTS=/usr/bin/nosetests-2.7 ECHO_N=echo -n _override_vars_archivers_pax=PKGREQD PKGREQD _override_vars_middleware_ros_comm=PKGREQD PKGREQD PKGREQD LC_CTYPE=C ZCAT=/usr/bin/zcat PKG_CONFIG_PATH=/opt/openrobots/lib/pkgconfig PYTHON27_LIB=/usr/lib64/libpython2.7.so PKG_CONFIG=/usr/bin/pkg-config _override_vars_pkgtools_digest=PKGREQD PKGREQD DIGEST=/opt/openrobots/sbin/robotpkg_digest _override_vars_sysutils_py_catkin_pkg=PKGREQD PKGREQD PKGREQD CC=/usr/bin/gcc _overrides_devel_boost_libs_PKGREQD=boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 PAX=/usr/bin/pax OPSYS=CentOS BULK_LOGDIR=/local/robotpkg/var/log/bulk _override_vars_lang_ros_genpy=PKGREQD PKGREQD PKGREQD NODENAME=fluffy64-centos7 LC_TIME=C PYTHON=/usr/bin/python2.7 PYTHON_INCLUDE=/usr/include/python2.7/ _override_vars_lang_ros_message_generation=PKGREQD PKGREQD PKGREQD GXX=/usr/bin/g++ _=/usr/bin/env --- Running set -e; \ /bin/mkdir -p /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build; \ cd /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build && cd ..; \ test ! -h CMakeLists.txt || rm -f CMakeLists.txt; \ /opt/openrobots/bin/catkin_init_workspace Creating symlink "/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/CMakeLists.txt" pointing to "/opt/openrobots/share/catkin/cmake/toplevel.cmake" Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9 && cd /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build && /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work PATH='/opt/openrobots/bin:/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin' LD_LIBRARY_PATH='' /usr/bin/cmake '-DBOOST_INCLUDEDIR=/usr/include' '-DBOOST_LIBRARYDIR=/usr/lib' -DPYTHON_EXECUTABLE=/usr/bin/python2.7 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ -DPYTHON_INCLUDE_DIR2=/usr/include/python2.7/ -DPYTHON_LIBRARY=/usr/lib64/libpython2.7.so '-Dcatkin_DIR=/opt/openrobots/share/catkin/cmake/' '-Dgenmsg_DIR=/opt/openrobots/share/genmsg/cmake/' '-Dmessage_generation_DIR=/opt/openrobots/share/message_generation/cmake/' '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=/opt/openrobots' -DCATKIN_DEVEL_PREFIX=/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/stage -DNOSETESTS=/usr/bin/nosetests-2.7 -DGTEST_ROOT=/usr -DCATKIN_BUILD_BINARY_PACKAGE=1 -DSETUPTOOLS_DEB_LAYOUT=OFF --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man ..; Not searching for unused variables given on the command line. -- The C compiler identification is GNU 4.8.5 -- The CXX compiler identification is GNU 4.8.5 -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working CXX compiler: /usr/bin/g++ -- Check for working CXX compiler: /usr/bin/g++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Using CATKIN_DEVEL_PREFIX: /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/stage -- Using CMAKE_PREFIX_PATH: /opt/openrobots -- This workspace overlays: /opt/openrobots -- Found PythonInterp: /usr/bin/python2.7 (found version "2.7.5") -- Using PYTHON_EXECUTABLE: /usr/bin/python2.7 -- Using default Python package layout -- Found PY_em: /usr/lib/python2.7/site-packages/em.pyc -- Using empy: /usr/lib/python2.7/site-packages/em.pyc -- Using CATKIN_ENABLE_TESTING: ON -- Skip enable_testing() when building binary package -- Using CATKIN_TEST_RESULTS_DIR: /local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build/test_results -- Found gtest: gtests will be built -- Using Python nosetests: /usr/bin/nosetests-2.7 -- catkin 0.7.16 -- BUILD_SHARED_LIBS is on -- BUILD_SHARED_LIBS is on -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- ~~ traversing 5 packages in topological order: -- ~~ - pal_wsg_gripper -- ~~ - pal_wsg_gripper_controller_configuration -- ~~ - pal_wsg_gripper_controller_configuration_gazebo -- ~~ - pal_wsg_gripper_description -- ~~ - pal_wsg_gripper_gazebo -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- +++ processing catkin package: 'pal_wsg_gripper' -- ==> add_subdirectory(pal_wsg_gripper) -- +++ processing catkin package: 'pal_wsg_gripper_controller_configuration' -- ==> add_subdirectory(pal_wsg_gripper_controller_configuration) -- +++ processing catkin package: 'pal_wsg_gripper_controller_configuration_gazebo' -- ==> add_subdirectory(pal_wsg_gripper_controller_configuration_gazebo) CMake Warning at /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:76 (find_package): Could not find a package configuration file provided by "xacro" with any of the following names: xacroConfig.cmake xacro-config.cmake Add the installation prefix of "xacro" to CMAKE_PREFIX_PATH or set "xacro_DIR" to a directory containing one of the above files. If "xacro" provides a separate development package or SDK, be sure it has been -- +++ processing catkin package: 'pal_wsg_gripper_description' -- ==> add_subdirectory(pal_wsg_gripper_description) installed. Call Stack (most recent call first): pal_wsg_gripper_description/CMakeLists.txt:4 (find_package) CMake Error at /opt/openrobots/share/catkin/cmake/catkinConfig.cmake:83 (find_package): -- Could not find the required component 'xacro'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found. -- Configuring incomplete, errors occurred! See also "/local/robotpkg/var/tmp/robotpkg/wip/pal-wsg-gripper/work/pal_wsg_gripper-0.0.9/build/CMakeFiles/CMakeOutput.log". Could not find a package configuration file provided by "xacro" with any of the following names: xacroConfig.cmake xacro-config.cmake Add the installation prefix of "xacro" to CMAKE_PREFIX_PATH or set "xacro_DIR" to a directory containing one of the above files. If "xacro" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): pal_wsg_gripper_description/CMakeLists.txt:4 (find_package)