robotpkg/wip/libmove3d bulk build results

Log for libmove3d-3.22.0r1 on Fedora-27-x86_64: configure.log (Back)

--- Environment --- _override_vars_wip_libmove3d=PKGREQD tag=Fedora-27-x86_64 LC_MONETARY=C LOWER_OPSYS=fedora LANG=C OS_VERSION=27 PKGTOOLS_VERSION=20110805.9 _override_vars_archivers_pax=PKGREQD PKGREQD BULK_LOGDIR=/local/robotpkg/var/log/bulk GXX=/usr/bin/g++ OLDPWD=/local/robotpkg/var/lib/robotpkg/wip/dptu-genom3 TAR=/usr/bin/tar MACHINE_KERNEL=Linux-4.18.19-100.fc27.x86_64-x86_64 _override_vars_devel_boost_libs=PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD PKGREQD _override_vars_pkgtools_digest=PKGREQD PKGREQD OWNER_GID=robots TNFTP=/opt/openrobots/sbin/tnftp MAKECONF=/opt/robotpkg/etc/robotpkg-wip.conf _overrides_archivers_pax_PKGREQD=pax pax _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20091122 tnftp>=20091122 MFLAGS=--no-print-directory _overrides_devel_boost_headers_PKGREQD=boost-headers>=1.34.1 boost-headers>=1.34.1 boost-headers>=1.34.1 EXPECT_TARGETS=fetch install package CC=/usr/bin/gcc ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg LC_COLLATE=C _override_vars_devel_boost_headers=PKGREQD PKGREQD PKGREQD _overrides_wip_libmove3d_PKGREQD=libmove3d-3.22.0r1 ROBOTPKG_BASE=/local/robotpkg MACHINE_PLATFORM=Fedora-27-x86_64 PWD=/local/robotpkg/var/lib/robotpkg/wip/libmove3d LC_CTYPE=C NODENAME=fluffy64-fedora27 _override_vars_motion_softMotion_libs=PKGREQD PKGREQD PKGREQD OS_KERNEL_VERSION=4.18.19-100.fc27.x86_64 PKG_DBDIR=/opt/openrobots/var/db/robotpkg _overrides_motion_softMotion_libs_PKGREQD=softMotion-libs>=3.10 softMotion-libs>=3.10 softMotion-libs>=3.10 RECURSIVE_PKGPATH=wip/libmove3d LOWER_OS_KERNEL=linux PAX=/usr/bin/pax OPSYS=Fedora _ROBOTPKG_NOW=0812181629 _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 bf= LC_NUMERIC=C OWNER_UID=rbulk _override_vars_pkgtools_tnftp=PKGREQD PKGREQD FC=false MACHINE_ARCH=x86_64 ECHO_N=echo -n BULKBASE=/opt/openrobots hline="$bf======================================================================$rm" _override_vars_math_gbM=PKGREQD PKGREQD PKGREQD _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD CXX=/usr/bin/g++ LOCALBASE=/opt/openrobots MAKEOVERRIDES=PKGREQD.cmdline=libmove3d-3.22.0r1 RECURSIVE_PKGPATH=wip/libmove3d\ tag=Fedora-27-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package LC_MESSAGES=C _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.9 pkg_install>=20110805.9 pkg_install>=20110805.9 GZIP_CMD=/usr/bin/gzip MAKELEVEL=4 rm= SHLVL=4 LOWER_ARCH=x86_64 ZCAT=/usr/bin/zcat DIGEST=/opt/openrobots/sbin/robotpkg_digest CMAKE=/usr/bin/cmake _overrides_devel_boost_libs_PKGREQD=boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 boost-libs>=1.34.1 CXXCPP=/usr/bin/g++ -E LOWER_OS_VERSION=27 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin ROBOTPKG_TRUSTED_ENV=robotpkg GCC=/usr/bin/gcc MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=libmove3d-3.22.0r1 RECURSIVE_PKGPATH=wip/libmove3d\ tag=Fedora-27-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package OS_KERNEL=Linux CPP=/usr/bin/gcc -E _overrides_math_gbM_PKGREQD=gbM>=0.9 gbM>=0.9 gbM>=0.9 LC_TIME=C _=/usr/bin/env --- Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0 && cd /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0 && /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work PATH='/opt/openrobots/bin:/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin' LD_LIBRARY_PATH='' /usr/bin/cmake -DGENERATE_VIEWER_LIB=ON -DGLIBCONFIG_INCLUDE_DIR=/usr/lib64/glib-2.0/include/ -DGLIB_INCLUDE_DIR=/usr/include/glib-2.0/ -DBOOST_INCLUDEDIR=/usr/include -DBOOST_LIBDIR=/usr/include '-DBOOST_INCLUDEDIR=/usr/include' '-DBOOST_LIBRARYDIR=/usr/lib' '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=' --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .; Not searching for unused variables given on the command line. -- The C compiler identification is GNU 7.3.1 -- The CXX compiler identification is GNU 7.3.1 -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/g++ -- Check for working CXX compiler: /usr/bin/g++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done test git post-update -- Current project version is -- Looking for Q_WS_X11 -- Looking for Q_WS_X11 - found -- Looking for Q_WS_WIN -- Looking for Q_WS_WIN - not found -- Looking for Q_WS_QWS -- Looking for Q_WS_QWS - not found -- Looking for Q_WS_MAC -- Looking for Q_WS_MAC - not found -- Found Qt4: /usr/bin/qmake-qt4 (found version "4.8.7") I've found Qt4 libraries. I will compile libmove3d with it. Enabled GENERATE_LIBMOVE3D dependency: MOVE3D_ROBOTICS Enabled GENERATE_LIBMOVE3D dependency: MOVE3D_CORE Enabled MOVE3D_ROBOTICS dependency: GRASP_PLANNING Enabled MOVE3D_ROBOTICS dependency: LIGHT_PLANNER Enabled MOVE3D_ROBOTICS dependency: MULTIGRAPH Enabled MOVE3D_ROBOTICS dependency: MULTILOCALPATH Enabled MOVE3D_ROBOTICS dependency: USE_GSL Enabled GRASP_PLANNING dependency: USE_GBM Active Flags : QT_LIBRARY QT_GL P3D_CONSTRAINTS P3D_COLLISION_CHECKING P3D_LOCALPATH P3D_PLANNER USE_P3D_BODY_AABB USE_GLUT DEBUG_STATUS GENERATE_LIBMOVE3D MOVE3D_ROBOTICS MOVE3D_CORE GRASP_PLANNING LIGHT_PLANNER MULTIGRAPH MULTILOCALPATH USE_GSL USE_GBM -- Found Doxygen: /usr/bin/doxygen (found version "1.8.13") found components: doxygen dot -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found -- Looking for gethostbyname -- Looking for gethostbyname - found -- Looking for connect -- Looking for connect - found -- Looking for remove -- Looking for remove - found -- Looking for shmat -- Looking for shmat - found -- Looking for IceConnectionNumber in ICE -- Looking for IceConnectionNumber in ICE - found -- Found X11: /usr/lib64/libX11.so -- Found LibXml2: /usr/lib64/libxml2.so (found version "2.9.8") CMake Warning (dev) at /usr/share/cmake/Modules/FindOpenGL.cmake:270 (message): Policy CMP0072 is not set: FindOpenGL prefers GLVND by default when available. Run "cmake --help-policy CMP0072" for policy details. Use the cmake_policy command to set the policy and suppress this warning. FindOpenGL found both a legacy GL library: OPENGL_gl_LIBRARY: /usr/lib64/libGL.so and GLVND libraries for OpenGL and GLX: -- Found OpenGL: /usr/lib64/libOpenGL.so OPENGL_opengl_LIBRARY: /usr/lib64/libOpenGL.so OPENGL_glx_LIBRARY: /usr/lib64/libGLX.so OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for compatibility with CMake 3.10 and below the legacy GL library will be used. Call Stack (most recent call first): CMakeLists.txt:296 (FIND_PACKAGE) This warning is for project developers. Use -Wno-dev to suppress it. -- Found components for GLU -- GLU_INCLUDE_DIR = /usr/include -- GLU_LIBRARIES = /usr/lib64/libGLU.so -- Found components for XPM -- XPM_LIBRARIES = /usr/lib64/libXpm.so -- Found components for GBM -- GBM_INCLUDE_DIR = /opt/openrobots/include -- GBM_LIBRARIES = /opt/openrobots/lib/libgb.so -- Found components for GSL -- GSL_INCLUDE_DIR = /usr/include -- GSL_LIBRARIES = /usr/lib64/libgsl.so;/usr/lib64/libgslcblas.so -- Boost version: 1.64.0 -- Found components for GLPK -- GLPK_INCLUDE_DIR = /usr/include -- GLPK_LIBRARIES = /usr/lib64/libglpk.so -- Found PkgConfig: /usr/bin/pkg-config (found version "1.3.12") -- Checking for module 'glib-2.0' -- Found glib-2.0, version 2.54.3 -- Found components for GTS -- GTS_INCLUDE_DIR = /usr/include -- GTS_LIBRARIES = /usr/lib64/libgts.so -- Found components for SOFTMOTION -- SOFTMOTION_INCLUDE_DIR = /opt/openrobots/include -- SOFTMOTION_LIBRARIES = /opt/openrobots/lib/libsoftMotion.so -- Found GLUT: /usr/lib64/libglut.so optimized/usr/lib64/libQtOpenGL.sodebug/usr/lib64/libQtOpenGL_debug.sooptimized/usr/lib64/libQtGui.sodebug/usr/lib64/libQtGui_debug.sooptimized/usr/lib64/libQtCore.sodebug/usr/lib64/libQtCore_debug.so/usr/lib64/libSM.so/usr/lib64/libICE.so/usr/lib64/libX11.so/usr/lib64/libXext.so/usr/lib64/libxml2.so/usr/lib64/libGL.so/usr/lib64/libGLU.so/usr/lib64/libGLU.so/usr/lib64/libXpm.so/opt/openrobots/lib/libgb.so/usr/lib64/libgsl.so/usr/lib64/libgslcblas.so/usr/lib64/libglpk.so/usr/lib64/libgts.so/opt/openrobots/lib/libsoftMotion.so/usr/lib64/libglut.so libmove3d_SOURCE_DIR:/local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0 CMake Warning (dev) at CMakeLists.txt:547 (get_directory_property): Policy CMP0059 is not set: Do not treat DEFINITIONS as a built-in directory property. Run "cmake --help-policy CMP0059" for policy details. Use the cmake_policy command to set the policy and suppress this warning. This warning is for project developers. Use -Wno-dev to suppress it. -DBIOMOVE3D_VERSION="" -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_LIBRARY -DQT_GL -DP3D_CONSTRAINTS -DP3D_COLLISION_CHECKING -DP3D_LOCALPATH -DP3D_PLANNER -DUSE_P3D_BODY_AABB -DUSE_GLUT -DDEBUG_STATUS -DGENERATE_LIBMOVE3D -DMOVE3D_ROBOTICS -DMOVE3D_CORE -DGRASP_PLANNING -DLIGHT_PLANNER -DMULTIGRAPH -DMULTILOCALPATH -DUSE_GSL -DUSE_GBM -DFOO -DBAR CMAKE_C_FLAGS = -pipe -O3 -DNDEBUG CMAKE_CXX_FLAGS = -pipe -O3 -DNDEBUG CMAKE_BINARY_DIR = /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0 -- Configuring done -- Generating done -- Build files have been written to: /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0