robotpkg/wip/libmove3d-planners bulk build results

Log for libmove3d-planners-1.4.0 on Debian-8-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for libmove3d-planners-1.4.0 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/tnftp-20130505~ssl.tgz ===> Checking bootstrap dependencies for libmove3d-planners-1.4.0 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.18 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.6.1: pkgrepo2deb-1.6.1 found ===> Done bootstrap-depends for libmove3d-planners-1.4.0 ===> Installing full dependencies for libmove3d-planners-1.4.0 => Dependency digest-20080510 already installed WARNING: Cannot check installed version of libXpm => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Debian-8-x86_64/All/libmove3d-3.22.0r1.tgz => Installing /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Debian-8-x86_64/All/libmove3d-hri-2.24.tgz => Dependency tnftp-20130505~ssl already installed ===> Checking build options for libmove3d-planners-1.4.0 => Building with no option. ===> Checking alternatives for libmove3d-planners-1.4.0 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for libmove3d-planners-1.4.0 => Required system package boost-headers>=1.34.1: boost-headers-1.55 found => Required system package boostlib-filesystem{>=1.34.1<1.49,>=1.50}: boost-lib-filesystem-1.55.0 found => Required system package boostlib-iostreams{>=1.34.1<1.49,>=1.50}: boost-lib-iostreams-1.55.0 found => Required system package boostlib-math{>=1.34.1<1.49,>=1.50}: boost-lib-math-1.55.0 found => Required system package boostlib-thread{>=1.34.1<1.49,>=1.50}: boost-lib-thread-1.55.0 found => Required system package cmake>=2.6: cmake-3.0.2 found => Required system package eigen3>=3.0.0: eigen3-3.2.2 found => Required system package g++>=3: g++-4.9.2 found => Required system package gcc>=3: gcc-4.9.2 found => Required system package glu>=7: glu-9.0.0 found => Required system package libXpm>=3.5.7: libXpm found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.28 found WARNING: Cannot check installed version of libXpm => Required robotpkg package libmove3d>=3.22.0: libmove3d-3.22.0r1 found => Required robotpkg package libmove3d-hri>=2.24: libmove3d-hri-2.24 found ===> Done depends for libmove3d-planners-1.4.0 ===> Extracting for libmove3d-planners-1.4.0 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for libmove3d-planners-1.4.0 I've found Qt4 libraries. I will compile libmove3d-planners with it. Active Flags : QT_LIBRARY P3D_CONSTRAINTS P3D_COLLISION_CHECKING P3D_LOCALPATH P3D_PLANNER LIGHT_PLANNER GRASP_PLANNING MULTILOCALPATH MULTIGRAPH USE_GBM USE_GSL HRI_COSTSPACE HRI_PLANNER HRICS_MHO_REPLACE_OTP DEBUG_STATUS IMPORTANT : ----- linking against ----> libmove3d-viewer MOVE3DVIEWER_INCLUDE_DIRS = /opt/openrobots/include/libmove3d/opt/openrobots/include/libmove3d/include/opt/openrobots/include/usr/include/qt4/usr/include/libxml2/opt/openrobots/include MOVE3DVIEWER_LIBRARIES = move3d CMake Error at /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:341 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:395 (_pkg_check_modules_internal) CMakeLists.txt:284 (PKG_CHECK_MODULES) include dirs: /usr/include;/usr/include/libxml2;/usr/include;/usr/include/eigen3;/usr/include;/opt/openrobots/include;/opt/openrobots/include An unexpected error occured. The last 10 log lines are shown below. | CMakeLists.txt:284 (PKG_CHECK_MODULES) | | | -- checking for module 'liblog4cxx' | -- found liblog4cxx, version 0.10.0 | -- Found LOG4CXX: /usr/lib/x86_64-linux-gnu/liblog4cxx.so | include dirs: /usr/include;/usr/include/libxml2;/usr/include;/usr/include/eigen3;/usr/include;/opt/openrobots/include;/opt/openrobots/include | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/libmove3d-planners/work/libmove3d-planners-1.4.0/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/libmove3d-planners/work/libmove3d-planners-1.4.0/CMakeFiles/CMakeError.log". /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/libmove3d-planners/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed => Marking libmove3d-planners-1.4.0 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for libmove3d-planners Removed digest-20080510 Removing dependency gbM-0.11~tcl Removing dependency softMotion-libs-3.12~tcl Removing dependency Removing dependency libmove3d-hri-2.24 Removed libmove3d-3.22.0r1 Removed tnftp-20130505~ssl