robotpkg/wip/infuse-envire bulk build results

Log for infuse-envire-0.1.1 on Fedora-31-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for infuse-envire-0.1.1 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Fedora-31-x86_64/All/tnftp-20151004~ssl.tgz ===> Checking bootstrap dependencies for infuse-envire-0.1.1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20151004~ssl found => Required system package gzip: gzip-1.10 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found ===> Done bootstrap-depends for infuse-envire-0.1.1 ===> Installing full dependencies for infuse-envire-0.1.1 => Dependency digest-20080510 already installed => Dependency tnftp-20151004~ssl already installed ===> Checking build options for infuse-envire-0.1.1 => Building with no option. ===> Checking alternatives for infuse-envire-0.1.1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for infuse-envire-0.1.1 => Required system package cmake>=2.6: cmake-3.17.4 found => Required system package eigen3>=3.0.0: eigen3-3.3.7 found => Required system package g++>=3: g++-9 found => Required system package gcc>=3: gcc-9 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-1.6.3 found ===> Done depends for infuse-envire-0.1.1 ===> Extracting for infuse-envire-0.1.1 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for infuse-envire-0.1.1 ===> Building for infuse-envire-0.1.1 In file included from /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/TransformGraph.hpp:13, from /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/EnvireGraph.hpp:38, from /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/EnvireGraph.cpp:28: /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/Graph.hpp: In instantiation of 'void envire::core::Graph::add_edge(envire::core::Graph::vertex_descriptor, envire::core::Graph::vertex_descriptor, const E&) [with FRAME_PROP = envire::core::Frame; EDGE_PROP = envire::core::Transform; envire::core::Graph::vertex_descriptor = void*]': /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/Graph.hpp:671:57: required from 'void envire::core::Graph::add_edge(const FrameId&, const FrameId&, const E&) [with FRAME_PROP = envire::core::Frame; EDGE_PROP = envire::core::Transform; envire::core::FrameId = std::__cxx11::basic_string]' /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/TransformGraph.hpp:271:17: required from 'void envire::core::TransformGraph::addTransform(const FrameId&, const FrameId&, const envire::core::Transform&) [with FRAME_PROP = envire::core::Frame; envire::core::FrameId = std::__cxx11::basic_string]' /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/EnvireGraph.cpp:322:60: required from here /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/Graph.hpp:638:14: warning: variable 'edge_pair_inv' set but not used [-Wunused-but-set-variable] 638 | EdgePair edge_pair_inv = boost::add_edge(target, origin, edgeProperty.inverse(), *this); | ^~~~~~~~~~~~~ /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/TreeView.cpp: In member function 'void envire::core::TreeView::removeEdge(envire::core::vertex_descriptor, envire::core::vertex_descriptor)': /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1/src/graph/TreeView.cpp:188:21: warning: 'realTarget' may be used uninitialized in this function [-Wmaybe-uninitialized] 188 | vertex_descriptor realTarget; | ^~~~~~~~~~ ===> Installing for infuse-envire-0.1.1 => Adding run-time search paths to pkg-config files robotpkg_create: can't stat `/opt/openrobots/lib/libinfuse_envire.so' robotpkg_create: can't stat `/opt/openrobots/lib/pkgconfig/infuse_envire.pc' => Registering installation for infuse-envire-0.1.1 robotpkg_admin: infuse-envire-0.1.1: File `/opt/openrobots/lib/libinfuse_envire.so' is in +CONTENTS but not on filesystem! robotpkg_admin: infuse-envire-0.1.1: File `/opt/openrobots/lib/pkgconfig/infuse_envire.pc' is in +CONTENTS but not on filesystem! ===> Done install for infuse-envire-0.1.1 ===> Building binary package for infuse-envire-0.1.1 robotpkg_create: can't stat `/opt/openrobots/lib/libinfuse_envire.so' robotpkg_create: can't stat `/opt/openrobots/lib/pkgconfig/infuse_envire.pc' robotpkg_create: lstat failed for file lib/libinfuse_envire.so: No such file or directory Creating package /opt/robotpkg/var/lib/robotpkg/wip/packages/bsd/Fedora-31-x86_64/All/infuse-envire-0.1.1 make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:74: pkg-tarup] Error 2 ERROR: This package cannot be extracted for the following reason: ERROR: ====================================================================== ERROR: A lib64 directory may not exist in LOCALBASE. ERROR: Having a lib64 directory within the robotpkg installation ERROR: tree is not supported. Please remove ERROR: /opt/openrobots/lib64 ERROR: ERROR: ====================================================================== make[3]: *** [/local/robotpkg/var/lib/robotpkg/mk/internal/can-be-built-here.mk:204: cbeh] Error 2 make[2]: *** [/local/robotpkg/var/lib/robotpkg/mk/package/package.mk:147: package-failed] Error 2 => Marking infuse-envire-0.1.1 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for infuse-envire robotpkg_delete: Couldn't remove /opt/openrobots/lib/libinfuse_envire.so robotpkg_delete: Couldn't remove /opt/openrobots/lib/pkgconfig/infuse_envire.pc Removed infuse-envire-0.1.1 Removed digest-20080510 Removed tnftp-20151004~ssl