robotpkg/wip/infuse-envire bulk build results

Log for infuse-envire-0.1.1 on Debian-8-x86_64: bulk.log (Back)

=> Checking for clear installation ===> Installing bootstrap dependencies for infuse-envire-0.1.1 => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/digest-20080510.tgz => Installing /opt/robotpkg/var/lib/robotpkg/packages/bsd/Debian-8-x86_64/All/tnftp-20151004~ssl.tgz ===> Checking bootstrap dependencies for infuse-envire-0.1.1 => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20151004~ssl found => Required system package gnupg>=1: gnupg-1.4.18 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.9: pkg_install-20110805.9 found => Required system package pkgrepo2deb>=1.9: pkgrepo2deb-1.9 found ===> Done bootstrap-depends for infuse-envire-0.1.1 ===> Installing full dependencies for infuse-envire-0.1.1 => Dependency digest-20080510 already installed => Dependency tnftp-20151004~ssl already installed ===> Checking build options for infuse-envire-0.1.1 => Building with no option. ===> Checking alternatives for infuse-envire-0.1.1 => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 ===> Checking dependencies for infuse-envire-0.1.1 => Required system package cmake>=2.6: cmake-3.0.2 found => Required system package eigen3>=3.0.0: eigen3-3.2.2 found => Required system package g++>=3: g++-4.9.2 found => Required system package gcc>=3: gcc-4.9.2 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.28 found ===> Done depends for infuse-envire-0.1.1 ===> Extracting for infuse-envire-0.1.1 => SHA1 checksums OK => RMD160 checksums OK ===> Configuring for infuse-envire-0.1.1 CMake Error at CMakeLists.txt:1 (cmake_minimum_required): CMake 3.5 or higher is required. You are running version 3.0.2 An unexpected error occured. The last 10 log lines are shown below. | NODENAME=fluffy64-debian8 | --- | Running set -e; | cd /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1 && cd /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/infuse-envire-0.1.1 && /usr/bin/env 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work PATH='/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin' LD_LIBRARY_PATH='' /usr/bin/cmake '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=' --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .; | CMake Error at CMakeLists.txt:1 (cmake_minimum_required): | CMake 3.5 or higher is required. You are running version 3.0.2 | | | Not searching for unused variables given on the command line. | -- Configuring incomplete, errors occurred! /local/robotpkg/var/lib/robotpkg/mk/configure/cmake-configure.mk:100: recipe for target 'do-configure-cmake' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/infuse-envire/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 /local/robotpkg/var/lib/robotpkg/mk/pkg/package.mk:42: recipe for target 'pkg-check-installed' failed => Marking infuse-envire-0.1.1 as broken ERROR: make: *** [package] Error 2 ===> Deinstalling for infuse-envire Removed digest-20080510 Removed tnftp-20151004~ssl