robotpkg/wip/head-action bulk build results

Log for head-action-0.0.1r4 on Ubuntu-20.04-x86_64: sysdep.log (Back)

Missing system package py38-ros-catkin>=0.7<0.8: searching in /opt/ros/melodic missing: /opt/ros/melodic/bin/catkin_init_workspace searching in /usr/local missing: /usr/local/bin/catkin_init_workspace searching in /usr missing: /usr/bin/catkin_init_workspace missing: /bin/catkin_init_workspace searching in /snap missing: /snap/bin/catkin_init_workspace Please install the Ubuntu package ros-melodic-catkin. - SYSTEM_PREFIX or PREFIX.ros-catkin can be set to the installation prefix of this package in robotpkg.conf. - If no py38-ros-catkin>=0.7<0.8 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-catkin= robotpkg Missing system package ros-comm>=1.13<1.15: searching in /opt/ros/melodic missing: /opt/ros/melodic/bin/roscore searching in /usr/local missing: /usr/local/bin/roscore searching in /usr missing: /usr/bin/roscore missing: /bin/roscore searching in /snap missing: /snap/bin/roscore Please install the Ubuntu package ros-melodic-ros-comm. - SYSTEM_PREFIX or PREFIX.ros-comm can be set to the installation prefix of this package in robotpkg.conf. - If no ros-comm>=1.13<1.15 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-comm= robotpkg Missing system package ros-common-msgs>=1.12<1.13: searching in /opt/ros/melodic missing: /opt/ros/melodic/include/actionlib_msgs/GoalID.h searching in /usr/local missing: /usr/local/include/actionlib_msgs/GoalID.h searching in /usr missing: /usr/include/x86_64-linux-gnu/actionlib_msgs/GoalID.h missing: /usr/include/actionlib_msgs/GoalID.h searching in /snap missing: /snap/include/actionlib_msgs/GoalID.h Please install the Ubuntu package ros-melodic-common-msgs. - SYSTEM_PREFIX or PREFIX.ros-common-msgs can be set to the installation prefix of this package in robotpkg.conf. - If no ros-common-msgs>=1.12<1.13 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-common-msgs= robotpkg Missing system package ros-control-msgs>=1.4<1.6: searching in /opt/ros/melodic missing: /opt/ros/melodic/include/control_msgs/JointControllerState.h searching in /usr/local missing: /usr/local/include/control_msgs/JointControllerState.h searching in /usr missing: /usr/include/x86_64-linux-gnu/control_msgs/JointControllerState.h missing: /usr/include/control_msgs/JointControllerState.h searching in /snap missing: /snap/include/control_msgs/JointControllerState.h Please install the Ubuntu package ros-melodic-control-msgs. - SYSTEM_PREFIX or PREFIX.ros-control-msgs can be set to the installation prefix of this package in robotpkg.conf. - If no ros-control-msgs>=1.4<1.6 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-control-msgs= robotpkg Missing system package ros-genmsg>=0.5<0.6: searching in /opt/ros/melodic missing: /opt/ros/melodic/lib/python3.8/site-packages/genmsg/__init__.py missing: /opt/ros/melodic/lib/python3.8/dist-packages/genmsg/__init__.py missing: /opt/ros/melodic/lib/python3/site-packages/genmsg/__init__.py missing: /opt/ros/melodic/lib/python3/dist-packages/genmsg/__init__.py missing: /opt/ros/melodic/lib/pymodules/python3.8/genmsg/__init__.py missing: /opt/ros/melodic/lib/pymodules/python3/genmsg/__init__.py searching in /usr/local missing: /usr/local/lib/python3.8/site-packages/genmsg/__init__.py missing: /usr/local/lib/python3.8/dist-packages/genmsg/__init__.py missing: /usr/local/lib/python3/site-packages/genmsg/__init__.py missing: /usr/local/lib/python3/dist-packages/genmsg/__init__.py missing: /usr/local/lib/pymodules/python3.8/genmsg/__init__.py missing: /usr/local/lib/pymodules/python3/genmsg/__init__.py searching in /usr missing: /usr/lib/x86_64-linux-gnu/python3.8/site-packages/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/python3.8/site-packages/genmsg/__init__.py missing: /usr/lib/python3.8/site-packages/genmsg/__init__.py missing: /lib/python3.8/site-packages/genmsg/__init__.py missing: /usr/lib/x86_64-linux-gnu/python3.8/dist-packages/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/python3.8/dist-packages/genmsg/__init__.py missing: /usr/lib/python3.8/dist-packages/genmsg/__init__.py missing: /lib/python3.8/dist-packages/genmsg/__init__.py missing: /usr/lib/x86_64-linux-gnu/python3/site-packages/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/python3/site-packages/genmsg/__init__.py missing: /usr/lib/python3/site-packages/genmsg/__init__.py missing: /lib/python3/site-packages/genmsg/__init__.py missing: /usr/lib/x86_64-linux-gnu/python3/dist-packages/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/python3/dist-packages/genmsg/__init__.py missing: /usr/lib/python3/dist-packages/genmsg/__init__.py missing: /lib/python3/dist-packages/genmsg/__init__.py missing: /usr/lib/x86_64-linux-gnu/pymodules/python3.8/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/pymodules/python3.8/genmsg/__init__.py missing: /usr/lib/pymodules/python3.8/genmsg/__init__.py missing: /lib/pymodules/python3.8/genmsg/__init__.py missing: /usr/lib/x86_64-linux-gnu/pymodules/python3/genmsg/__init__.py missing: /lib/x86_64-linux-gnu/pymodules/python3/genmsg/__init__.py missing: /usr/lib/pymodules/python3/genmsg/__init__.py missing: /lib/pymodules/python3/genmsg/__init__.py searching in /snap missing: /snap/lib/python3.8/site-packages/genmsg/__init__.py missing: /snap/lib/python3.8/dist-packages/genmsg/__init__.py missing: /snap/lib/python3/site-packages/genmsg/__init__.py missing: /snap/lib/python3/dist-packages/genmsg/__init__.py missing: /snap/lib/pymodules/python3.8/genmsg/__init__.py missing: /snap/lib/pymodules/python3/genmsg/__init__.py Please install the Ubuntu package ros-melodic-genmsg. - SYSTEM_PREFIX or PREFIX.ros-genmsg can be set to the installation prefix of this package in robotpkg.conf. - If no ros-genmsg>=0.5<0.6 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-genmsg= robotpkg Missing system package ros-genpy>=0.6<0.7: searching in /opt/ros/melodic missing: /opt/ros/melodic/lib/genpy/genmsg_py.py missing: /opt/ros/melodic/share/genpy/bin/genmsg_py.py searching in /usr/local missing: /usr/local/lib/genpy/genmsg_py.py missing: /usr/local/share/genpy/bin/genmsg_py.py searching in /usr missing: /usr/lib/x86_64-linux-gnu/genpy/genmsg_py.py missing: /lib/x86_64-linux-gnu/genpy/genmsg_py.py missing: /usr/lib/genpy/genmsg_py.py missing: /lib/genpy/genmsg_py.py missing: /usr/share/genpy/bin/genmsg_py.py searching in /snap missing: /snap/lib/genpy/genmsg_py.py missing: /snap/share/genpy/bin/genmsg_py.py Please install the Ubuntu package ros-melodic-genpy. - SYSTEM_PREFIX or PREFIX.ros-genpy can be set to the installation prefix of this package in robotpkg.conf. - If no ros-genpy>=0.6<0.7 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-genpy= robotpkg Missing system package ros-geometry>=1.12<1.13: searching in /opt/ros/melodic missing: /opt/ros/melodic/include/eigen_conversions/eigen_kdl.h searching in /usr/local missing: /usr/local/include/eigen_conversions/eigen_kdl.h searching in /usr missing: /usr/include/x86_64-linux-gnu/eigen_conversions/eigen_kdl.h missing: /usr/include/eigen_conversions/eigen_kdl.h searching in /snap missing: /snap/include/eigen_conversions/eigen_kdl.h Please install the Ubuntu package ros-melodic-geometry. - SYSTEM_PREFIX or PREFIX.ros-geometry can be set to the installation prefix of this package in robotpkg.conf. - If no ros-geometry>=1.12<1.13 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-geometry= robotpkg Missing system package ros-kdl-parser>=1.13<1.14: searching in /opt/ros/melodic missing: /opt/ros/melodic/include/kdl_parser/kdl_parser.hpp searching in /usr/local missing: /usr/local/include/kdl_parser/kdl_parser.hpp searching in /usr missing: /usr/include/x86_64-linux-gnu/kdl_parser/kdl_parser.hpp missing: /usr/include/kdl_parser/kdl_parser.hpp searching in /snap missing: /snap/include/kdl_parser/kdl_parser.hpp Please install the Ubuntu package ros-melodic-kdl-parser. - SYSTEM_PREFIX or PREFIX.ros-kdl-parser can be set to the installation prefix of this package in robotpkg.conf. - If no ros-kdl-parser>=1.13<1.14 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-kdl-parser= robotpkg Missing system package ros-message-generation>=0.4<0.5: searching in /opt/ros/melodic missing: /opt/ros/melodic/share/message_generation/cmake/message_generationConfig.cmake searching in /usr/local missing: /usr/local/share/message_generation/cmake/message_generationConfig.cmake searching in /usr missing: /usr/share/message_generation/cmake/message_generationConfig.cmake searching in /snap missing: /snap/share/message_generation/cmake/message_generationConfig.cmake Please install the Ubuntu package ros-melodic-message-generation. - SYSTEM_PREFIX or PREFIX.ros-message-generation can be set to the installation prefix of this package in robotpkg.conf. - If no ros-message-generation>=0.4<0.5 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-message-generation= robotpkg Missing system package ros-message-runtime>=0.4<0.5: searching in /opt/ros/melodic missing: /opt/ros/melodic/share/message_runtime/package.xml searching in /usr/local missing: /usr/local/share/message_runtime/package.xml searching in /usr missing: /usr/share/message_runtime/package.xml searching in /snap missing: /snap/share/message_runtime/package.xml Please install the Ubuntu package ros-melodic-message-runtime. - SYSTEM_PREFIX or PREFIX.ros-message-runtime can be set to the installation prefix of this package in robotpkg.conf. - If no ros-message-runtime>=0.4<0.5 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-message-runtime= robotpkg Missing system package ros-orocos-kinematics-dynamics>=1.1: searching in /opt/ros/melodic missing: /opt/ros/melodic/share/orocos_kinematics_dynamics/package.xml searching in /usr/local missing: /usr/local/share/orocos_kinematics_dynamics/package.xml searching in /usr missing: /usr/share/orocos_kinematics_dynamics/package.xml searching in /snap missing: /snap/share/orocos_kinematics_dynamics/package.xml Please install the Ubuntu package ros-melodic-orocos-kinematics-dynamics. - SYSTEM_PREFIX or PREFIX.ros-orocos-kinematics-dynamics can be set to the installation prefix of this package in robotpkg.conf. - If no ros-orocos-kinematics-dynamics>=1.1 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-orocos-kinematics-dynamics= robotpkg Missing system package ros-std-msgs>=0.5: searching in /opt/ros/melodic missing: /opt/ros/melodic/include/std_msgs/Int32.h searching in /usr/local missing: /usr/local/include/std_msgs/Int32.h searching in /usr missing: /usr/include/x86_64-linux-gnu/std_msgs/Int32.h missing: /usr/include/std_msgs/Int32.h searching in /snap missing: /snap/include/std_msgs/Int32.h Please install the Ubuntu package ros-melodic-std-msgs. - SYSTEM_PREFIX or PREFIX.ros-std-msgs can be set to the installation prefix of this package in robotpkg.conf. - If no ros-std-msgs>=0.5 package can be made available in your system, you can use the robotpkg version, by setting in robotpkg.conf PREFER.ros-std-msgs= robotpkg