robotpkg/wip/certi bulk build results

Log for certi-3.5.1 on Fedora-28-x86_64: configure.log (Back)

--- Environment --- tag=Fedora-28-x86_64 LC_MONETARY=C LOWER_OPSYS=fedora LANG=C OS_VERSION=28 PKGTOOLS_VERSION=20110805.9 _override_vars_archivers_pax=PKGREQD PKGREQD BULK_LOGDIR=/local/robotpkg/var/log/bulk GXX=/usr/bin/g++ OLDPWD=/local/robotpkg/var/lib/robotpkg FLEX=/usr/bin/flex TAR=/usr/bin/tar MACHINE_KERNEL=Linux-5.0.16-100.fc28.x86_64-x86_64 _override_vars_pkgtools_digest=PKGREQD PKGREQD OWNER_GID=robots TNFTP=/opt/openrobots/sbin/tnftp MAKECONF=/opt/robotpkg/etc/robotpkg-wip.conf _overrides_archivers_pax_PKGREQD=pax pax _overrides_pkgtools_tnftp_PKGREQD=tnftp>=20091122 tnftp>=20091122 MFLAGS=--no-print-directory EXPECT_TARGETS=fetch install package CC=/usr/bin/gcc ROBOTPKG_DIR=/local/robotpkg/var/lib/robotpkg LC_COLLATE=C ROBOTPKG_BASE=/local/robotpkg MACHINE_PLATFORM=Fedora-28-x86_64 PWD=/local/robotpkg/var/lib/robotpkg/wip/certi LC_CTYPE=C NODENAME=fluffy64-fedora28 OS_KERNEL_VERSION=5.0.16-100.fc28.x86_64 PKG_DBDIR=/opt/openrobots/var/db/robotpkg RECURSIVE_PKGPATH=wip/certi LOWER_OS_KERNEL=linux PAX=/usr/bin/pax OPSYS=Fedora _ROBOTPKG_NOW=0823211846 _overrides_pkgtools_digest_PKGREQD=digest>=20080510 digest>=20080510 _override_vars_wip_certi=PKGREQD bf= LC_NUMERIC=C OWNER_UID=rbulk _override_vars_pkgtools_tnftp=PKGREQD PKGREQD _overrides_wip_certi_PKGREQD=certi-3.5.1 FC=false MACHINE_ARCH=x86_64 ECHO_N=echo -n BULKBASE=/opt/openrobots hline="$bf======================================================================$rm" _override_vars_pkgtools_pkg_install=PKGREQD PKGREQD PKGREQD CXX=/usr/bin/g++ LOCALBASE=/opt/openrobots MAKEOVERRIDES=PKGREQD.cmdline=certi-3.5.1 RECURSIVE_PKGPATH=wip/certi\ tag=Fedora-28-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package LC_MESSAGES=C _overrides_pkgtools_pkg_install_PKGREQD=pkg_install>=20110805.9 pkg_install>=20110805.9 pkg_install>=20110805.9 GZIP_CMD=/usr/bin/gzip MAKELEVEL=4 rm= SHLVL=4 LOWER_ARCH=x86_64 ZCAT=/usr/bin/zcat DIGEST=/opt/openrobots/sbin/robotpkg_digest CMAKE=/usr/bin/cmake CXXCPP=/usr/bin/g++ -E LOWER_OS_VERSION=28 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin ROBOTPKG_TRUSTED_ENV=robotpkg GCC=/usr/bin/gcc MAKEFLAGS= --no-print-directory -- PKGREQD.cmdline=certi-3.5.1 RECURSIVE_PKGPATH=wip/certi\ tag=Fedora-28-x86_64 BULK_LOGDIR=/local/robotpkg/var/log/bulk BULKBASE=/opt/openrobots LOCALBASE=/opt/openrobots PKG_DBDIR=/opt/openrobots/var/db/robotpkg EXPECT_TARGETS=fetch\ install\ package OS_KERNEL=Linux CPP=/usr/bin/gcc -E LC_TIME=C _=/usr/bin/env --- Running set -e; \ cd /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source && cd /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source && /usr/bin/env YACC='/usr/bin/bison -y' LEX=/usr/bin/flex 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/certi/work PATH='/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin' LD_LIBRARY_PATH='' /usr/bin/cmake -DCERTI_USE_NULL_PRIME_MESSAGE_PROTOCOL=ON '-DCMAKE_MODULE_PATH=' '-DCMAKE_PREFIX_PATH=' -DFORCE_NO_X11=ON --no-warn-unused-cli -DUNIX=1 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH=/opt/openrobots -DCMAKE_INSTALL_RPATH:PATH=/opt/openrobots/lib -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE CMAKE_EXE_LINKER_FLAGS=' ' -DCMAKE_MAKE_PROGRAM=make -DCMAKE_C_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_C_FLAGS_DEBUG= -DCMAKE_C_FLAGS_RELEASE= -DCMAKE_CXX_FLAGS=' -pipe -O3 -DNDEBUG' -DCMAKE_CXX_FLAGS_DEBUG= -DCMAKE_CXX_FLAGS_RELEASE= -DPKGINFODIR=info -DPKGMANDIR=man .; Not searching for unused variables given on the command line. -- The CXX compiler identification is GNU 8.3.1 -- Check for working CXX compiler: /usr/bin/g++ -- Check for working CXX compiler: /usr/bin/g++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done -- The C compiler identification is GNU 8.3.1 -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Native build. -- Target is 64 bits -- Check if the system is big endian -- Searching 16 bit integer -- Looking for sys/types.h -- Looking for sys/types.h - found -- Looking for stdint.h -- Looking for stdint.h - found -- Looking for stddef.h -- Looking for stddef.h - found -- Check size of unsigned short -- Check size of unsigned short - done -- Using unsigned short -- Check if the system is big endian - little endian -- Target is Little Endian -- Configuring CERTI version 3.5.1 -- Looking for time.h -- Looking for time.h - found -- Looking for clock_gettime -- Looking for clock_gettime - found -- Looking for clock_settime -- Looking for clock_settime - found -- Looking for clock_getres -- Looking for clock_getres - found -- Looking for clock_nanosleep -- Looking for clock_nanosleep - found -- Looking for sys/time.h CMake Warning (dev) at /usr/share/cmake/Modules/CheckIncludeFile.cmake:80 (message): Policy CMP0075 is not set: Include file check macros honor CMAKE_REQUIRED_LIBRARIES. Run "cmake --help-policy CMP0075" for policy details. Use the cmake_policy command to set the policy and suppress this warning. CMAKE_REQUIRED_LIBRARIES is set to: /usr/lib64/librt.so For compatibility with CMake 3.11 and below this check is ignoring it. Call Stack (most recent call first): CMakeLists.txt:316 (CHECK_INCLUDE_FILE) This warning is for project developers. Use -Wno-dev to suppress it. -- Looking for sys/time.h - found -- Looking for gettimeofday -- Looking for gettimeofday - found -- Looking for basename in gen -- Looking for basename in gen - not found -- Looking for connect in socket -- Looking for connect in socket - not found -- Found LibXml2: /usr/lib64/libxml2.so (found version "2.9.8") -- FORCE_NO_X11 OPTION has been set: only Billard Test Application with no GUI will be built. -- Looking for lex... -- Looking for lex... - found lex is /usr/bin/flex -- Looking for yacc... -- Looking for yacc... - found yacc is /usr/bin/bison -- INHIBIT Compiler warning for LEX/YACC generated files -- INHIBIT Compiler (GCC) warning for gengetopt generated files: /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/RTIG/RTIG_cmdline.c;/local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/RTIG/RTIG_cmdline.h. -- INHIBIT Compiler (GCC) warning for gengetopt generated files: /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/RTIA/RTIA_cmdline.c;/local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/RTIA/RTIA_cmdline.h. -- libRTI variant: HLA 1.3 NG -- libRTI variant: HLA 1516 -- libRTI variant: HLA 1516e -- INHIBIT Compiler (GCC) warning for gengetopt generated files: Billard_cmdline.c;Billard_cmdline.h. -- Some X11 header were not found: only Billard Test Application with no GUI will be built. -- INHIBIT Compiler (GCC) warning for gengetopt generated files: /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/test/testFederate/testFederate_cmdline.c;/local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source/test/testFederate/testFederate_cmdline.h. -- Found PythonInterp: /usr/bin/python (found version "2.7.15") -- *** CERTI has been successfully configured ******** -- Configuring done -- Generating done -- Build files have been written to: /local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source