robotpkg/wip bulk build results

Log for Ubuntu-17.10-x86_64 (Back)

--- Updating robotpkg ------------------------------------------------ Pulling /local/robotpkg/var/lib/robotpkg/wip Already up-to-date. Updating pkgtools/pkg_install ===> Updating for pkg_install-20110805.7 pkg_install-20110805.7 is already installed and up-to-date. Updating pkgtools/rbulkit ===> Updating for rbulkit-20170123 rbulkit-20170123 is already installed and up-to-date. Updating pkgtools/pkgrepo2deb ===> Updating for pkgrepo2deb-1.2.1 pkgrepo2deb-1.2.1 is already installed and up-to-date. --- Running build for bulk-rbulk-wip ----------------------------------- ===> Sorting packages for rbulk wip set Scanning wip/libmove3d-hri:* Scanning wip/talos-roboticsgroup-gazebo-plugins:* Scanning wip/orocos-dot_service:* Scanning pkgtools/tnftp:tnftp>=20130505~ssl Scanning wip/certi:* Scanning wip/qpOASES:* Scanning wip/gdalwrap:* Scanning wip/mumps:* Scanning wip/jointStateMapper:* Scanning wip/metapod:* [wip/metapod:*] Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. [wip/metapod:*] Warning: use DYNAMIC_PLIST_DIRS instead. Scanning wip/sot-pattern-generator-v3:* Scanning wip/py-laaswm:* Scanning wip/talos-ros-control:* Scanning wip/jsbsim:* Scanning wip/dptu-genom3:* Scanning wip/can-utils:* Scanning wip/chilitags:* Scanning wip/hrp2-14-description:* Scanning wip/hrp2-computer-monitor:* Scanning wip/FRILibrary:* Scanning wip/py-sot-tools-v3:* Scanning wip/sot-talos:* Scanning wip/sot-dyninv:* Scanning wip/mhp-genom:* Scanning wip/hrp2-dev:* Scanning wip/pinocchio:* Scanning wip/libpointmatcher:* Scanning wip/hatpconsole:* Scanning wip/talos-pal-gazebo-plugins:* Scanning wip/jrl-walkgen-v3:* Scanning wip/py-hla:* Scanning wip/ompl:* Scanning wip/talos-pal-hardware-gazebo:* Scanning wip/move3d-studio:* Scanning wip/talos-data:* Scanning wip/sot-hrp2-v3:* Scanning wip/move3d-assets:* Scanning wip/talos-pal-transmissions:* [wip/talos-pal-transmissions:*] Display something for talos-ros-controllers /local/robotpkg Scanning wip/hyper-genom-plugin:* Scanning wip/morse-hla:* Scanning wip/hyper-viewer:* Scanning wip/track-target-genom:* Scanning wip/hrp2-bringup:* Scanning wip/hyper:* Scanning wip/gerard-bauzil:* Scanning wip/pr2-pick-object:* Scanning wip/urg:* Scanning wip/hatptester:* Scanning wip/jafar-qdisplay:* Scanning wip/dynamic-graph-v3:* Scanning wip/spark-genom:* Scanning wip/talos-metapkg-ros-control-sot:* Scanning wip/histodet:* Scanning wip/talos-pal-hardware-interfaces:* Scanning wip/octovis:* Scanning wip/openhrp3-hrp2:* Scanning wip/sot-application:* Scanning wip/MPC_DEMTreatment-genom:* [wip/MPC_DEMTreatment-genom:*] Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. Scanning wip/mrpt:* Scanning wip/py-eigen:* Scanning wip/vnet-yarp:* Scanning wip/talos-simulation:* Scanning wip/MPC_controller-genom:* [wip/MPC_controller-genom:*] Warning: the LICENSE of wip/MPC_controller-genom is undefined. Scanning wip/py-morse:* Scanning wip/simple-humanoid-description:* Scanning wip/MPC_avoidObs-genom:* [wip/MPC_avoidObs-genom:*] Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. Scanning wip/MPC_planner-genom:* [wip/MPC_planner-genom:*] Warning: the LICENSE of wip/MPC_planner-genom is undefined. Scanning wip/soth:* Scanning wip/atlaas-genom:* Scanning wip/libmove3d-planners:* Scanning wip/kukaFri-libs:* Scanning wip/sot-hrprtc-hrp2:* Scanning wip/tsid:* Scanning wip/talos-ros-controllers:* Scanning wip/orocos-bfl:* Scanning wip/sot-dynamic-pinocchio-v3:* Scanning wip/laaswm-gui:* Scanning wip/osg-dae:* Scanning wip/sot-dyninv-v3:* Scanning wip/morse-pocolibs:* Scanning wip/py-jsbsim:* Scanning wip/gladys:* Scanning wip/msgconnector:* Scanning wip/lua-rfsm:* Scanning wip/roralink:* Scanning wip/talos-dev:* Scanning wip/morse-mavlink:* Scanning wip/sot-application-v3:* Scanning wip/sot-hrp2:* Scanning wip/antlr2:* Scanning wip/pal-msgs:* Scanning wip/parametric-curves:* Scanning wip/libfreenect:* Scanning wip/robotModelParser-libs:* Scanning wip/talos-moveit-config:* Scanning wip/sot-romeo-v3:* Scanning wip/atlaas:* Scanning wip/ur5-description:* [wip/ur5-description:*] Warning: the LICENSE of wip/ur5-description is undefined. Scanning wip/orocos-yarp_transport:* Scanning middleware/orocos-rtt:orocos-rtt>=2.5 Scanning wip/talos-robot:* Scanning wip/libmove3d:* Scanning wip/mavlink:* Scanning wip/dynamic-graph-bridge-v3:* Scanning wip/morse-ros:* Scanning wip/hrp2-machine:* Scanning wip/MPC:* Scanning wip/openhrp3-simulator-wo-rtm:* Scanning wip/sot-core-v3:* Scanning wip/eigen-quadprog:* Scanning wip/py-mavlink:* Scanning wip/libnabo:* Scanning wip/py-dynamic-graph-v3:* Scanning wip/joystick-genom:* Scanning wip/hatponboard-lib:* Scanning wip/jafar-rtslam:* Scanning wip/hri-simulation:* Scanning wip/talos-gazebo-ros-control:* Scanning wip/libhatp:* Scanning wip/jafar-rtslam:~MTI Scanning wip/py-mavlink:py35-mavlink-1.1.62 Scanning wip/py-jsbsim:py35-jsbsim-20150424r1 Scanning wip/py-hla:py35-hla-1.1.1r1 Scanning wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* Scanning wip/dptu-genom3:dptu-genom3-0.2~pocolibs-client-c+codels+openprs+pocolibs-server+!* Scanned 255 packages (216 unique) [0%] Processing wip/mavlink:mavlink-20150929 ===> Bulk building for mavlink-20150929 Binary package for mavlink-20150929 is up-to-date. [0%] Processing wip/libmove3d:libmove3d-3.22.0r1 ===> Cleaning temporary files for libmove3d-3.22.0r1 ===> Bulk building for libmove3d-3.22.0r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing gbM-0.11~tcl.tgz WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm => Installing softMotion-libs-3.12~tcl.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package freeglut: freeglut found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package glib2>=2.20: glib2-2.54.1 found => Required system package glpk>=4.36: glpk found => Required system package glu>=7: glu-9.0.0 found => Required system package gsl>=1: gsl-2.4 found => Required system package gts>=0.7: gts-0.7.6 found => Required system package libXpm>=3.5.7: libXpm found => Required system package libstdc++: libstdc++ found => Required system package libxml2>=2: libxml2-2.9.4 found => Required system package qhull: qhull found WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm => Required robotpkg package gbM>=0.9: gbM-0.11~tcl found => Required robotpkg package softMotion-libs>=3.10: softMotion-libs-3.12~tcl found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0/graspPlanning/gpGrasp.cpp: In member function 'p3d_rob* gpHand_properties::initialize()': | /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0/graspPlanning/gpGrasp.cpp:1354:84: warning: too many arguments for format [-Wformat-extra-args] | GP_ROMEO_LEFT_HAND_ROBOT_NAME, GP_ROMEO_RIGHT_HAND_ROBOT_NAME); | ^ | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0' | CMakeFiles/Makefile2:70: recipe for target 'CMakeFiles/move3d.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/libmove3d-3.22.0' | Makefile:143: recipe for target 'all' failed | make[1]: *** [CMakeFiles/move3d.dir/all] Error 2 | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/libmove3d/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking libmove3d-3.22.0r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for libmove3d-3.22.0r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libmove3d-3.22.0r1 ===> Done bulk for libmove3d-3.22.0r1 [0%] Processing wip/morse-ros:morse-ros-1.4 ===> Cleaning temporary files for morse-ros-1.4 ===> Bulk building for morse-ros-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required robotpkg package morse>=1.0: N/A => Required robotpkg package py35-catkin-pkg>=0.2: N/A => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for morse-ros-1.4: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/morse-ros/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for morse-ros-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for morse-ros-1.4 ===> Done bulk for morse-ros-1.4 [1%] Processing wip/openhrp3-simulator-wo-rtm:openhrp3-simulator-wo-rtm-1.2.0 ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Bulk building for openhrp3-simulator-wo-rtm-1.2.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing gepetto-viewer-2.0.0.tgz => Installing ros-catkin-0.6.9r2.tgz => Installing ros-common-msgs-1.11.4.tgz => Dependency ros-genmsg-0.5.3 already installed => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-roscpp-core-0.5.4r1 already installed => Dependency ros-std-msgs-0.5.9 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy provided by ros-indigo => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required robotpkg package gepetto-viewer>=2.0.0: gepetto-viewer-2.0.0 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-roscpp-core>=0.5<0.6: ros-roscpp-core-0.5.4r1 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | "roscpp_DIR" to a directory containing one of the above files. If "roscpp" | provides a separate development package or SDK, be sure it has been | installed. | Call Stack (most recent call first): | CMakeLists.txt:11 (find_package) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/openhrp3-simulator-wo-rtm/work/openhrp3_simulator_wo_rtm-1.2.0/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/openhrp3-simulator-wo-rtm/work/openhrp3_simulator_wo_rtm-1.2.0/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/openhrp3-simulator-wo-rtm/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking openhrp3-simulator-wo-rtm-1.2.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for openhrp3-simulator-wo-rtm-1.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Done bulk for openhrp3-simulator-wo-rtm-1.2.0 [1%] Processing wip/MPC:MPC-1.0r2 ===> Cleaning temporary files for MPC-1.0r2 ===> Bulk building for MPC-1.0r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package freeglut: freeglut found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package glib2>=2.20: glib2-2.54.1 found => Required system package glu>=7: glu-9.0.0 found => Required system package libX11>=1: libX11-1.6.4 found => Required system package libstdc++: libstdc++ found => Required system package mesa>=6.5: mesa-17.2.2 found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for MPC-1.0r2 An unexpected error occured. The last 10 log lines are shown below. | ^ | /local/robotpkg/var/tmp/robotpkg/wip/MPC/work/MPC-1.0/MPC/core/./trajGen/inc/TrajGen.hpp:91:25: error: 'constexpr' needed for in-class initialization of static data member 'const double mpc::TrajGen::UnSurE' of non-integral type [-fpermissive] | static const double UnSurE = 1000000000.0; /**< great value for computation of the derivatives by finite differences */ | ^~~~~~ | make[2]: *** [core/CMakeFiles/MPC-core.dir/planner/src/RoadMapTP.cpp.o] Error 1 | core/CMakeFiles/MPC-core.dir/build.make:1790: recipe for target 'core/CMakeFiles/MPC-core.dir/planner/src/RoadMapTP.cpp.o' failed | make[1]: *** [core/CMakeFiles/MPC-core.dir/all] Error 2 | make: *** [all] Error 2 | CMakeFiles/Makefile2:135: recipe for target 'core/CMakeFiles/MPC-core.dir/all' failed | Makefile:129: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/MPC/work/build.log make[3]: *** [do-build] Error 2 => Marking MPC-1.0r2 as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for MPC-1.0r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for MPC-1.0r2 ===> Done bulk for MPC-1.0r2 [2%] Processing wip/hrp2-machine:hrp2-machine-1.0.2 ===> Bulk building for hrp2-machine-1.0.2 Binary package for hrp2-machine-1.0.2 is up-to-date. [2%] Processing wip/eigen-quadprog:eigen-quadprog-1.0.0 ===> Bulk building for eigen-quadprog-1.0.0 Binary package for eigen-quadprog-1.0.0 is up-to-date. [3%] Processing wip/py-mavlink:py35-mavlink-1.1.62 ===> Cleaning temporary files for py35-mavlink-1.1.62 ===> Bulk building for py35-mavlink-1.1.62 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.14.1 found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py35-mavlink-1.1.62: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-mavlink/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for py35-mavlink-1.1.62 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-mavlink-1.1.62 ===> Done bulk for py35-mavlink-1.1.62 [3%] Processing wip/py-mavlink:py27-mavlink-1.1.62 ===> Bulk building for py27-mavlink-1.1.62 Binary package for py27-mavlink-1.1.62 is up-to-date. [4%] Processing wip/joystick-genom:joystick-genom-1.0 ===> Bulk building for joystick-genom-1.0~openprs+tcl+tclserv_client Binary package for joystick-genom-1.0~openprs+tcl+tclserv_client is up-to-date. [4%] Processing wip/jafar-rtslam:jafar-rtslam-0.3~!* ===> Cleaning temporary files for jafar-rtslam-0.3 ===> Bulk building for jafar-rtslam-0.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Installing boost-numeric-bindings-20101109.tgz => Dependency digest-20080510 already installed => Required robotpkg package jafar-correl>=0.1: N/A => Required robotpkg package jafar-image>=2.1: N/A => Installing jafar-jmath-0.5.tgz => Dependency jafar-kernel-0.6r1 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jafar-rtslam-0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jafar-rtslam-0.3 ===> Done bulk for jafar-rtslam-0.3 [5%] Processing wip/jafar-rtslam:~MTI ===> Cleaning temporary files for jafar-rtslam-0.3~MTI ===> Bulk building for jafar-rtslam-0.3~MTI => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Installing MTI-0.6.tgz => Installing boost-numeric-bindings-20101109.tgz => Dependency digest-20080510 already installed => Required robotpkg package jafar-correl>=0.1: N/A => Required robotpkg package jafar-image>=2.1: N/A => Installing jafar-jmath-0.5.tgz => Dependency jafar-kernel-0.6r1 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jafar-rtslam-0.3~MTI => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jafar-rtslam-0.3~MTI ===> Done bulk for jafar-rtslam-0.3~MTI [5%] Processing wip/libhatp:libhatp-1.3.0 ===> Bulk building for libhatp-1.3.0 Binary package for libhatp-1.3.0 is up-to-date. [6%] Processing wip/libmove3d-hri:libmove3d-hri-2.24 ===> Cleaning temporary files for libmove3d-hri-2.24 ===> Bulk building for libmove3d-hri-2.24 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package libmove3d>=3.22.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for libmove3d-hri-2.24 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libmove3d-hri-2.24 ===> Done bulk for libmove3d-hri-2.24 [6%] Processing wip/certi:certi-3.5.1 ===> Cleaning temporary files for certi-3.5.1 ===> Bulk building for certi-3.5.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package bison: bison found => Required system package cmake>=2.8.11: cmake-3.9.1 found => Required system package flex>=2.5.33: flex-2.6.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package libxml2>=2: libxml2-2.9.4 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | libFedTime.so.1.0.0: undefined reference to `typeinfo for RTI::Exception' | collect2: error: ld returned 1 exit status | make[2]: *** [libRTI/hla-1_3/TestFedTime] Error 1 | libRTI/hla-1_3/CMakeFiles/TestFedTime.dir/build.make:103: recipe for target 'libRTI/hla-1_3/TestFedTime' failed | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source' | CMakeFiles/Makefile2:1638: recipe for target 'libRTI/hla-1_3/CMakeFiles/TestFedTime.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/certi/work/CERTI-3.5.1-Source' | make[1]: *** [libRTI/hla-1_3/CMakeFiles/TestFedTime.dir/all] Error 2 => Marking certi-3.5.1 as broken | make: *** [all] Error 2 | Makefile:165: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/certi/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for certi-3.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for certi-3.5.1 ===> Done bulk for certi-3.5.1 [6%] Processing wip/qpOASES:qpOASES-3.2.0 ===> Bulk building for qpOASES-3.2.0 Binary package for qpOASES-3.2.0 is up-to-date. [7%] Processing wip/gdalwrap:gdalwrap-0.1.10 ===> Bulk building for gdalwrap-0.1.10 Binary package for gdalwrap-0.1.10 is up-to-date. [7%] Processing wip/mumps:mumps-4.10.0 ===> Bulk building for mumps-4.10.0 Binary package for mumps-4.10.0 is up-to-date. [8%] Processing wip/talos-ros-control:talos-ros-control-0.2.10 ===> Bulk building for talos-ros-control-0.2.10 Binary package for talos-ros-control-0.2.10 is up-to-date. [8%] Processing wip/jointStateMapper:jointStateMapper-1.2.1r1 ===> Cleaning temporary files for jointStateMapper-1.2.1r1 ===> Bulk building for jointStateMapper-1.2.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required robotpkg package openrobots-pose>=1.2: NOT found ERROR: Required robotpkg package openrobots-pose>=1.2: NOT found => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jointStateMapper-1.2.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jointStateMapper-1.2.1r1 ===> Done bulk for jointStateMapper-1.2.1r1 [9%] Processing wip/metapod:metapod-1.0.10 ===> Cleaning temporary files for metapod-1.0.10 ===> Bulk building for metapod-1.0.10 => Checking for clear installation Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package graphviz>=2: graphviz-2.38.0 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | make[1]: *** [tests/spatial/CMakeFiles/test_transform.dir/all] Error 2 | CMakeFiles/Makefile2:866: recipe for target 'tests/spatial/CMakeFiles/test_transform.dir/all' failed | make[2]: *** [tests/spatial/CMakeFiles/test_rotation.dir/test_rotation.cc.o] Error 1 | make[1]: *** [tests/spatial/CMakeFiles/test_rotation.dir/all] Error 2 | tests/spatial/CMakeFiles/test_rotation.dir/build.make:65: recipe for target 'tests/spatial/CMakeFiles/test_rotation.dir/test_rotation.cc.o' failed | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/metapod/work/metapod-1.0.10' | CMakeFiles/Makefile2:829: recipe for target 'tests/spatial/CMakeFiles/test_rotation.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/metapod/work/metapod-1.0.10' | Makefile:165: recipe for target 'all' failed | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/metapod/work/build.log make[3]: *** [do-build] Error 2 => Marking metapod-1.0.10 as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. ===> Logging bulk summary for metapod-1.0.10 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for metapod-1.0.10 ===> Done bulk for metapod-1.0.10 [9%] Processing wip/py-laaswm:py27-laaswm-1.3r1 ===> Bulk building for py27-laaswm-1.3r1 Binary package for py27-laaswm-1.3r1 is up-to-date. [10%] Processing wip/jsbsim:jsbsim-20150424 ===> Bulk building for jsbsim-20150424 Binary package for jsbsim-20150424 is up-to-date. [10%] Processing wip/dptu-genom3:dptu-genom3-0.2~pocolibs-client-c+codels+openprs+pocolibs-server+!* ===> Bulk building for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server Binary package for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server is up-to-date. [11%] Processing wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* ===> Bulk building for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server Binary package for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server is up-to-date. [11%] Processing wip/can-utils:can-utils-20160229 ===> Bulk building for can-utils-20160229 Binary package for can-utils-20160229 is up-to-date. [12%] Processing wip/chilitags:chilitags-1.3.1 ===> Cleaning temporary files for chilitags-1.3.1 ===> Bulk building for chilitags-1.3.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=4.7 => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package g++>=4.7: g++-7 found => Required system package libstdc++: libstdc++ found => Required system package opencv>=2.4: opencv-3.1.0 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | -- Detecting CXX compile features | -- Detecting CXX compile features - done | CMake Error at /usr/share/OpenCV/OpenCVConfig.cmake:232 (message): | opencv_ts is required but was not found | Call Stack (most recent call first): | CMakeLists.txt:9 (find_package) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/chilitags/work/chilitags-1.3.1/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/chilitags/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking chilitags-1.3.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for chilitags-1.3.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for chilitags-1.3.1 ===> Done bulk for chilitags-1.3.1 [12%] Processing wip/hrp2-14-description:hrp2-14-description-1.0.4 ===> Bulk building for hrp2-14-description-1.0.4 Binary package for hrp2-14-description-1.0.4 is up-to-date. [12%] Processing wip/hrp2-computer-monitor:hrp2-computer-monitor-1.0.2 ===> Bulk building for hrp2-computer-monitor-1.0.2 Binary package for hrp2-computer-monitor-1.0.2 is up-to-date. [13%] Processing wip/FRILibrary:FRILibrary-1.2r1 ===> Bulk building for FRILibrary-1.2r1 Binary package for FRILibrary-1.2r1 is up-to-date. [13%] Processing wip/py-hla:py27-hla-1.1.1r1 ===> Cleaning temporary files for py27-hla-1.1.1r1 ===> Bulk building for py27-hla-1.1.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found ERROR: Required robotpkg package certi>=3.4.0: BROKEN => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-hla-1.1.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hla-1.1.1r1 ===> Done bulk for py27-hla-1.1.1r1 [14%] Processing wip/py-hla:py35-hla-1.1.1r1 ===> Cleaning temporary files for py35-hla-1.1.1r1 ===> Bulk building for py35-hla-1.1.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found ERROR: Required robotpkg package certi>=3.4.0: BROKEN => Dependency digest-20080510 already installed => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py35-hla-1.1.1r1: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-hla/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for py35-hla-1.1.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-hla-1.1.1r1 ===> Done bulk for py35-hla-1.1.1r1 [14%] Processing wip/ompl:ompl-1.0.0 ===> Cleaning temporary files for ompl-1.0.0 ===> Bulk building for ompl-1.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.8.7: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.0.0-Source' | [ 72%] Built target test_state_spaces | [ 72%] Linking CXX executable ../bin/test_state_operations | cd /local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.0.0-Source/tests && /usr/bin/cmake -E cmake_link_script CMakeFiles/test_state_operations.dir/link.txt --verbose=1 | /usr/bin/g++ -pipe -O3 -DNDEBUG -O3 -rdynamic CMakeFiles/test_state_operations.dir/base/state_operations.cpp.o -o ../bin/test_state_operations -Wl,-rpath,/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.0.0-Source/lib ../lib/libompl.so.1.0.0 -lboost_date_time -lboost_program_options -lboost_serialization -lboost_filesystem -lboost_system -lboost_unit_test_framework -lboost_thread -lboost_chrono -lpthread -lboost_serialization -lboost_filesystem -lboost_system | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.0.0-Source' | [ 72%] Built target test_state_operations | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/ompl/work/ompl-1.0.0-Source' | make: *** [all] Error 2 | Makefile:165: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/ompl/work/build.log make[3]: *** [do-build] Error 2 => Marking ompl-1.0.0 as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for ompl-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for ompl-1.0.0 ===> Done bulk for ompl-1.0.0 [15%] Processing wip/talos-data:talos-data-0.0.14r5 ===> Bulk building for talos-data-0.0.14r5 Binary package for talos-data-0.0.14r5 is up-to-date. [15%] Processing wip/move3d-assets:move3d-assets-20120125 ===> Bulk building for move3d-assets-20120125 Binary package for move3d-assets-20120125 is up-to-date. [16%] Processing wip/talos-pal-transmissions:talos-pal-transmissions-0.2.3 Display something for talos-ros-controllers /local/robotpkg Display something for talos-ros-controllers /local/robotpkg ===> Cleaning temporary files for talos-pal-transmissions-0.2.3 ===> Bulk building for talos-pal-transmissions-0.2.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing ros-catkin-0.6.9r2.tgz => Installing ros-comm-1.11.20.tgz => Installing ros-common-msgs-1.11.4.tgz => Dependency ros-genmsg-0.5.3 already installed => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing talos-ros-control-0.2.10.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy provided by ros-indigo => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-comm>=1.11<1.12: ros-comm-1.11.20 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => Required robotpkg package talos-ros-control>=0.2: talos-ros-control-0.2.10 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | cmake_modules-config.cmake | | Add the installation prefix of "cmake_modules" to CMAKE_PREFIX_PATH or set | "cmake_modules_DIR" to a directory containing one of the above files. If | "cmake_modules" provides a separate development package or SDK, be sure it | has been installed. | Call Stack (most recent call first): | CMakeLists.txt:5 (find_package) | | For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-transmissions/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking talos-pal-transmissions-0.2.3 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for talos-pal-transmissions-0.2.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata Display something for talos-ros-controllers /local/robotpkg ===> Cleaning temporary files for talos-pal-transmissions-0.2.3 ===> Done bulk for talos-pal-transmissions-0.2.3 [16%] Processing wip/morse-hla:morse-hla-1.4 ===> Cleaning temporary files for morse-hla-1.4 ===> Bulk building for morse-hla-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required robotpkg package morse>=1.0: N/A => Required robotpkg package py35-hla>=1.1.1: N/A => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for morse-hla-1.4: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/morse-hla/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for morse-hla-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for morse-hla-1.4 ===> Done bulk for morse-hla-1.4 [17%] Processing wip/track-target-genom:track-target-genom-0.2r1 ===> Bulk building for track-target-genom-0.2r1~openprs+tcl+tclserv_client Binary package for track-target-genom-0.2r1~openprs+tcl+tclserv_client is up-to-date. [17%] Processing wip/hrp2-bringup:hrp2-bringup-1.0.6 ===> Bulk building for hrp2-bringup-1.0.6 Binary package for hrp2-bringup-1.0.6 is up-to-date. [18%] Processing wip/hyper:hyper-0.13r1 ===> Cleaning temporary files for hyper-0.13r1 ===> Bulk building for hyper-0.13r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.46.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.46.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.46.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.46.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.46.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for hyper-0.13r1 An unexpected error occured. The last 10 log lines are shown below. | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | compilation terminated. | make[2]: *** [CMakeFiles/hyper_logic.dir/src/logic/backward_chaining.cc.o] Error 1 | make[1]: *** [CMakeFiles/hyper_logic.dir/all] Error 2 | make: *** [all] Error 2 | CMakeFiles/hyper_logic.dir/build.make:65: recipe for target 'CMakeFiles/hyper_logic.dir/src/logic/backward_chaining.cc.o' failed | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/hyper/work/hyper-0.13' | CMakeFiles/Makefile2:1530: recipe for target 'CMakeFiles/hyper_logic.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/hyper/work/hyper-0.13' | Makefile:143: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/hyper/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking hyper-0.13r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for hyper-0.13r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hyper-0.13r1 ===> Done bulk for hyper-0.13r1 [18%] Processing wip/gerard-bauzil:gerard-bauzil-1.0.1 ===> Bulk building for gerard-bauzil-1.0.1 Binary package for gerard-bauzil-1.0.1 is up-to-date. [18%] Processing wip/urg:urg-0.8.18 ===> Bulk building for urg-0.8.18 Binary package for urg-0.8.18 is up-to-date. [19%] Processing wip/jafar-qdisplay:jafar-qdisplay-0.2r1 ===> Cleaning temporary files for jafar-qdisplay-0.2r1 ===> Bulk building for jafar-qdisplay-0.2r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Installing boost-numeric-bindings-20101109.tgz => Dependency digest-20080510 already installed => Required robotpkg package jafar-image>=2.1: N/A => Installing jafar-jmath-0.5.tgz => Dependency jafar-kernel-0.6r1 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jafar-qdisplay-0.2r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jafar-qdisplay-0.2r1 ===> Done bulk for jafar-qdisplay-0.2r1 [19%] Processing wip/spark-genom:spark-genom-3.9 ===> Cleaning temporary files for spark-genom-3.9~mightability+openprs+tcl+tclserv_client ===> Bulk building for spark-genom-3.9~mightability+openprs+tcl+tclserv_client => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing genBasic-genom-0.4r1~openprs+tcl+tclserv_client.tgz => Installing genHum-genom-1.1r1~openprs+tcl+tclserv_client.tgz => Installing genManip-genom-0.9~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed ERROR: Required robotpkg package libmove3d>=3.22.0: BROKEN ERROR: Required robotpkg package libmove3d-hri>=2.24: BROKEN => Installing libt3d-2.6~doc.tgz => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Installing mocap-genom-1.3~openprs+tcl+tclserv_client.tgz => Installing niut-genom-0.6~openprs+tcl+tclserv_client.tgz => Dependency pocolibs-2.16 already installed => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Required robotpkg package viman-genom>=1.4: N/A ===> Logging bulk summary for spark-genom-3.9~mightability+openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for spark-genom-3.9~mightability+openprs+tcl+tclserv_client ===> Done bulk for spark-genom-3.9~mightability+openprs+tcl+tclserv_client [20%] Processing wip/dynamic-graph-v3:dynamic-graph-v3-3.0.1 ===> Bulk building for dynamic-graph-v3-3.0.1 Binary package for dynamic-graph-v3-3.0.1 is up-to-date. [20%] Processing wip/histodet:histodet-1.0r2 ===> Bulk building for histodet-1.0r2 Binary package for histodet-1.0r2 is up-to-date. [21%] Processing wip/MPC_DEMTreatment-genom:MPC_DEMTreatment-genom-0.2 ===> Cleaning temporary files for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client ===> Bulk building for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client => Checking for clear installation Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. ERROR: Required robotpkg package MPC>=1.0: BROKEN => Dependency digest-20080510 already installed => Installing dtm-genom-1.5~openprs+tcl+tclserv_client.tgz => Dependency genBasic-genom-0.4r1~openprs+tcl+tclserv_client already installed => Dependency genPos-genom-0.3r1~openprs+tcl+tclserv_client already installed => Dependency genom-2.12~doc already installed => Dependency libt3d-2.6~doc already installed => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Dependency stereopixel-genom-1.3~openprs+tcl+tclserv_client already installed => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Dependency velodyne-genom-1.6~openprs+tcl+tclserv_client already installed Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. ===> Logging bulk summary for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client ===> Done bulk for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client [21%] Processing wip/talos-pal-hardware-interfaces:talos-pal-hardware-interfaces-0.0.3 ===> Bulk building for talos-pal-hardware-interfaces-0.0.3 Binary package for talos-pal-hardware-interfaces-0.0.3 is up-to-date. [22%] Processing wip/octovis:octoviz-1.6.1 ===> Cleaning temporary files for octoviz-1.6.1 ===> Bulk building for octoviz-1.6.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required system package libqglviewer>=2.3: MISSING => Installing octomap-1.6.1.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for octoviz-1.6.1: ERROR: ERROR: libqglviewer>=2.3 (Ubuntu package libqglviewer-qt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/octovis/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for octoviz-1.6.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for octoviz-1.6.1 ===> Done bulk for octoviz-1.6.1 [22%] Processing wip/sot-application:sot-application-1.0.0r1 ===> Bulk building for sot-application-1.0.0r1 Binary package for sot-application-1.0.0r1 is up-to-date. [23%] Processing wip/mrpt:mrpt-1.2.2r2 ===> Cleaning temporary files for mrpt-1.2.2r2 ===> Bulk building for mrpt-1.2.2r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package assimp>=2.0: assimp-3.3.1 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package freeglut: freeglut found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libjpeg: libjpeg found => Required system package libstdc++: libstdc++ found => Required system package opencv>=2.2.0: opencv-3.1.0 found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package podlators: podlators found => Required system package wxwidgets>=2.8: wxwidgets-3.0.3 found => Required system package zlib>=1.2.3: zlib-1.2.11 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for mrpt-1.2.2r2 An unexpected error occured. The last 10 log lines are shown below. | -- Phidgets : No | -- RoboPeak LIDAR : Yes | -- SwissRanger 3/4000 3D camera : No | -- Videre SVS stereo camera : No | -- xSENS MT 3rd generation : Yes (Built-in) | -- xSENS MT 4th generation : Yes (Built-in) | -- | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/mrpt/work/mrpt-1.2.2/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/mrpt/work/mrpt-1.2.2/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/mrpt/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking mrpt-1.2.2r2 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for mrpt-1.2.2r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for mrpt-1.2.2r2 ===> Done bulk for mrpt-1.2.2r2 [23%] Processing wip/vnet-yarp:vnet-yarp-0.2r2 ===> Cleaning temporary files for vnet-yarp-0.2r2 ===> Bulk building for vnet-yarp-0.2r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Required robotpkg package ace>=5.6: NOT found ERROR: Required robotpkg package ace>=5.6: NOT found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Required robotpkg package yarp>=2.3.1: NOT found ERROR: Required robotpkg package yarp>=2.3.1: NOT found ===> Logging bulk summary for vnet-yarp-0.2r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for vnet-yarp-0.2r2 ===> Done bulk for vnet-yarp-0.2r2 [24%] Processing wip/py-eigen:eigenpy-1.4.0r2 ===> Bulk building for eigenpy-1.4.0r2 Binary package for eigenpy-1.4.0r2 is up-to-date. [24%] Processing wip/py-morse:py35-morse-1.4 ===> Cleaning temporary files for py35-morse-1.4 ===> Bulk building for py35-morse-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py35-morse-1.4: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-morse/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for py35-morse-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-morse-1.4 ===> Done bulk for py35-morse-1.4 [25%] Processing wip/simple-humanoid-description:simple-humanoid-description-1.0.1 ===> Bulk building for simple-humanoid-description-1.0.1 Binary package for simple-humanoid-description-1.0.1 is up-to-date. [25%] Processing wip/MPC_planner-genom:MPC_planner-genom-0.2r1 ===> Cleaning temporary files for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client ===> Bulk building for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client => Checking for clear installation Warning: the LICENSE of wip/MPC_planner-genom is undefined. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/MPC_planner-genom is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found Warning: the LICENSE of wip/MPC_planner-genom is undefined. Warning: the LICENSE of wip/MPC_planner-genom is undefined. ERROR: Required robotpkg package MPC>=1.0: BROKEN => Dependency digest-20080510 already installed => Installing dtm-genom-1.5~openprs+tcl+tclserv_client.tgz => Dependency genBasic-genom-0.4r1~openprs+tcl+tclserv_client already installed => Dependency genPos-genom-0.3r1~openprs+tcl+tclserv_client already installed => Dependency genom-2.12~doc already installed => Dependency libt3d-2.6~doc already installed => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Dependency stereopixel-genom-1.3~openprs+tcl+tclserv_client already installed => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Dependency velodyne-genom-1.6~openprs+tcl+tclserv_client already installed Warning: the LICENSE of wip/MPC_planner-genom is undefined. Warning: the LICENSE of wip/MPC_planner-genom is undefined. ===> Logging bulk summary for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client ===> Done bulk for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client [25%] Processing wip/soth:soth-2.0.1r1 ===> Cleaning temporary files for soth-2.0.1r1 ===> Bulk building for soth-2.0.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | && int(InnerSize) * (int(DstEvaluator::CoeffReadCost)+int(SrcEvaluator::CoeffReadCost)) <= int(UnrollingLimit) | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | make[2]: *** [src/CMakeFiles/soth.dir/HCOD.cpp.o] Error 1 | make[1]: *** [src/CMakeFiles/soth.dir/all] Error 2 | src/CMakeFiles/soth.dir/build.make:161: recipe for target 'src/CMakeFiles/soth.dir/HCOD.cpp.o' failed | make: *** [all] Error 2 | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/soth/work/soth-2.0.1' | CMakeFiles/Makefile2:504: recipe for target 'src/CMakeFiles/soth.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/soth/work/soth-2.0.1' | Makefile:165: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/soth/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking soth-2.0.1r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for soth-2.0.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for soth-2.0.1r1 ===> Done bulk for soth-2.0.1r1 [26%] Processing wip/libmove3d-planners:libmove3d-planners-1.4.0 ===> Cleaning temporary files for libmove3d-planners-1.4.0 ===> Bulk building for libmove3d-planners-1.4.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found WARNING: Cannot check installed version of boost-lib-filesystem WARNING: Cannot check installed version of boost-lib-iostreams WARNING: Cannot check installed version of boost-lib-math WARNING: Cannot check installed version of boost-lib-thread => Dependency digest-20080510 already installed WARNING: Cannot check installed version of libXpm ERROR: Required robotpkg package libmove3d>=3.22.0: BROKEN ERROR: Required robotpkg package libmove3d-hri>=2.24: BROKEN => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of boost-lib-filesystem WARNING: Cannot check installed version of boost-lib-iostreams WARNING: Cannot check installed version of boost-lib-math WARNING: Cannot check installed version of boost-lib-thread WARNING: Cannot check installed version of libXpm ===> Logging bulk summary for libmove3d-planners-1.4.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libmove3d-planners-1.4.0 ===> Done bulk for libmove3d-planners-1.4.0 [26%] Processing wip/kukaFri-libs:kukaFri-libs-1.3 ===> Bulk building for kukaFri-libs-1.3 Binary package for kukaFri-libs-1.3 is up-to-date. [27%] Processing wip/talos-ros-controllers:talos-ros-controllers-0.2.11 ===> Cleaning temporary files for talos-ros-controllers-0.2.11 ===> Bulk building for talos-ros-controllers-0.2.11 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-msgs-1.3.1.tgz => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Installing ros-robot-model-1.11.5.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing ros-xacro-1.9.2.tgz => Installing talos-pal-hardware-interfaces-0.0.3.tgz => Dependency talos-ros-control-0.2.10 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy ros>=hydro provided by ros-indigo => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required robotpkg package ros-actionlib>=1.11<1.12: ros-actionlib-1.11.9 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-comm>=1.11<1.12: ros-comm-1.11.20 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-control-msgs>=1.3<1.4: ros-control-msgs-1.3.1 found => Required robotpkg package ros-control-toolbox>=1.13<1.15: ros-control-toolbox-1.13.2r1 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-geometry>=1.11<1.12: ros-geometry-1.11.3r1 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-pluginlib>=1.10<1.11: ros-pluginlib-1.10.1 found => Required robotpkg package ros-robot-model>=1.11<1.12: ros-robot-model-1.11.5 found => Required robotpkg package ros-ros>=1.11<1.12: ros-ros-1.11.4 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => Required robotpkg package ros-xacro>=1.9<1.10: ros-xacro-1.9.2 found => Required robotpkg package talos-pal-hardware-interfaces>=0.0.2: talos-pal-hardware-interfaces-0.0.3 found => Required robotpkg package talos-ros-control>=0.2: talos-ros-control-0.2.10 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | "cmake_modules_DIR" to a directory containing one of the above files. If | "cmake_modules" provides a separate development package or SDK, be sure it | has been installed. | Call Stack (most recent call first): | talos_joint_trajectory_controller/CMakeLists.txt:51 (find_package) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/talos-ros-controllers/work/talos_ros_controllers-0.2.11/build/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/talos-ros-controllers/work/talos_ros_controllers-0.2.11/build/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-ros-controllers/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking talos-ros-controllers-0.2.11 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for talos-ros-controllers-0.2.11 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-ros-controllers-0.2.11 ===> Done bulk for talos-ros-controllers-0.2.11 [27%] Processing wip/orocos-bfl:orocos-bfl-0.8.0 ===> Bulk building for orocos-bfl-0.8.0 Binary package for orocos-bfl-0.8.0 is up-to-date. [28%] Processing wip/laaswm-gui:laaswm-gui-1.4 ===> Bulk building for laaswm-gui-1.4 Binary package for laaswm-gui-1.4 is up-to-date. [28%] Processing wip/osg-dae:osg-dae-3.2.1r1 ===> Bulk building for osg-dae-3.2.1r1 Binary package for osg-dae-3.2.1r1 is up-to-date. [29%] Processing wip/morse-pocolibs:morse-pocolibs-1.4 ===> Cleaning temporary files for morse-pocolibs-1.4 ===> Bulk building for morse-pocolibs-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required robotpkg package morse>=1.0: N/A => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for morse-pocolibs-1.4: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/morse-pocolibs/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for morse-pocolibs-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for morse-pocolibs-1.4 ===> Done bulk for morse-pocolibs-1.4 [29%] Processing wip/py-jsbsim:py27-jsbsim-20150424r1 ===> Cleaning temporary files for py27-jsbsim-20150424r1 ===> Bulk building for py27-jsbsim-20150424r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package cvs>=1: cvs-1.12.1324 found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing jsbsim-20150424.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required robotpkg package jsbsim>=1.0: jsbsim-20150424 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | Could NOT find Cython (missing: CYTHON_EXECUTABLE) | Call Stack (most recent call first): | /usr/share/cmake-3.9/Modules/FindPackageHandleStandardArgs.cmake:377 (_FPHSA_FAILURE_MESSAGE) | CMakeModules/FindCython.cmake:42 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | CMakeModules/UseCython.cmake:74 (find_package) | CMakeLists.txt:6 (include) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/jsbsim-20150424/tests/CMakeFiles/CMakeOutput.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking py27-jsbsim-20150424r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py27-jsbsim-20150424r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-jsbsim-20150424r1 ===> Done bulk for py27-jsbsim-20150424r1 [30%] Processing wip/py-jsbsim:py35-jsbsim-20150424r1 ===> Cleaning temporary files for py35-jsbsim-20150424r1 ===> Bulk building for py35-jsbsim-20150424r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package cvs>=1: cvs-1.12.1324 found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing jsbsim-20150424.tgz => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for py35-jsbsim-20150424r1: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for py35-jsbsim-20150424r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py35-jsbsim-20150424r1 ===> Done bulk for py35-jsbsim-20150424r1 [30%] Processing wip/msgconnector:msgconnector-2.13.0 ===> Cleaning temporary files for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp ===> Bulk building for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Required robotpkg package ace>=5.6: NOT found ERROR: Required robotpkg package ace>=5.6: NOT found => Dependency digest-20080510 already installed => Installing libhatp-1.3.0.tgz => Installing liboro-1.1r1~doc.tgz => Installing openprs-1.1b10.tgz => Dependency tnftp-20130505~ssl already installed => Required robotpkg package yarp>=2.3.1: NOT found ERROR: Required robotpkg package yarp>=2.3.1: NOT found ===> Logging bulk summary for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp ===> Done bulk for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp [31%] Processing wip/gladys:gladys-0.2.8 ===> Bulk building for gladys-0.2.8~python Binary package for gladys-0.2.8~python is up-to-date. [31%] Processing wip/lua-rfsm:lua-rfsm-20131212.44fcec2db5r2 ===> Bulk building for lua-rfsm-20131212.44fcec2db5r2 Binary package for lua-rfsm-20131212.44fcec2db5r2 is up-to-date. [31%] Processing wip/roralink:roralink-0.1 ===> Bulk building for roralink-0.1 Binary package for roralink-0.1 is up-to-date. [32%] Processing wip/morse-mavlink:morse-mavlink-1.4 ===> Cleaning temporary files for morse-mavlink-1.4 ===> Bulk building for morse-mavlink-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing mavlink-20150929.tgz => Required robotpkg package morse>=1.0: N/A => Required robotpkg package py35-mavlink>=1.1.62: N/A => Required system package python35>=3.5<3.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for morse-mavlink-1.4: ERROR: ERROR: python35>=3.5<3.6 (Ubuntu package python3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/morse-mavlink/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for morse-mavlink-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for morse-mavlink-1.4 ===> Done bulk for morse-mavlink-1.4 [32%] Processing wip/pal-msgs:pal-msgs-0.11.3 ===> Cleaning temporary files for pal-msgs-0.11.3 ===> Bulk building for pal-msgs-0.11.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing py27-rospkg-1.0.29r1.tgz => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Installing ros-cmake-modules-0.3.1.tgz => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy ros>=hydro provided by ros-indigo => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required robotpkg package py27-rospkg>=1.0.29: py27-rospkg-1.0.29r1 found => Required robotpkg package ros-actionlib>=1.11<1.12: ros-actionlib-1.11.9 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-cmake-modules>=0.3: ros-cmake-modules-0.3.1 found => Required robotpkg package ros-comm>=1.11<1.12: ros-comm-1.11.20 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-control-toolbox>=1.13<1.15: ros-control-toolbox-1.13.2r1 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-geometry>=1.11<1.12: ros-geometry-1.11.3r1 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-pluginlib>=1.10<1.11: ros-pluginlib-1.10.1 found => Required robotpkg package ros-ros>=1.11<1.12: ros-ros-1.11.4 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | set "humanoid_nav_msgs_DIR" to a directory containing one of the above | files. If "humanoid_nav_msgs" provides a separate development package or | SDK, be sure it has been installed. | Call Stack (most recent call first): | pal_walking_msgs/CMakeLists.txt:4 (find_package) | | | -- Configuring incomplete, errors occurred! | See also "/local/robotpkg/var/tmp/robotpkg/wip/pal-msgs/work/pal_msgs-0.11.3/build/CMakeFiles/CMakeOutput.log". | See also "/local/robotpkg/var/tmp/robotpkg/wip/pal-msgs/work/pal_msgs-0.11.3/build/CMakeFiles/CMakeError.log". For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/pal-msgs/work/configure.log make[3]: *** [do-configure-cmake] Error 1 => Marking pal-msgs-0.11.3 as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for pal-msgs-0.11.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for pal-msgs-0.11.3 ===> Done bulk for pal-msgs-0.11.3 [33%] Processing wip/antlr2:antlr2-2.7.7 ===> Bulk building for antlr2-2.7.7 Binary package for antlr2-2.7.7 is up-to-date. [33%] Processing wip/talos-moveit-config:talos-moveit-config-0.2.3 ===> Bulk building for talos-moveit-config-0.2.3 Binary package for talos-moveit-config-0.2.3 is up-to-date. [34%] Processing wip/parametric-curves:parametric-curves-1.0.1 ===> Bulk building for parametric-curves-1.0.1 Binary package for parametric-curves-1.0.1 is up-to-date. [34%] Processing wip/libfreenect:libfreenect-20110118.2ea3ebr1 ===> Cleaning temporary files for libfreenect-20110118.2ea3ebr1 ===> Bulk building for libfreenect-20110118.2ea3ebr1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.14.1 found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package A BSD-compatible install program: install-sh found => Required system package libXmu>=1: libXmu-1.1.2 found => Required system package libstdc++: libstdc++ found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for libfreenect-20110118.2ea3ebr1 An unexpected error occured. The last 10 log lines are shown below. | m_devices.insert(std::make_pair(_index, device)); | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~ | wrappers/cpp/CMakeFiles/cppview.dir/build.make:65: recipe for target 'wrappers/cpp/CMakeFiles/cppview.dir/cppview.cpp.o' failed | make[2]: *** [wrappers/cpp/CMakeFiles/cppview.dir/cppview.cpp.o] Error 1 | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libfreenect/work/libfreenect-20110118.2ea3eb' | CMakeFiles/Makefile2:537: recipe for target 'wrappers/cpp/CMakeFiles/cppview.dir/all' failed | make[1]: *** [wrappers/cpp/CMakeFiles/cppview.dir/all] Error 2 | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libfreenect/work/libfreenect-20110118.2ea3eb' | Makefile:132: recipe for target 'all' failed | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/libfreenect/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking libfreenect-20110118.2ea3ebr1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for libfreenect-20110118.2ea3ebr1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libfreenect-20110118.2ea3ebr1 ===> Done bulk for libfreenect-20110118.2ea3ebr1 [35%] Processing wip/robotModelParser-libs:robotModelParser-libs-1.0 ===> Bulk building for robotModelParser-libs-1.0 Binary package for robotModelParser-libs-1.0 is up-to-date. [35%] Processing wip/orocos-yarp_transport:orocos-yarp_transport-20150316 ===> Cleaning temporary files for orocos-yarp_transport-20150316~doc ===> Bulk building for orocos-yarp_transport-20150316~doc => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-2.14.1 found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Required robotpkg package ace>=5.6: NOT found ERROR: Required robotpkg package ace>=5.6: NOT found => Dependency digest-20080510 already installed WARNING: Cannot check installed version of docbook => Required robotpkg package orocos-rtt>=2.5: NOT found ERROR: Required robotpkg package orocos-rtt>=2.5: NOT found => Dependency tnftp-20130505~ssl already installed => Required robotpkg package yarp>=2.2: NOT found ERROR: Required robotpkg package yarp>=2.2: NOT found WARNING: Cannot check installed version of docbook ===> Logging bulk summary for orocos-yarp_transport-20150316~doc => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for orocos-yarp_transport-20150316~doc ===> Done bulk for orocos-yarp_transport-20150316~doc [36%] Processing wip/atlaas:atlaas-0.1.6 ===> Bulk building for atlaas-0.1.6 Binary package for atlaas-0.1.6 is up-to-date. [36%] Processing wip/ur5-description:ur5-description-1.0.0 ===> Bulk building for ur5-description-1.0.0 Binary package for ur5-description-1.0.0 is up-to-date. [37%] Processing wip/talos-robot:talos-robot-0.0.14r1 ===> Bulk building for talos-robot-0.0.14r1 Binary package for talos-robot-0.0.14r1 is up-to-date. [37%] Processing wip/libnabo:libnabo-1.0.4 ===> Bulk building for libnabo-1.0.4 Binary package for libnabo-1.0.4 is up-to-date. [37%] Processing wip/py-dynamic-graph-v3:py27-dynamic-graph-v3-3.0.2 ===> Bulk building for py27-dynamic-graph-v3-3.0.2 Binary package for py27-dynamic-graph-v3-3.0.2 is up-to-date. [38%] Processing wip/hatponboard-lib:hatponboard-lib-3.4.0 ===> Cleaning temporary files for hatponboard-lib-3.4.0~enable-goal ===> Bulk building for hatponboard-lib-3.4.0~enable-goal => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found WARNING: Cannot check installed version of antlr2 => Dependency digest-20080510 already installed ERROR: Required robotpkg package msgconnector>=2.13.0: BROKEN => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of antlr2 ===> Logging bulk summary for hatponboard-lib-3.4.0~enable-goal => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hatponboard-lib-3.4.0~enable-goal ===> Done bulk for hatponboard-lib-3.4.0~enable-goal [38%] Processing wip/talos-gazebo-ros-control:talos-gazebo-ros-control-2.6.6 ===> Cleaning temporary files for talos-gazebo-ros-control-2.6.6 ===> Bulk building for talos-gazebo-ros-control-2.6.6 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Installing ros-robot-model-1.11.5.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing talos-ros-control-0.2.10.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy ros>=hydro provided by ros-indigo => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gazebo>=1: gazebo-7.5.0 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libogre>=1.0: libogre-1.9.0 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required robotpkg package ros-actionlib>=1.11<1.12: ros-actionlib-1.11.9 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-comm>=1.11<1.12: ros-comm-1.11.20 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-control-toolbox>=1.13<1.15: ros-control-toolbox-1.13.2r1 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-geometry>=1.11<1.12: ros-geometry-1.11.3r1 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-pluginlib>=1.10<1.11: ros-pluginlib-1.10.1 found => Required robotpkg package ros-robot-model>=1.11<1.12: ros-robot-model-1.11.5 found => Required robotpkg package ros-ros>=1.11<1.12: ros-ros-1.11.4 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => Required robotpkg package talos-ros-control>=0.2: talos-ros-control-0.2.10 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | [ 87%] Built target talos_gazebo_ros_control | make[2]: *** [CMakeFiles/talos_default_robot_hw_sim.dir/src/internal/velocity_joint.cpp.o] Error 1 | CMakeFiles/talos_default_robot_hw_sim.dir/build.make:137: recipe for target 'CMakeFiles/talos_default_robot_hw_sim.dir/src/internal/velocity_joint.cpp.o' failed | make[2]: *** Waiting for unfinished jobs.... | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/talos_gazebo_ros_control-2.6.6' | make[1]: *** [CMakeFiles/talos_default_robot_hw_sim.dir/all] Error 2 | make: *** [all] Error 2 | CMakeFiles/Makefile2:299: recipe for target 'CMakeFiles/talos_default_robot_hw_sim.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/talos_gazebo_ros_control-2.6.6' | Makefile:132: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 => Marking talos-gazebo-ros-control-2.6.6 as broken ===> Logging bulk summary for talos-gazebo-ros-control-2.6.6 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-gazebo-ros-control-2.6.6 ===> Done bulk for talos-gazebo-ros-control-2.6.6 [39%] Processing wip/orocos-dot_service:orocos-dot_service-20120308 ===> Cleaning temporary files for orocos-dot_service-20120308 ===> Bulk building for orocos-dot_service-20120308 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Required robotpkg package orocos-rtt>=2: NOT found ERROR: Required robotpkg package orocos-rtt>=2: NOT found => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for orocos-dot_service-20120308 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for orocos-dot_service-20120308 ===> Done bulk for orocos-dot_service-20120308 [39%] Processing wip/talos-roboticsgroup-gazebo-plugins:talos-roboticsgroup-gazebo-plugins-0.0.3 ===> Cleaning temporary files for talos-roboticsgroup-gazebo-plugins-0.0.3 ===> Bulk building for talos-roboticsgroup-gazebo-plugins-0.0.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing gazebo-ros-pkgs-2.4.13r1.tgz => Dependency ros-actionlib-1.11.9 already installed => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Dependency ros-control-toolbox-1.13.2r1 already installed => Dependency ros-genmsg-0.5.3 already installed => Dependency ros-geometry-1.11.3r1 already installed => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-pluginlib-1.10.1 already installed => Dependency ros-robot-model-1.11.5 already installed => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing talos-pal-hardware-interfaces-0.0.3.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros indigo: ros>=groovy ros>=hydro ros>=hydro provided by ros-indigo => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.8.3: cmake-3.9.1 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gazebo>=1: gazebo-7.5.0 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py27-nose>=0.10: py27-nose-1.3.7 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required robotpkg package gazebo-ros-pkgs>=2.4<2.5: gazebo-ros-pkgs-2.4.13r1 found => Required robotpkg package ros-actionlib>=1.11<1.12: ros-actionlib-1.11.9 found => Required robotpkg package ros-catkin>=0.6<0.7: ros-catkin-0.6.9r2 found => Required robotpkg package ros-comm>=1.11<1.12: ros-comm-1.11.20 found => Required robotpkg package ros-common-msgs>=1.11<1.12: ros-common-msgs-1.11.4 found => Required robotpkg package ros-control-toolbox>=1.13<1.15: ros-control-toolbox-1.13.2r1 found => Required robotpkg package ros-genmsg>=0.5<0.6: ros-genmsg-0.5.3 found => Required robotpkg package ros-geometry>=1.11<1.12: ros-geometry-1.11.3r1 found => Required robotpkg package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required robotpkg package ros-message-runtime>=0.4<0.5: ros-message-runtime-0.4.12 found => Required robotpkg package ros-pluginlib>=1.10<1.11: ros-pluginlib-1.10.1 found => Required robotpkg package ros-robot-model>=1.11<1.12: ros-robot-model-1.11.5 found => Required robotpkg package ros-ros>=1.11<1.12: ros-ros-1.11.4 found => Required robotpkg package ros-std-msgs>=0.5: ros-std-msgs-0.5.9 found => Required robotpkg package talos-pal-hardware-interfaces>=0.0.2: talos-pal-hardware-interfaces-0.0.3 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | make[1]: *** [CMakeFiles/talos_roboticsgroup_gazebo_mimic_joint_plugin.dir/all] Error 2 | make[1]: *** Waiting for unfinished jobs.... | [ 75%] Linking CXX shared library /local/robotpkg/var/tmp/robotpkg/wip/talos-roboticsgroup-gazebo-plugins/work/stage/lib/libtalos_roboticsgroup_gazebo_disable_link_plugin.so | /usr/bin/cmake -E cmake_link_script CMakeFiles/talos_roboticsgroup_gazebo_disable_link_plugin.dir/link.txt --verbose=1 | /usr/bin/g++ -fPIC -pipe -O3 -DNDEBUG -Wl,-rpath,/opt/openrobots/lib -shared -Wl,-soname,libtalos_roboticsgroup_gazebo_disable_link_plugin.so -o /local/robotpkg/var/tmp/robotpkg/wip/talos-roboticsgroup-gazebo-plugins/work/stage/lib/libtalos_roboticsgroup_gazebo_disable_link_plugin.so CMakeFiles/talos_roboticsgroup_gazebo_disable_link_plugin.dir/src/disable_link_plugin.cpp.o -L/usr/lib/x86_64-linux-gnu/gazebo-7/plugins -Wl,-rpath,/usr/lib/x86_64-linux-gnu/gazebo-7/plugins:/opt/openrobots/lib: /opt/openrobots/lib/libgazebo_ros_api_plugin.so /opt/openrobots/lib/libgazebo_ros_paths_plugin.so /opt/openrobots/lib/libroslib.so /opt/openrobots/lib/libtf.so /opt/openrobots/lib/libtf2_ros.so /opt/openrobots/lib/libactionlib.so /opt/openrobots/lib/libmessage_filters.so /opt/openrobots/lib/libtf2.so /opt/openrobots/lib/libcontrol_toolbox.so -ltinyxml /opt/openrobots/lib/libdynamic_reconfigure_config_init_mutex.so /opt/openrobots/lib/librealtime_tools.so /opt/openrobots/lib/libroscpp.so -lboost_signals -lboost_filesystem /opt/openrobots/lib/librosconsole.so /opt/openrobots/lib/librosconsole_log4cxx.so /opt/openrobots/lib/librosconsole_backend_interface.so -llog4cxx -lboost_regex /opt/openrobots/lib/libxmlrpcpp.so /opt/openrobots/lib/libroscpp_serialization.so /opt/openrobots/lib/librostime.so /opt/openrobots/lib/libcpp_common.so -lboost_system -lboost_thread -lboost_chrono -lboost_date_time -lboost_atomic -lpthread -lconsole_bridge -lgazebo -lgazebo_client -lgazebo_gui -lgazebo_sensors -lgazebo_rendering -lgazebo_physics -lgazebo_ode -lgazebo_transport -lgazebo_msgs -lgazebo_util -lgazebo_common -lgazebo_gimpact -lgazebo_opcode -lgazebo_opende_ou -lgazebo_math -lboost_thread -lboost_signals -lboost_system -lboost_filesystem -lboost_program_options -lboost_regex -lboost_iostreams -lboost_date_time -lboost_chrono -lboost_atomic -lpthread -lprotobuf -lpthread -lsdformat -lignition-math2 -lOgreMain -lboost_thread -lboost_date_time -lboost_system -lboost_atomic -lboost_chrono -lboost_chrono -lpthread -lOgreTerrain -lOgrePaging -lignition-math2 -lboost_signals -lboost_filesystem /opt/openrobots/lib/librosconsole.so /opt/openrobots/lib/librosconsole_log4cxx.so /opt/openrobots/lib/librosconsole_backend_interface.so -llog4cxx -lboost_regex /opt/openrobots/lib/libxmlrpcpp.so /opt/openrobots/lib/libroscpp_serialization.so /opt/openrobots/lib/librostime.so /opt/openrobots/lib/libcpp_common.so -lboost_system -lboost_thread -lboost_chrono -lboost_date_time -lboost_atomic -lpthread -lconsole_bridge -lgazebo -lgazebo_client -lgazebo_gui -lgazebo_sensors -lgazebo_rendering -lgazebo_physics -lgazebo_ode -lgazebo_transport -lgazebo_msgs -lgazebo_util -lgazebo_common -lgazebo_gimpact -lgazebo_opcode -lgazebo_opende_ou -lgazebo_math -lboost_program_options -lboost_iostreams -lprotobuf -lpthread -lsdformat -lOgreMain -lOgreTerrain -lOgrePaging | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/talos-roboticsgroup-gazebo-plugins/work/talos_roboticsgroup_gazebo_plugins-0.0.3' | [ 75%] Built target talos_roboticsgroup_gazebo_disable_link_plugin | make: *** [all] Error 2 => Marking talos-roboticsgroup-gazebo-plugins-0.0.3 as broken | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/talos-roboticsgroup-gazebo-plugins/work/talos_roboticsgroup_gazebo_plugins-0.0.3' | Makefile:132: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-roboticsgroup-gazebo-plugins/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for talos-roboticsgroup-gazebo-plugins-0.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-roboticsgroup-gazebo-plugins-0.0.3 ===> Done bulk for talos-roboticsgroup-gazebo-plugins-0.0.3 [40%] Processing wip/sot-dyninv:sot-dyninv-2.0.0 ===> Cleaning temporary files for sot-dyninv-2.0.0 ===> Bulk building for sot-dyninv-2.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing jrl-mal-1.19.6r1~jrl-mathtools.tgz => Installing py27-dynamic-graph-2.5.6r1.tgz => Installing sot-core-2.9.10.tgz ERROR: Required robotpkg package soth>=2.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-dyninv-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-dyninv-2.0.0 ===> Done bulk for sot-dyninv-2.0.0 [40%] Processing wip/mhp-genom:mhp-genom-3.15 ===> Cleaning temporary files for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client ===> Bulk building for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing gbM-0.11~tcl.tgz => Installing genManip-genom-0.9~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed ERROR: Required robotpkg package libmove3d>=3.22.0: BROKEN ERROR: Required robotpkg package libmove3d-hri>=2.24: BROKEN => Installing libt3d-2.6~doc.tgz => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz => Required robotpkg package spark-genom>=3.9: N/A => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed ===> Logging bulk summary for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client ===> Done bulk for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client [41%] Processing wip/libpointmatcher:libpointmatcher-1.1.0 ===> Cleaning temporary files for libpointmatcher-1.1.0 ===> Bulk building for libpointmatcher-1.1.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing libnabo-1.0.4.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package googletest: googletest found => Required system package latex>=3.14: latex-3.14159265 found => Required system package libstdc++: libstdc++ found => Required system package ncurses>=5: ncurses-6.0 found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package yaml-cpp>=0.2: yaml-cpp-0.5.2 found => Required robotpkg package libnabo>=1.0.4: libnabo-1.0.4 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for libpointmatcher-1.1.0 An unexpected error occured. The last 10 log lines are shown below. | MaySliceVectorize = bool(MightVectorize) && bool(DstHasDirectAccess) | ^~~~~~~~~~~~~~~~~~~~~~~~ | make[2]: *** [CMakeFiles/pointmatcher.dir/pointmatcher/DataPoints.cpp.o] Error 1 | make[1]: *** [CMakeFiles/pointmatcher.dir/all] Error 2 | CMakeFiles/pointmatcher.dir/build.make:113: recipe for target 'CMakeFiles/pointmatcher.dir/pointmatcher/DataPoints.cpp.o' failed | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libpointmatcher/work/libpointmatcher-1.1.0' | CMakeFiles/Makefile2:134: recipe for target 'CMakeFiles/pointmatcher.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/libpointmatcher/work/libpointmatcher-1.1.0' | Makefile:143: recipe for target 'all' failed | make: *** [all] Error 2 => Marking libpointmatcher-1.1.0 as broken For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/libpointmatcher/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for libpointmatcher-1.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libpointmatcher-1.1.0 ===> Done bulk for libpointmatcher-1.1.0 [41%] Processing wip/pinocchio:pinocchio-1.2.6r1 ===> Bulk building for pinocchio-1.2.6r1 Binary package for pinocchio-1.2.6r1 is up-to-date. [42%] Processing wip/talos-pal-gazebo-plugins:talos-pal-gazebo-plugins-1.1.5r2 ===> Cleaning temporary files for talos-pal-gazebo-plugins-1.1.5r2 ===> Bulk building for talos-pal-gazebo-plugins-1.1.5r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package pal-msgs>=0.11.3: BROKEN => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Installing ros-robot-model-1.11.5.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-pal-gazebo-plugins-1.1.5r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-pal-gazebo-plugins-1.1.5r2 ===> Done bulk for talos-pal-gazebo-plugins-1.1.5r2 [42%] Processing wip/hatpconsole:hatpconsole-2.0.0 ===> Cleaning temporary files for hatpconsole-2.0.0 ===> Bulk building for hatpconsole-2.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing libhatp-1.3.0.tgz ERROR: Required robotpkg package msgconnector>=2.13.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for hatpconsole-2.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hatpconsole-2.0.0 ===> Done bulk for hatpconsole-2.0.0 [43%] Processing wip/jrl-walkgen-v3:jrl-walkgen-v3-4.0.1 ===> Cleaning temporary files for jrl-walkgen-v3-4.0.1 ===> Bulk building for jrl-walkgen-v3-4.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing jrl-mal-1.19.6r1~jrl-mathtools.tgz => Installing pinocchio-1.2.6r1.tgz => Installing qpOASES-3.2.0.tgz => Installing simple-humanoid-description-1.0.1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use the GNU fortran compiler: fortran-compiler provided by => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package gcc-fortran>=3: gcc-fortran-7 found => Required system package graphviz>=2: graphviz-2.38.0 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required robotpkg package jrl-mal>=1.8.3: jrl-mal-1.19.6r1~jrl-mathtools found => Required robotpkg package pinocchio>=1.1.2: pinocchio-1.2.6r1 found => Required robotpkg package qpOASES>=3.2.0: qpOASES-3.2.0 found => Required robotpkg package simple-humanoid-description>=1.0.1: simple-humanoid-description-1.0.1 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for jrl-walkgen-v3-4.0.1 An unexpected error occured. The last 10 log lines are shown below. | make[2]: *** [src/CMakeFiles/jrl-walkgen.dir/GlobalStrategyManagers/DoubleStagePreviewControlStrategy.cpp.o] Error 1 | make[2]: *** Waiting for unfinished jobs.... | src/CMakeFiles/jrl-walkgen.dir/build.make:329: recipe for target 'src/CMakeFiles/jrl-walkgen.dir/Mathematics/FootConstraintsAsLinearSystem.cpp.o' failed | make[2]: *** [src/CMakeFiles/jrl-walkgen.dir/Mathematics/FootConstraintsAsLinearSystem.cpp.o] Error 1 | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build' | make[1]: *** [src/CMakeFiles/jrl-walkgen.dir/all] Error 2 | CMakeFiles/Makefile2:378: recipe for target 'src/CMakeFiles/jrl-walkgen.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build' | make: *** [all] Error 2 | Makefile:165: recipe for target 'all' failed For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking jrl-walkgen-v3-4.0.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for jrl-walkgen-v3-4.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jrl-walkgen-v3-4.0.1 ===> Done bulk for jrl-walkgen-v3-4.0.1 [43%] Processing wip/talos-pal-hardware-gazebo:talos-pal-hardware-gazebo-0.0.9r1 ===> Cleaning temporary files for talos-pal-hardware-gazebo-0.0.9r1 ===> Bulk building for talos-pal-hardware-gazebo-0.0.9r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing ros-catkin-0.6.9r2.tgz => Installing ros-comm-1.11.20.tgz => Installing ros-common-msgs-1.11.4.tgz => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package talos-gazebo-ros-control>=2.6.5: BROKEN => Installing talos-pal-hardware-interfaces-0.0.3.tgz => Dependency talos-ros-control-0.2.10 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-pal-hardware-gazebo-0.0.9r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-pal-hardware-gazebo-0.0.9r1 ===> Done bulk for talos-pal-hardware-gazebo-0.0.9r1 [43%] Processing wip/move3d-studio:move3d-studio-1.4r3 ===> Cleaning temporary files for move3d-studio-1.4r3~qtstudio ===> Bulk building for move3d-studio-1.4r3~qtstudio => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing gbM-0.11~tcl.tgz WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm ERROR: Required robotpkg package libmove3d>=3.22.0: BROKEN ERROR: Required robotpkg package libmove3d-hri>=2.24: BROKEN ERROR: Required robotpkg package libmove3d-planners>=1.4.0: BROKEN => Installing softMotion-libs-3.12~tcl.tgz => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm ===> Logging bulk summary for move3d-studio-1.4r3~qtstudio => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for move3d-studio-1.4r3~qtstudio ===> Done bulk for move3d-studio-1.4r3~qtstudio [44%] Processing wip/hyper-genom-plugin:hyper-genom-plugin-0.12 ===> Cleaning temporary files for hyper-genom-plugin-0.12 ===> Bulk building for hyper-genom-plugin-0.12 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hyper>=0.12: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for hyper-genom-plugin-0.12 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hyper-genom-plugin-0.12 ===> Done bulk for hyper-genom-plugin-0.12 [44%] Processing wip/hyper-viewer:hyper-viewer-0.1r1 ===> Cleaning temporary files for hyper-viewer-0.1r1 ===> Bulk building for hyper-viewer-0.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package hyper>=0.12: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for hyper-viewer-0.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hyper-viewer-0.1r1 ===> Done bulk for hyper-viewer-0.1r1 [45%] Processing wip/hatptester:hatptester-1.5.3 ===> Cleaning temporary files for hatptester-1.5.3 ===> Bulk building for hatptester-1.5.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package msgconnector>=2.13.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for hatptester-1.5.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hatptester-1.5.3 ===> Done bulk for hatptester-1.5.3 [45%] Processing wip/pr2-pick-object:laas-pr2-pick-object ===> Cleaning temporary files for laas-pr2-pick-object ===> Bulk building for laas-pr2-pick-object => Checking for clear installation => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Required robotpkg package coldman-genom>=1.3: N/A => Installing eltclsh-1.16.tgz => Installing genHum-genom-1.1r1~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing laaswm-1.2.tgz => Installing laaswm-libs-1.2.tgz => Installing libt3d-2.6~doc.tgz => Required robotpkg package mhp-genom>=3.15: N/A => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz => Required robotpkg package pqp>=1.3r2: N/A => Installing softMotion-libs-3.12~tcl.tgz => Required robotpkg package spark-genom>=3.9: N/A => Required robotpkg package viman-genom>=1.4: N/A ===> Logging bulk summary for laas-pr2-pick-object => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for laas-pr2-pick-object ===> Done bulk for laas-pr2-pick-object [46%] Processing wip/talos-simulation:talos-simulation-0.0.14r2 ===> Cleaning temporary files for talos-simulation-0.0.14r2 ===> Bulk building for talos-simulation-0.0.14r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Installing ros-robot-model-1.11.5.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing talos-moveit-config-0.2.3.tgz ERROR: Required robotpkg package talos-pal-gazebo-plugins>=1.1.5: BROKEN ERROR: Required robotpkg package talos-pal-hardware-gazebo>=0.0.9: BROKEN => Installing talos-robot-0.0.14r1.tgz ERROR: Required robotpkg package talos-roboticsgroup-gazebo-plugins>=0.0.3: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-simulation-0.0.14r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-simulation-0.0.14r2 ===> Done bulk for talos-simulation-0.0.14r2 [46%] Processing wip/MPC_avoidObs-genom:MPC_avoidObs-genom-0.2r1 ===> Cleaning temporary files for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client ===> Bulk building for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client => Checking for clear installation Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. => Installing GPS-genom-1.7~openprs+tcl+tclserv_client.tgz ERROR: Required robotpkg package MPC>=1.0: BROKEN ERROR: Required robotpkg package MPC_DEMTreatment-genom>=0.2: BROKEN ERROR: Required robotpkg package MPC_planner-genom>=0.2: BROKEN => Dependency digest-20080510 already installed => Installing dtm-genom-1.5~openprs+tcl+tclserv_client.tgz => Dependency genBasic-genom-0.4r1~openprs+tcl+tclserv_client already installed => Dependency genPos-genom-0.3r1~openprs+tcl+tclserv_client already installed => Dependency genom-2.12~doc already installed => Dependency libt3d-2.6~doc already installed => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Dependency stereopixel-genom-1.3~openprs+tcl+tclserv_client already installed => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Dependency velodyne-genom-1.6~openprs+tcl+tclserv_client already installed Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. ===> Logging bulk summary for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client ===> Done bulk for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client [47%] Processing wip/atlaas-genom:atlaas-genom-0.1.6 ===> Bulk building for atlaas-genom-0.1.6~openprs+tcl+tclserv_client Binary package for atlaas-genom-0.1.6~openprs+tcl+tclserv_client is up-to-date. [47%] Processing wip/sot-hrprtc-hrp2:sot-hrprtc-hrp2-1.2.2 ===> Cleaning temporary files for sot-hrprtc-hrp2-1.2.2 ===> Bulk building for sot-hrprtc-hrp2-1.2.2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-2.5.7.tgz => Installing dynamic-graph-bridge-2.0.9.tgz => Dependency dynamic-graph-bridge-msgs-0.2.0 already installed => Installing hrp2-14-1.9.3.tgz => Installing hrp2-14-description-1.0.4.tgz => Installing hrp2-bringup-1.0.6.tgz => Dependency hrp2-computer-monitor-1.0.2 already installed => Installing hrp2-dynamics-1.5.3.tgz => Dependency hrp2-machine-1.0.2 already installed => Required robotpkg package openrtm-aist>=1 : NOT found ERROR: Required robotpkg package openrtm-aist>=1 : NOT found => Dependency py27-dynamic-graph-2.5.6r1 already installed => Dependency py27-sot-tools-1.0.1 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing sot-application-1.0.0r1.tgz => Dependency sot-core-2.9.10 already installed => Dependency sot-dynamic-2.9.2 already installed ERROR: Required robotpkg package sot-dyninv>=2.0.0: BROKEN => Installing sot-pattern-generator-2.9.1.tgz => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-hrprtc-hrp2-1.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrprtc-hrp2-1.2.2 ===> Done bulk for sot-hrprtc-hrp2-1.2.2 [48%] Processing wip/tsid:tsid-1.0.1 ===> Cleaning temporary files for tsid-1.0.1 ===> Bulk building for tsid-1.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing pinocchio-1.2.6r1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-unit_test_framework>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.2.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required robotpkg package pinocchio>=1.2.4: pinocchio-1.2.6r1 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | return se3::getFrameJacobian(m_model, data, index, J); | ^ | make[2]: *** [src/CMakeFiles/tsid.dir/robots/robot-wrapper.cpp.o] Error 1 | src/CMakeFiles/tsid.dir/build.make:761: recipe for target 'src/CMakeFiles/tsid.dir/robots/robot-wrapper.cpp.o' failed | make[1]: *** [src/CMakeFiles/tsid.dir/all] Error 2 | make[2]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/tsid/work/tsid-1.0.1' | CMakeFiles/Makefile2:504: recipe for target 'src/CMakeFiles/tsid.dir/all' failed | make[1]: Leaving directory '/local/robotpkg/var/tmp/robotpkg/wip/tsid/work/tsid-1.0.1' | Makefile:143: recipe for target 'all' failed | make: *** [all] Error 2 => Marking tsid-1.0.1 as broken For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/tsid/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for tsid-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tsid-1.0.1 ===> Done bulk for tsid-1.0.1 [48%] Processing wip/sot-hrp2:sot-hrp2-1.1.2 ===> Cleaning temporary files for sot-hrp2-1.1.2 ===> Bulk building for sot-hrp2-1.1.2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-2.5.7.tgz => Installing dynamic-graph-bridge-2.0.9.tgz => Dependency dynamic-graph-bridge-msgs-0.2.0 already installed => Installing hrp2-14-1.9.3.tgz => Installing hrp2-14-description-1.0.4.tgz => Installing hrp2-bringup-1.0.6.tgz => Dependency hrp2-computer-monitor-1.0.2 already installed => Installing hrp2-dynamics-1.5.3.tgz => Dependency hrp2-machine-1.0.2 already installed => Dependency py27-dynamic-graph-2.5.6r1 already installed => Dependency py27-sot-tools-1.0.1 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed => Installing sot-application-1.0.0r1.tgz => Dependency sot-core-2.9.10 already installed => Dependency sot-dynamic-2.9.2 already installed ERROR: Required robotpkg package sot-dyninv>=2.0.0: BROKEN => Installing sot-pattern-generator-2.9.1.tgz => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-hrp2-1.1.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrp2-1.1.2 ===> Done bulk for sot-hrp2-1.1.2 [49%] Processing wip/sot-core-v3:sot-core-v3-3.1.1 ===> Cleaning temporary files for sot-core-v3-3.1.1 ===> Bulk building for sot-core-v3-3.1.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-v3-3.0.1.tgz => Installing py27-dynamic-graph-v3-3.0.2.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package boost-headers>=1.34.1: boost-headers-1.62 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-math>=1.34.1: boost-libs-1.62.0 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.62.0 found => Required system package cmake>=2.6: cmake-3.9.1 found => Required system package doxygen>=1.5: doxygen-1.8.13 found => Required system package eigen3>=3.0.0: eigen3-3.3.4 found => Required system package g++>=3: g++-7 found => Required system package gcc>=3: gcc-7 found => Required system package graphviz>=2: graphviz-2.38.0 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.29.1 found => Required system package py-sphinx>=1.1: py-sphinx-1.5.6 found => Required system package python27>=2.7<2.8: python27-2.7.14 found => Required robotpkg package dynamic-graph-v3>=3.0.0: dynamic-graph-v3-3.0.1 found => Required robotpkg package py27-dynamic-graph-v3>=3.0: py27-dynamic-graph-v3-3.0.2 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for sot-core-v3-3.1.1 => Compiling python files => Adding run-time search paths to pkg-config files robotpkg_create: can't stat `/opt/openrobots/lib/libsot-core.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/sot.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/op-point-modifier.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/operator.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/derivator.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/switch.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/fir-filter.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/integrator-abstract.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/integrator-euler.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/matrix-constant.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/vector-constant.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/vector-to-rotation.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/gain-adaptive.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/task-pd.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/constraint.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/gain-hyperbolic.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/task.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/task-conti.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/task-unilateral.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-point6d.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-vector3.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-generic.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-joint-limits.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-1d.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-point6d-relative.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-visual-point.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-task.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-line-distance.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/feature-posture.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/visual-point-projecter.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/reader.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/time-stamp.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/timer.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/seq-play.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/sequencer.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/robot-simu.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/motion-period.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/neck-limitation.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/mailbox-vector.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/kalman.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/joint-limitator.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/gripper-control.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/com-freezer.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/clamp-workspace.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/binary-int-to-uint.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/periodic-call-entity.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/joint-trajectory-entity.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/control-gr.so.1' robotpkg_create: can't stat `/opt/openrobots/lib/plugin/control-pd.so.1' => Registering installation for sot-core-v3-3.1.1 robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/libsot-core.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/sot.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/op-point-modifier.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/operator.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/derivator.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/switch.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/fir-filter.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/integrator-abstract.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/integrator-euler.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/matrix-constant.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/vector-constant.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/vector-to-rotation.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/gain-adaptive.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/task-pd.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/constraint.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/gain-hyperbolic.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/task.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/task-conti.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/task-unilateral.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-point6d.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-vector3.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-generic.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-joint-limits.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-1d.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-point6d-relative.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-visual-point.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-task.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-line-distance.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/feature-posture.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/visual-point-projecter.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/reader.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/time-stamp.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/timer.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/seq-play.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/sequencer.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/robot-simu.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/motion-period.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/neck-limitation.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/mailbox-vector.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/kalman.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/joint-limitator.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/gripper-control.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/com-freezer.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/clamp-workspace.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/binary-int-to-uint.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/periodic-call-entity.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/joint-trajectory-entity.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/control-gr.so.1' is in +CONTENTS but not on filesystem! robotpkg_admin: sot-core-v3-3.1.1: File `/opt/openrobots/lib/plugin/control-pd.so.1' is in +CONTENTS but not on filesystem! make[2]: *** [pkg-tarup] Error 1 => Marking sot-core-v3-3.1.1 as broken ERROR: make: *** [package] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/lib/libsot-core.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/sot.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/op-point-modifier.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/operator.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/derivator.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/switch.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/fir-filter.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/integrator-abstract.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/integrator-euler.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/matrix-constant.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/vector-constant.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/vector-to-rotation.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/gain-adaptive.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/task-pd.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/constraint.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/gain-hyperbolic.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/task.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/task-conti.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/task-unilateral.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-point6d.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-vector3.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-generic.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-joint-limits.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-1d.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-point6d-relative.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-visual-point.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-task.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-line-distance.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/feature-posture.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/visual-point-projecter.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/reader.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/time-stamp.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/timer.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/seq-play.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/sequencer.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/robot-simu.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/motion-period.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/neck-limitation.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/mailbox-vector.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/kalman.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/joint-limitator.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/gripper-control.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/com-freezer.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/clamp-workspace.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/binary-int-to-uint.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/periodic-call-entity.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/joint-trajectory-entity.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/control-gr.so.1 robotpkg_delete: Couldn't remove /opt/openrobots/lib/plugin/control-pd.so.1 ===> Logging bulk summary for sot-core-v3-3.1.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-core-v3-3.1.1 ===> Done bulk for sot-core-v3-3.1.1 [49%] Processing wip/hri-simulation:hri-simulationr1 ===> Cleaning temporary files for hri-simulationr1 ===> Bulk building for hri-simulationr1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Installing alog-0.5.tgz => Dependency digest-20080510 already installed => Installing genPos-genom-0.3r1~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing libt3d-2.6~doc.tgz => Required robotpkg package mhp-genom>=3.15: N/A => Required robotpkg package morse-pocolibs>=0.2: N/A => Installing move3d-assets-20120125.tgz => Installing platine-genom-0.5~openprs+tcl+tclserv_client.tgz => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Installing py27-poco-1.5.tgz => Required robotpkg package spark-genom>=3.9: N/A => Dependency tnftp-20130505~ssl already installed => Required robotpkg package viman-genom>=1.4: N/A ===> Logging bulk summary for hri-simulationr1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hri-simulationr1 ===> Done bulk for hri-simulationr1 [50%] Processing wip/py-sot-tools-v3:py27-sot-tools-v3-2.0.2 ===> Cleaning temporary files for py27-sot-tools-v3-2.0.2 ===> Bulk building for py27-sot-tools-v3-2.0.2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for py27-sot-tools-v3-2.0.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-sot-tools-v3-2.0.2 ===> Done bulk for py27-sot-tools-v3-2.0.2 [50%] Processing wip/MPC_controller-genom:MPC_controller-genom-0.2 ===> Cleaning temporary files for MPC_controller-genom-0.2~openprs+tcl+tclserv_client ===> Bulk building for MPC_controller-genom-0.2~openprs+tcl+tclserv_client => Checking for clear installation Warning: the LICENSE of wip/MPC_controller-genom is undefined. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: the LICENSE of wip/MPC_controller-genom is undefined. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found Warning: the LICENSE of wip/MPC_controller-genom is undefined. Warning: the LICENSE of wip/MPC_controller-genom is undefined. ERROR: Required robotpkg package MPC>=1.0: BROKEN ERROR: Required robotpkg package MPC_avoidObs-genom>=0.2: BROKEN ERROR: Required robotpkg package MPC_planner-genom>=0.2: BROKEN => Dependency digest-20080510 already installed => Installing dtm-genom-1.5~openprs+tcl+tclserv_client.tgz => Dependency genBasic-genom-0.4r1~openprs+tcl+tclserv_client already installed => Dependency genPos-genom-0.3r1~openprs+tcl+tclserv_client already installed => Dependency genom-2.12~doc already installed => Dependency libt3d-2.6~doc already installed => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Dependency stereopixel-genom-1.3~openprs+tcl+tclserv_client already installed => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Dependency velodyne-genom-1.6~openprs+tcl+tclserv_client already installed Warning: the LICENSE of wip/MPC_controller-genom is undefined. Warning: the LICENSE of wip/MPC_controller-genom is undefined. ===> Logging bulk summary for MPC_controller-genom-0.2~openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for MPC_controller-genom-0.2~openprs+tcl+tclserv_client ===> Done bulk for MPC_controller-genom-0.2~openprs+tcl+tclserv_client [50%] Processing wip/sot-dynamic-pinocchio-v3:sot-dynamic-pinocchio-v3-3.1.6r2 ===> Cleaning temporary files for sot-dynamic-pinocchio-v3-3.1.6r2 ===> Bulk building for sot-dynamic-pinocchio-v3-3.1.6r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing pinocchio-1.2.6r1.tgz ERROR: Required robotpkg package py27-sot-tools-v3>=2.0: BROKEN ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-dynamic-pinocchio-v3-3.1.6r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-dynamic-pinocchio-v3-3.1.6r2 ===> Done bulk for sot-dynamic-pinocchio-v3-3.1.6r2 [51%] Processing wip/sot-dyninv-v3:sot-dyninv-v3-3.0.0 ===> Cleaning temporary files for sot-dyninv-v3-3.0.0 ===> Bulk building for sot-dyninv-v3-3.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing py27-dynamic-graph-v3-3.0.2.tgz ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN ERROR: Required robotpkg package soth>=2.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-dyninv-v3-3.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-dyninv-v3-3.0.0 ===> Done bulk for sot-dyninv-v3-3.0.0 [51%] Processing wip/sot-application-v3:sot-application-v3-1.1.3 ===> Cleaning temporary files for sot-application-v3-1.1.3 ===> Bulk building for sot-application-v3-1.1.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-application-v3-1.1.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-application-v3-1.1.3 ===> Done bulk for sot-application-v3-1.1.3 [52%] Processing wip/dynamic-graph-bridge-v3:dynamic-graph-bridge-v3-3.0.8 ===> Cleaning temporary files for dynamic-graph-bridge-v3-3.0.8 ===> Bulk building for dynamic-graph-bridge-v3-3.0.8 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-msgs-0.2.0.tgz => Installing dynamic-graph-v3-3.0.1.tgz => Installing py27-dynamic-graph-v3-3.0.2.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Installing ros-common-msgs-1.11.4.tgz => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-geometry2-0.5.15 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-realtime-tools-1.9.2.tgz => Dependency ros-roscpp-core-0.5.4r1 already installed => Dependency ros-rospack-2.2.4 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for dynamic-graph-bridge-v3-3.0.8 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for dynamic-graph-bridge-v3-3.0.8 ===> Done bulk for dynamic-graph-bridge-v3-3.0.8 [52%] Processing wip/sot-pattern-generator-v3:sot-pattern-generator-v3-3.0.0 ===> Cleaning temporary files for sot-pattern-generator-v3-3.0.0 ===> Bulk building for sot-pattern-generator-v3-3.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package jrl-walkgen-v3>=4.0.0: BROKEN => Installing pinocchio-1.2.6r1.tgz ERROR: Required robotpkg package sot-application-v3>=1.1.0: BROKEN ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-pattern-generator-v3-3.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-pattern-generator-v3-3.0.0 ===> Done bulk for sot-pattern-generator-v3-3.0.0 [53%] Processing wip/sot-hrp2-v3:sot-hrp2-v3-2.1.0 ===> Cleaning temporary files for sot-hrp2-v3-2.1.0 ===> Bulk building for sot-hrp2-v3-2.1.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-msgs-0.2.0.tgz ERROR: Required robotpkg package dynamic-graph-bridge-v3>=3.0.0 : BROKEN => Installing dynamic-graph-v3-3.0.1.tgz => Installing py27-dynamic-graph-v3-3.0.2.tgz ERROR: Required robotpkg package py27-sot-tools-v3>=2.0: BROKEN => Dependency ros-comm-1.11.20 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-hrp2-v3-2.1.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrp2-v3-2.1.0 ===> Done bulk for sot-hrp2-v3-2.1.0 [53%] Processing wip/talos-metapkg-ros-control-sot:talos-metapkg-ros-control-sot-0.0.3r2 ===> Cleaning temporary files for talos-metapkg-ros-control-sot-0.0.3r2 ===> Bulk building for talos-metapkg-ros-control-sot-0.0.3r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package patch>=2.0: patch-2.7.5 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package dynamic-graph-bridge-v3>=3.0.0 : BROKEN => Installing ros-actionlib-1.11.9.tgz => Dependency ros-catkin-0.6.9r2 already installed => Dependency ros-comm-1.11.20 already installed => Dependency ros-common-msgs-1.11.4 already installed => Installing ros-control-toolbox-1.13.2r1.tgz => Dependency ros-genmsg-0.5.3 already installed => Installing ros-geometry-1.11.3r1.tgz => Dependency ros-message-generation-0.2.10 already installed => Dependency ros-message-runtime-0.4.12 already installed => Installing ros-pluginlib-1.10.1.tgz => Installing ros-robot-model-1.11.5.tgz => Dependency ros-ros-1.11.4 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package talos-ros-controllers>=0.2.8: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-metapkg-ros-control-sot-0.0.3r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-metapkg-ros-control-sot-0.0.3r2 ===> Done bulk for talos-metapkg-ros-control-sot-0.0.3r2 [54%] Processing wip/openhrp3-hrp2:openhrp3-hrp2-1.2.0 ===> Cleaning temporary files for openhrp3-hrp2-1.2.0 ===> Bulk building for openhrp3-hrp2-1.2.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package dynamic-graph-bridge-v3>=3.0.0 : BROKEN => Installing hrp2-14-1.9.3.tgz ERROR: Required robotpkg package openhrp3-simulator-wo-rtm>=1.0.0: BROKEN => Installing ros-catkin-0.6.9r2.tgz => Installing ros-comm-1.11.20.tgz => Installing ros-common-msgs-1.11.4.tgz => Dependency ros-std-msgs-0.5.9 already installed => Installing ros-xacro-1.9.2.tgz ERROR: Required robotpkg package sot-hrp2-v3>=2.0.0: BROKEN => Dependency tnftp-20130505~ssl already installed => Installing urdfdom-0.3.0r2.tgz ===> Logging bulk summary for openhrp3-hrp2-1.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-hrp2-1.2.0 ===> Done bulk for openhrp3-hrp2-1.2.0 [54%] Processing wip/sot-romeo-v3:sot-romeo-v3-2.0.1 ===> Cleaning temporary files for sot-romeo-v3-2.0.1 ===> Bulk building for sot-romeo-v3-2.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-msgs-0.2.0.tgz ERROR: Required robotpkg package dynamic-graph-bridge-v3>=3.0.0 : BROKEN => Installing dynamic-graph-v3-3.0.1.tgz => Installing py27-dynamic-graph-v3-3.0.2.tgz ERROR: Required robotpkg package py27-sot-tools-v3>=2.0: BROKEN => Dependency ros-comm-1.11.20 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-rospack-2.2.4 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-romeo-v3-2.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-romeo-v3-2.0.1 ===> Done bulk for sot-romeo-v3-2.0.1 [55%] Processing wip/sot-talos:sot-talos-0.0.3 ===> Cleaning temporary files for sot-talos-0.0.3 ===> Bulk building for sot-talos-0.0.3 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-msgs-0.2.0.tgz ERROR: Required robotpkg package dynamic-graph-bridge-v3>=3.0.0 : BROKEN => Installing dynamic-graph-v3-3.0.1.tgz => Installing py27-dynamic-graph-v3-3.0.2.tgz ERROR: Required robotpkg package py27-sot-tools-v3>=2.0: BROKEN => Dependency ros-comm-1.11.20 already installed => Dependency ros-message-runtime-0.4.12 already installed => Dependency ros-std-msgs-0.5.9 already installed ERROR: Required robotpkg package sot-application-v3>=1.1.0: BROKEN ERROR: Required robotpkg package sot-core-v3>=3.0.0: BROKEN ERROR: Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: BROKEN => Installing talos-data-0.0.14r5.tgz ERROR: Required robotpkg package talos-metapkg-ros-control-sot>=0.0.1: BROKEN ERROR: Required robotpkg package talos-ros-controllers>=0.2.8: BROKEN => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for sot-talos-0.0.3 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-talos-0.0.3 ===> Done bulk for sot-talos-0.0.3 [55%] Processing wip/hrp2-dev:hrp2-dev-20171009 ===> Cleaning temporary files for hrp2-dev-20171009 ===> Bulk building for hrp2-dev-20171009 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found => Installing hrp2-14-description-1.0.4.tgz ERROR: Required robotpkg package openhrp3-hrp2>=1.0.0: BROKEN ===> Logging bulk summary for hrp2-dev-20171009 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hrp2-dev-20171009 ===> Done bulk for hrp2-dev-20171009 [56%] Processing wip/talos-dev:talos-dev-20171009 ===> Cleaning temporary files for talos-dev-20171009 ===> Bulk building for talos-dev-20171009 => Checking for clear installation => Required system package gnupg>=1: gnupg-2.1.15 found => Required system package gzip: gzip-1.6 found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2.1: pkgrepo2deb-1.2.1 found ERROR: Required robotpkg package sot-talos>=0.0.1: BROKEN ERROR: Required robotpkg package talos-gazebo-ros-control>=2.6.5: BROKEN ERROR: Required robotpkg package talos-simulation>=0.0.13: BROKEN ===> Logging bulk summary for talos-dev-20171009 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-dev-20171009 ===> Done bulk for talos-dev-20171009 ===> Done bulk for rbulk wip set --- Bulk started Wed Jan 17 17:05:14 CET 2018 --- Bulk stopped Wed Jan 17 18:50:56 CET 2018