robotpkg/wip bulk build results

Log for Ubuntu-12.04-x86_64 (Back)

--- Updating robotpkg ------------------------------------------------ Pulling /local/robotpkg/var/lib/robotpkg/wip Updating 7ba0b1b..fb7b6d4 Fast-forward jrl-walkgen-v3/Makefile | 2 +- sot-dyninv-v3/Makefile | 2 +- sot-pattern-generator-v3/Makefile | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) Updating pkgtools/pkg_install ===> Updating for pkg_install-20110805.7 pkg_install-20110805.7 is already installed and up-to-date. Updating pkgtools/rbulkit ===> Updating for rbulkit-20170123 rbulkit-20170123 is already installed and up-to-date. Updating pkgtools/pkgrepo2deb ===> Updating for pkgrepo2deb-1.2 pkgrepo2deb-1.2 is already installed and up-to-date. --- Running build for bulk-rbulk-wip ----------------------------------- ===> Sorting packages for rbulk wip set Scanning wip/libmove3d-hri:* Scanning wip/talos-roboticsgroup-gazebo-plugins:* Scanning wip/orocos-dot_service:* Scanning pkgtools/tnftp:tnftp>=20130505~ssl Scanning wip/certi:* Scanning wip/qpOASES:* Scanning wip/gdalwrap:* Scanning wip/mumps:* Scanning wip/jointStateMapper:* Scanning wip/metapod:* [wip/metapod:*] Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. [wip/metapod:*] Warning: use DYNAMIC_PLIST_DIRS instead. Scanning wip/sot-pattern-generator-v3:* Scanning wip/py-laaswm:* Scanning wip/talos-ros-control:* Scanning wip/jsbsim:* Scanning wip/dptu-genom3:* Scanning wip/can-utils:* Scanning wip/chilitags:* Scanning wip/hrp2-14-description:* Scanning wip/hrp2-computer-monitor:* Scanning wip/FRILibrary:* Scanning wip/py-sot-tools-v3:* Scanning wip/sot-talos:* Scanning wip/sot-dyninv:* Scanning wip/mhp-genom:* Scanning wip/hrp2-dev:* Scanning wip/pinocchio:* Scanning wip/libpointmatcher:* Scanning wip/hatpconsole:* Scanning wip/talos-pal-gazebo-plugins:* Scanning wip/jrl-walkgen-v3:* Scanning wip/py-hla:* Scanning wip/ompl:* Scanning wip/talos-pal-hardware-gazebo:* Scanning wip/move3d-studio:* Scanning wip/talos-data:* Scanning wip/sot-hrp2-v3:* Scanning wip/move3d-assets:* Scanning wip/talos-pal-transmissions:* [wip/talos-pal-transmissions:*] Display something for talos-ros-controllers /local/robotpkg Scanning wip/hyper-genom-plugin:* Scanning wip/morse-hla:* Scanning wip/hyper-viewer:* Scanning wip/track-target-genom:* Scanning wip/hrp2-bringup:* Scanning wip/hyper:* Scanning wip/gerard-bauzil:* Scanning wip/pr2-pick-object:* Scanning wip/urg:* Scanning wip/hatptester:* Scanning wip/jafar-qdisplay:* Scanning wip/dynamic-graph-v3:* Scanning wip/spark-genom:* Scanning wip/talos-metapkg-ros-control-sot:* Scanning wip/histodet:* Scanning wip/talos-pal-hardware-interfaces:* Scanning wip/octovis:* Scanning wip/openhrp3-hrp2:* Scanning wip/sot-application:* Scanning wip/MPC_DEMTreatment-genom:* [wip/MPC_DEMTreatment-genom:*] Warning: the LICENSE of wip/MPC_DEMTreatment-genom is undefined. Scanning wip/mrpt:* Scanning wip/py-eigen:* Scanning wip/vnet-yarp:* Scanning wip/talos-simulation:* Scanning wip/MPC_controller-genom:* [wip/MPC_controller-genom:*] Warning: the LICENSE of wip/MPC_controller-genom is undefined. Scanning wip/py-morse:* Scanning wip/simple-humanoid-description:* Scanning wip/MPC_avoidObs-genom:* [wip/MPC_avoidObs-genom:*] Warning: the LICENSE of wip/MPC_avoidObs-genom is undefined. Scanning wip/MPC_planner-genom:* [wip/MPC_planner-genom:*] Warning: the LICENSE of wip/MPC_planner-genom is undefined. Scanning wip/soth:* Scanning wip/atlaas-genom:* Scanning wip/libmove3d-planners:* Scanning wip/kukaFri-libs:* Scanning wip/sot-hrprtc-hrp2:* Scanning wip/tsid:* Scanning wip/talos-ros-controllers:* Scanning wip/orocos-bfl:* Scanning wip/sot-dynamic-pinocchio-v3:* Scanning wip/laaswm-gui:* Scanning wip/osg-dae:* Scanning wip/sot-dyninv-v3:* Scanning wip/morse-pocolibs:* Scanning wip/py-jsbsim:* Scanning wip/gladys:* Scanning wip/msgconnector:* Scanning wip/lua-rfsm:* Scanning wip/roralink:* Scanning wip/talos-dev:* Scanning wip/morse-mavlink:* Scanning wip/sot-application-v3:* Scanning wip/sot-hrp2:* Scanning wip/antlr2:* Scanning wip/pal-msgs:* Scanning wip/libfreenect:* Scanning wip/robotModelParser-libs:* Scanning wip/talos-moveit-config:* Scanning wip/sot-romeo-v3:* Scanning wip/atlaas:* Scanning wip/orocos-yarp_transport:* Scanning middleware/orocos-rtt:orocos-rtt>=2.5 Scanning wip/talos-robot:* Scanning wip/libmove3d:* Scanning wip/mavlink:* Scanning wip/dynamic-graph-bridge-v3:* Scanning wip/morse-ros:* Scanning wip/hrp2-machine:* Scanning wip/MPC:* Scanning wip/openhrp3-simulator-wo-rtm:* Scanning wip/sot-core-v3:* Scanning wip/eigen-quadprog:* Scanning wip/py-mavlink:* Scanning wip/libnabo:* Scanning wip/py-dynamic-graph-v3:* Scanning wip/joystick-genom:* Scanning wip/hatponboard-lib:* Scanning wip/jafar-rtslam:* Scanning wip/hri-simulation:* Scanning wip/talos-gazebo-ros-control:* Scanning wip/libhatp:* Scanning wip/jafar-rtslam:~MTI Scanning wip/py-mavlink:py32-mavlink-1.1.62 Scanning wip/py-jsbsim:py32-jsbsim-20150424r1 Scanning wip/py-hla:py32-hla-1.1.1r1 Scanning wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* Scanning wip/dptu-genom3:dptu-genom3-0.2~pocolibs-client-c+codels+openprs+pocolibs-server+!* Scanned 224 packages (187 unique) [0%] Processing wip/mavlink:mavlink-20150929 ===> Bulk building for mavlink-20150929 Binary package for mavlink-20150929 is up-to-date. [0%] Processing wip/libmove3d:libmove3d-3.22.0r1 ===> Bulk building for libmove3d-3.22.0r1 Binary package for libmove3d-3.22.0r1 is up-to-date. [1%] Processing wip/openhrp3-simulator-wo-rtm:openhrp3-simulator-wo-rtm-1.2.0 ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Bulk building for openhrp3-simulator-wo-rtm-1.2.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required robotpkg package gepetto-viewer>=2.0.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for openhrp3-simulator-wo-rtm-1.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-simulator-wo-rtm-1.2.0 ===> Done bulk for openhrp3-simulator-wo-rtm-1.2.0 [1%] Processing wip/MPC:MPC-1.0r2 ===> Bulk building for MPC-1.0r2 Binary package for MPC-1.0r2 is up-to-date. [2%] Processing wip/hrp2-machine:hrp2-machine-1.0.2 ===> Bulk building for hrp2-machine-1.0.2 Binary package for hrp2-machine-1.0.2 is up-to-date. [2%] Processing wip/eigen-quadprog:eigen-quadprog-1.0.0 ===> Cleaning temporary files for eigen-quadprog-1.0.0 ===> Bulk building for eigen-quadprog-1.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use the GNU fortran compiler: fortran-compiler provided by => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package eigen3>=3.0.0: eigen3-3.0.5 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package gcc-fortran>=3: gcc-fortran-4.6 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | from /local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0/src/QuadProg.cpp:17: | /usr/include/eigen3/Eigen/Sparse:19:2: error: #error The sparse module API is not stable yet. To use it anyway, please define the EIGEN_YES_I_KNOW_SPARSE_MODULE_IS_NOT_STABLE_YET preprocessor token. | /usr/bin/cmake -E cmake_progress_report /local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0/CMakeFiles 13 | [ 83%] Building Fortran object src/CMakeFiles/eigen-quadprog.dir/BLAS/f/blas.f.o | cd /local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0/src && /usr/bin/gfortran -Deigen_quadprog_EXPORTS -DEIGEN_QUADPROG_EXPORT -O3 -fPIC -I/local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0 -I/local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0/include -isystem /usr/include/eigen3 -c /local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0/src/BLAS/f/blas.f -o CMakeFiles/eigen-quadprog.dir/BLAS/f/blas.f.o | make[2]: *** [src/CMakeFiles/eigen-quadprog.dir/QuadProg.cpp.o] Error 1 | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0' | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/eigen-quadprog-1.0.0' | make[1]: *** [src/CMakeFiles/eigen-quadprog.dir/all] Error 2 | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/eigen-quadprog/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking eigen-quadprog-1.0.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for eigen-quadprog-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for eigen-quadprog-1.0.0 ===> Done bulk for eigen-quadprog-1.0.0 [3%] Processing wip/py-mavlink:py27-mavlink-1.1.62 ===> Bulk building for py27-mavlink-1.1.62 Binary package for py27-mavlink-1.1.62 is up-to-date. [3%] Processing wip/py-mavlink:py32-mavlink-1.1.62 ===> Cleaning temporary files for py32-mavlink-1.1.62 ===> Bulk building for py32-mavlink-1.1.62 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package git>=1.6: git-1.7.9.5 found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.2: python>=2.5<3.7 provided by python32>=3.2<3.3 => Required system package gcc>=3: gcc-4.6 found => Required system package python32>=3.2<3.3: python32-3.2.3 found => SHA1 checksums OK => RMD160 checksums OK => Compiling python files File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__init__.py", line 81 raise AttributeError, "Unknown XML interface: %s" %(xmlIf) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlif4Dom.py", line 58 print "Using 4Dom interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifApi.py", line 370 raise AttributeError, "Attribute %s not found!" %(repr(tupleOrAttrName)) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifDom.py", line 69 print "Xinclude: %s" %href ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifElementTree.py", line 72 print "Using elementtree interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifMinidom.py", line 63 print "Using minidom interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifUtils.py", line 193 raise LookupError, "Prefix for namespaceURI '%s' not found!" % (ns) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmliftest.py", line 12 print xmlTree.printTree(prettyPrint=1) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/minixsvWrapper.py", line 36 print validSyntaxText ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/pyxsval.py", line 93 raise KeyError, "xmlIfKey %s already implemented!" %(xmlIfKey) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalBase.py", line 135 except TagException, errInst: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalErrorHandler.py", line 122 print string.join (self.infoDict.keys(), "n") ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalSchema.py", line 431 except TagException, errInst: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalSimpleTypes.py", line 78 except BaseTypeError, errstr: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalUtils.py", line 48 r"Cc" : ur"x00-x1fx7f-x9f", ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__init__.py", line 81 raise AttributeError, "Unknown XML interface: %s" %(xmlIf) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlif4Dom.py", line 58 print "Using 4Dom interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifApi.py", line 370 raise AttributeError, "Attribute %s not found!" %(repr(tupleOrAttrName)) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifDom.py", line 69 print "Xinclude: %s" %href ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifElementTree.py", line 72 print "Using elementtree interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifMinidom.py", line 63 print "Using minidom interface module..." ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmlifUtils.py", line 193 raise LookupError, "Prefix for namespaceURI '%s' not found!" % (ns) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/xmliftest.py", line 12 print xmlTree.printTree(prettyPrint=1) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/minixsvWrapper.py", line 36 print validSyntaxText ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/pyxsval.py", line 93 raise KeyError, "xmlIfKey %s already implemented!" %(xmlIfKey) ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalBase.py", line 135 except TagException, errInst: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalErrorHandler.py", line 122 print string.join (self.infoDict.keys(), "n") ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalSchema.py", line 431 except TagException, errInst: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalSimpleTypes.py", line 78 except BaseTypeError, errstr: ^ SyntaxError: invalid syntax File "/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/xsvalUtils.py", line 48 r"Cc" : ur"x00-x1fx7f-x9f", ^ SyntaxError: invalid syntax robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/mavnative.so' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyo' => Registering installation for py32-mavlink-1.1.62 robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/mavnative.so' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyc' is in +CONTENTS but not on filesystem! robotpkg_admin: py32-mavlink-1.1.62: File `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyo' is in +CONTENTS but not on filesystem! robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/mavnative.so' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyo' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyc' robotpkg_create: can't stat `/opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyo' robotpkg_create: lstat failed for file lib/python3.2/site-packages/mavnative.so: No such file or directory make[2]: *** [pkg-tarup] Error 2 => Marking py32-mavlink-1.1.62 as broken ERROR: make: *** [package] Error 2 robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/mavnative.so robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/__init__.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlif4Dom.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifApi.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifDom.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifElementTree.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifMinidom.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmlifUtils.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/genxmlif/__pycache__/xmliftest.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/minixsvWrapper.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/pyxsval.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalBase.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalErrorHandler.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSchema.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalSimpleTypes.cpython-32.pyo robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyc robotpkg_delete: Couldn't remove /opt/openrobots/lib/python3.2/site-packages/pymavlink/generator/lib/minixsv/__pycache__/xsvalUtils.cpython-32.pyo robotpkg_delete: Directory `/opt/openrobots/share/mavlink' disappeared, skipping ===> Logging bulk summary for py32-mavlink-1.1.62 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py32-mavlink-1.1.62 ===> Done bulk for py32-mavlink-1.1.62 [4%] Processing wip/joystick-genom:joystick-genom-1.0 ===> Bulk building for joystick-genom-1.0~openprs+tcl+tclserv_client Binary package for joystick-genom-1.0~openprs+tcl+tclserv_client is up-to-date. [4%] Processing wip/jafar-rtslam:jafar-rtslam-0.3~!* ===> Bulk building for jafar-rtslam-0.3 Binary package for jafar-rtslam-0.3 is up-to-date. [5%] Processing wip/jafar-rtslam:~MTI ===> Bulk building for jafar-rtslam-0.3~MTI Binary package for jafar-rtslam-0.3~MTI is up-to-date. [5%] Processing wip/libhatp:libhatp-1.3.0 ===> Bulk building for libhatp-1.3.0 Binary package for libhatp-1.3.0 is up-to-date. [6%] Processing wip/libmove3d-hri:libmove3d-hri-2.24 ===> Bulk building for libmove3d-hri-2.24 Binary package for libmove3d-hri-2.24 is up-to-date. [6%] Processing wip/certi:certi-3.5.1 ===> Cleaning temporary files for certi-3.5.1 ===> Bulk building for certi-3.5.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Required system package cmake>=2.8.11: MISSING => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for certi-3.5.1: ERROR: ERROR: cmake>=2.8.11 ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/certi/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for certi-3.5.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for certi-3.5.1 ===> Done bulk for certi-3.5.1 [7%] Processing wip/qpOASES:qpOASES-3.2.0 ===> Bulk building for qpOASES-3.2.0 Binary package for qpOASES-3.2.0 is up-to-date. [8%] Processing wip/gdalwrap:gdalwrap-0.1.10 ===> Cleaning temporary files for gdalwrap-0.1.10 ===> Bulk building for gdalwrap-0.1.10 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required system package gdal>=1.6: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for gdalwrap-0.1.10: ERROR: ERROR: gdal>=1.6 (Ubuntu package libgdal1-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/gdalwrap/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for gdalwrap-0.1.10 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for gdalwrap-0.1.10 ===> Done bulk for gdalwrap-0.1.10 [8%] Processing wip/mumps:mumps-4.10.0 ===> Bulk building for mumps-4.10.0 Binary package for mumps-4.10.0 is up-to-date. [9%] Processing wip/jointStateMapper:jointStateMapper-1.2.1r1 ===> Cleaning temporary files for jointStateMapper-1.2.1r1 ===> Bulk building for jointStateMapper-1.2.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required robotpkg package openrobots-pose>=1.2: NOT found ERROR: Required robotpkg package openrobots-pose>=1.2: NOT found => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for jointStateMapper-1.2.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jointStateMapper-1.2.1r1 ===> Done bulk for jointStateMapper-1.2.1r1 [9%] Processing wip/metapod:metapod-1.0.10 ===> Cleaning temporary files for metapod-1.0.10 ===> Bulk building for metapod-1.0.10 => Checking for clear installation Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package eigen3>=3.0.0: eigen3-3.0.5 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package graphviz>=2: graphviz-2.26.3 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.26 found Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => SHA1 checksums OK => RMD160 checksums OK Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. => Adding run-time search paths to pkg-config files robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/metapod_license_file.txt' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.config' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.urdf' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/metapod_license_file.txt' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.config' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.urdf' robotpkg_create: can't stat `/opt/openrobots/bin/metapodfromurdf' => Registering installation for metapod-1.0.10 robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_humanoid/metapod_license_file.txt' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.config' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.urdf' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_arm/metapod_license_file.txt' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.config' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.urdf' is in +CONTENTS but not on filesystem! robotpkg_admin: metapod-1.0.10: File `/opt/openrobots/bin/metapodfromurdf' is in +CONTENTS but not on filesystem! robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/metapod_license_file.txt' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.config' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.urdf' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/metapod_license_file.txt' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.config' robotpkg_create: can't stat `/opt/openrobots/share/metapod/data/simple_arm/simple_arm.urdf' robotpkg_create: can't stat `/opt/openrobots/bin/metapodfromurdf' robotpkg_create: lstat failed for file share/metapod/data/simple_humanoid/metapod_license_file.txt: No such file or directory make[2]: *** [pkg-tarup] Error 2 => Marking metapod-1.0.10 as broken ERROR: make: *** [package] Error 2 Warning: DOXYGEN_PLIST_DIR in wip/metapod is deprecated. Warning: use DYNAMIC_PLIST_DIRS instead. robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_humanoid/metapod_license_file.txt robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.config robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_humanoid/simple_humanoid.urdf robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_arm/metapod_license_file.txt robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_arm/simple_arm.config robotpkg_delete: Couldn't remove /opt/openrobots/share/metapod/data/simple_arm/simple_arm.urdf robotpkg_delete: Couldn't remove /opt/openrobots/bin/metapodfromurdf ===> Logging bulk summary for metapod-1.0.10 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for metapod-1.0.10 ===> Done bulk for metapod-1.0.10 [10%] Processing wip/py-laaswm:py27-laaswm-1.3r1 ===> Bulk building for py27-laaswm-1.3r1 Binary package for py27-laaswm-1.3r1 is up-to-date. [10%] Processing wip/talos-ros-control:talos-ros-control-0.2.10 ===> Bulk building for talos-ros-control-0.2.10 Binary package for talos-ros-control-0.2.10 is up-to-date. [11%] Processing wip/jsbsim:jsbsim-20150424 ===> Bulk building for jsbsim-20150424 Binary package for jsbsim-20150424 is up-to-date. [11%] Processing wip/dptu-genom3:dptu-genom3-0.2~pocolibs-client-c+codels+openprs+pocolibs-server+!* ===> Bulk building for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server Binary package for dptu-genom3-0.2~codels+openprs+pocolibs-client-c+pocolibs-server is up-to-date. [12%] Processing wip/dptu-genom3:dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server+!* ===> Bulk building for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server Binary package for dptu-genom3-0.2~codels+openprs+ros-client-c+ros-client-ros+ros-server is up-to-date. [12%] Processing wip/can-utils:can-utils-20160229 ===> Bulk building for can-utils-20160229 Binary package for can-utils-20160229 is up-to-date. [13%] Processing wip/chilitags:chilitags-1.3.1 ===> Cleaning temporary files for chilitags-1.3.1 ===> Bulk building for chilitags-1.3.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required system package g++>=4.7: MISSING => Required system package opencv>=2.4: MISSING => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for chilitags-1.3.1: ERROR: ERROR: g++>=4.7 (Ubuntu package g++) ERROR: opencv>=2.4 (Ubuntu package libopencv-dev libcv-dev libhighgui-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/chilitags/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for chilitags-1.3.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for chilitags-1.3.1 ===> Done bulk for chilitags-1.3.1 [13%] Processing wip/hrp2-14-description:hrp2-14-description-1.0.4 ===> Bulk building for hrp2-14-description-1.0.4 Binary package for hrp2-14-description-1.0.4 is up-to-date. [14%] Processing wip/hrp2-computer-monitor:hrp2-computer-monitor-1.0.2 ===> Bulk building for hrp2-computer-monitor-1.0.2 Binary package for hrp2-computer-monitor-1.0.2 is up-to-date. [14%] Processing wip/FRILibrary:FRILibrary-1.2 ===> Bulk building for FRILibrary-1.2 Binary package for FRILibrary-1.2 is up-to-date. [15%] Processing wip/py-hla:py27-hla-1.1.1r1 ===> Cleaning temporary files for py27-hla-1.1.1r1 ===> Bulk building for py27-hla-1.1.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing certi-20130312r1.tgz => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required robotpkg package certi>=3.4.0: certi-20130312r1 found ERROR: ====================================================================== ERROR: A package matching `certi>=3.4.0' ERROR: should be installed but some files are missing. ERROR: ERROR: searching in /opt/openrobots ERROR: found: /opt/openrobots/bin/rtia ERROR: missing: /opt/openrobots/include/hla13/RTI.hh ERROR: ERROR: Please reinstall the package in ../../wip/certi ERROR: ====================================================================== make[2]: *** [do-depends] Error 1 ERROR: make: *** [depends] Error 2 ===> Logging bulk summary for py27-hla-1.1.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-hla-1.1.1r1 ===> Done bulk for py27-hla-1.1.1r1 [16%] Processing wip/py-hla:py32-hla-1.1.1r1 ===> Cleaning temporary files for py32-hla-1.1.1r1 ===> Bulk building for py32-hla-1.1.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing certi-20130312r1.tgz => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.2: python>=2.5<3.7 provided by python32>=3.2<3.3 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package python32>=3.2<3.3: python32-3.2.3 found => Required robotpkg package certi>=3.4.0: certi-20130312r1 found ERROR: ====================================================================== ERROR: A package matching `certi>=3.4.0' ERROR: should be installed but some files are missing. ERROR: ERROR: searching in /opt/openrobots ERROR: found: /opt/openrobots/bin/rtia ERROR: missing: /opt/openrobots/include/hla13/RTI.hh ERROR: ERROR: Please reinstall the package in ../../wip/certi ERROR: ====================================================================== make[2]: *** [do-depends] Error 1 ERROR: make: *** [depends] Error 2 ===> Logging bulk summary for py32-hla-1.1.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py32-hla-1.1.1r1 ===> Done bulk for py32-hla-1.1.1r1 [16%] Processing wip/ompl:ompl-1.0.0 ===> Bulk building for ompl-1.0.0 Binary package for ompl-1.0.0 is up-to-date. [17%] Processing wip/talos-data:talos-data-0.0.14r5 ===> Bulk building for talos-data-0.0.14r5 Binary package for talos-data-0.0.14r5 is up-to-date. [17%] Processing wip/move3d-assets:move3d-assets-20120125 ===> Bulk building for move3d-assets-20120125 Binary package for move3d-assets-20120125 is up-to-date. [18%] Processing wip/talos-pal-transmissions:talos-pal-transmissions-0.2.3 Display something for talos-ros-controllers /local/robotpkg ===> Bulk building for talos-pal-transmissions-0.2.3 Binary package for talos-pal-transmissions-0.2.3 is up-to-date. [18%] Processing wip/track-target-genom:track-target-genom-0.2r1 ===> Bulk building for track-target-genom-0.2r1~openprs+tcl+tclserv_client Binary package for track-target-genom-0.2r1~openprs+tcl+tclserv_client is up-to-date. [19%] Processing wip/hrp2-bringup:hrp2-bringup-1.0.6 ===> Bulk building for hrp2-bringup-1.0.6 Binary package for hrp2-bringup-1.0.6 is up-to-date. [19%] Processing wip/hyper:hyper-0.13r1 ===> Bulk building for hyper-0.13r1 Binary package for hyper-0.13r1 is up-to-date. [20%] Processing wip/gerard-bauzil:gerard-bauzil-1.0.1 ===> Cleaning temporary files for gerard-bauzil-1.0.1 ===> Bulk building for gerard-bauzil-1.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required robotpkg package gepetto-viewer>=2.0.0: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for gerard-bauzil-1.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for gerard-bauzil-1.0.1 ===> Done bulk for gerard-bauzil-1.0.1 [20%] Processing wip/urg:urg-0.8.18 ===> Bulk building for urg-0.8.18 Binary package for urg-0.8.18 is up-to-date. [21%] Processing wip/jafar-qdisplay:jafar-qdisplay-0.2r1 ===> Bulk building for jafar-qdisplay-0.2r1 Binary package for jafar-qdisplay-0.2r1 is up-to-date. [21%] Processing wip/spark-genom:spark-genom-3.9 ===> Cleaning temporary files for spark-genom-3.9~mightability+openprs+tcl+tclserv_client ===> Bulk building for spark-genom-3.9~mightability+openprs+tcl+tclserv_client => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing genBasic-genom-0.4r1~openprs+tcl+tclserv_client.tgz => Installing genHum-genom-1.1r1~openprs+tcl+tclserv_client.tgz => Installing genManip-genom-0.9~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing libmove3d-3.22.0r1.tgz => Installing libmove3d-hri-2.24.tgz => Installing libt3d-2.6~doc.tgz => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Installing mocap-genom-1.3~openprs+tcl+tclserv_client.tgz => Installing niut-genom-0.6~openprs+tcl+tclserv_client.tgz => Dependency pocolibs-2.16 already installed => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Installing viman-genom-1.6~openprs+tcl+tclserv_client.tgz => Building with the following options: => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use tcl-8.5: tcl>=8.4 provided by tcl85>=8.5<8.6 => Required system package autoconf>=2.59: autoconf-2.68 found => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package libtool>=1.5.22: libtool-2.4.2 found => Required system package perl>=5: perl-5 found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package tcl85>=8.5<8.6: tcl85-8.5 found => Required robotpkg package genBasic-genom>=0.1: genBasic-genom-0.4r1~openprs+tcl+tclserv_client found => Required robotpkg package genHum-genom>=1.1: genHum-genom-1.1r1~openprs+tcl+tclserv_client found => Required robotpkg package genManip-genom>=0.9: genManip-genom-0.9~openprs+tcl+tclserv_client found => Required robotpkg package genom>=2.9: genom-2.12~doc found => Required robotpkg package libmove3d>=3.22.0: libmove3d-3.22.0r1 found => Required robotpkg package libmove3d-hri>=2.24: libmove3d-hri-2.24 found => Required robotpkg package libt3d>=2.6: libt3d-2.6~doc found => Required robotpkg package libtclserv_client>=0.3: libtclserv_client-0.5r1 found => Required robotpkg package mkdep>=2.6: mkdep-2.7r1 found => Required robotpkg package mocap-genom>=1.3: mocap-genom-1.3~openprs+tcl+tclserv_client found => Required robotpkg package niut-genom>=0.6: niut-genom-0.6~openprs+tcl+tclserv_client found => Required robotpkg package pocolibs>=2.11: pocolibs-2.16 found => Required robotpkg package pom-genom>=0.5r1: pom-genom-0.7~openprs+tcl+tclserv_client found => Required robotpkg package tclserv>=2.7: tclserv-2.8.1 found => Required robotpkg package transgen>=1.1b0: transgen-1.1b1 found => Required robotpkg package viman-genom>=1.4: viman-genom-1.6~openprs+tcl+tclserv_client found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for spark-genom-3.9~mightability+openprs+tcl+tclserv_client => Generating spark module An unexpected error occured. The last 10 log lines are shown below. | _override_vars_wip_libmove3d=PKGREQD PKGREQD PKGREQD | --- | Running set -e;cd /local/robotpkg/var/tmp/robotpkg/wip/spark-genom/work/spark-genom-3.9 && | /usr/bin/env CONFIG_SHELL=/bin/sh LIBS='' 'CPPFLAGS=' 'CFLAGS=-pipe -O3 -DNDEBUG' 'LDFLAGS=' 'CXXFLAGS=-pipe -O3 -DNDEBUG' PREFIX='/opt/openrobots' HOME=/local/robotpkg/var/tmp/robotpkg/wip/spark-genom/work PATH='/opt/openrobots/bin:/opt/openrobots/sbin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin' LD_LIBRARY_PATH='' | /opt/openrobots/bin/genom -DUSE_MIGHTABILITY_MAPS -o -t -x spark | Package libmove3d-planners was not found in the pkg-config search path. | Perhaps you should add the directory containing `libmove3d-planners.pc' | to the PKG_CONFIG_PATH environment variable | No package 'libmove3d-planners' found | error running /usr/bin/pkg-config For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/spark-genom/work/configure.log make[3]: *** [genom-generate] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking spark-genom-3.9~mightability+openprs+tcl+tclserv_client as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for spark-genom-3.9~mightability+openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for spark-genom-3.9~mightability+openprs+tcl+tclserv_client ===> Done bulk for spark-genom-3.9~mightability+openprs+tcl+tclserv_client [22%] Processing wip/dynamic-graph-v3:dynamic-graph-v3-3.0.1 ===> Bulk building for dynamic-graph-v3-3.0.1 Binary package for dynamic-graph-v3-3.0.1 is up-to-date. [22%] Processing wip/histodet:histodet-1.0r2 ===> Bulk building for histodet-1.0r2 Binary package for histodet-1.0r2 is up-to-date. [23%] Processing wip/MPC_DEMTreatment-genom:MPC_DEMTreatment-genom-0.2 ===> Bulk building for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client Binary package for MPC_DEMTreatment-genom-0.2~openprs+tcl+tclserv_client is up-to-date. [24%] Processing wip/talos-pal-hardware-interfaces:talos-pal-hardware-interfaces-0.0.3 ===> Bulk building for talos-pal-hardware-interfaces-0.0.3 Binary package for talos-pal-hardware-interfaces-0.0.3 is up-to-date. [24%] Processing wip/octovis:octoviz-1.6.1 ===> Cleaning temporary files for octoviz-1.6.1 ===> Bulk building for octoviz-1.6.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required system package libqglviewer>=2.3: MISSING => Installing octomap-1.6.1.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for octoviz-1.6.1: ERROR: ERROR: libqglviewer>=2.3 (Ubuntu package libqglviewer-qt4-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/octovis/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for octoviz-1.6.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for octoviz-1.6.1 ===> Done bulk for octoviz-1.6.1 [25%] Processing wip/sot-application:sot-application-1.0.0r1 ===> Bulk building for sot-application-1.0.0r1 Binary package for sot-application-1.0.0r1 is up-to-date. [25%] Processing wip/mrpt:mrpt-1.2.2r2 ===> Bulk building for mrpt-1.2.2r2 Binary package for mrpt-1.2.2r2 is up-to-date. [26%] Processing wip/vnet-yarp:vnet-yarp-0.2r2 ===> Bulk building for vnet-yarp-0.2r2 Binary package for vnet-yarp-0.2r2 is up-to-date. [26%] Processing wip/py-eigen:eigenpy-1.3.3 ===> Bulk building for eigenpy-1.3.3 Binary package for eigenpy-1.3.3 is up-to-date. [27%] Processing wip/py-morse:py32-morse-1.4 ===> Cleaning temporary files for py32-morse-1.4 ===> Bulk building for py32-morse-1.4 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.2: python>=3.2 provided by python32>=3.2<3.3 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package python32>=3.2<3.3: python32-3.2.3 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | CMake Error at config/FindPackageHandleStandardArgs.cmake:97 (MESSAGE): | Could NOT find PythonInterp: Found unsuitable version "3.2.3", but required | is at least "3.3" (found /usr/bin/python3.2) | Call Stack (most recent call first): | config/FindPackageHandleStandardArgs.cmake:286 (_FPHSA_FAILURE_MESSAGE) | config/FindPythonInterp.cmake:139 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | CMakeLists.txt:30 (find_package) | | | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-morse/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking py32-morse-1.4 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py32-morse-1.4 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py32-morse-1.4 ===> Done bulk for py32-morse-1.4 [27%] Processing wip/simple-humanoid-description:simple-humanoid-description-1.0.1 ===> Bulk building for simple-humanoid-description-1.0.1 Binary package for simple-humanoid-description-1.0.1 is up-to-date. [28%] Processing wip/MPC_planner-genom:MPC_planner-genom-0.2r1 ===> Bulk building for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client Binary package for MPC_planner-genom-0.2r1~openprs+tcl+tclserv_client is up-to-date. [28%] Processing wip/soth:soth-2.0.1r1 ===> Bulk building for soth-2.0.1r1 Binary package for soth-2.0.1r1 is up-to-date. [29%] Processing wip/libmove3d-planners:libmove3d-planners-1.4.0 ===> Cleaning temporary files for libmove3d-planners-1.4.0 ===> Bulk building for libmove3d-planners-1.4.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found WARNING: Cannot check installed version of boost-lib-filesystem WARNING: Cannot check installed version of boost-lib-iostreams WARNING: Cannot check installed version of boost-lib-math WARNING: Cannot check installed version of boost-lib-thread => Dependency digest-20080510 already installed WARNING: Cannot check installed version of libXpm => Installing libmove3d-3.22.0r1.tgz => Installing libmove3d-hri-2.24.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem{>=1.34.1<1.49,>=1.50}: boost-libs{ found => Required system package boostlib-iostreams{>=1.34.1<1.49,>=1.50}: boost-libs{ found => Required system package boostlib-math{>=1.34.1<1.49,>=1.50}: boost-libs{ found => Required system package boostlib-thread{>=1.34.1<1.49,>=1.50}: boost-libs{ found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package eigen3>=3.0.0: eigen3-3.0.5 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package glu>=7: glu-8.0.4 found => Required system package libXpm>=3.5.7: libXpm found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found WARNING: Cannot check installed version of boost-lib-filesystem WARNING: Cannot check installed version of boost-lib-iostreams WARNING: Cannot check installed version of boost-lib-math WARNING: Cannot check installed version of boost-lib-thread WARNING: Cannot check installed version of libXpm => Required robotpkg package libmove3d>=3.22.0: libmove3d-3.22.0r1 found => Required robotpkg package libmove3d-hri>=2.24: libmove3d-hri-2.24 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | Call Stack (most recent call first): | /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal) | CMakeLists.txt:284 (PKG_CHECK_MODULES) | | | -- checking for module 'liblog4cxx' | -- found liblog4cxx, version 0.10.0 | -- Found LOG4CXX: /usr/lib/liblog4cxx.so | include dirs: /usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include/libxml2;/usr/include;/usr/include/eigen3;/usr/include;/opt/openrobots/include;/opt/openrobots/include | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/libmove3d-planners/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking libmove3d-planners-1.4.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for libmove3d-planners-1.4.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for libmove3d-planners-1.4.0 ===> Done bulk for libmove3d-planners-1.4.0 [29%] Processing wip/kukaFri-libs:kukaFri-libs-1.3 ===> Bulk building for kukaFri-libs-1.3 Binary package for kukaFri-libs-1.3 is up-to-date. [30%] Processing wip/talos-ros-controllers:talos-ros-controllers-0.2.11 ===> Bulk building for talos-ros-controllers-0.2.11 Binary package for talos-ros-controllers-0.2.11 is up-to-date. [31%] Processing wip/orocos-bfl:orocos-bfl-0.8.0 ===> Bulk building for orocos-bfl-0.8.0 Binary package for orocos-bfl-0.8.0 is up-to-date. [31%] Processing wip/laaswm-gui:laaswm-gui-1.4 ===> Bulk building for laaswm-gui-1.4 Binary package for laaswm-gui-1.4 is up-to-date. [32%] Processing wip/osg-dae:osg-dae-3.2.1r1 ===> Cleaning temporary files for osg-dae-3.2.1r1 ===> Bulk building for osg-dae-3.2.1r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20130505~ssl: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing collada-dom-2.3.1r2.tgz => Dependency digest-20080510 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-system>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package openscenegraph>=3: openscenegraph-3.0.1 found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required robotpkg package collada-dom>=2.3.1: collada-dom-2.3.1r2 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | -- found collada14dom , version 2.3.1 | -- Pkg-config module collada14dom v2.3.1 has been detected with success. | CMake Error at cmake/pkg-config.cmake:749 (MESSAGE): | The package openscenegraph has not been found. | Call Stack (most recent call first): | cmake/pkg-config.cmake:767 (BUILD_PREFIX_FOR_PKG) | src/osgPlugins/dae/CMakeLists.txt:86 (PKG_CONFIG_USE_DEPENDENCY) | | | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/osg-dae/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking osg-dae-3.2.1r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for osg-dae-3.2.1r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for osg-dae-3.2.1r1 ===> Done bulk for osg-dae-3.2.1r1 [32%] Processing wip/py-jsbsim:py27-jsbsim-20150424r1 ===> Cleaning temporary files for py27-jsbsim-20150424r1 ===> Bulk building for py27-jsbsim-20150424r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package cvs>=1: cvs-1.12.138 found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing jsbsim-20150424.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required robotpkg package jsbsim>=1.0: jsbsim-20150424 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE): | Could NOT find Cython (missing: CYTHON_EXECUTABLE) | Call Stack (most recent call first): | /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE) | CMakeModules/FindCython.cmake:42 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | CMakeModules/UseCython.cmake:74 (find_package) | CMakeLists.txt:6 (include) | | | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking py27-jsbsim-20150424r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py27-jsbsim-20150424r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py27-jsbsim-20150424r1 ===> Done bulk for py27-jsbsim-20150424r1 [33%] Processing wip/py-jsbsim:py32-jsbsim-20150424r1 ===> Cleaning temporary files for py32-jsbsim-20150424r1 ===> Bulk building for py32-jsbsim-20150424r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package cvs>=1: cvs-1.12.138 found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing jsbsim-20150424.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-3.2: python>=2.5<3.7 provided by python32>=3.2<3.3 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package python32>=3.2<3.3: python32-3.2.3 found => Required robotpkg package jsbsim>=1.0: jsbsim-20150424 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE): | Could NOT find Cython (missing: CYTHON_EXECUTABLE) | Call Stack (most recent call first): | /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE) | CMakeModules/FindCython.cmake:42 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) | CMakeModules/UseCython.cmake:74 (find_package) | CMakeLists.txt:6 (include) | | | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/py-jsbsim/work/configure.log make[3]: *** [do-configure-cmake] Error 1 make[2]: *** [pkg-check-installed] Error 2 => Marking py32-jsbsim-20150424r1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for py32-jsbsim-20150424r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for py32-jsbsim-20150424r1 ===> Done bulk for py32-jsbsim-20150424r1 [33%] Processing wip/msgconnector:msgconnector-2.13.0 ===> Bulk building for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp Binary package for msgconnector-2.13.0~bridge-print+liboro+openprs+yarp is up-to-date. [34%] Processing wip/gladys:gladys-0.2.8 ===> Cleaning temporary files for gladys-0.2.8~python ===> Bulk building for gladys-0.2.8~python => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required robotpkg package gdalwrap>=0.1: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for gladys-0.2.8~python => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for gladys-0.2.8~python ===> Done bulk for gladys-0.2.8~python [34%] Processing wip/lua-rfsm:lua-rfsm-20131212.44fcec2db5r2 ===> Bulk building for lua-rfsm-20131212.44fcec2db5r2 Binary package for lua-rfsm-20131212.44fcec2db5r2 is up-to-date. [35%] Processing wip/roralink:roralink-0.1 ===> Bulk building for roralink-0.1 Binary package for roralink-0.1 is up-to-date. [35%] Processing wip/antlr2:antlr2-2.7.7 ===> Bulk building for antlr2-2.7.7 Binary package for antlr2-2.7.7 is up-to-date. [36%] Processing wip/pal-msgs:pal-msgs-0.11.3 ===> Bulk building for pal-msgs-0.11.3 Binary package for pal-msgs-0.11.3 is up-to-date. [36%] Processing wip/libfreenect:libfreenect-20110118.2ea3ebr1 ===> Bulk building for libfreenect-20110118.2ea3ebr1 Binary package for libfreenect-20110118.2ea3ebr1 is up-to-date. [37%] Processing wip/robotModelParser-libs:robotModelParser-libs-1.0 ===> Bulk building for robotModelParser-libs-1.0 Binary package for robotModelParser-libs-1.0 is up-to-date. [37%] Processing wip/talos-moveit-config:talos-moveit-config-0.2.3 ===> Bulk building for talos-moveit-config-0.2.3 Binary package for talos-moveit-config-0.2.3 is up-to-date. [38%] Processing wip/orocos-yarp_transport:orocos-yarp_transport-20150316 ===> Bulk building for orocos-yarp_transport-20150316~doc Binary package for orocos-yarp_transport-20150316~doc is up-to-date. [39%] Processing wip/atlaas:atlaas-0.1.6 ===> Cleaning temporary files for atlaas-0.1.6 ===> Bulk building for atlaas-0.1.6 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required robotpkg package gdalwrap>=0.1: N/A => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for atlaas-0.1.6 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for atlaas-0.1.6 ===> Done bulk for atlaas-0.1.6 [39%] Processing wip/talos-robot:talos-robot-0.0.14r1 ===> Bulk building for talos-robot-0.0.14r1 Binary package for talos-robot-0.0.14r1 is up-to-date. [40%] Processing wip/libnabo:libnabo-1.0.4 ===> Bulk building for libnabo-1.0.4 Binary package for libnabo-1.0.4 is up-to-date. [40%] Processing wip/py-dynamic-graph-v3:py27-dynamic-graph-v3-3.0.2 ===> Bulk building for py27-dynamic-graph-v3-3.0.2 Binary package for py27-dynamic-graph-v3-3.0.2 is up-to-date. [41%] Processing wip/hatponboard-lib:hatponboard-lib-3.4.0 ===> Bulk building for hatponboard-lib-3.4.0~enable-goal Binary package for hatponboard-lib-3.4.0~enable-goal is up-to-date. [41%] Processing wip/talos-gazebo-ros-control:talos-gazebo-ros-control-2.6.6 ===> Cleaning temporary files for talos-gazebo-ros-control-2.6.6 ===> Bulk building for talos-gazebo-ros-control-2.6.6 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing talos-ros-control-0.2.10.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros hydro: ros>=groovy ros>=hydro provided by ros-hydro => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.8.3: cmake-2.8.7 found => Required system package eigen3>=3.0.0: eigen3-3.0.5 found => Required system package g++>=3: g++-4.6 found => Required system package gazebo>=1: gazebo-1.9.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package googletest: googletest found => Required system package libogre>=1.0: libogre-1.7.4 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package py27-nose>=0.10: py27-nose-1.1.2 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required system package ros-actionlib>=1.10<1.11: ros-actionlib-1.10.3 found => Required system package ros-catkin>=0.5<0.6: ros-catkin-0.5.90 found => Required system package ros-comm>=1.10<1.11: ros-comm-1.10.12 found => Required system package ros-common-msgs>=1.10<1.11: ros-common-msgs-1.10.6 found => Required system package ros-control-toolbox>=1.10<1.13: ros-control-toolbox-1.10.4 found => Required system package ros-genmsg>=0.4<0.5: ros-genmsg-0.4.26 found => Required system package ros-geometry>=1.10<1.11: ros-geometry-1.10.8 found => Required system package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required system package ros-message-runtime>=0.4<0.5 : ros-message-runtime-0.4.12 found => Required system package ros-pluginlib>=1.9<1.10: ros-pluginlib-1.9.24 found => Required system package ros-robot-model>=1.10<1.11: ros-robot-model-1.10.21 found => Required system package ros-ros>=1.10<1.11: ros-ros-1.10.11 found => Required system package ros-std-msgs>=0.5 : ros-std-msgs-0.5.8 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required robotpkg package talos-ros-control>=0.2: talos-ros-control-0.2.10 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | make[1]: *** [CMakeFiles/talos_default_robot_hw_sim.dir/all] Error 2 | make[1]: *** Waiting for unfinished jobs.... | Linking CXX shared library /local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/stage/lib/libtalos_gazebo_ros_control.so | /usr/bin/cmake -E cmake_link_script CMakeFiles/talos_gazebo_ros_control.dir/link.txt --verbose=1 | /usr/bin/g++ -fPIC -pipe -O3 -DNDEBUG -Wl,-rpath,/opt/ros/hydro/lib -shared -Wl,-soname,libtalos_gazebo_ros_control.so -o /local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/stage/lib/libtalos_gazebo_ros_control.so CMakeFiles/talos_gazebo_ros_control.dir/src/gazebo_ros_control_plugin.cpp.o -L/usr/lib/gazebo-1.9/plugins /opt/ros/hydro/lib/libcontrol_toolbox.so /opt/ros/hydro/lib/libtf.so /opt/ros/hydro/lib/libtf2_ros.so /opt/ros/hydro/lib/libactionlib.so /opt/ros/hydro/lib/libmessage_filters.so /opt/ros/hydro/lib/libtf2.so /opt/ros/hydro/lib/libdynamic_reconfigure_config_init_mutex.so /opt/openrobots/lib/libtalos_controller_manager.so /opt/ros/hydro/lib/librealtime_tools.so /opt/openrobots/lib/libtalos_transmission_interface_parser.so /opt/openrobots/lib/libtalos_transmission_interface_loader.so /opt/openrobots/lib/libtalos_transmission_interface_loader_plugins.so /opt/ros/hydro/lib/libresource_retriever.so -ltinyxml /opt/ros/hydro/lib/libclass_loader.so -lPocoFoundation -ldl /opt/ros/hydro/lib/libroslib.so /opt/ros/hydro/lib/liburdf.so /opt/ros/hydro/lib/liburdfdom_sensor.so /opt/ros/hydro/lib/liburdfdom_model_state.so /opt/ros/hydro/lib/liburdfdom_model.so /opt/ros/hydro/lib/liburdfdom_world.so /opt/ros/hydro/lib/librosconsole_bridge.so /opt/ros/hydro/lib/libroscpp.so -lboost_signals-mt -lboost_filesystem-mt /opt/ros/hydro/lib/librosconsole.so /opt/ros/hydro/lib/librosconsole_log4cxx.so /opt/ros/hydro/lib/librosconsole_backend_interface.so -llog4cxx -lboost_regex-mt /opt/ros/hydro/lib/libroscpp_serialization.so /opt/ros/hydro/lib/librostime.so -lboost_date_time-mt -lboost_system-mt -lboost_thread-mt -lpthread /opt/ros/hydro/lib/libxmlrpcpp.so /opt/ros/hydro/lib/libcpp_common.so /opt/ros/hydro/lib/libconsole_bridge.so -lgazebo_ccd -lgazebo_common -lgazebo_gimpact -lgazebo_gui -lgazebo_gui_building -lgazebo_gui_viewers -lgazebo_math -lgazebo_msgs -lgazebo_ode -lgazebo_opcode -lgazebo_opende_ou -lgazebo_physics -lgazebo_physics_ode -lgazebo_rendering -lgazebo_selection_buffer -lgazebo_sensors -lgazebo_skyx -lgazebo_transport -lgazebo_util -lgazebo_player -lprotobuf -lsdformat -Wl,-rpath,/usr/lib/gazebo-1.9/plugins:/opt/ros/hydro/lib:/opt/openrobots/lib:::::::::::::::::::: | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/talos_gazebo_ros_control-2.6.6' | /usr/bin/cmake -E cmake_progress_report /local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/talos_gazebo_ros_control-2.6.6/CMakeFiles 9 | [ 66%] Built target talos_gazebo_ros_control | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/talos_gazebo_ros_control-2.6.6' | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-gazebo-ros-control/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking talos-gazebo-ros-control-2.6.6 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for talos-gazebo-ros-control-2.6.6 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-gazebo-ros-control-2.6.6 ===> Done bulk for talos-gazebo-ros-control-2.6.6 [42%] Processing wip/orocos-dot_service:orocos-dot_service-20120308 ===> Bulk building for orocos-dot_service-20120308 Binary package for orocos-dot_service-20120308 is up-to-date. [42%] Processing wip/talos-roboticsgroup-gazebo-plugins:talos-roboticsgroup-gazebo-plugins-0.0.3 ===> Bulk building for talos-roboticsgroup-gazebo-plugins-0.0.3 Binary package for talos-roboticsgroup-gazebo-plugins-0.0.3 is up-to-date. [43%] Processing wip/sot-dyninv:sot-dyninv-2.0.0 ===> Bulk building for sot-dyninv-2.0.0 Binary package for sot-dyninv-2.0.0 is up-to-date. [43%] Processing wip/mhp-genom:mhp-genom-3.15 ===> Cleaning temporary files for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client ===> Bulk building for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing gbM-0.11~tcl.tgz => Installing genManip-genom-0.9~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing libmove3d-3.22.0r1.tgz => Installing libmove3d-hri-2.24.tgz => Installing libt3d-2.6~doc.tgz => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz ERROR: Required robotpkg package spark-genom>=3.9: BROKEN => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed ===> Logging bulk summary for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client ===> Done bulk for mhp-genom-3.15~openprs+pr2+spark+tcl+tclserv_client [44%] Processing wip/libpointmatcher:libpointmatcher-1.1.0 ===> Bulk building for libpointmatcher-1.1.0 Binary package for libpointmatcher-1.1.0 is up-to-date. [44%] Processing wip/pinocchio:pinocchio-1.2.5r1 ===> Bulk building for pinocchio-1.2.5r1 Binary package for pinocchio-1.2.5r1 is up-to-date. [45%] Processing wip/talos-pal-gazebo-plugins:talos-pal-gazebo-plugins-1.1.5r2 ===> Cleaning temporary files for talos-pal-gazebo-plugins-1.1.5r2 ===> Bulk building for talos-pal-gazebo-plugins-1.1.5r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing pal-msgs-0.11.3.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros hydro: ros>=groovy ros>=hydro provided by ros-hydro => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.8.3: cmake-2.8.7 found => Required system package eigen3>=3.0.0: eigen3-3.0.5 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package googletest: googletest found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package py27-nose>=0.10: py27-nose-1.1.2 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required system package ros-actionlib>=1.10<1.11: ros-actionlib-1.10.3 found => Required system package ros-catkin>=0.5<0.6: ros-catkin-0.5.90 found => Required system package ros-comm>=1.10<1.11: ros-comm-1.10.12 found => Required system package ros-common-msgs>=1.10<1.11: ros-common-msgs-1.10.6 found => Required system package ros-control-toolbox>=1.10<1.13: ros-control-toolbox-1.10.4 found => Required system package ros-genmsg>=0.4<0.5: ros-genmsg-0.4.26 found => Required system package ros-geometry>=1.10<1.11: ros-geometry-1.10.8 found => Required system package ros-message-generation>=0.2<0.3: ros-message-generation-0.2.10 found => Required system package ros-message-runtime>=0.4<0.5 : ros-message-runtime-0.4.12 found => Required system package ros-pluginlib>=1.9<1.10: ros-pluginlib-1.9.24 found => Required system package ros-robot-model>=1.10<1.11: ros-robot-model-1.10.21 found => Required system package ros-ros>=1.10<1.11: ros-ros-1.10.11 found => Required system package ros-std-msgs>=0.5 : ros-std-msgs-0.5.8 found => Required system package tinyxml>=2: tinyxml-2.6.2 found => Required robotpkg package pal-msgs>=0.11.3: pal-msgs-0.11.3 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for talos-pal-gazebo-plugins-1.1.5r2 An unexpected error occured. The last 10 log lines are shown below. | /usr/bin/cmake -E cmake_progress_report /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/talos_pal_gazebo_plugins-1.1.5/CMakeFiles 3 | [ 66%] Built target gazebo_pal_hand | Linking CXX shared library /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/stage/lib/libgazebo_ros_forcetorque.so | /usr/bin/cmake -E cmake_link_script CMakeFiles/gazebo_ros_forcetorque.dir/link.txt --verbose=1 | /usr/bin/g++ -fPIC -pipe -O3 -DNDEBUG -Wl,-rpath,/opt/ros/hydro/lib -shared -Wl,-soname,libgazebo_ros_forcetorque.so -o /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/stage/lib/libgazebo_ros_forcetorque.so CMakeFiles/gazebo_ros_forcetorque.dir/src/gazebo_ros_forcetorque.cpp.o -L/usr/lib/gazebo-1.9/plugins -lgazebo_ccd -lgazebo_common -lgazebo_gimpact -lgazebo_gui -lgazebo_gui_building -lgazebo_gui_viewers -lgazebo_math -lgazebo_msgs -lgazebo_ode -lgazebo_opcode -lgazebo_opende_ou -lgazebo_physics -lgazebo_physics_ode -lgazebo_rendering -lgazebo_selection_buffer -lgazebo_sensors -lgazebo_skyx -lgazebo_transport -lgazebo_util -lgazebo_player -lprotobuf -lsdformat /opt/ros/hydro/lib/libcontrol_toolbox.so /opt/ros/hydro/lib/libtf.so /opt/ros/hydro/lib/libtf2_ros.so /opt/ros/hydro/lib/libactionlib.so /opt/ros/hydro/lib/libmessage_filters.so /opt/ros/hydro/lib/libtf2.so /opt/ros/hydro/lib/libdynamic_reconfigure_config_init_mutex.so /opt/ros/hydro/lib/librealtime_tools.so /opt/ros/hydro/lib/libroscpp.so -lboost_signals-mt -lboost_filesystem-mt /opt/ros/hydro/lib/librosconsole.so /opt/ros/hydro/lib/librosconsole_log4cxx.so /opt/ros/hydro/lib/librosconsole_backend_interface.so -llog4cxx -lboost_regex-mt /opt/ros/hydro/lib/libxmlrpcpp.so /opt/ros/hydro/lib/libroscpp_serialization.so /opt/ros/hydro/lib/librostime.so -lboost_date_time-mt -lboost_system-mt -lboost_thread-mt -lpthread /opt/ros/hydro/lib/libcpp_common.so /opt/ros/hydro/lib/libconsole_bridge.so -Wl,-rpath,/usr/lib/gazebo-1.9/plugins:/opt/ros/hydro/lib:::::::::::::::::::: | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/talos_pal_gazebo_plugins-1.1.5' | /usr/bin/cmake -E cmake_progress_report /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/talos_pal_gazebo_plugins-1.1.5/CMakeFiles 4 | [ 66%] Built target gazebo_ros_forcetorque | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/talos_pal_gazebo_plugins-1.1.5' | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/talos-pal-gazebo-plugins/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking talos-pal-gazebo-plugins-1.1.5r2 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for talos-pal-gazebo-plugins-1.1.5r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-pal-gazebo-plugins-1.1.5r2 ===> Done bulk for talos-pal-gazebo-plugins-1.1.5r2 [45%] Processing wip/hatpconsole:hatpconsole-2.0.0 ===> Bulk building for hatpconsole-2.0.0 Binary package for hatpconsole-2.0.0 is up-to-date. [46%] Processing wip/jrl-walkgen-v3:jrl-walkgen-v3-4.0.1 ===> Cleaning temporary files for jrl-walkgen-v3-4.0.1 ===> Bulk building for jrl-walkgen-v3-4.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing jrl-mal-1.19.6r1~jrl-mathtools.tgz => Installing pinocchio-1.2.5r1.tgz => Installing qpOASES-3.2.0.tgz => Installing simple-humanoid-description-1.0.1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use the GNU fortran compiler: fortran-compiler provided by => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package gcc-fortran>=3: gcc-fortran-4.6 found => Required system package graphviz>=2: graphviz-2.26.3 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required robotpkg package jrl-mal>=1.8.3: jrl-mal-1.19.6r1~jrl-mathtools found => Required robotpkg package pinocchio>=1.1.2: pinocchio-1.2.5r1 found => Required robotpkg package qpOASES>=3.2.0: qpOASES-3.2.0 found => Required robotpkg package simple-humanoid-description>=1.0.1: simple-humanoid-description-1.0.1 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for jrl-walkgen-v3-4.0.1 An unexpected error occured. The last 10 log lines are shown below. | [ 90%] Building CXX object tests/CMakeFiles/TestMorisawa2007GoingDown1064.dir/ClockCPUTime.cpp.o | cd /local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build/tests && /usr/bin/g++ -DBOOST_NO_CXX11_DEFAULTED_FUNCTIONS -DHAVE_SYS_TIME_H -std=c++0x -O3 -DNDEBUG -I/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build -I/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build/include -I/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/include -isystem /usr/include/eigen3 -I/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/src -isystem /opt/openrobots/include -isystem /usr/include/assimp -I/opt/openrobots/include -I/opt/openrobots/include -DWITH_URDFDOM -DWITH_HPP_FCL -I/opt/openrobots/include -I/usr/include/assimp -I/usr/include/eigen3 -o CMakeFiles/TestMorisawa2007GoingDown1064.dir/ClockCPUTime.cpp.o -c /local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/tests/ClockCPUTime.cpp | make[2]: *** [tests/CMakeFiles/TestMorisawa2007GoingDown1064.dir/TestObject.cpp.o] Error 1 | make[2]: *** Waiting for unfinished jobs.... | make[1]: *** [tests/CMakeFiles/TestNaveau2015Online64.dir/all] Error 2 | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build' | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build' | make[1]: *** [tests/CMakeFiles/TestMorisawa2007GoingDown1064.dir/all] Error 2 | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/jrl-walkgen-v3-4.0.1/_build' | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/jrl-walkgen-v3/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking jrl-walkgen-v3-4.0.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for jrl-walkgen-v3-4.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for jrl-walkgen-v3-4.0.1 ===> Done bulk for jrl-walkgen-v3-4.0.1 [47%] Processing wip/talos-pal-hardware-gazebo:talos-pal-hardware-gazebo-0.0.9r1 ===> Cleaning temporary files for talos-pal-hardware-gazebo-0.0.9r1 ===> Bulk building for talos-pal-hardware-gazebo-0.0.9r1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed ERROR: Required robotpkg package talos-gazebo-ros-control>=2.6.5: BROKEN => Installing talos-pal-hardware-interfaces-0.0.3.tgz => Dependency talos-ros-control-0.2.10 already installed => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-pal-hardware-gazebo-0.0.9r1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-pal-hardware-gazebo-0.0.9r1 ===> Done bulk for talos-pal-hardware-gazebo-0.0.9r1 [47%] Processing wip/move3d-studio:move3d-studio-1.4r3 ===> Cleaning temporary files for move3d-studio-1.4r3~qtstudio ===> Bulk building for move3d-studio-1.4r3~qtstudio => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing gbM-0.11~tcl.tgz WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm => Installing libmove3d-3.22.0r1.tgz => Installing libmove3d-hri-2.24.tgz ERROR: Required robotpkg package libmove3d-planners>=1.4.0: BROKEN => Dependency softMotion-libs-3.12~debug+tcl already installed => Dependency tnftp-20130505~ssl already installed WARNING: Cannot check installed version of glpk WARNING: Cannot check installed version of libXpm ===> Logging bulk summary for move3d-studio-1.4r3~qtstudio => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for move3d-studio-1.4r3~qtstudio ===> Done bulk for move3d-studio-1.4r3~qtstudio [48%] Processing wip/hyper-genom-plugin:hyper-genom-plugin-0.12 ===> Bulk building for hyper-genom-plugin-0.12 Binary package for hyper-genom-plugin-0.12 is up-to-date. [48%] Processing wip/hyper-viewer:hyper-viewer-0.1r1 ===> Bulk building for hyper-viewer-0.1r1 Binary package for hyper-viewer-0.1r1 is up-to-date. [49%] Processing wip/hatptester:hatptester-1.5.3 ===> Bulk building for hatptester-1.5.3 Binary package for hatptester-1.5.3 is up-to-date. [49%] Processing wip/pr2-pick-object:laas-pr2-pick-object ===> Bulk building for laas-pr2-pick-object Binary package for laas-pr2-pick-object is up-to-date. [50%] Processing wip/talos-simulation:talos-simulation-0.0.14r2 ===> Cleaning temporary files for talos-simulation-0.0.14r2 ===> Bulk building for talos-simulation-0.0.14r2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing talos-moveit-config-0.2.3.tgz ERROR: Required robotpkg package talos-pal-gazebo-plugins>=1.1.5: BROKEN ERROR: Required robotpkg package talos-pal-hardware-gazebo>=0.0.9: BROKEN => Installing talos-robot-0.0.14r1.tgz => Installing talos-roboticsgroup-gazebo-plugins-0.0.3.tgz => Dependency tnftp-20130505~ssl already installed ===> Logging bulk summary for talos-simulation-0.0.14r2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-simulation-0.0.14r2 ===> Done bulk for talos-simulation-0.0.14r2 [50%] Processing wip/MPC_avoidObs-genom:MPC_avoidObs-genom-0.2r1 ===> Bulk building for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client Binary package for MPC_avoidObs-genom-0.2r1~openprs+tcl+tclserv_client is up-to-date. [51%] Processing wip/atlaas-genom:atlaas-genom-0.1.6 ===> Cleaning temporary files for atlaas-genom-0.1.6~openprs+tcl+tclserv_client ===> Bulk building for atlaas-genom-0.1.6~openprs+tcl+tclserv_client => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Required robotpkg package atlaas>=0.1: N/A => Dependency digest-20080510 already installed => Required robotpkg package gdalwrap>=0.1: N/A => Installing genBasic-genom-0.4r1~openprs+tcl+tclserv_client.tgz => Installing genPos-genom-0.3r1~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing libimages3d-3.4r3.tgz => Dependency libt3d-2.6~doc already installed => Dependency libtclserv_client-0.5r1 already installed => Installing mkdep-2.7r1.tgz => Dependency pocolibs-2.16 already installed => Installing pom-genom-0.7~openprs+tcl+tclserv_client.tgz => Dependency tclserv-2.8.1 already installed => Dependency tnftp-20130505~ssl already installed => Dependency transgen-1.1b1 already installed => Installing velodyne-genom-1.6~openprs+tcl+tclserv_client.tgz ===> Logging bulk summary for atlaas-genom-0.1.6~openprs+tcl+tclserv_client => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for atlaas-genom-0.1.6~openprs+tcl+tclserv_client ===> Done bulk for atlaas-genom-0.1.6~openprs+tcl+tclserv_client [51%] Processing wip/sot-hrprtc-hrp2:sot-hrprtc-hrp2-1.2.2 ===> Cleaning temporary files for sot-hrprtc-hrp2-1.2.2 ===> Bulk building for sot-hrprtc-hrp2-1.2.2 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing dynamic-graph-2.5.7.tgz => Installing dynamic-graph-bridge-2.0.9.tgz => Dependency dynamic-graph-bridge-msgs-0.2.0 already installed => Installing hrp2-14-1.9.3.tgz => Installing hrp2-14-description-1.0.4.tgz => Installing hrp2-bringup-1.0.6.tgz => Dependency hrp2-computer-monitor-1.0.2 already installed => Installing hrp2-dynamics-1.5.3.tgz => Dependency hrp2-machine-1.0.2 already installed => Dependency py27-dynamic-graph-2.5.6r1 already installed => Dependency py27-sot-tools-1.0.1 already installed => Installing sot-application-1.0.0r1.tgz => Dependency sot-core-2.9.10 already installed => Dependency sot-dynamic-2.9.2 already installed => Installing sot-dyninv-2.0.0.tgz => Installing sot-pattern-generator-2.9.1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros hydro: ros>=groovy provided by ros-hydro => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package graphviz>=2: graphviz-2.26.3 found => Required system package libstdc++: libstdc++ found => Required system package openrtm-aist>=1 : openrtm-aist-1.1.0 found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required system package ros-comm>=1.10<1.11: ros-comm-1.10.12 found => Required system package ros-message-runtime>=0.4<0.5 : ros-message-runtime-0.4.12 found => Required system package ros-std-msgs>=0.5 : ros-std-msgs-0.5.8 found => Required robotpkg package dynamic-graph>=2.5.6: dynamic-graph-2.5.7 found => Required robotpkg package dynamic-graph-bridge>=1.0.0: dynamic-graph-bridge-2.0.9 found => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: dynamic-graph-bridge-msgs-0.2.0 found => Required robotpkg package hrp2-14>=1.7.5: hrp2-14-1.9.3 found => Required robotpkg package hrp2-14-description>=1.0.0: hrp2-14-description-1.0.4 found => Required robotpkg package hrp2-bringup>=1.0.0: hrp2-bringup-1.0.6 found => Required robotpkg package hrp2-computer-monitor>=1.0.0: hrp2-computer-monitor-1.0.2 found => Required robotpkg package hrp2-dynamics>=1.5: hrp2-dynamics-1.5.3 found => Required robotpkg package hrp2-machine>=1.0.0: hrp2-machine-1.0.2 found => Required robotpkg package py27-dynamic-graph>=2.5: py27-dynamic-graph-2.5.6r1 found => Required robotpkg package py27-sot-tools>=1.0: py27-sot-tools-1.0.1 found => Required robotpkg package sot-application>=1.0.0: sot-application-1.0.0r1 found => Required robotpkg package sot-core>=2.5: sot-core-2.9.10 found => Required robotpkg package sot-dynamic>=2.5: sot-dynamic-2.9.2 found => Required robotpkg package sot-dyninv>=2.0.0: sot-dyninv-2.0.0 found => Required robotpkg package sot-pattern-generator>=2.7: sot-pattern-generator-2.9.1 found => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | -- PKG_CONFIG_STRING: sot-core | CMake Error at cmake/openhrp.cmake:61 (MESSAGE): | None of the following robots (HRP2JRL;HRP2LAAS;HRP4LIRMM) were found in | GRX_PREFIX-NOTFOUND. | Call Stack (most recent call first): | CMakeLists.txt:32 (SEARCH_GRX_ROBOTS) | | -- Pkg-config module sot-core v2.9.10 has been detected with success. | | -- Configuring incomplete, errors occurred! For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/sot-hrprtc-hrp2/work/configure.log make[3]: *** [do-configure-cmake] Error 1 => Marking sot-hrprtc-hrp2-1.2.2 as broken make[2]: *** [pkg-check-installed] Error 2 ERROR: make: *** [package] Error 2 ===> Logging bulk summary for sot-hrprtc-hrp2-1.2.2 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-hrprtc-hrp2-1.2.2 ===> Done bulk for sot-hrprtc-hrp2-1.2.2 [52%] Processing wip/tsid:tsid-1.0.0 ===> Cleaning temporary files for tsid-1.0.0 ===> Bulk building for tsid-1.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Required system package eigen3>=3.2.0: MISSING => Installing pinocchio-1.2.5r1.tgz => Dependency tnftp-20130505~ssl already installed ERROR: ====================================================================== ERROR: Missing system packages required for tsid-1.0.0: ERROR: ERROR: eigen3>=3.2.0 (Ubuntu package libeigen3-dev) ERROR: ERROR: Please use the system package management tool to install these ERROR: dependencies. If a robotpkg version of a dependency is available, ERROR: you can configure robotpkg.conf to use this version instead. ERROR: ERROR: See /local/robotpkg/var/tmp/robotpkg/wip/tsid/work/sysdep.log for details. ERROR: ====================================================================== make[2]: *** [sys-depends] Error 2 ===> Logging bulk summary for tsid-1.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for tsid-1.0.0 ===> Done bulk for tsid-1.0.0 [52%] Processing wip/sot-hrp2:sot-hrp2-1.1.2 ===> Bulk building for sot-hrp2-1.1.2 Binary package for sot-hrp2-1.1.2 is up-to-date. [53%] Processing wip/sot-core-v3:sot-core-v3-3.1.1 ===> Bulk building for sot-core-v3-3.1.1 Binary package for sot-core-v3-3.1.1 is up-to-date. [54%] Processing wip/hri-simulation:hri-simulationr1 ===> Cleaning temporary files for hri-simulationr1 ===> Bulk building for hri-simulationr1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing alog-0.5.tgz => Dependency digest-20080510 already installed => Installing genPos-genom-0.3r1~openprs+tcl+tclserv_client.tgz => Dependency genom-2.12~doc already installed => Installing libt3d-2.6~doc.tgz ERROR: Required robotpkg package mhp-genom>=3.15: BROKEN => Installing morse-pocolibs-1.2.2r1.tgz => Installing move3d-assets-20120125.tgz => Installing platine-genom-0.5~openprs+tcl+tclserv_client.tgz => Dependency pom-genom-0.7~openprs+tcl+tclserv_client already installed => Installing py27-poco-1.5.tgz ERROR: Required robotpkg package spark-genom>=3.9: BROKEN => Dependency tnftp-20130505~ssl already installed => Installing viman-genom-1.6~openprs+tcl+tclserv_client.tgz ===> Logging bulk summary for hri-simulationr1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hri-simulationr1 ===> Done bulk for hri-simulationr1 [54%] Processing wip/py-sot-tools-v3:py27-sot-tools-v3-2.0.2 ===> Bulk building for py27-sot-tools-v3-2.0.2 Binary package for py27-sot-tools-v3-2.0.2 is up-to-date. [55%] Processing wip/MPC_controller-genom:MPC_controller-genom-0.2 ===> Bulk building for MPC_controller-genom-0.2~openprs+tcl+tclserv_client Binary package for MPC_controller-genom-0.2~openprs+tcl+tclserv_client is up-to-date. [55%] Processing wip/sot-dynamic-pinocchio-v3:sot-dynamic-pinocchio-v3-3.1.5r1 ===> Bulk building for sot-dynamic-pinocchio-v3-3.1.5r1 Binary package for sot-dynamic-pinocchio-v3-3.1.5r1 is up-to-date. [56%] Processing wip/sot-dyninv-v3:sot-dyninv-v3-3.0.0 ===> Cleaning temporary files for sot-dyninv-v3-3.0.0 ===> Bulk building for sot-dyninv-v3-3.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing py27-dynamic-graph-v3-3.0.2.tgz => Installing sot-core-v3-3.1.1.tgz => Installing soth-2.0.1r1.tgz => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python<3.0 provided by python27>=2.7<2.8 => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required robotpkg package py27-dynamic-graph-v3>=3.0: py27-dynamic-graph-v3-3.0.2 found => Required robotpkg package sot-core-v3>=3.0.0: sot-core-v3-3.1.1 found => Required robotpkg package soth>=2.0.0: soth-2.0.1r1 found => SHA1 checksums OK => RMD160 checksums OK => Compiling python files => Adding run-time search paths to pkg-config files => Registering installation for sot-dyninv-v3-3.0.0 => Linking package in /opt/robotpkg/var/lib/robotpkg/packages/bsd/Ubuntu-12.04-x86_64/pub => Building debian binary package ===> Logging bulk summary for sot-dyninv-v3-3.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-dyninv-v3-3.0.0 ===> Done bulk for sot-dyninv-v3-3.0.0 [56%] Processing wip/sot-application-v3:sot-application-v3-1.1.3 ===> Bulk building for sot-application-v3-1.1.3 Binary package for sot-application-v3-1.1.3 is up-to-date. [57%] Processing wip/dynamic-graph-bridge-v3:dynamic-graph-bridge-v3-3.0.8 ===> Bulk building for dynamic-graph-bridge-v3-3.0.8 Binary package for dynamic-graph-bridge-v3-3.0.8 is up-to-date. [57%] Processing wip/sot-pattern-generator-v3:sot-pattern-generator-v3-3.0.0 ===> Cleaning temporary files for sot-pattern-generator-v3-3.0.0 ===> Bulk building for sot-pattern-generator-v3-3.0.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package patch>=2.0: patch-2.6.1 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing jrl-walkgen-v3-4.0.1.tgz => Dependency pinocchio-1.2.5r1 already installed => Installing sot-application-v3-1.1.3.tgz => Dependency sot-core-v3-3.1.1 already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package libstdc++: libstdc++ found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required robotpkg package jrl-walkgen-v3>=4.0.0: jrl-walkgen-v3-4.0.1 found => Required robotpkg package pinocchio>=1.1.2: pinocchio-1.2.5r1 found => Required robotpkg package sot-application-v3>=1.1.0: sot-application-v3-1.1.3 found => Required robotpkg package sot-core-v3>=3.0.0: sot-core-v3-3.1.1 found => SHA1 checksums OK => RMD160 checksums OK => Applying robotpkg patches for sot-pattern-generator-v3-3.0.0 An unexpected error occured. The last 10 log lines are shown below. | cd /local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0/src && /usr/bin/cmake -E cmake_link_script CMakeFiles/sot-pattern_generator-step_computer_pos-wrap.dir/link.txt --verbose=1 | /usr/bin/g++ -fPIC -pipe -O3 -DNDEBUG -pedantic -Wno-long-long -Wall -Wextra -Wcast-align -Wcast-qual -Wformat -Wwrite-strings -Wconversion -shared -Wl,-soname,dynamic_graph/sot/pattern_generator/step_computer_pos/wrap.so -o dynamic_graph/sot/pattern_generator/step_computer_pos/wrap.so CMakeFiles/sot-pattern_generator-step_computer_pos-wrap.dir/__/cmake/dynamic_graph/python-module-py.cc.o -L/opt/openrobots/lib -Wl,--no-as-needed step-computer-pos.so.3.0.0 -lpython2.7 step-queue.so.3.0.0 step-checker.so.3.0.0 step-observer.so.3.0.0 exception-pg.so.3.0.0 -Wl,-rpath,/opt/openrobots/lib -Wl,-rpath,/usr/lib -llapack -lblas -L/opt/openrobots/lib -ljrl-walkgen -lsublapack -lpinocchio -lboost_filesystem -lboost_system -lurdfdom_sensor -lurdfdom_model_state -lurdfdom_model -lurdfdom_world -lhpp-fcl -lboost_thread-mt -lboost_date_time-mt -lboost_filesystem-mt -lboost_system-mt -lconsole_bridge -loctomap -loctomath -lassimp -lpinocchio -lboost_filesystem -lboost_system -lurdfdom_sensor -lurdfdom_model_state -lurdfdom_model -lurdfdom_world -lhpp-fcl -lboost_thread-mt -lboost_date_time-mt -lboost_filesystem-mt -lboost_system-mt -lconsole_bridge -loctomap -loctomath -lassimp -lsot-core -ldynamic-graph-python -ldynamic-graph -Wl,-rpath,/opt/openrobots/lib:/local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0/src: | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0' | /usr/bin/cmake -E cmake_progress_report /local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0/CMakeFiles 23 | [ 72%] Built target sot-pattern_generator-step_computer_pos-wrap | make[2]: *** [src/CMakeFiles/pg.dir/pg.cpp.o] Error 1 | make[1]: *** [src/CMakeFiles/pg.dir/all] Error 2 | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0' | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/sot-pattern-generator-v3-3.0.0' | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/sot-pattern-generator-v3/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking sot-pattern-generator-v3-3.0.0 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for sot-pattern-generator-v3-3.0.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-pattern-generator-v3-3.0.0 ===> Done bulk for sot-pattern-generator-v3-3.0.0 [58%] Processing wip/sot-hrp2-v3:sot-hrp2-v3-2.1.0 ===> Bulk building for sot-hrp2-v3-2.1.0 Binary package for sot-hrp2-v3-2.1.0 is up-to-date. [58%] Processing wip/talos-metapkg-ros-control-sot:talos-metapkg-ros-control-sot-0.0.3r2 ===> Bulk building for talos-metapkg-ros-control-sot-0.0.3r2 Binary package for talos-metapkg-ros-control-sot-0.0.3r2 is up-to-date. [59%] Processing wip/openhrp3-hrp2:openhrp3-hrp2-1.2.0 ===> Cleaning temporary files for openhrp3-hrp2-1.2.0 ===> Bulk building for openhrp3-hrp2-1.2.0 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-v3-3.0.8.tgz => Installing hrp2-14-1.9.3.tgz => Required robotpkg package openhrp3-simulator-wo-rtm>=1.0.0: N/A => Installing sot-hrp2-v3-2.1.0.tgz => Dependency tnftp-20130505~ssl already installed => Dependency urdfdom-0.3.0r2 already installed ===> Logging bulk summary for openhrp3-hrp2-1.2.0 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for openhrp3-hrp2-1.2.0 ===> Done bulk for openhrp3-hrp2-1.2.0 [59%] Processing wip/sot-romeo-v3:sot-romeo-v3-2.0.1 ===> Cleaning temporary files for sot-romeo-v3-2.0.1 ===> Bulk building for sot-romeo-v3-2.0.1 => Checking for clear installation => Installing digest-20080510.tgz => Installing tnftp-20130505~ssl.tgz => Required robotpkg package digest>=20080510: digest-20080510 found => Required robotpkg package tnftp>=20091122: tnftp-20130505~ssl found => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pax and tar archivers: pax found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing console-bridge-0.2.7.tgz => Dependency digest-20080510 already installed => Installing dynamic-graph-bridge-msgs-0.2.0.tgz => Installing dynamic-graph-bridge-v3-3.0.8.tgz => Dependency dynamic-graph-v3-3.0.1 already installed => Dependency py27-dynamic-graph-v3-3.0.2 already installed => Dependency py27-sot-tools-v3-2.0.2 already installed => Dependency sot-core-v3-3.1.1 already installed => Dependency sot-dynamic-pinocchio-v3-3.1.5c already installed => Dependency tnftp-20130505~ssl already installed => Building with no option. => Use the GNU C++ compiler: c++-compiler provided by g++>=3 => Use the GNU C compiler: c-compiler provided by gcc>=3 => Use python-2.7: python>=2.5<3.7 provided by python27>=2.7<2.8 => Use ros hydro: ros>=groovy provided by ros-hydro => Required system package boost-headers>=1.34.1: boost-headers-1.46.1 found => Required system package boostlib-filesystem>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-iostreams>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-math>=1.34.1: boost-libs-1.46.1 found => Required system package boostlib-thread>=1.34.1: boost-libs-1.46.1 found => Required system package cmake>=2.6: cmake-2.8.7 found => Required system package doxygen>=1.5: doxygen-1.7.6.1 found => Required system package g++>=3: g++-4.6 found => Required system package gcc>=3: gcc-4.6 found => Required system package graphviz>=2: graphviz-2.26.3 found => Required system package libstdc++: libstdc++ found => Required system package pdflatex: pdflatex found => Required system package pkg-config>=0.22: pkg-config-0.26 found => Required system package python27>=2.7<2.8: python27-2.7.3 found => Required system package ros-comm>=1.10<1.11: ros-comm-1.10.12 found => Required system package ros-message-runtime>=0.4<0.5 : ros-message-runtime-0.4.12 found => Required system package ros-rospack>=2.1<2.2: ros-rospack-2.1.25 found => Required system package ros-std-msgs>=0.5 : ros-std-msgs-0.5.8 found => Required robotpkg package console-bridge>=0.1: console-bridge-0.2.7 found => Required robotpkg package dynamic-graph-bridge-msgs>=0.2.0: dynamic-graph-bridge-msgs-0.2.0 found => Required robotpkg package dynamic-graph-bridge-v3>=3.0.0: dynamic-graph-bridge-v3-3.0.8 found => Required robotpkg package dynamic-graph-v3>=3.0.0: dynamic-graph-v3-3.0.1 found => Required robotpkg package py27-dynamic-graph-v3>=3.0: py27-dynamic-graph-v3-3.0.2 found => Required robotpkg package py27-sot-tools-v3>=2.0: py27-sot-tools-v3-2.0.2 found => Required robotpkg package sot-core-v3>=3.0.0: sot-core-v3-3.1.1 found => Required robotpkg package sot-dynamic-pinocchio-v3>=3.1.1: sot-dynamic-pinocchio-v3-3.1.5c found WARNING: Using console-bridge in /opt/openrobots WARNING: The following packages may interfere with the build because they WARNING: are located in paths used by other dependencies: WARNING: console-bridge in /opt/ros/hydro => SHA1 checksums OK => RMD160 checksums OK An unexpected error occured. The last 10 log lines are shown below. | /local/robotpkg/var/tmp/robotpkg/wip/sot-romeo-v3/work/sot-romeo-v3-2.0.1/src/sot-romeo-controller.hh:25:7: note: because the following virtual functions are pure within 'SoTRomeoController': | /opt/openrobots/include/sot/core/abstract-sot-external-interface.hh:73:20: note: virtual void dynamicgraph::sot::AbstractSotExternalInterface::setSecondOrderIntegration() | /opt/openrobots/include/sot/core/abstract-sot-external-interface.hh:74:20: note: virtual void dynamicgraph::sot::AbstractSotExternalInterface::setNoIntegration() | /local/robotpkg/var/tmp/robotpkg/wip/sot-romeo-v3/work/sot-romeo-v3-2.0.1/src/sot-romeo-controller.cpp:162:3: warning: control reaches end of non-void function [-Wreturn-type] | make[2]: *** [src/CMakeFiles/sot-romeo-controller.dir/sot-romeo-controller.cpp.o] Error 1 | make[2]: *** Waiting for unfinished jobs.... | make[2]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/sot-romeo-v3/work/sot-romeo-v3-2.0.1' | make[1]: *** [src/CMakeFiles/sot-romeo-controller.dir/all] Error 2 | make[1]: Leaving directory `/local/robotpkg/var/tmp/robotpkg/wip/sot-romeo-v3/work/sot-romeo-v3-2.0.1' | make: *** [all] Error 2 For details or bug reports, check the complete log file in: /local/robotpkg/var/tmp/robotpkg/wip/sot-romeo-v3/work/build.log make[3]: *** [do-build] Error 2 make[2]: *** [pkg-check-installed] Error 2 => Marking sot-romeo-v3-2.0.1 as broken ERROR: make: *** [package] Error 2 ===> Logging bulk summary for sot-romeo-v3-2.0.1 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for sot-romeo-v3-2.0.1 ===> Done bulk for sot-romeo-v3-2.0.1 [60%] Processing wip/sot-talos:sot-talos-0.0.3 ===> Bulk building for sot-talos-0.0.3 Binary package for sot-talos-0.0.3 is up-to-date. [60%] Processing wip/hrp2-dev:hrp2-dev-20171009 ===> Cleaning temporary files for hrp2-dev-20171009 ===> Bulk building for hrp2-dev-20171009 => Checking for clear installation => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing hrp2-14-description-1.0.4.tgz => Required robotpkg package openhrp3-hrp2>=1.0.0: N/A ===> Logging bulk summary for hrp2-dev-20171009 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for hrp2-dev-20171009 ===> Done bulk for hrp2-dev-20171009 [61%] Processing wip/talos-dev:talos-dev-20171009 ===> Cleaning temporary files for talos-dev-20171009 ===> Bulk building for talos-dev-20171009 => Checking for clear installation => Required system package gnupg>=1: gnupg-1.4.11 found => Required system package gzip: gzip-1.4 found => Required system package pkg_install>=20110805.7: pkg_install-20110805.7 found => Required system package pkgrepo2deb>=1.2: pkgrepo2deb-1.2 found => Installing sot-talos-0.0.3.tgz ERROR: Required robotpkg package talos-gazebo-ros-control>=2.6.5: BROKEN ERROR: Required robotpkg package talos-simulation>=0.0.13: BROKEN ===> Logging bulk summary for talos-dev-20171009 => Checking leftover files => Creating bulk log files => Logging bulk metadata ===> Cleaning temporary files for talos-dev-20171009 ===> Done bulk for talos-dev-20171009 ===> Done bulk for rbulk wip set --- Bulk started Fri Nov 17 11:47:42 CET 2017 --- Bulk stopped Fri Nov 17 12:32:10 CET 2017